[Risolto]Problema con Gnome dopo aggiornamento a Stretch

Problemi con l'installazione di Debian...

[Risolto]Problema con Gnome dopo aggiornamento a Stretch

Messaggioda dev_null » 13/07/2017, 13:47

Buongiorno a tutti,
Ho un problema dopo aver effettuato l'aggiornamento a Debian 9. All'avvio le scritte sullo schermo lampeggiano per un po' e poi si fermano, e il pc si blocca. L'ultima riga è questa:
Codice: Seleziona tutto
[  OK  ] Started GNOME Display Manager.

Se accedo a un altro terminale (CTRL+ALT+F2) mi accorgo che c'è un problema con la scheda grafica (perchè la risoluzione non è quella giusta, i caratteri sono troppo grandi). Prima dell'aggiornamento usavo i driver fglrx che da quanto so non sono più supportati. Allora carico il modulo radeon, la situazione migliora e la dimensione dei caratteri sullo schermo torna alla normalità. Se avvio startx non dà messaggi di errore, tranne questo:
Codice: Seleziona tutto
(II) [KMS] Kernel modesetting enabled.

Se inserisco:
Codice: Seleziona tutto
xinit /usr/bin/gnome-session

il server termina con un errore, il file /var/log/Xorg.0.log è questo:
Codice: Seleziona tutto
[   420.565] (==) Using config file: "/etc/X11/xorg.conf"
[   420.566] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   420.566] (==) ServerLayout "aticonfig Layout"
[   420.566] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
[   420.566] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
[   420.566] (**) |   |-->Device "aticonfig-Device[0]-0"
[   420.566] (==) Automatically adding devices
[   420.566] (==) Automatically enabling devices
[   420.566] (==) Automatically adding GPU devices
[   420.566] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   420.566] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[   420.566]    Entry deleted from font path.
[   420.567] (==) FontPath set to:
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/100dpi/:unscaled,
   /usr/share/fonts/X11/75dpi/:unscaled,
   /usr/share/fonts/X11/Type1,
   /usr/share/fonts/X11/100dpi,
   /usr/share/fonts/X11/75dpi,
   built-ins
[   420.567] (==) ModulePath set to "/usr/lib/xorg/modules"
[   420.567] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[   420.567] (II) Loader magic: 0x556611a6be00
[   420.567] (II) Module ABI versions:
[   420.567]    X.Org ANSI C Emulation: 0.4
[   420.567]    X.Org Video Driver: 23.0
[   420.567]    X.Org XInput driver : 24.1
[   420.567]    X.Org Server Extension : 10.0
[   420.568] (++) using VT number 2

[   420.573] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_3506
[   420.574] (--) PCI:*(0:1:0:0) 1002:68f9:1043:0386 rev 0, Mem @ 0xe0000000/268435456, 0xf7bc0000/131072, I/O @ 0x0000c000/256, BIOS @ 0x????????/131072
[   420.574] (II) "glx" will be loaded by default.
[   420.575] (II) LoadModule: "glx"
[   420.575] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   420.577] (II) Module glx: vendor="X.Org Foundation"
[   420.577]    compiled for 1.19.2, module version = 1.0.0
[   420.577]    ABI class: X.Org Server Extension, version 10.0
[   420.577] (II) LoadModule: "radeon"
[   420.577] (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
[   420.577] (II) Module radeon: vendor="X.Org Foundation"
[   420.577]    compiled for 1.19.0, module version = 7.8.0
[   420.577]    Module class: X.Org Video Driver
[   420.577]    ABI class: X.Org Video Driver, version 23.0
[   420.577] (II) RADEON: Driver for ATI/AMD Radeon chipsets:
   ATI Radeon Mobility X600 (M24), ATI FireMV 2400,
   ATI Radeon Mobility X300 (M24), ATI FireGL M24 GL, 
    ...
[   420.580] (II) [KMS] drm report modesetting isn't supported.
[   420.580] (EE) Screen 0 deleted because of no matching config section.
[   420.580] (II) UnloadModule: "radeon"
[   420.580] (EE) Device(s) detected, but none match those in the config file.
[   420.580] (EE)
Fatal server error:
[   420.580] (EE) no screens found(EE)
[   420.580] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[   420.580] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   420.580] (EE)
[   420.582] (EE) Server terminated with error (1). Closing log file.

Secondo voi qual è il problema?
Ultima modifica di dev_null il 14/07/2017, 15:43, modificato 1 volta in totale.
dev_null
Newbie
Newbie
 
Messaggi: 8
Iscritto il: 13/07/2017, 13:03

Re: Problema con Gnome dopo aggiornamento a Stretch

Messaggioda dev_null » 13/07/2017, 13:53

Aggiungo che ho cambiato il file xorg.conf (in modo sbagliato credo) cambiando fglrx in radeon, e quindi il mio xorg.conf ora è così:
Codice: Seleziona tutto
Section "ServerLayout"
   Identifier     "aticonfig Layout"
   Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
   Identifier   "aticonfig-Monitor[0]-0"
   Option       "VendorName" "ATI Proprietary Driver"
   Option       "ModelName" "Generic Autodetecting Monitor"
   Option       "DPMS" "true"
EndSection

Section "Device"
   Identifier  "aticonfig-Device[0]-0"
   Driver      "radeon"
   BusID       "PCI:1:0:0"
EndSection

Section "Screen"
   Identifier "aticonfig-Screen[0]-0"
   Device     "aticonfig-Device[0]-0"
   Monitor    "aticonfig-Monitor[0]-0"
   DefaultDepth     24
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection

dev_null
Newbie
Newbie
 
Messaggi: 8
Iscritto il: 13/07/2017, 13:03

Re: Problema con Gnome dopo aggiornamento a Stretch

Messaggioda mark » 13/07/2017, 14:48

se hai tolto i driver proprietari completamente ti dovrebbe bastare cancellare o rinominare xorg.conf e sfruttare la capacità di autoconfigurazione di xorg
comunque la parte significativa del log è questa
Codice: Seleziona tutto
[   420.580] (EE) Screen 0 deleted because of no matching config section.
[   420.580] (II) UnloadModule: "radeon"
[   420.580] (EE) Device(s) detected, but none match those in the config file.
[   420.580] (EE)
Fatal server error:
[   420.580] (EE) no screens found(EE)
[   420.580] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[   420.580] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   420.580] (EE)
[   420.582] (EE) Server terminated with error (1). Closing log file.
Avatar utente
mark
Hero Member
Hero Member
 
Messaggi: 527
Iscritto il: 10/01/2007, 16:53

Re: Problema con Gnome dopo aggiornamento a Stretch

Messaggioda dev_null » 13/07/2017, 14:55

Ho spostato il file xorg.conf nella home ma non è stato generato il nuovo xorg.conf, inoltre ho inserito il modulo radeon in /etc/modules ma non viene caricato automaticamente all'avvio
dev_null
Newbie
Newbie
 
Messaggi: 8
Iscritto il: 13/07/2017, 13:03

Re: Problema con Gnome dopo aggiornamento a Stretch

Messaggioda mark » 13/07/2017, 15:09

probabilmente i driver proprietari hanno disabilitato radeon in qualche file di configurazione, prova a verificare che non sia messo in blacklist nel file /etc/modprobe.d/blacklist.conf oppure che tra le opzioni di boot ci sia un "nomodeset"
Avatar utente
mark
Hero Member
Hero Member
 
Messaggi: 527
Iscritto il: 10/01/2007, 16:53

Re: Problema con Gnome dopo aggiornamento a Stretch

Messaggioda dev_null » 13/07/2017, 15:15

Il file blacklist.conf non esiste ma nella cartella modprobe.d c'è il file amd64-microcode-blacklist.conf che contiene:
blacklist microcode

poi c'è il file fglrx-blacklist-radeon.conf che contiene:
Codice: Seleziona tutto
blacklist radeon

e poi ci sono altri file come modesetting.conf, dkms.conf e intel-microcode-blacklist.conf. Cosa dovrei fare?
dev_null
Newbie
Newbie
 
Messaggi: 8
Iscritto il: 13/07/2017, 13:03

Re: Problema con Gnome dopo aggiornamento a Stretch

Messaggioda Spoon » 13/07/2017, 15:23

Ciao, come suggerito da mark rimuovi il file di configurazione di Xorg. Quando si utilizzano i driver liberi esso è in grado di riconoscere autonomamente l'hardWare e caricare il driver corretto.
Aggiungo che non è vero che il modulo radeon non veniva caricato autonomamente, come si può notare d questa riga del log:
Codice: Seleziona tutto
[   420.577] (II) LoadModule: "radeon"

tuttavia il driver era poi scaricato a causa di errori nel file di configurazione. Consiglierei di rimuovere ogni pacchetto riguardante i driver fglrx se non intendi più usarli, in modo da evitare conflitti (cosa che l'ultimo messaggio suggerisce).
Spoon
wiki member
wiki member
 
Messaggi: 302
Iscritto il: 23/11/2013, 14:37

Re: Problema con Gnome dopo aggiornamento a Stretch

Messaggioda dev_null » 13/07/2017, 15:32

Ho rimosso il file /etc/modprobe.d/fglrx-blakclist-radeon e i driver vengono caricati correttamente all'avvio ora ma gnome non part comunque. L'ultimo messaggio è:
Codice: Seleziona tutto
[  OK  ] Started GNOME Display Manager.r client and server.nced themselves....
ù
Ho cambiato terminale e ho digitato dmesg che mi dà:
Codice: Seleziona tutto
gnome-session-f [2107]: segfault at 0 ip 00007f... sp 00007ff... error 4 in libgtk-3.so.0.2200.11[7f38a87...]
dev_null
Newbie
Newbie
 
Messaggi: 8
Iscritto il: 13/07/2017, 13:03

Re: Problema con Gnome dopo aggiornamento a Stretch

Messaggioda dev_null » 13/07/2017, 15:34

In tutto ciò comunque il file xorg.conf non è ancora stato generato automaticamente
dev_null
Newbie
Newbie
 
Messaggi: 8
Iscritto il: 13/07/2017, 13:03

Re: Problema con Gnome dopo aggiornamento a Stretch

Messaggioda mark » 13/07/2017, 18:53

In tutto ciò comunque il file xorg.conf non è ancora stato generato automaticamente

giusto cosi con i driver liberi si può fare a meno di xorg.conf
error 4 in libgtk-3.so.0.2200.11

prova a reinstallare https://packages.debian.org/stretch/libgtk-3-0
Avatar utente
mark
Hero Member
Hero Member
 
Messaggi: 527
Iscritto il: 10/01/2007, 16:53

Re: Problema con Gnome dopo aggiornamento a Stretch

Messaggioda dev_null » 13/07/2017, 19:05

Ci ho già provato ma non è servito a niente. Comunque se scrivo il comando
Codice: Seleziona tutto
xrandr
esce scritto:
Codice: Seleziona tutto
Can't open display

Se invece, dopo aver terminato gdm, scrivo:
Codice: Seleziona tutto
xinit /usr/bin/gnome-session
ottengo
Codice: Seleziona tutto
[   168.153] (==) Using config file: "/etc/X11/xorg.conf"
[   168.154] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   168.154] (==) ServerLayout "X.org Configured"
[   168.154] (**) |-->Screen "Screen0" (0)
[   168.154] (**) |   |-->Monitor "Monitor0"
[   168.154] (**) |   |-->Device "Card0"
[   168.154] (**) |-->Input Device "Mouse0"
[   168.154] (**) |-->Input Device "Keyboard0"
[   168.154] (==) Automatically adding devices
[   168.154] (==) Automatically enabling devices
[   168.154] (==) Automatically adding GPU devices
[   168.154] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   168.154] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[   168.154]    Entry deleted from font path.
[   168.154] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[   168.154]    Entry deleted from font path.
[   168.154] (**) FontPath set to:
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/100dpi/:unscaled,
   /usr/share/fonts/X11/75dpi/:unscaled,
   /usr/share/fonts/X11/Type1,
   /usr/share/fonts/X11/100dpi,
   /usr/share/fonts/X11/75dpi,
   built-ins,
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/100dpi/:unscaled,
   /usr/share/fonts/X11/75dpi/:unscaled,
   /usr/share/fonts/X11/Type1,
   /usr/share/fonts/X11/100dpi,
   /usr/share/fonts/X11/75dpi,
   built-ins
[   168.154] (**) ModulePath set to "/usr/lib/xorg/modules"
[   168.154] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[   168.154] (WW) Disabling Mouse0
[   168.154] (WW) Disabling Keyboard0
[   168.154] (II) Loader magic: 0x558521609e00
[   168.154] (II) Module ABI versions:
[   168.154]    X.Org ANSI C Emulation: 0.4
[   168.154]    X.Org Video Driver: 23.0
[   168.154]    X.Org XInput driver : 24.1
[   168.154]    X.Org Server Extension : 10.0
[   168.159] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_34
[   168.160] (II) xfree86: Adding drm device (/dev/dri/card0)
[   168.161] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 11 paused 0
[   168.163] (--) PCI:*(0:1:0:0) 1002:68f9:1043:0386 rev 0, Mem @ 0xe0000000/268435456, 0xf7bc0000/131072, I/O @ 0x0000c000/256, BIOS @ 0x????????/131072
[   168.163] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[   168.163] (II) LoadModule: "glx"
[   168.163] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   168.165] (II) Module glx: vendor="X.Org Foundation"
[   168.165]    compiled for 1.19.2, module version = 1.0.0
[   168.165]    ABI class: X.Org Server Extension, version 10.0
[   168.165] (II) LoadModule: "radeon"
[   168.165] (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
[   168.165] (II) Module radeon: vendor="X.Org Foundation"
[   168.165]    compiled for 1.19.0, module version = 7.8.0
[   168.165]    Module class: X.Org Video Driver
[   168.165]    ABI class: X.Org Video Driver, version 23.0
[   168.165] (II) RADEON: Driver for ATI/AMD Radeon chipsets:
[   168.167] (EE)
Fatal server error:
[   168.167] (EE) parse_vt_settings: Cannot open /dev/tty0 (Permission denied)
[   168.167] (EE)
[   168.167] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[   168.167] (EE) Please also check the log file at "/home/dev_null/.local/share/xorg/Xorg.0.log" for additional information.
[   168.168] (EE)
[   168.168] (WW) xf86CloseConsole: KDSETMODE failed: Bad file descriptor
[   168.168] (WW) xf86CloseConsole: VT_GETMODE failed: Bad file descriptor
[   168.173] (EE) Server terminated with error (1). Closing log file.
dev_null
Newbie
Newbie
 
Messaggi: 8
Iscritto il: 13/07/2017, 13:03

Re: [Risolto]Problema con Gnome dopo aggiornamento a Stretch

Messaggioda dev_null » 14/07/2017, 15:44

Ho risolto installando da CD Debian 9
dev_null
Newbie
Newbie
 
Messaggi: 8
Iscritto il: 13/07/2017, 13:03


Torna a Installazione

Chi c’è in linea

Visitano il forum: Nessuno e 4 ospiti