[RISOLTO] Kmail non parte

Problemi con l'installazione di Debian...

Re: Kmail non parte

Messaggioda s3v » 18/09/2017, 15:30

samiel ha scritto:in cerca di cosa?

m


Ci sono i log del backend del database (MySQL o MariaDB)
Avatar utente
s3v
Global Moderator
Global Moderator
 
Messaggi: 5448
Iscritto il: 31/12/2008, 11:54

Re: Kmail non parte

Messaggioda samiel » 18/09/2017, 16:11

Ci sono centinaia di file e francamente non ho idea di quali siano rilevanti.
In ogni caso su Testing ho installato mariadb, ma trovo una directory mysql
col file di log che allego, sperando sia quello giusto...

m
Allegati
mysql.err.tar.gz
(1.97 KiB) Scaricato 12 volte
samiel
wiki member
wiki member
 
Messaggi: 2033
Iscritto il: 12/08/2006, 15:05
Località: Venezia

Re: Kmail non parte

Messaggioda s3v » 21/09/2017, 11:18

Ma Akonadi è in esecuzione?
Codice: Seleziona tutto
$ akonadictl status

Utilizza anche Akonadiconsole: https://packages.debian.org/sid/utils/akonadiconsole
Non l'ho mai usato ma vedo che c'è un debugger incorporato che può fornire informazioni utili.

Ipotizzo che ci siano problemi di database e che, a causa d questo, akonadi non parte.
Avatar utente
s3v
Global Moderator
Global Moderator
 
Messaggi: 5448
Iscritto il: 31/12/2008, 11:54

Re: Kmail non parte

Messaggioda samiel » 21/09/2017, 13:57

Codice: Seleziona tutto
samiel@debian:~$ akonadictl status
Akonadi Control: running
Akonadi Server: running
akonadiprivate_log: search paths:  ("lib/x86_64-linux-gnu", "lib/x86_64-linux-gnu/qt5/plugins/", "lib/x86_64-linux-gnu/kf5/", "lib/x86_64-linux-gnu/kf5/plugins/", "/usr/lib/qt5/plugins/", "/usr/lib/x86_64-linux-gnu/qt5/plugins", "/usr/bin")
Akonadi Server Search Support: available (Remote Search)
Available Agent Types: akonadi_akonotes_resource, akonadi_archivemail_agent, akonadi_birthdays_resource, akonadi_contacts_resource, akonadi_davgroupware_resource, akonadi_followupreminder_agent, akonadi_googlecalendar_resource, akonadi_googlecontacts_resource, akonadi_ical_resource, akonadi_icaldir_resource, akonadi_imap_resource, akonadi_indexing_agent, akonadi_invitations_agent, akonadi_kalarm_dir_resource, akonadi_kalarm_resource, akonadi_kolab_resource, akonadi_maildir_resource, akonadi_maildispatcher_agent, akonadi_mailfilter_agent, akonadi_mbox_resource, akonadi_migration_agent, akonadi_mixedmaildir_resource, akonadi_newmailnotifier_agent, akonadi_notes_agent, akonadi_notes_resource, akonadi_openxchange_resource, akonadi_pop3_resource, akonadi_sendlater_agent, akonadi_vcard_resource, akonadi_vcarddir_resource
samiel@debian:~$

akonadiconsole mi produce un log che riporto in allegato
Allegati
akonadidebug.tar.gz
(2.23 KiB) Scaricato 18 volte
samiel
wiki member
wiki member
 
Messaggi: 2033
Iscritto il: 12/08/2006, 15:05
Località: Venezia

Re: Kmail non parte

Messaggioda Aki » 04/10/2017, 6:24

@samiel: hai aggiornamenti ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 7418
Iscritto il: 27/12/2007, 16:59

Re: Kmail non parte

Messaggioda samiel » 04/10/2017, 13:52

no... non sapendo come procedere
kmail continua a caricarsi la prima volta,
poi se lo chiudo non si riavvia più
samiel
wiki member
wiki member
 
Messaggi: 2033
Iscritto il: 12/08/2006, 15:05
Località: Venezia

Re: Kmail non parte

Messaggioda Aki » 08/10/2017, 14:36

Hai qualche anomalia nei file di configurazione; puoi clonare la Tua utenza rinominandola prima e fare poi sul clone degli esperimenti per la cancellazione dei file di configurazione di kmail, oppure in alternativa fare un backup della tua utenza e ricrearla ex-novo.
Aki
Global Moderator
Global Moderator
 
Messaggi: 7418
Iscritto il: 27/12/2007, 16:59

Re: Kmail non parte

Messaggioda samiel » 08/10/2017, 14:59

sì, appena ho un po di tempo faccio un backup dei contenuti
e cancello e ricreo l'utente, vi saprò dire quanto prima

grazie
m
samiel
wiki member
wiki member
 
Messaggi: 2033
Iscritto il: 12/08/2006, 15:05
Località: Venezia

Re: Kmail non parte

Messaggioda s3v » 09/10/2017, 18:23

samiel ha scritto:no... non sapendo come procedere
kmail continua a caricarsi la prima volta,
poi se lo chiudo non si riavvia più


Hai provato a vedere se il programma non viene chiuso correttamente o se sembra chiudersi ma rimane attivo nel vassoio di sistema?
Codice: Seleziona tutto
$ ps aux | grep -i kmail

dopo la chiusura dovrebbe indicarti se esiste ancora un'istanza attiva del programma.
Avatar utente
s3v
Global Moderator
Global Moderator
 
Messaggi: 5448
Iscritto il: 31/12/2008, 11:54

Re: Kmail non parte

Messaggioda samiel » 09/10/2017, 19:15

Codice: Seleziona tutto
samiel@debian:~$ ps aux | grep -i kmail
samiel    1880  4.3  2.1 3324168 169800 ?      Sl   20:12   0:03 /usr/bin/kmail -qwindowtitle KMail
samiel    1945  0.0  0.2 291668 19884 ?        S    20:12   0:00 file.so [kdeinit5] file local:/run/user/1000/klauncherTJ1305.1.slave-socket local:/run/user/1000/kmail2Fp1880.2.slave-socket
samiel    1946  0.0  0.2 291664 19888 ?        S    20:12   0:00 file.so [kdeinit5] file local:/run/user/1000/klauncherTJ1305.1.slave-socket local:/run/user/1000/kmail2qJ1880.3.slave-socket
samiel    1947  0.0  0.2 291668 19884 ?        S    20:12   0:00 file.so [kdeinit5] file local:/run/user/1000/klauncherTJ1305.1.slave-socket local:/run/user/1000/kmail2Wq1880.4.slave-socket
samiel    1948  0.0  0.2 297964 20448 ?        S    20:12   0:00 file.so [kdeinit5] file local:/run/user/1000/klauncherTJ1305.1.slave-socket local:/run/user/1000/kmail2XU1880.5.slave-socket
samiel    1949  0.0  0.2 291664 19884 ?        S    20:12   0:00 file.so [kdeinit5] file local:/run/user/1000/klauncherTJ1305.1.slave-socket local:/run/user/1000/kmail2ao1880.6.slave-socket
samiel    2202  0.0  0.0  12784   984 pts/0    S+   20:13   0:00 grep -i kmail

Cosa devo dedurre?
samiel
wiki member
wiki member
 
Messaggi: 2033
Iscritto il: 12/08/2006, 15:05
Località: Venezia

Re: Kmail non parte

Messaggioda s3v » 24/10/2017, 19:32

samiel ha scritto:
Codice: Seleziona tutto
samiel@debian:~$ ps aux | grep -i kmail
samiel    1880  4.3  2.1 3324168 169800 ?      Sl   20:12   0:03 /usr/bin/kmail -qwindowtitle KMail


KMail rimane in esecuzione.
Puoi provare a killare il processo (1880 in questo caso) prima di farlo ripartire.
In ogni caso segnalerei il bug.
Avatar utente
s3v
Global Moderator
Global Moderator
 
Messaggi: 5448
Iscritto il: 31/12/2008, 11:54

Re: Kmail non parte

Messaggioda samiel » 24/10/2017, 19:44

si tratta di un bug
e non di qualcosa che è successo esclusivemente nel mio sistema?
samiel
wiki member
wiki member
 
Messaggi: 2033
Iscritto il: 12/08/2006, 15:05
Località: Venezia

Re: Kmail non parte

Messaggioda mark » 25/10/2017, 8:06

Avatar utente
mark
Hero Member
Hero Member
 
Messaggi: 527
Iscritto il: 10/01/2007, 16:53

Re: Kmail non parte

Messaggioda samiel » 29/10/2017, 13:37

ho eliminato e ricreato l'utente,
ora kmail sembra funzionare correttamente

grazie e tutti
m
samiel
wiki member
wiki member
 
Messaggi: 2033
Iscritto il: 12/08/2006, 15:05
Località: Venezia

Re: Kmail non parte

Messaggioda Aki » 29/10/2017, 15:37

La discussione si può contrassegnare come risolta ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 7418
Iscritto il: 27/12/2007, 16:59

PrecedenteProssimo

Torna a Installazione

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti