[RISOLTO] HP microserver GEN 10 vga VS display port

Problemi con l'installazione di Debian...

[RISOLTO] HP microserver GEN 10 vga VS display port

Messaggioda sirio81 » 02/01/2018, 15:56

Ciao a tutti, ho un HP micro server gen 10.
Ha 2 uscite display port e 1 vga.
Ho eseguito l'installazione di debian stretch usando la vga.
Terminata l'installazione e riavviato il server, lo schermo resta nero.
Presumo che venga usata una delle due display port al posto della vga.
Non ho installato xorg.
Come posso trovare riscontro sulla porta in uso (via shell) e forzare l'uso della vga?

Codice: Seleziona tutto
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Carrizo (rev 87) (prog-if 00 [VGA controller])
        Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] Carrizo
        Flags: fast devsel, IRQ 34
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        Memory at f0000000 (64-bit, prefetchable) [size=8M]
        I/O ports at f000 [size=256]
        Memory at feb00000 (32-bit, non-prefetchable) [size=256K]
        Expansion ROM at 000c0000 [disabled] [size=128K]
        Capabilities: [48] Vendor Specific Information: Len=08 <?>
        Capabilities: [50] Power Management version 3
        Capabilities: [58] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [a0] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
        Capabilities: [270] #19
        Capabilities: [2b0] Address Translation Service (ATS)
        Capabilities: [2c0] Page Request Interface (PRI)
        Capabilities: [2d0] Process Address Space ID (PASID)
        Kernel modules: amdgpu
Ultima modifica di sirio81 il 03/01/2018, 8:25, modificato 1 volta in totale.
sirio81
Hero Member
Hero Member
 
Messaggi: 1056
Iscritto il: 13/02/2006, 5:04

Re: HP microserver GEN 10 vga VS display port

Messaggioda Aki » 02/01/2018, 16:31

Perché non invii un log di sistema prodotto durante l’avvio del computer acquisito tramite ssh ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 8164
Iscritto il: 27/12/2007, 16:59

Re: HP microserver GEN 10 vga VS display port

Messaggioda byte64 » 02/01/2018, 16:36

Devo proprio installarne a brevissimo uno uguale anche io, penso di utilizzare l'immagine firmware-9.3.0-amd64-netinst.iso (come faccio sempre coi server brand), tu quale hai usato?
Per la vga se non hai usato la iso di cui sopra, devi passare un parametro al kernel:

"Adding "nomodeset" to kernel command line works around the issue in Stretch. Solution is to install firmware-linux-nonfree"

Fonte: https://wiki.debian.org/HP/ProLiant

Ciao
byte64
Sr. Member
Sr. Member
 
Messaggi: 367
Iscritto il: 07/01/2017, 19:02
Località: Bergamo

Re: HP microserver GEN 10 vga VS display port

Messaggioda sirio81 » 02/01/2018, 18:18

Ho usato firmware-9.3.0-amd64-netinst.iso.
Domani provo la soluzione da te fornita.
Grazie!
sirio81
Hero Member
Hero Member
 
Messaggi: 1056
Iscritto il: 13/02/2006, 5:04

Re: HP microserver GEN 10 vga VS display port

Messaggioda sirio81 » 03/01/2018, 8:25

Installando firmware-linux la vga funziona!
Nota: l'installazione l'ho fatta tramite firmware-9.3.0-amd64-netinst.iso ma questo non significa che il pacchetto firmware-linux venga installato.
Va installato successivamente.
sirio81
Hero Member
Hero Member
 
Messaggi: 1056
Iscritto il: 13/02/2006, 5:04

Re: [RISOLTO] HP microserver GEN 10 vga VS display port

Messaggioda Aki » 03/01/2018, 8:40

@sirio81: quale file firmware risulta direttamente interessato al malfunzionamento ? Dovresti poterlo verificare dai log di sistema prima e dopo l’ibstallazione del pacchetto dei firmware non-free
Aki
Global Moderator
Global Moderator
 
Messaggi: 8164
Iscritto il: 27/12/2007, 16:59

Re: [RISOLTO] HP microserver GEN 10 vga VS display port

Messaggioda byte64 » 03/01/2018, 10:13

Ho appena finito l'installazione di stretch sullo stesso modello di server, il firmware per utilizzare la vga è firmware-amd-graphics
Ciao
byte64
Sr. Member
Sr. Member
 
Messaggi: 367
Iscritto il: 07/01/2017, 19:02
Località: Bergamo

Re: [RISOLTO] HP microserver GEN 10 vga VS display port

Messaggioda Aki » 03/01/2018, 13:06

Sposto il messaggio dalla sezione "generale" alla sezione "installazione".
Aki
Global Moderator
Global Moderator
 
Messaggi: 8164
Iscritto il: 27/12/2007, 16:59


Torna a Installazione

Chi c’è in linea

Visitano il forum: Nessuno e 5 ospiti