problei installazione debian

Problemi con l'installazione di Debian...

problei installazione debian

Messaggioda mm-barabba » 31/10/2005, 9:54

ho fatto alcuni tentativi ma ho grossi problemi
ho due HD sata
partizionati così
sda 30 Gb da dividere in partizioni per linux
sda 90 Gb Dati

sdb 30 Gb winxp
sdb 90 Gb dati
le partizioni dati e winxp in ntfs

ho installato winxp tutto ok

ho fatto partire l'installazione debian netinstal testing
ho creato le mie partizioni,installato sistema base
al termine ho installato Grub nel mbr sdb1 di winxp
ma non mi parte grub al riavvio

sono andato a vedere con il cd di xp di ripristinare win
ma la partizione dove era installato è sconosciuta
non è più ntfs

gentilmente chiedo aiuto
non capisco perchè mi ha modificato la partizione
o forse sbaglio io ,sapevo che linux non gode molto le partizioni ntfs , ma cosa posso fare
che mi convenga mettere il grub su un floppy per far partire debian e lasciare a win il suo mbr

please aiuto,,,,,,,,,grazie :sboing:
mm-barabba
 

Re: problei installazione debian

Messaggioda keltik » 31/10/2005, 10:30

ho installato Grub nel mbr sdb1 di winxp
ma non mi parte grub al riavvio
nel bios hai configurato il secondo disco sata come predefinito per l' avvio? se non è così non credo che riuscirai ad avviare la macchina, imho.

altra cosa: sdb1 non è un mbr, ma una partizione. il MBR per quel disco sata è SDB semplicemente. stesso discorso per SDA.

:ciauz:
Avatar utente
keltik
Hero Member
Hero Member
 
Messaggi: 1454
Iscritto il: 01/01/2005, 17:12

Re: problei installazione debian

Messaggioda mm-barabba » 31/10/2005, 11:12

scusate per le mie spiegazioni non molto precise ma
sono un neofita
ok
dal bios il secondo disco sata è predefinito all'avvio
e window parte bene

riguardo sdb1
pensavo l'MBR fosse installato nella partizione di windows
adesso che mi dici cosi mi vien da pensare di aver messo grub nel posto sbagliato

nel frattempo di leggere la tua risposta ho fatto n'altra prova
ho reinstalato windowsxp
poi sono ripartito con l'installazione di debian
stavolta ho scelto di installare grub su floppy
/dev/fd0
ho inserito un floppy vuoto formatato da win in FAT

al riavvio scopro che sul floppy non c'è scritto niente
perchè?
ora riprovo a formattare il floppy con linux ma ho le opzioni dos o etx2 ,scelgo etx2 e rifaccio tutto con grub su floppy

se poi non va ancora provo come hai detto tu
e faccio /dev/SDB
:conf:
mm-barabba
 

Re: problei installazione debian

Messaggioda mm-barabba » 31/10/2005, 11:39

azz ho fatto n'laltro esperimento
ho fatto l'installazione e gli ho detto di mettere grub sul disco 1
riavviando gli ho detto dal bios di partire dal primo disco e ora funziona
ma non ho viglia di entrare nel bios ogni volta che accendo il pc per sciegliere il sistema operativo
posso modificarlo dopo il grub per fargli vedere windows
o devo usare uno dei metodi citati prima ??


rigrazie :s1:
mm-barabba
 

Re: problei installazione debian

Messaggioda keltik » 31/10/2005, 12:08

scusa, ma non riesco a seguire bene quello che scrivi :-/

ad ogni modo: avvia il pc con linux. a quel punto puoi installare grub dove vuoi (anche sull' altro disco), purchè sia correttamente configurato.

:ciauz:
Avatar utente
keltik
Hero Member
Hero Member
 
Messaggi: 1454
Iscritto il: 01/01/2005, 17:12

Re: problei installazione debian

Messaggioda mm-barabba » 31/10/2005, 13:24

risolto il problema

ho fatto installare grub su una partizione /boot
sul primo disco sata dove c'erano le altre partizioni linux
dove a voluto lui senza modificare niente
adesso all'avvio mi chiede se voglio win o deb
e funziona tutto perfettamente
ho messo dal bios di partire dal primo disco sata dove c'è linux
:s1:


grazie per l'aiuto spero che tutto ciò possa servire a altri
mm-barabba
 


Torna a Installazione

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti

cron