[RISOLTO] Crontab esegue script, ma non genera output

Bash, Perl, Python, Ruby, ...

[RISOLTO] Crontab esegue script, ma non genera output

Messaggioda paolone.biz » 29/08/2015, 9:20

Buongiorno a tutti,
Devo fare degli snapshot da alcune webcam. ;)
Ho 2 macchine virtuali con sopra una 7.6 ed una 7.8

Ho fatto uno script abbastanza semplice:
Codice: Seleziona tutto
#!/bin/bash
echo "START"
wget --output-document temp.jpg "http://192.168.1.2/snapshot.cgi"
echo "WGET OK"
date_time=$(date)
echo "STOP $date_time"

poi con crontab -e
Codice: Seleziona tutto
*/1 * * * * /web/webcam/webcam.sh | tee -a /web/webcam/logfile.log

Sulla macchina virtuale 7.6 funziona al volo tutto, ogni minuti mi scarica la nuova foto, sulla 7.8 ho rogne... ???

Il cron mi esegue lo script, mi genera il file di log, ogni minuti aggiunge delle righe, ma dell'immagine neanche traccia...

Lo script a mano funziona, ho provato a giocare con i permessi della directory, ma nulla da fare...

Cosa può essere? :-\
Grazie
Paolo
Ultima modifica di paolone.biz il 01/09/2015, 20:08, modificato 1 volta in totale.
Avatar utente
paolone.biz
Newbie
Newbie
 
Messaggi: 40
Iscritto il: 26/08/2007, 9:47
Località: Italy

Re: Crontab esegue script, ma non genera output

Messaggioda s3v » 30/08/2015, 10:25

Il problema è qui:
#!/bin/bash
echo "START"
wget --output-document temp.jpg "http://192.168.1.2/snapshot.cgi"
echo "WGET OK"
date_time=$(date)
echo "STOP $date_time"

Cron cerca di creare Il file "temp.jpg" (senza un path assoluto) sotto la radice (/) e non nella directory in cui si trova lo script.
Risolvi con:
...
wget --output-document /web/webcam/temp.jpg "http://192.168.1.2/snapshot.cgi"
...

Dai un'occhiata anche a http://guide.debianizzati.org/index.php ... uling_Cron, in particolare alla sezione "Logging" in cui si spiega dove leggere i log in caso di errori.
Avatar utente
s3v
Global Moderator
Global Moderator
 
Messaggi: 5733
Iscritto il: 31/12/2008, 11:54


Torna a Scripting

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron