[RISOLTO] Errore strano con gedit

Discussioni relative a Debian e Linux

[RISOLTO] Errore strano con gedit

Messaggioda marcomg » 17/02/2012, 14:40

Ho una debian wheezy Linux ACER 3.2.0-1-amd64 #1 SMP Sun Feb 5 15:17:15 UTC 2012 x86_64 GNU/Linux

Lancio da terminale gedit con privilegi root con l'intenzione di modificare il sources.list e cambiare de wheezy a testing.

Non me lo avvia e mi da questo errore:
Codice: Seleziona tutto
root@ACER:/home/marco# gedit

(gedit:3198): EggSMClient-WARNING **: Failed to connect to the session manager: None of the authentication protocols specified are supported


** (gedit:3198): WARNING **: Could not connect to session bus
root@ACER:/home/marco#


Se lo lancio senza privilegi di root funziona a meraviglia.
Sono sicuro che non vi ho dato abbastanza informazioni. Ditemi cosa vi devo dire e io ve lo dico.
Ultima modifica di marcomg il 17/02/2012, 15:22, modificato 1 volta in totale.
Windows is what you open when you want fresh air from outside.
Avatar utente
marcomg
Hero Member
Hero Member
 
Messaggi: 5605
Iscritto il: 22/08/2011, 18:54

Re: Errore strano con gedit

Messaggioda ferdybassi » 17/02/2012, 14:46

E' stato detto un milione di volte sul forum nell'ultimo mese.
L'utente root non ha la possibilità di usare una sessione grafica, ergo tutti i programmi che hanno bisogno di una sessione grafica non funzionano.
Se vuoi usare gedit come root, devi dare il comando:
Codice: Seleziona tutto
gksu gedit

come utente normale.
Funziona come
Codice: Seleziona tutto
su

ma serve per i programmi che hanno bisogno di X.

Ciao ciao
Immagine  Immagine
Avatar utente
ferdybassi
Administrator
Administrator
 
Messaggi: 3285
Iscritto il: 28/12/2006, 4:22
Località: S. Angelo Lodigiano (LO)

Re: Errore strano con gedit

Messaggioda marcomg » 17/02/2012, 15:07

Veramente a me funzionava tempo fa...
Con su.
Windows is what you open when you want fresh air from outside.
Avatar utente
marcomg
Hero Member
Hero Member
 
Messaggi: 5605
Iscritto il: 22/08/2011, 18:54

Re: Errore strano con gedit

Messaggioda gmc » 17/02/2012, 15:19

marcomg ha scritto:Veramente a me funzionava tempo fa...
Con su.

Avrai fatto qualcosa con xhost. Scommetto che se da terminale, come utente della sessione corrente dai
Codice: Seleziona tutto
xhost + local:

poi funziona tutto a meraviglia... (però le applicazioni kde avranno problemi perché utilizzano dbus)

Maggiori informazioni su man xhost o cercando su google.

Detto questo ti consiglio vivamente di utilizzare gksu (o kdesu), anche per evitare di fare casino con xhost.

Ciao,
Peppe
Υπεραγία Θεοτόκε Σωσον ημάς!
Avatar utente
gmc
Global Moderator
Global Moderator
 
Messaggi: 1917
Iscritto il: 22/05/2007, 19:02
Località: Stuttgart (Stoccarda), Germania

Re: Errore strano con gedit

Messaggioda marcomg » 17/02/2012, 15:22

Potrebbe essere che l'ultima volta lo ho fatto con squeeze? Tia ssucuro che con
su
gedit /etc/ecc, ecc
Partiva gedit.
Comunque ho risolto usando nano!
Grazie mille!
Windows is what you open when you want fresh air from outside.
Avatar utente
marcomg
Hero Member
Hero Member
 
Messaggi: 5605
Iscritto il: 22/08/2011, 18:54


Torna a Generale

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti

cron