Pagina 1 di 1

Shotcut non si avvia (tramite snap)

MessaggioInviato: 04/05/2018, 16:45
da olgraz
Salve a tutti

ho installato shotcut (un programma per video editing) su debian Stretch tramite snap. L'installazione è andata bene ma ho dei problemi con l'avvio del programma.
Lanciandolo da terminale mi da questo output:

Codice: Seleziona tutto
yuliya@debian:~$ shotcut

** (shotcut:1791): WARNING **: Pixbuf theme: Cannot load pixmap file /usr/share/themes/Adwaita/gtk-2.0/assets/progressbar-horz-trough.png: Impossibile riconoscere il formato di immagine per il file «/usr/share/themes/Adwaita/gtk-2.0/assets/progressbar-horz-trough.png»


(shotcut:1791): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_width: assertion 'GDK_IS_PIXBUF (pixbuf)' failed

(shotcut:1791): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_height: assertion 'GDK_IS_PIXBUF (pixbuf)' failed

** (shotcut:1791): WARNING **: Invalid borders specified for theme pixmap:
        /usr/share/themes/Adwaita/gtk-2.0/assets/progressbar-horz-trough.png,
borders don't fit within the image
bin/shotcut: symbol lookup error: /snap/shotcut/21/usr/lib/x86_64-linux-gnu/mesa/libGL.so.1: undefined symbol: drmGetDevice2
yuliya@debian:~$


Da quello che ho capito shotcut non riconosce il formato di un elemento del tema Adwaita.
Non so come fare per risolvere il problema forse installando un altro tema? Ma quale?
qualcuno sa cosa fare?

Re: Shotcut non si avvia

MessaggioInviato: 05/05/2018, 9:09
da mark
il messaggio di errore rilevante è questo
Codice: Seleziona tutto
bin/shotcut: symbol lookup error: /snap/shotcut/21/usr/lib/x86_64-linux-gnu/mesa/libGL.so.1: undefined symbol: drmGetDevice2

immagino che il programma richieda una versione più recente di mesa rispetto a quella installata

Re: Shotcut non si avvia

MessaggioInviato: 05/05/2018, 13:46
da caturen
Since this snap is using classic confinement based on the portable zip above, not all dependencies are bundled, and it has the same run-time requirements as the portable zip.
fai prima a scaricati lo zip, lo estrai dove ti pare e lanci programma da lì
https://shotcut.org/download/

Re: Shotcut non si avvia

MessaggioInviato: 05/05/2018, 15:52
da olgraz
fai prima a scaricati lo zip, lo estrai dove ti pare e lanci programma da lì


Ci ho già provato ma non parte neanche quello

Re: Shotcut non si avvia

MessaggioInviato: 05/05/2018, 17:09
da caturen
io l'ho scaricato e fatto partire. Mi chiede di installare un pacchetto
Immagine
Installato il pacchetto, programma parte senza problemi
Immagine
questo su debian sid

Re: Shotcut non si avvia

MessaggioInviato: 06/05/2018, 17:35
da olgraz
Ho provato ad installare quella libreria da terminale ma non la trova. Probabilmente è solo sui repo di Sid.
Proverò qualche altro video editor Openshot, da un primo sguardo, non mi sembra male.
Grazie per le risposte, alla prossima.

Re: Shotcut non si avvia

MessaggioInviato: 07/05/2018, 5:21
da caturen
Non so cosa hai fatto, ma quella libreria è presente su tutte le versioni di debian https://packages.debian.org/search?keyw ... sdl2-2.0-0