problemi copia file

Discussioni relative a Debian e Linux

problemi copia file

Messaggioda c.realkiller » 16/05/2018, 16:52

ho riscontrato su debian 9 uno strano comportamento: copiando dei file su chiavetta usb da hdd usando cp o gcp o rsync etc, che se la chiavetta è montata con l'auto mount (in media) la copia dei file è estremamente lenta, mentre se creo un punto di mount in mnt/ e monto li la chiavetta, la copia dei file è estremamente veloce.
qualcuno sa darmi delle spiegazioni in merito?
grazie
Avatar utente
c.realkiller
Newbie
Newbie
 
Messaggi: 20
Iscritto il: 04/08/2009, 12:42
Località: gallipoli

Re: problemi copia file

Messaggioda Aki » 17/05/2018, 17:14

c.realkiller ha scritto:[..] se la chiavetta è montata con l'auto mount (in media) la copia dei file è estremamente lenta, mentre se creo un punto di mount in mnt/ e monto li la chiavetta, la copia dei file è estremamente veloce.

Senza avere misure precise, si potrebbe ipotizzare che nei due diversi casi d'uso sono usate diverse opzioni di mount: questo lo puoi verificare con il comando mount da riga di comando (senza altri parametri).

In ogni caso, sarebbe utile poter disporre di misure quantificate relativamente ai due diversi casi d'uso. Puoi farlo facilmente usando il comando time; ad esempio (ho usanto /dev/null solo come esempio):
Codice: Seleziona tutto
script log.txt
/usr/bin/time -v "cp /dev/null /dev/null"
exit
Aki
Global Moderator
Global Moderator
 
Messaggi: 7751
Iscritto il: 27/12/2007, 16:59

Re: problemi copia file

Messaggioda c.realkiller » 20/05/2018, 16:09

Grazie della risposta, appena avrò accesso nuovamente alla macchina in questione postero gli output.
Buona domenica
Avatar utente
c.realkiller
Newbie
Newbie
 
Messaggi: 20
Iscritto il: 04/08/2009, 12:42
Località: gallipoli

Re: problemi copia file

Messaggioda c.realkiller » 20/05/2018, 22:57

usando time questo è l'output:
real 0m6,129s
user 0m0,010s
sys 0m1,218s
ma una volta finita la copia, andando a espellere il dispositivo, mi esce una finestrella di pop-up che mi avvisa: non espellere il dispositivo, dispositivo occupato etc..etc...
in dmesg vedo questo
Codice: Seleziona tutto
[19255.215216] usb 1-1.4: reset high-speed USB device number 5 using ehci-pci
[20781.781077] usb 1-1.4: reset high-speed USB device number 5 using ehci-pci
[22861.627087] usb 3-1: new high-speed USB device number 2 using xhci_hcd
[22861.849564] usb 3-1: New USB device found, idVendor=090c, idProduct=1000
[22861.849572] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[22861.849577] usb 3-1: Product: USB DISK
[22861.849582] usb 3-1: Manufacturer: SMI Corporation
[22861.948443] usb-storage 3-1:1.0: USB Mass Storage device detected
[22861.948672] scsi host6: usb-storage 3-1:1.0
[22861.948799] usbcore: registered new interface driver usb-storage
[22861.963064] usbcore: registered new interface driver uas
[22863.282547] scsi 6:0:0:0: Direct-Access     SMI      USB DISK         1100 PQ: 0 ANSI: 4
[22863.283758] sd 6:0:0:0: Attached scsi generic sg2 type 0
[22863.283916] sd 6:0:0:0: [sdb] 15974400 512-byte logical blocks: (8.18 GB/7.62 GiB)
[22863.284611] sd 6:0:0:0: [sdb] Write Protect is off
[22863.284620] sd 6:0:0:0: [sdb] Mode Sense: 43 00 00 00
[22863.285278] sd 6:0:0:0: [sdb] No Caching mode page found
[22863.285294] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[22863.291922]  sdb: sdb1
[22863.293914] sd 6:0:0:0: [sdb] Attached SCSI removable disk
Avatar utente
c.realkiller
Newbie
Newbie
 
Messaggi: 20
Iscritto il: 04/08/2009, 12:42
Località: gallipoli

Re: problemi copia file

Messaggioda Aki » 21/05/2018, 18:37

c.realkiller ha scritto:usando time questo è l'output:
Codice: Seleziona tutto
real 0m6,129s
user 0m0,010s
sys 0m1,218s
[..] una volta finita la copia, andando a espellere il dispositivo, mi esce una finestrella di pop-up che mi avvisa: non espellere il dispositivo, dispositivo occupato

Dal log del messaggio precedente, risulta che ha impiegato 6 secondi a copiare il o i file, quindi non mi sembra che i tempi siano eccessivamente lunghi come hai riferito nel primo messaggio della discussione. Per analizzare più in dettaglio, dovresti fornire il log completo dei comandi che ti ho suggerito e non solo una parte.

Per quanto riguarda l'impossibilità a rimuovere il disco USB, può dipendere da molti fattori (ad esempio, lo svuotamento dei buffer del disco), ma anche in tal caso in assenza di log non è possibile fornire risposte. Spero tu abbia già considerato che non può essere "smontato" (espulso) un disco USB se è attivo un processo che utilizza la path del dispositivo (ad esempio, c'è una finestra di terminale aperta con directory corrente all'interno della path del disco esterno USB).
Aki
Global Moderator
Global Moderator
 
Messaggi: 7751
Iscritto il: 27/12/2007, 16:59

Re: problemi copia file

Messaggioda Aki » 27/05/2018, 17:59

@c.realkiller : puoi aggiornare la discussione ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 7751
Iscritto il: 27/12/2007, 16:59


Torna a Generale

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti