virtualbox 5.2.16 e libcurl3, libcurl4 e cmake

Discussioni relative a Debian e Linux

virtualbox 5.2.16 e libcurl3, libcurl4 e cmake

Messaggioda capocla » 18/07/2018, 17:59

Salve,
Oggi mentre facevo l'aggiornamento mi è uscito che virtualbox non si era aggiornato alla versione 5.2.16 perché necessita di libcurl3. Installando libcurl3, però, mi vengono tolte automaticamente libcurl4 e cmake.
A cosa servono queste librerie di preciso?
Grazie
capocla
Sr. Member
Sr. Member
 
Messaggi: 293
Iscritto il: 14/06/2008, 19:23

Re: virtualbox 5.2.16 e libcurl3, libcurl4 e cmake

Messaggioda s3v » 18/07/2018, 19:47

Non lo hai specificato ma presumo tu stia usando una testing/sid con VirtualBox preso dai repository del produttore.
Se questo è il caso, puoi farci ben poco.
Il repository messo a disposizione è per Stretch (stable) e dunque VB viene garantita funzionante per Stretch.
Puoi aspettare che risolvano o rimuovere manualmente i pacchetti che vanno in conflitto con "libcurl3".
Prova con:
Codice: Seleziona tutto
# apt purge -s nomepacchetto

che si limita a simulare la rimozione senza effettuarla realmente; in questo modo puoi vedere quali altri pacchetti tenta di rimuovere.
Personalmente ti sconsiglio questa strada, fossi in te aspetterei visto che in fondo si tratta di un salto di "minor revision" (io, figurati, sono ancora con la 5.1).
Avatar utente
s3v
Global Moderator
Global Moderator
 
Messaggi: 5589
Iscritto il: 31/12/2008, 11:54

Re: virtualbox 5.2.16 e libcurl3, libcurl4 e cmake

Messaggioda capocla » 19/07/2018, 8:58

OK, grazie
capocla
Sr. Member
Sr. Member
 
Messaggi: 293
Iscritto il: 14/06/2008, 19:23


Torna a Generale

Chi c’è in linea

Visitano il forum: Google [Bot] e 6 ospiti