Pagina 1 di 1

[RISOLTO] Visualizzazione dispositivi

MessaggioInviato: 06/10/2018, 23:42
da jimmy-red
Ciao a tutti, è parecchio che non scrivevo perchè fino a qualche settimana fa filava tutto liscio con la mia Debian Testing XFCE, solo che dopo qualche aggiornamento sul desktop è apparsa una strana icona "PROC" con il simbolo di un disco/dispositivo, e allo stesso modo Thunar nell'elenco dispositivi mostra tra gli altri anche tale "PROC"; oltre a questo inserendo una chiavetta USB, Thunar non la vede, ma in realtà da console viene vista benissimo
Codice: Seleziona tutto
[ 8413.808060] usb 1-7: new high-speed USB device number 5 using ehci-pci
[ 8413.965491] usb 1-7: New USB device found, idVendor=0781, idProduct=5591, bcdDevice= 1.00
[ 8413.965505] usb 1-7: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 8413.965514] usb 1-7: Product: Ultra USB 3.0
[ 8413.965521] usb 1-7: Manufacturer: SanDisk
[ 8413.965528] usb 1-7: SerialNumber: 4C530001070609119312
[ 8418.603842] usb-storage 1-7:1.0: USB Mass Storage device detected
[ 8418.608951] scsi host2: usb-storage 1-7:1.0
[ 8418.609128] usbcore: registered new interface driver usb-storage
[ 8418.925608] usbcore: registered new interface driver uas
[ 8419.617081] scsi 2:0:0:0: Direct-Access     SanDisk  Ultra USB 3.0    1.00 PQ: 0 ANSI: 6
[ 8419.619699] sd 2:0:0:0: Attached scsi generic sg2 type 0
[ 8419.621809] sd 2:0:0:0: [sdb] 30031872 512-byte logical blocks: (15.4 GB/14.3 GiB)
[ 8419.623177] sd 2:0:0:0: [sdb] Write Protect is off
[ 8419.623184] sd 2:0:0:0: [sdb] Mode Sense: 43 00 00 00
[ 8419.624288] sd 2:0:0:0: [sdb] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
[ 8419.634756]  sdb: sdb1
[ 8419.638530] sd 2:0:0:0: [sdb] Attached SCSI removable disk
[ 9089.285958] usb 1-7: USB disconnect, device number 5

Anche Cairo-dock non visualizza più i volumi e il filesystem :'( :'(
Credo sia un problema di "udisk2" o "D-Bus", ma non so dove mettere le mani !!

Re: Visualizzazione dispositivi

MessaggioInviato: 07/10/2018, 8:59
da Aki
Ciao,
Il pacchetto udisk2 è stato recentemente aggiornato in Debian Testing, ma non ci sono bug report per segnalazioni simili alla tua. Qualora fosse effettivamente coinvolto in quanto riferisci, con il comando udisksctl dovresti poter raccogliere informazioni utili, ad esempio con i seguenti comandi, impartiti come utente root, quando il malfunzionamento è in corso:
Codice: Seleziona tutto
script log.txt
udisksctl status
udisksctl dump > tmplog
cat tmplog
exit

Il file log.txt conterrà l'output dei comandi impartiti che potrai analizzare e inviare al forum per supporto. Ti ricordo, inoltre, che con il comando udisksctl monitor puoi verificare come il servizio udisksd risponde all'inserimento di una periferica usb.

Re: Visualizzazione dispositivi

MessaggioInviato: 07/10/2018, 21:00
da jimmy-red
Ciao Aki, sempre presente: ho seguito i comandi consigliati e questo è l'esito dello script: http://paste.debian.net/1046272/

Prima di eseguirlo avevo inserito una chiavetta USB; ho dato un'occhiata al testo, ma non ci capisco un'acca !

Re: Visualizzazione dispositivi

MessaggioInviato: 08/10/2018, 8:27
da Aki
Ciao, felice di rileggerti. Non rilevo la presenza del disco PROC nell'output che hai inviato (in allegato). Questo mi fa pensare che il malfunzionamento non risieda in udisks.

Re: Visualizzazione dispositivi

MessaggioInviato: 13/10/2018, 21:43
da jimmy-red
Infatti confermo che non ho un disco PROC: da qualche tempo è apparso sul Desktop tale icona tipo risorsa e da proprietà mi dice che è
Codice: Seleziona tutto
/proc

A parte questo, il problema maggiore è che non vede il file system della pennetta USB :'( :'(

Re: Visualizzazione dispositivi

MessaggioInviato: 14/10/2018, 17:13
da jimmy-red
Oggi avevo un pò di tempo per smanettare al PC e credo di aver trovato per caso la soluzione al mio problema: in pratica guardando nelle Preferenze Avanzate di THUNAR è apparso un messaggio di errore a causa di "gvfs": ho fatto una rapida verifica e risultava installato solo il pacchetto "gvfs-common" ma non erano installati ne "gvfs" ne "gvfs-fuse"; ho provveduto alla loro installazione e al successivo riavvio la situazione è tornata normale: Cairo-Dock ora vede il file system, così come Thunar, e dal Desktop è sparito l'icona "PROC", anche la pennetta USB all'inserimento fa partire Thunar che ne mostra il suo contenuto.
Non capisco cosa possa essere successo, probabilmente qualche aggiornamento mi ha segato i pacchetti in questione: metto RISOLTO nel tread.