Debian Buster dopo aggiornamento si blocca ripetutamente

Discussioni relative a Debian e Linux

Debian Buster dopo aggiornamento si blocca ripetutamente

Messaggioda stephanie » 29/11/2018, 21:39

Un saluto a tutto il forum,

ieri dopo avere aggiornato la mia Debian Buster da Synaptic purtroppo il sistema si blocca ripetutamente, per diversi minuti, e non riesco a capire le cause.

Può succedere che per due o tre ore ore vada tutto liscio e che poi ci siano blocchi di 8-10 minuti a pochissima distanza l'uno dall'altro.

Cercando su Internet ho visto che a volte il problema è dovuto a ifupdown, che ho sotituito con ifupdown2, ma il problema rimane.

Succede improvvisamente, generalmente il sistema operativo è interamente bloccato (anche l'orologio si ferma), si riesce a muovere solo il mouse senza cliccare.

Poco fa mi è però successo solo con Firefox, che rimaneva bloccato mentre il resto funzionava. La cosa strana è che in quel frangente avevo dato un apt-get autoremove da terminale e si bloccava, forzata la chiusura di Firefox anche il terminale ha ripreso a funzionare.

Sembra quasi ci sia qualcosa che poi fa bloccare tutto, ma non riesco a capire cosa.

Avevo già pensato a Firefox, visto che l'upgrade l'aveva aggiornato, ed avevo già provato a non avviare Firefox usando altri browser, ma questo pomeriggio il sistema si è bloccato ugualmente.

Avete qualche consiglio per potere risalire alle cause, è possibile monitorare in qualche modo a cosa può essere dovuto?

Fino a due giorni fa funzionava tutto perfettamente, sono 12 anni che uso Linux e 8 che uso Debian... mai successa una cosa del genere, e di testing ne ho usate diverse.

Grazie per qualsiasi aiuto, non so proprio come muovermi per circoscrivere il problema, perché adesso è troppo vago, l'unico tentativo è provare a scollegare la rete per qualche ora per vedere se è eventualmente lì il problema, anche se è molto limitativo lavorare in queste condizioni...

È una Debian Buster a 64-bit con Desktop Mate.

Buona serata a tutti,

Stéphanie
Ultima modifica di stephanie il 29/11/2018, 22:10, modificato 1 volta in totale.
stephanie
Newbie
Newbie
 
Messaggi: 35
Iscritto il: 05/08/2017, 12:44

Re: Debian Buster dopo aggiornamento si blocca ripetutament

Messaggioda stephanie » 29/11/2018, 21:58

Appena ho inviato il messaggio precedente ed il sistema si è nuovamente bloccato. Dopo alcuni minuti, rimanendo bloccato ho dovuto spegnere e riavviare il pc.

L'impressione (ma forse sbaglio) è che abbia in qualche modo a che fare con la rete, in questo caso l'unica cosa successa è stata di inviare il precedente messaggio.

Dopo si è bloccato un'altra volta mentre usavo un gestionale che si connette a server Firebird, installato sulla stessa macchina, in modalità TCP/IP. Fatto il log-in, la prima query ha mandato in blocco il computer per 4 minuti.

Aggiornamento: il computer si è bloccato ancora altre tre volte stasera, per circa 7-8 minuti ciascuna. L'ultima mi ero disconnessa dal Network Manager, quindi anche senza Internet, senza posta elettronica e senza browser il problema si è verificato lo stesso.

Due volte è successo dopo che ho finito di ascoltare due brani MP3 con VLC. In entrambi i casi appena finito l'ascolto ho provato a rinominare il file (da Caja) e proprio mentre li rinominavo si è bloccato. Ieri avevo avuto un problema con pulseaudio non funzionante, che alla fine ho risolto con un killall timidity che teneva bloccato pulseaudio e disinstallando timidity-daemon.

Dando da terminale un apt-get autoremove ottengo questo:

Codice: Seleziona tutto
root@PcServer:/home/stephanie# apt-get autoremove
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti saranno RIMOSSI:
  pulseaudio-module-gsettings pulseaudio-module-zeroconf
0 aggiornati, 0 installati, 2 da rimuovere e 1 non aggiornati.
Dopo quest'operazione, verranno liberati 240 kB di spazio su disco.
Continuare? [S/n] S
dpkg: attenzione: "ldconfig" non è stato trovato in PATH o non è un eseguibile
dpkg: attenzione: "start-stop-daemon" non è stato trovato in PATH o non è un eseguibile
dpkg: errore: 2 programmi attesi non sono stati trovati in PATH o non sono eseguibili
Nota: la variabile PATH di root dovrebbe contenere /usr/local/sbin, /usr/sbin e /sbin
E: Sub-process /usr/bin/dpkg returned an error code (2)
root@PcServer:/home/stephanie#


Grazie per ogni aiuto, non so proprio come risolvere.

Buona serata,

Stéphanie
stephanie
Newbie
Newbie
 
Messaggi: 35
Iscritto il: 05/08/2017, 12:44

Re: Debian Buster dopo aggiornamento si blocca ripetutament

Messaggioda Ombra » 30/11/2018, 8:11

Dando da terminale un apt-get autoremove ottengo questo:


questo è un problema non correlato ai freeze, util-linux è stato aggiornato di recente e ora per loggarsi come root bisogna usare
Codice: Seleziona tutto
su -


vedi qui

Per quanto riguarda i freeze, visto che se hai pazienza si sblocca, suggerisco di annotarsi l'orario di inizio del freeze e, una volta che si sblocca, visionare i log di sistema in cerca di qualche indizio in corrispondenza dell' orario del blocco.
Ombra
wiki member
wiki member
 
Messaggi: 472
Iscritto il: 11/08/2007, 18:06
Località: Bologna

Re: Debian Buster dopo aggiornamento si blocca ripetutament

Messaggioda stephanie » 30/11/2018, 11:55

Grazie per la risposta, scusa la domanda da ignorante, ma non sono una sistemista, dove posso verificare i log di sistema?

Per il blocco potrebbe magari essere qualcosa legato alla scheda video, magari in seguito ad un aggiornamento di XOrg con l'update?


Grazie e buona giornata,

Stéphanie
stephanie
Newbie
Newbie
 
Messaggi: 35
Iscritto il: 05/08/2017, 12:44

Re: Debian Buster dopo aggiornamento si blocca ripetutament

Messaggioda Ombra » 30/11/2018, 13:30

dove posso verificare i log di sistema?

dovresti averne una certa quantità in
Codice: Seleziona tutto
/var/log/

vedi per esempio (ma non solo) /var/log/syslog;
puoi anche dare una occhiata a
Codice: Seleziona tutto
# dmesg

infine, per quanto riguarda Xorg, i log sono in var/log/ se è setuid, invece li trovi nella tua home sotto
Codice: Seleziona tutto
.local/share/xorg/

nel caso di 'Xorg non root'
Ombra
wiki member
wiki member
 
Messaggi: 472
Iscritto il: 11/08/2007, 18:06
Località: Bologna

Re: Debian Buster dopo aggiornamento si blocca ripetutament

Messaggioda stephanie » 30/11/2018, 17:18

Grazie per l'aiuto, guardando in /var/log ho notato che nel file XOrg.log sono presenti una serie continua di messaggi:

Codice: Seleziona tutto
(EE) modeset(0): Failed to get GBM bo for flip to new front.
(EE) modeset(0): present flip failed


che si verificano di norma dopo delle righe Modeline:

Codice: Seleziona tutto
    43.955] (II) modeset(0): Modeline "1920x1080"x0.0  148.50  1920 2008 2052 2200  1080 1084 1089 1125 +hsync +vsync (67.5 kHz eP)
[    43.955] (II) modeset(0): Modeline "1920x1080i"x0.0   74.25  1920 2008 2052 2200  1080 1084 1094 1125 interlace +hsync +vsync (33.8 kHz e)
[    43.955] (II) modeset(0): Modeline "1280x720"x0.0   74.25  1280 1390 1430 1650  720 725 730 750 +hsync +vsync (45.0 kHz e)
[    43.955] (II) modeset(0): Modeline "720x480"x0.0   27.00  720 736 798 858  480 489 495 525 -hsync -vsync (31.5 kHz e)
[    43.955] (II) modeset(0): Modeline "1440x480i"x0.0   27.00  1440 1478 1602 1716  480 488 494 525 interlace -hsync -vsync (15.7 kHz e)
[    43.955] (II) modeset(0): Modeline "1440x576i"x0.0   27.00  1440 1464 1590 1728  576 580 586 625 interlace -hsync -vsync (15.6 kHz e)
[    43.955] (II) modeset(0): Modeline "640x480"x0.0   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz e)
[    43.955] (II) modeset(0): Modeline "720x576"x0.0   27.00  720 732 796 864  576 581 586 625 -hsync -vsync (31.2 kHz e)
[    43.955] (II) modeset(0): Modeline "1280x720"x0.0   74.25  1280 1720 1760 1980  720 725 730 750 +hsync +vsync (37.5 kHz e)
[    43.955] (II) modeset(0): Modeline "1920x1080i"x0.0   74.25  1920 2448 2492 2640  1080 1084 1094 1125 interlace +hsync +vsync (28.1 kHz e)
[    43.955] (II) modeset(0): Modeline "1920x1080"x0.0  148.50  1920 2448 2492 2640  1080 1084 1089 1125 +hsync +vsync (56.2 kHz e)
[    43.955] (II) modeset(0): Modeline "800x600"x0.0   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz e)
[    43.955] (II) modeset(0): Modeline "640x480"x0.0   31.50  640 656 720 840  480 481 484 500 -hsync -vsync (37.5 kHz e)
[    43.955] (II) modeset(0): Modeline "720x400"x0.0   28.32  720 738 846 900  400 412 414 449 -hsync +vsync (31.5 kHz e)
[    43.955] (II) modeset(0): Modeline "1280x1024"x0.0  135.00  1280 1296 1440 1688  1024 1025 1028 1066 +hsync +vsync (80.0 kHz e)
[    43.955] (II) modeset(0): Modeline "1024x768"x0.0   78.75  1024 1040 1136 1312  768 769 772 800 +hsync +vsync (60.0 kHz e)
[    43.955] (II) modeset(0): Modeline "1024x768"x0.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz e)
[    43.955] (II) modeset(0): Modeline "800x600"x0.0   49.50  800 816 896 1056  600 601 604 625 +hsync +vsync (46.9 kHz e)
[    43.955] (II) modeset(0): Modeline "1152x864"x0.0  108.00  1152 1216 1344 1600  864 865 868 900 +hsync +vsync (67.5 kHz e)
[    43.956] (II) modeset(0): Modeline "1280x1024"x0.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz e)
[    43.956] (II) modeset(0): Modeline "1600x900"x60.0  119.00  1600 1696 1864 2128  900 901 904 932 -hsync +vsync (55.9 kHz e)
[    44.496] (EE) modeset(0): Failed to get GBM bo for flip to new front.
[    44.496] (EE) modeset(0): present flip failed
[    45.069] (EE) modeset(0): Failed to get GBM bo for flip to new front.
[    45.069] (EE) modeset(0): present flip failed
[    45.079] (EE) modeset(0): Failed to get GBM bo for flip to new front.
[    45.079] (EE) modeset(0): present flip failed
[    45.095] (EE) modeset(0): Failed to get GBM bo for flip to new front.
[    45.095] (EE) modeset(0): present flip failed
[    45.123] (EE) modeset(0): Failed to get GBM bo for flip to new front.
[    45.123] (EE) modeset(0): present flip failed
[    45.131] (EE) modeset(0): Failed to get GBM bo for flip to new front.
[    45.131] (EE) modeset(0): present flip failed
[    45.176] (EE) modeset(0): Failed to get GBM bo for flip to new front.
[    45.176] (EE) modeset(0): present flip failed
[    45.179] (EE) modeset(0): Failed to get GBM bo for flip to new front.
[    45.179] (EE) modeset(0): present flip failed
[    45.195] (EE) modeset(0): Failed to get GBM bo for flip to new front.
[    45.195] (EE) modeset(0): present flip failed
[    45.265] (EE) modeset(0): Failed to get GBM bo for flip to new front.
[    45.265] (EE) modeset(0): present flip failed


Il file XOrg1.log mi sembra invece normale.

Allego comunque i due files XOrg0.log e XOrg1.log.

Stavolta (sono rientrata ora in ufficio) il pc si è bloccato subito dopo il log-in.

Grazie per qualsiasi aiuto su come risolvere, buona giornata,

Stéphanie
stephanie
Newbie
Newbie
 
Messaggi: 35
Iscritto il: 05/08/2017, 12:44

Re: Debian Buster dopo aggiornamento si blocca ripetutament

Messaggioda stephanie » 30/11/2018, 17:53

Ho trovato questo link relativo a Redhat:

https://bugzilla.redhat.com/show_bug.cgi?id=1645553

Potrebbe essere un bug di XOrg dopo l'aggiornamento?

Grazie e buona serata,

Stéphanie
stephanie
Newbie
Newbie
 
Messaggi: 35
Iscritto il: 05/08/2017, 12:44

Re: Debian Buster dopo aggiornamento si blocca ripetutament

Messaggioda stephanie » 30/11/2018, 19:17

Buonasera a tutti,

ho provato ad installare Gnome3 con gdm, utilizzando wayland invece di XOrg il sistema sembrerebbe funzionare senza bloccarsi.

Questa soluzione crea però due problemi:

1) Alcuni applicativi (tra cui quelli scritti con Lazarus) sembrano non funzionare sotto wayland:

https://forum.lazarus.freepascal.org/in ... ic=39968.0

2) Synaptic non funziona sotto wayland:

https://ubuntuforums.org/showthread.php?t=2375138

e la soluzione proposta nel thread linkato sopra a me purtroppo non funziona:

Codice: Seleziona tutto
root@PcServer:/home/stephanie# xhost +si:localuser:root
No protocol specified
xhost:  unable to open display ":0"
root@PcServer:/home/stephanie#


Il secondo punto potrei accettarlo lavorando con apt-get o aptitude, per il primo ho necessità di trovare in qualche modo una soluzione, che può ripresentarsi con software che richiedano l'ambiente grafico X11, che in wayland viene solo emulato.

Per cercare di trovare una soluzione ho provato ad avviare Debian con Gnome 3 e XOrg, purtroppo dopo un paio d'ore il sistema si è nuovamente bloccato, questa volta il blocco è durato molto meno (uno o due minuti credo), ma comunque c'è stato.

In /var/log sembra che i files XOrg.0.log e XOrg1log non vengano più aggiornati, mentre in .local/schare/xorg il file XOrg.0.log non presenti particolari anomalie (lo allego comunque).

Grazie per qualsiasi aiuto.

Buona serata,

Stéphanie
Allegati
Xorg.0.7z
(6.55 KiB) Scaricato 16 volte
Ultima modifica di stephanie il 30/11/2018, 23:39, modificato 1 volta in totale.
stephanie
Newbie
Newbie
 
Messaggi: 35
Iscritto il: 05/08/2017, 12:44

Re: Debian Buster dopo aggiornamento si blocca ripetutament

Messaggioda stephanie » 30/11/2018, 23:02

Aggiornamento: purtroppo credevo di avere risolto, ma il problema di XOrg si verifica anche con Gnome 3, anche se sembra in maniera meno invasiva che con Mate.

Ho aggiornato i dettagli nel post precedente.

L'ideale sarebbe a questo punto se in qualche modo riuscissi a fare funzionare le applicazioni che richiedono X11 con wayland. Soprattutto ho un gestionale scritto in Lazarus che tra l'altro è l'applicazione principale che gira sul pc.

In extremis potrei pensare a virtualizzare una macchina con un'altra distribuzione (o per lo meno una Debian Stable) su cui fare girare il gestionale... ma non sarebbe proprio il massimo... Da anni ho fatto la scelta di usare Linux proprio per avere un sistema stabile, e vorrei trovare una soluzione più ortodossa.

È possibile tentare un downgrade di XOrg?

Secondo voi possono esserci miglioramenti riducendo la risoluzione del monitor oppure la frequenza di aggiornamento? Attualmente la risoluzione è 1920 * 1080 con aggiornamento a 30 Hz, sto provando a fare qualche tentativo, adesso sono passata a 1600*900, ma non ho idea se fare qualche tentativo su questi due parametri possa servire a qualcosa.

Grazie per qualsiasi aiuto, non so più dove sbattere la testa...

Buona serata,

Stéphanie
stephanie
Newbie
Newbie
 
Messaggi: 35
Iscritto il: 05/08/2017, 12:44

Re: Debian Buster dopo aggiornamento si blocca ripetutament

Messaggioda mrdebug » 01/12/2018, 9:53

Ciao, ciò che descrivi non sono problemi da poco ma direi piuttosto seri. Io è da un po' di anni che mi rifiuto di provare le distribuzioni in testing appunto perché uso il pc per lavoro e non mi posso permettere un fermo macchina.

Per la faccenda lazarus, che è basato su fpc, che è normalmente basato su gtk l'unica cosa che mi viene da pensare sono i driver della scheda video.
Sono quelli open source o quelli del produttore?
Se hai modo di usare quelli del produttore essi normalmente sono più performanti di quelli open.
Firefox - chrome funzionano? OpenGL?
mrdebug
Sr. Member
Sr. Member
 
Messaggi: 344
Iscritto il: 23/07/2005, 7:38

Re: Debian Buster dopo aggiornamento si blocca ripetutament

Messaggioda stephanie » 01/12/2018, 10:24

Ciao e grazie della risposta,

in effetti per me è un problema piuttosto serio, penso che da ora in poi non installerò più testing, finora avevo scelto le testing come compromesso tra la stable e la unstable, per avere pacchetti abbastanza aggiornati senza grossi problemi, ed in effetti in tutti questi anni blocchi non ne avevo mai avuti.

Guardando in rete, mi sembra che blocchi dovuti a XOrg con Mate siano successi anche su Fedora e su Ubuntu (pure derivata dalla testing), la cosa che mi lascia perplessa è che alcuni post risalgono addirittura a questa primavera.

In ogni caso mi sembra che anche Stretch abbia la stessa identica versione di XOrg, ma forse essendo gli altri pacchetti meno recenti il conflitto non si verifica.

Non ho installato nessun driver della scheda video, quindi direi che siano quelli open:

Codice: Seleziona tutto
stephanie@PcServer:~$ lspci | grep -E 'VGA|Display|3D'
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 630 (rev 04)
stephanie@PcServer:~$


Guardando sul sito della Intel non vedo però aihmé drivers per Linux della Graphics 630:

https://www.intel.it/content/www/it/it/ ... s-630.html

Firefox e Chrome funzionano. OpenGL è presente, se do' il comando:

Codice: Seleziona tutto
stephanie@PcServer:~$ glxinfo | grep "OpenGL version"
OpenGL version string: 3.0 Mesa 18.2.5
stephanie@PcServer:~$


Adesso sto provando con la risoluzione a 1600*900, non so se una risoluzione inferiore possa in qualche modo permettere ai drivers open di lavorare meglio.

Grazie per ogni aiuto, perché non ho idea di come fare, e pensare che fino a due giorni fa era tutto perfetto...

Buona giornata a tutti,

Stéphanie
stephanie
Newbie
Newbie
 
Messaggi: 35
Iscritto il: 05/08/2017, 12:44

Re: Debian Buster dopo aggiornamento si blocca ripetutament

Messaggioda Spoon » 01/12/2018, 11:44

Ciao, hai provato a guardare se il tuo problema è riportato in uno di questi bug report?
https://bugs.debian.org/cgi-bin/pkgrepo ... ing#_1_3_5

Da come lo descrivi uno dei colpevoli potrebbe essere il driver video, anche se non ho grandissime speranze a riguardo essendo una scheda non nuovissima e integrata. Visto che il problema si è presentato dopo l'aggiornamento, che pacchetti hai aggiornato? I log relativi sono /var/log/dkpg.log e quelli contenuti in /var/log/apt. Può essere che synaptic tenga un suo log ma non usandolo non ne sono a conoscenza.
Spoon
wiki member
wiki member
 
Messaggi: 336
Iscritto il: 23/11/2013, 14:37

Re: Debian Buster dopo aggiornamento si blocca ripetutament

Messaggioda stephanie » 01/12/2018, 14:20

Ciao e grazie della risposta,

ho provato a guardare nei bug reports, i due più simili sono:

https://bugs.debian.org/cgi-bin/bugrepo ... bug=575965
https://bugs.debian.org/cgi-bin/bugrepo ... bug=787267

anche se non sono identici.

Nel mio caso il problema maggiore è stato il conflitto tra XOrg e Mate, da quando sono passata a Gnome 3 la situazione è infatti migliorata notevolmente, i blocchi sono ora molto più distanziati (prima avvenivano a pochi minuti di distanza) e molto più brevi (un paio di minuti contro i 10-12 minuti di prima).

Da quando ho ridotto la risoluzione a 1600*900 la situazione mi sembra ancora migliorata. Questa mattina il primo blocco si è verificato circa un'ora e mezza dopo l'avvio e, per la prima volta, non paralizzava completamente il sistema. Stavo lavorando su MuseScore ed improvvisamente non riuscivo più a selezionare le note, cliccando però in alto a sinistra su Attività di Gnome vedevo le altre finestre aperte, ho potuto andare su Firefox e scrivere un indirizzo nella barra, poi comunque anche Firefox non visualizzava la pagina, ma almeno la tastiera stavolta non era bloccata. Ho provato a disconnettermi dalla rete, visualizzavo il messaggio in disconnessione, ha impiegato molto tempo a scollegarsi (però il mouse funzionava). Dopo è apparsa la finestra "MuseScore non risponde", ho scelto di attendere. Dopo un po' la situazione si è finalmente sbloccata ed il pc ha ripreso a funzionare.

Con Gnome 3 / XOrg e la risoluzione a 1920 * 1080 i blocchi erano totali, come con Mate (anche se molto meno frequenti e più rapidi rispetto a Mate). Adesso sembrerebbero parziali, nel senso che almeno si riesce a passare da una finestra all'altra e ad usare la testiera durante i blocchi.

Ora sto tenendo controllata la situazione, eventualmente potrei provare ridurre ancora la risoluzione a 1024*768, anche se sarebbe davvero un po' scarsa, soprattutto con un monitor da 27 pollici.

Eventualmente sarebbe possibile disabilitare l'accelerazione video per tenere la situazione il più semplice possibile?

Il file /var/log/dkpg.log non mi sembra dia molte informazioni, mentre in /var/log/apt l'history.log fornisce il dettaglio dell'upgrade che avevo fatto. Credo che fossero almeno 2-3 mesi che non aggiornavo il sistema, con la testing vado normalmente cauta e visto che non avevo problemi ero rimasta ferma. Purtroppo ho avuto un problema di malfunzionamento di PulseAudio e nel tentare di risolverlo ho aggiornato il sistema (alla fine invece era un conflitto con timidity e bastava un killall timidity che teneva bloccato PulseAudio, poi ho disinstallato timidity-daemon che altrimenti continuava dopo ogni avvio a tenere bloccato PulseAudio).

Dell'aggiornamento i files che riguardano XOrg mi sembrano questi:

Codice: Seleziona tutto
xserver-xorg-video-qxl:amd64 (0.1.5-2, 0.1.5-2+b1), xserver-xorg-video-vesa:amd64 (1:2.3.4-1+b2, 1:2.4.0-1), xserver-xorg-video-nouveau:amd64 (1:1.0.15-2, 1:1.0.15-3), xserver-xorg-video-amdgpu:amd64 (18.0.1-1, 18.1.0-1), xserver-xorg-core:amd64 (2:1.19.6-1, 2:1.20.3-1), xserver-xorg-video-fbdev:amd64 (1:0.4.4-1+b5, 1:0.5.0-1), xserver-xorg-input-libinput:amd64 (0.27.1-1, 0.28.1-1), xserver-xorg-legacy:amd64 (2:1.19.6-1, 2:1.20.3-1), xserver-xorg-video-intel:amd64 (2:2.99.917+git20171229-1, xserver-xorg-video-vmware:amd64 (1:13.2.1-1+b1, 1:13.3.0-2), xserver-xorg-video-ati:amd64 (1:18.0.1-1, 1:18.1.0-1), xserver-xorg-video-radeon:amd64 (1:18.0.1-1, 1:18.1.0-1),


L'ultima cosa, mi sono accorta che XSane non vedeva più lo scanner, una multifunzione Xerox WorkCentre 3225 con drivers per Linux, la stampante funzionava, lo scanner no. Disinstallando e reinstallando il driver dello scanner ora funziona di nuovo. Non credo che questo abbia a che fare con il blocco, penso sia dovuto solo all'aggiornamento di Debian che ha effettuato l'update di xsane (xsane-common:amd64 (0.999-5, 0.999-6), xsane:amd64 (0.999-5, 0.999-6+b1) ), ma anche i drivers della Xerox installano due librerie, di cui una sicuramente collegata a xsane (libsane-smfp.so.1.0.1 e libscmssc.so).

Grazie per qualsiasi aiuto.

Buona giornata a tutti,

Stéphanie
Allegati
dpkg_copy.7z
(1.64 KiB) Scaricato 13 volte
history.log.7z
(26.27 KiB) Scaricato 14 volte
stephanie
Newbie
Newbie
 
Messaggi: 35
Iscritto il: 05/08/2017, 12:44

Re: Debian Buster dopo aggiornamento si blocca ripetutament

Messaggioda stephanie » 04/12/2018, 21:48

Buonasera a tutti,

ieri ho provato a ridurre ulteriormente la risoluzione a 1280 * 720, ma il sistema ha cominciato ad accusare molti più blocchi e di nuovo totali, per cui ho riportato la risoluzione a 1600 * 900. La cosa strana è che dopo avere cambiato risoluzione sembra che sia rimasta più facilità ai blocchi, rispetto a prima, anche una volta tornata a 1600 * 900, quindi ho riavviato il pc.

Dopo ho provato a scegliere da Grub il kernel precedente, versione 4.16.0.2 (invece della 4.18.0.2). Per ora sembrerebbe che questa soluzione funzioni, nel senso che sia ieri sera che oggi non si sono più verificati blocchi, anche se il condizionale è d'obbligo e devo attendere ancora qualche giorno per potere essere sicura. In ogni caso, per non correre rischi, sono rimasta con Gnome 3 e la risoluzione a 1600 * 900.

L'aggiornamento che ha creato problemi non ha tuttavia toccato il kernel, è possibile che ci siano problemi con la più recente versione di XOrg ed il nuovo kernel, per lo meno con le mia scheda Intel.

Spero che il futuro aggiornamento del kernel alla versione 4.20, qualora non risolvesse il problema, non mi precluda comunque la possibilità di continuare ad usare la 4.16.0.2.

Ne approfitto per una domanda: è possibile impostare il kernel 4.16.0.2 come predefinito per non dovere sempre avviare con le impostazioni avanzate tutte le volte?

Grazie e buona serata a tutti,

Stéphanie
stephanie
Newbie
Newbie
 
Messaggi: 35
Iscritto il: 05/08/2017, 12:44

Re: Debian Buster dopo aggiornamento si blocca ripetutament

Messaggioda Spoon » 05/12/2018, 14:02

Se con il kernel 4.16 funziona deve esserci qualche conflitto tra le nuove versioni di kernel e Xorg, come dici tu. Immagino tu stia usando il driver i915 giusto?
Posso provare a fare qualche tentativo ma dubito di avere le conoscenze tecniche necessarie per poter risolvere a fondo la questione. Potresti fare qualche prova
  • usando l'opzine "nomodeset" al boot
  • avviando con il driver generico vesa (anche se su un 27" potrebbe non essere il massimo)
  • tenendo sotto controllo utilizzo di RAM e swap, per quanto non mi sembri questo il caso esiste la possibilita' che i blocchi si verifichino per l'utilizzo intensivo della swap
Spoon
wiki member
wiki member
 
Messaggi: 336
Iscritto il: 23/11/2013, 14:37

Prossimo

Torna a Generale

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti