Debian Buster dopo aggiornamento si blocca ripetutamente

Discussioni relative a Debian e Linux

Re: Debian Buster dopo aggiornamento si blocca ripetutament

Messaggioda Underpass » 05/12/2018, 15:51

Quale driver i915 stai usando? Mi pare che esista anche come pacchetto nei repository.
Materia: contrasta i tentativi di mutazione operati dal Tempo, resiste agli attacchi dell'Energia, costringe il Pensiero a divenire pratico.
Avatar utente
Underpass
Hero Member
Hero Member
 
Messaggi: 729
Iscritto il: 09/08/2006, 2:09

Re: Debian Buster dopo aggiornamento si blocca ripetutament

Messaggioda stephanie » 05/12/2018, 21:42

Ciao e grazie per le risposte,

confermo che sto usando il driver i915:

Codice: Seleziona tutto
        *-display
             description: VGA compatible controller
             product: Intel Corporation
             vendor: Intel Corporation
             physical id: 2
             bus info: pci@0000:00:02.0
             version: 04
             width: 64 bits
             clock: 33MHz
             capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
             configuration: driver=i915 latency=0
             resources: irq:124 memory:f6000000-f6ffffff memory:e0000000-efffffff ioport:f000(size=64) memory:c0000-dffff


Il pacchetto xserver-xorg-video-intel, che contiene i drivers i915, è installato nel sistema (lo era anche da prima del problema, perché l'upgrade che ha innescato il problema l'ha solo aggiornato (xserver-xorg-video-intel:amd64 (2:2.99.917+git20171229-1, 2:2.99.917+git20180925-2)).

Ho visto che nel dettaglio del pacchetto è tuttavia indicato "L'uso di questo driver è sconsigliato se il proprio HW è abbastanza recente (da circa il 2007 in poi). Si può provare a disinstallare questo driver e lasciare che il server usi invece il suo driver di modesetting incorporato."

Il pc è abbastanza nuovo, del 2017, tuttavia ho un po' timore a rimuovere questo pacchetto di combinare qualche guaio, adesso avviando con il kernel 4.16.0.2 sembra funzionare tutto perfettamente, anche se prudenzialmente ho mantenuto Gnome 3 e la risoluzione a 1600*900, anche se da quello che mi sembra di vedere, la disinstallazione del pacchetto non dovrebbe creare problemi:

https://ubuntuforums.org/showthread.php?t=2327307
https://ubuntuforums.org/showthread.php?t=2378753

Avevo anche provato a modificare il file /etc/default/grub mettendo GRUB_DEFAULT=4 (visto che nell'ordine vengono proposti, andando in opzioni avanzate i kernel 4.18.0.3, apparso oggi dopo il riavvio a seguito del comando update-grub, 4.18.0.2 ed infine 4.16.0.2, ciascuno con modalità ricovery mode), ma non ho visto differenze, devo andare sempre in opzioni avanzate Linux e scegliere il kernel 4.16.0.2.

Non so bene cosa fare, se visto che con il kernel 4.16 funziona correttamente sia meglio starmene tranquilla fintanto che Buster non sarà rilasciata come stable, oppure se valga la pena fare qualche altro tentativo, senza però correre rischi visto che il pc lo uso per lavoro.

Ancora grazie di tutto l'aiuto, buona serata,

Stéphanie
stephanie
Newbie
Newbie
 
Messaggi: 35
Iscritto il: 05/08/2017, 12:44

Re: Debian Buster dopo aggiornamento si blocca ripetutament

Messaggioda Underpass » 06/12/2018, 12:53

Ciao, io sul mio PC precedente (del 2007) avevo avuto problemi con questo driver dei repository e avevo rimosso il pacchetto. Dopodiché non avevo avuto più problemi.

Il driver i915 è contenuto nel kernel, secondo me la prova la puoi fare. Eventualmente lo reinstalli.
Materia: contrasta i tentativi di mutazione operati dal Tempo, resiste agli attacchi dell'Energia, costringe il Pensiero a divenire pratico.
Avatar utente
Underpass
Hero Member
Hero Member
 
Messaggi: 729
Iscritto il: 09/08/2006, 2:09

Re: Debian Buster dopo aggiornamento si blocca ripetutament

Messaggioda Aki » 08/12/2018, 11:58

Scusate se mi inserisco.

La distribuzione "testing" ha come finalità quella di evidenziare le anomalie dei programmi eventualmente non rilevate precedentemente nella distribuzione "unstable", come potrebbe essere (da confermare) nel caso che hai segnalato. Ciò al fine di interessare i manutentori dei pacchetti Debian affinché le segnalazioni siano analizzate (con l'aiuto dei segnalanti) e, se confermate, affinché siano apportate le correzioni del caso ai pacchetti nelle distribuzioni "unstable", "testing" ed, infine, per il successivo rilascio in Debian "stable".

Il principale strumento utile a tal fine è il bug tracking system di Debian (http://bugs.debian.org) .

Pertanto, se possibile, sarebbe utile che creassi un bug report da inviare tramite bug tracking system di Debian (http://bugs.debian.org) riferendo in dettaglio quanto hai riscontrato. Le indicazioni su come effettuare la segnalazione le trovi in https://www.debian.org/Bugs/Reporting. Sono disponibili anche programmi grafici per agevolare tale compito (come reportbug-ng). Sarebbe utile riportate in questa discussione il link al bug report.

In tal modo, saresti di aiuto oltre a te stessa, anche agli altri membri della comunità/utilizzatori di Debian.
Aki
Global Moderator
Global Moderator
 
Messaggi: 8163
Iscritto il: 27/12/2007, 16:59

Re: Debian Buster dopo aggiornamento si blocca ripetutament

Messaggioda stephanie » 09/12/2018, 15:04

Grazie per tutte le risposte, ho disinstallato xserver-xorg-video-intel senza problemi, ma senza risolvere, nel senso che se scelgo nuovamente il kernel 4.18 i blocchi si verificano come prima.

Ho notato all'avvio del sistema, dopo avere scelto il kernel, un messaggio failed to load i915 kbl vers 1.04, non sono riuscita a scriverlo esattamente perché poi si apre subito la finestra del log-in, presumibilmente c'era anche prima e non ci ho mai fatto caso anche perché appare verso la fine dei messaggi di avvio prima che appaia poi la finestra del log-in.

Ho già scaricato il pacchetto ReportBug-NG (grazie per il suggerimento) e cercherò di segnalare il bug. Ho aspettato finora di finire gli ultimi tentativi per potere circoscrivere maggiormente il problema. Mi sembra che il bug derivi da questi tre elementi insieme: X.Org X Server 2:1.20.3-1, il kernel Linux 4.18.0.X e la mia scheda grafica VGA compatible controller: Intel Corporation HD Graphics 630 (rev 04) , con effetti molto peggiori su Mate rispetto a Gnome 3, meno impattanti a 1600*900 che a 1920*1080 oppure a 1280*720. Il problema principale per me sarà DI riuscire a riassumere il problema in un inglese comprensibile :-)

Con il kernel 4.16 funziona tutto correttamente, da oggi ho provato a passare a XFCE invece di GNOME 3 con risoluzione piena (1920*1080), per ora sembra funzionare tutto.

Quello che ora mi sarebbe utile (anche se non fondamentale, sarebbe solo una comodità in più), se fattibile senza rischi visto che uso il pc per lavoro, sarebbe di fare partire il kernel 4.16 come predefinito all'avvio del sistema. Ho provato a modificare il file /etc/default/grub mettendo GRUB_DEFAULT=4, senza risolvere, non ho fatto tentativi più complessi per paura di non riuscire poi a riavviare correttamente. Comunque alla fine è un dettaglio, l'importante è essere in qualche modo riuscita a bypassare il problema ed utilizzare il pc.

Ancora grazie e buona domenica a tutti,

Stéphanie
stephanie
Newbie
Newbie
 
Messaggi: 35
Iscritto il: 05/08/2017, 12:44

Re: Debian Buster dopo aggiornamento si blocca ripetutament

Messaggioda Aki » 09/12/2018, 15:13

stephanie ha scritto:Ho notato all'avvio del sistema, dopo avere scelto il kernel, un messaggio failed to load i915 kbl vers 1.04, non sono riuscita a scriverlo esattamente perché poi si apre subito la finestra del log-in, presumibilmente c'era anche prima e non ci ho mai fatto caso anche perché appare verso la fine dei messaggi di avvio prima che appaia poi la finestra del log-in.

Avviando il sistema nelle condizioni in cui si genera l'errore ed usando lo script http://guide.debianizzati.org/index.php/Creazione_automatica_di_un_file_di_log_per_inviare_quesiti_al_forum , puoi generare un file di log che dovrebbe contenere il messaggio di errore a cui sopra fai riferimento, in modo da poterlo meglio analizzare. In ogni caso, se possibile, fornisci l'output del seguente comando:
Codice: Seleziona tutto
su -l -c "journalctl --no-pager | grep i915"
Aki
Global Moderator
Global Moderator
 
Messaggi: 8163
Iscritto il: 27/12/2007, 16:59

Re: Debian Buster dopo aggiornamento si blocca ripetutament

Messaggioda stephanie » 09/12/2018, 16:24

Ciao e grazie della risposta,

ecco l'output del comando, che contiene il messaggio visualizzato all'avvio:

Codice: Seleziona tutto
stephanie@PcServer:~$ su -l -c "journalctl --no-pager | grep i915"
dic 09 11:39:46 PcServer kernel: i915 0000:00:02.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=io+mem:owns=io+mem
dic 09 11:39:46 PcServer kernel: [drm] Initialized i915 1.6.0 20171222 for 0000:00:02.0 on minor 0
dic 09 11:39:46 PcServer kernel: i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
dic 09 11:39:46 PcServer kernel: i915 0000:00:02.0: firmware: failed to load i915/kbl_dmc_ver1_04.bin (-2)
dic 09 11:39:46 PcServer kernel: i915 0000:00:02.0: Direct firmware load for i915/kbl_dmc_ver1_04.bin failed with error -2
dic 09 11:39:46 PcServer kernel: i915 0000:00:02.0: Failed to load DMC firmware i915/kbl_dmc_ver1_04.bin. Disabling runtime power management.
dic 09 11:39:46 PcServer kernel: i915 0000:00:02.0: DMC firmware homepage: https://01.org/linuxgraphics/downloads/firmware
dic 09 11:39:46 PcServer kernel: snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
stephanie@PcServer:~$


Il link riportato rimanderebbe a:

https://git.kernel.org/pub/scm/linux/ke ... /tree/i915

Dovrei provare a scaricare il file kbl_dmc_ver1_04.bin e ad installarlo o riguardando solo il runtime power management non ha molta importanza?

Il link, per il DMC, riporta:

Codice: Seleziona tutto
DMC provides additional graphics low-power idle states. It provides capability to save and restore display registers across these low-power states independently from the OS/Kernel.


Ancora grazie e buona domenica,

Stéphanie
stephanie
Newbie
Newbie
 
Messaggi: 35
Iscritto il: 05/08/2017, 12:44

Re: Debian Buster dopo aggiornamento si blocca ripetutament

Messaggioda Aki » 09/12/2018, 16:36

I file mancanti fanno parte del firmware (il software all'interno) della scheda grafica. Per installare i file mancanti, puoi impartire i seguenti comandi come utente root:
Codice: Seleziona tutto
wget http://ftp.us.debian.org/debian/pool/non-free/f/firmware-nonfree/firmware-misc-nonfree_20180825+dfsg-1~bpo9+1_all.deb
dpkg -i firmware-misc-nonfree_20180825+dfsg-1~bpo9+1_all.deb

Al successivo riavvio saranno caricati dal sistema operativo e l'errore non dovrebbe più presentarsi.

La mancanza di firmware potrebbe essere parte della catena causale dei malfunzionamenti che riferisci.

EDIT: fatto salvo non stai scrivendo da una regione del mondo diversa dall'Italia, l'orologio di sistema sembra riportare un orario errato.
Aki
Global Moderator
Global Moderator
 
Messaggi: 8163
Iscritto il: 27/12/2007, 16:59

Re: Debian Buster dopo aggiornamento si blocca ripetutament

Messaggioda stephanie » 09/12/2018, 19:43

Grazie mille, ora il messaggio di errore non compare più.

Adesso devo fare qualche test con il kernel 4.18 per vedere se i blocchi si verificano ancora oppure no.

L'ora di sistema mi sembra corretta, perché il comando date mi riporta l'ora giusta:

Codice: Seleziona tutto
stephanie@PcServer:~$ date
dom  9 dic 2018, 19.35.47, CET
stephanie@PcServer:~$


Credo che nel comando su -l -c "journalctl --no-pager | grep i915" venisse visualizzato l'orario dell'avvio.

Ancora grazie, vi aggiorno se si verificheranno ancora blocchi con il kernel 4.18 dopo l'installazione del pacchetto firmware-misc-nonfree_20180825+dfsg-1~bpo9+1_all.

Buona domenica sera ed ancora grazie,

Stéphanie
stephanie
Newbie
Newbie
 
Messaggi: 35
Iscritto il: 05/08/2017, 12:44

Re: Debian Buster dopo aggiornamento si blocca ripetutament

Messaggioda stephanie » 10/12/2018, 12:34

Buongiorno a tutti,

ho provato a riavviare con il kernel 4.18 dopo avere installato il pacchetto firmware-misc-nonfree_20180825+dfsg-1~bpo9+1_all . Purtroppo, anche se all'avvio non compare più nessun messaggio di errore, i blocchi si sono verificati di nuovo.

Nell'ultimo blocco avevo aperta una finestra del terminale che funzionava regolarmente, mentre (con Gnome 3 a 1600*900) le altre finestre si potevano vedere, ma erano bloccate.

Da quanto non uso più Mate sembra che i log di Xorg non vengano più aggiornati in /var/log.

Credo quindi che dovrò segnalare il bug, spero possa poi venire risolto nei successivi aggiornamenti, anche se mi rendo conto che è sicuramente complicato per il team di Debian riuscire a riprodurre il problema, perché sembra riguardare tre elementi insieme, la scheda video, il kernel 4.18 con la versione aggiornata di XOrg.

L'unica cosa, spero che la possibilità di avviare con il kernel 4.16 rimanga sempre, anche con i prossimi aggiornamenti di Buster (lo presumo, perché all'avvio permette di scegliere indietro fino alla versione 4.13), anche se sarei propensa ad essere molto cauta con gli aggiornamenti, per lo meno finché Buster non sarà rilasciata come stable.

Ancora grazie per tutto l'aiuto, per il momento sceglierò manualmente il kernel 4.16 ad ogni avvio, per fortuna in questo modo funziona tutto correttamente, ero davvero preoccupata perché i blocchi rendevano altrimenti praticamente inutilizzabile il pc.

Buon inizio settimana a tutti,

Stéphanie
stephanie
Newbie
Newbie
 
Messaggi: 35
Iscritto il: 05/08/2017, 12:44

Precedente

Torna a Generale

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti