[RISOLTO] Dopo l'ultimo aggiornamento l'audio non funziona

Discussioni relative a Debian e Linux

[RISOLTO] Dopo l'ultimo aggiornamento l'audio non funziona

Messaggioda PallaBall » 12/07/2019, 15:40

Salve a tutti,
oggi ho eseguito l'update di sistema e la conseguenza è stata che l'audio non è più riconosciuto.
Dalle impostazioni del suono vedo solamente un device "Dummy Output"

eseguendo un lspci ecco cosa vedo:

Codice: Seleziona tutto
00:1f.3 Audio device: Intel Corporation Device 9d71 (rev 21)



Come posso ripristinare l'audio?

Vi informo che quando attaccavo le cuffie il sistema mi riconosceva automaticamente che potevo scegliere una delle seguenti opzioni:
- solo audio
- audio + microfono
- solo microfono

Aggiungo che in recovery mode trovo il seguente messaggio (vedi allegato)



Grazie
Allegati
screenshot.jpg
screenshot.jpg (62.28 KiB) Osservato 1069 volte
Ultima modifica di PallaBall il 22/07/2019, 19:17, modificato 1 volta in totale.
Tutti sanno che una cosa è impossibile da realizzare, finchè arriva uno sprovveduto che non lo sa e la inventa. (Albert Einstein)
Immagine Immagine
Avatar utente
PallaBall
Full Member
Full Member
 
Messaggi: 129
Iscritto il: 14/06/2008, 18:40
Località: Italia

Re: Dopo l'ultimo aggiornamento l'audio non funziona

Messaggioda PallaBall » 12/07/2019, 20:45

Dovrei aver trovato una parte della soluzione al problema:

In giro per internet ho trovato che bisogna impostare alsa per selezionare correttamente l'output in Settings->Sound. Il seguente link spiega quello che ho tentato di fare: https://www.linuxuprising.com/2018/06/f ... ue-in.html

Purtroppo vedo la nuova scheda (solamente per output), ma non si sente nulla.

P-er verificare il device che ho ho eseguito il seguente comando:
Codice: Seleziona tutto
lspci -nnk | grep -A2 Audio
00:1f.3 Audio device [0403]: Intel Corporation Device [8086:9d71] (rev 21)
   Subsystem: Dell Device [1028:0786]
   Kernel driver in use: snd_hda_intel


Domanda: come faccio a compilare correttamente il file /etc/modprobe.d/alsa-base.conf per la mia scheda audio?

Attualmente ho messo:
Codice: Seleziona tutto
options snd-hda-intel model=generic
Tutti sanno che una cosa è impossibile da realizzare, finchè arriva uno sprovveduto che non lo sa e la inventa. (Albert Einstein)
Immagine Immagine
Avatar utente
PallaBall
Full Member
Full Member
 
Messaggi: 129
Iscritto il: 14/06/2008, 18:40
Località: Italia

Re: Dopo l'ultimo aggiornamento l'audio non funziona

Messaggioda Aki » 13/07/2019, 9:12

Puoi fornire un log più dettagliato usando lo script citato in calce nel mio messaggio ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 8704
Iscritto il: 27/12/2007, 16:59

Re: Dopo l'ultimo aggiornamento l'audio non funziona

Messaggioda PallaBall » 14/07/2019, 19:59

Allego il log.

Aggiungo che proprio in questo momento mi stanno funzionando le casse del mio PC e quando attacco le cuffie posso sentire l'audio (non so perchè forse la mia ultima modifica che vi ho descritto).

Comunque quando inserisco il jack non mi fa scegliere alcuna opzione e quindi non posso usare il microfono delle cuffie, ma solamente quello del PC


Grazie
Allegati
log_14Jul_205631.xz
(59.23 KiB) Scaricato 25 volte
Tutti sanno che una cosa è impossibile da realizzare, finchè arriva uno sprovveduto che non lo sa e la inventa. (Albert Einstein)
Immagine Immagine
Avatar utente
PallaBall
Full Member
Full Member
 
Messaggi: 129
Iscritto il: 14/06/2008, 18:40
Località: Italia

Re: Dopo l'ultimo aggiornamento l'audio non funziona

Messaggioda Aki » 14/07/2019, 21:05

PallaBall ha scritto:Aggiungo che proprio in questo momento mi stanno funzionando le casse del mio PC e quando attacco le cuffie posso sentire l'audio (non so perchè forse la mia ultima modifica che vi ho descritto).

Quindi il malfunzionamento è risolto ?

PallaBall ha scritto:Comunque quando inserisco il jack non mi fa scegliere alcuna opzione e quindi non posso usare il microfono delle cuffie, ma solamente quello del PC

Le cuffie hanno un cavo con jack separato per il microfono inserito nel connettore dedicato al microfono esterno ? Scusa la banalità della domanda, sei sicuro di aver inserito il jack del microfono nel connettore del microfono ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 8704
Iscritto il: 27/12/2007, 16:59

Re: Dopo l'ultimo aggiornamento l'audio non funziona

Messaggioda PallaBall » 15/07/2019, 7:24

Il malfunzionamento non è risolto in quanto non ho la stessa situazione di prima.

L'audio funziona non ho tutte le opzioni di prima.

Le cuffie hanno un solo Jack e prima il sistema mi riconosceva le opzioni come descritto nel primo post (prima potevo usare le cuffiette del cellulare per fare delle chiamate con Skype o zoom , ora no perché il microfono riconosciuto è solamente quello del PC e si sentono tutti i rumori o devo parlare ad alta voce )


Grazie
Tutti sanno che una cosa è impossibile da realizzare, finchè arriva uno sprovveduto che non lo sa e la inventa. (Albert Einstein)
Immagine Immagine
Avatar utente
PallaBall
Full Member
Full Member
 
Messaggi: 129
Iscritto il: 14/06/2008, 18:40
Località: Italia

Re: Dopo l'ultimo aggiornamento l'audio non funziona

Messaggioda Aki » 17/07/2019, 8:02

PallaBall ha scritto:oggi ho eseguito l'update di sistema e la conseguenza è stata che l'audio non è più riconosciuto.
Dalle impostazioni del suono vedo solamente un device "Dummy Output"

Quale versione di Debian intendi utilizzare ? Che tipo di aggiornamento hai effettuato ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 8704
Iscritto il: 27/12/2007, 16:59

Re: Dopo l'ultimo aggiornamento l'audio non funziona

Messaggioda PallaBall » 17/07/2019, 9:38

Utilizzo Debian GNU/Linux 9 (stretch) 64-bit

Ti allego il tail sui log di apt:

Codice: Seleziona tutto
tail -1000 /var/log/apt/history.log

Start-Date: 2019-07-05  12:24:52
Commandline: packagekit role='install-packages'
Requested-By: palla (1000)
Install: velocity:amd64 (1.7-5, automatic), libxstream-java:amd64 (1.4.9-2, automatic), libbsf-java:amd64 (1:2.4.0-5, automatic), libcommons-net-java:amd64 (3.5-1, automatic), libjaxp1.3-java:amd64 (1.3.05-2, automatic), libhamcrest-java:amd64 (1.3-6, automatic), libcommons-jexl-java:amd64 (1.1-3, automatic), libjcharts-java:amd64 (0.7.5-4, automatic), libgeronimo-jms-1.1-spec-java:amd64 (1.1-1.2, automatic), libjsoup-java:amd64 (1.10.2-1, automatic), fop:amd64 (1:2.1-6, automatic), libdnsjava-java:amd64 (2.1.8-1, automatic), libhttpmime-java:amd64 (4.5.2-2, automatic), libxalan2-java:amd64 (2.7.1-9, automatic), libcommons-io-java:amd64 (2.5-1, automatic), libxmlgraphics-commons-java:amd64 (2.1-2, automatic), libhtmlparser-java:amd64 (1.6.20060610.dfsg0-5, automatic), libexcalibur-logkit-java:amd64 (2.0-11, automatic), libexcalibur-logger-java:amd64 (2.1-6, automatic), libjline-java:amd64 (1.0-2, automatic), libcommons-jexl2-java:amd64 (2.1.1-3, automatic), libavalon-framework-java:amd64 (4.2.0-9, automatic), libjtidy-java:amd64 (7+svn20110807-4, automatic), libbatik-java:amd64 (1.8-4+deb9u1, automatic), rhino:amd64 (1.7.7.1-1, automatic), jmeter-help:amd64 (2.13-2, automatic), libhttpclient-java:amd64 (4.5.2-2, automatic), libcommons-math3-java:amd64 (3.6.1-2, automatic), jmeter:amd64 (2.13-2), icc-profiles-free:amd64 (2.0.1+dfsg-1, automatic), junit4:amd64 (4.12-4, automatic), libsaxon-java:amd64 (1:6.5.5-10, automatic), libfontbox-java:amd64 (1:1.8.12-1, automatic), libcommons-lang-java:amd64 (2.6-6, automatic), libhttpcore-java:amd64 (4.4.6-1, automatic), libcommons-lang3-java:amd64 (3.5-1, automatic), librhino-java:amd64 (1.7.7.1-1, automatic), libcommons-pool2-java:amd64 (2.4.2-2, automatic), libcommons-httpclient-java:amd64 (3.1-12, automatic), libmongodb-java:amd64 (2.12.4-1, automatic), librsyntaxtextarea-java:amd64 (2.5.0-1, automatic), libfop-java:amd64 (1:2.1-6, automatic), java-wrappers:amd64 (0.1.28, automatic), liboro-java:amd64 (2.0.8a-12, automatic), jmeter-http:amd64 (2.13-2, automatic)
End-Date: 2019-07-05  12:26:00

Start-Date: 2019-07-08  09:18:46
Commandline: apt-get upgrade
Requested-By: palla (1000)
Upgrade: containerd.io:amd64 (1.2.5-1, 1.2.6-3), openssl:amd64 (1.1.0j-1~deb9u1, 1.1.0k-1~deb9u1), skypeforlinux:amd64 (8.47.0.59, 8.48.0.51), libexpat1:amd64 (2.2.0-2+deb9u1, 2.2.0-2+deb9u2), libssl-dev:amd64 (1.1.0j-1~deb9u1, 1.1.0k-1~deb9u1), libssl-doc:amd64 (1.1.0j-1~deb9u1, 1.1.0k-1~deb9u1), libssl1.1:amd64 (1.1.0j-1~deb9u1, 1.1.0k-1~deb9u1), docker-ce:amd64 (5:18.09.6~3-0~debian-stretch, 5:18.09.7~3-0~debian-stretch), libssl1.0.2:amd64 (1.0.2r-1~deb9u1, 1.0.2s-1~deb9u1), docker-ce-cli:amd64 (5:18.09.6~3-0~debian-stretch, 5:18.09.7~3-0~debian-stretch)
End-Date: 2019-07-08  09:20:21

Start-Date: 2019-07-10  12:11:58
Commandline: apt-get upgrade
Requested-By: palla (1000)
Upgrade: postgresql-common:amd64 (201.pgdg90+1, 203.pgdg90+1), libzmq5:amd64 (4.2.1-4+deb9u1, 4.2.1-4+deb9u2), skypeforlinux:amd64 (8.48.0.51, 8.49.0.49), cf-cli:amd64 (6.45.0, 6.46.0), debian-archive-keyring:amd64 (2017.5, 2017.5+deb9u1), postgresql-client-common:amd64 (201.pgdg90+1, 203.pgdg90+1)
End-Date: 2019-07-10  12:12:29

Start-Date: 2019-07-10  17:01:20
Commandline: apt-get install nmap
Requested-By: palla (1000)
Install: liblinear3:amd64 (2.1.0+dfsg-2, automatic), nmap:amd64 (7.40-1), ndiff:amd64 (7.40-1, automatic)
End-Date: 2019-07-10  17:01:40

Start-Date: 2019-07-12  10:17:34
Commandline: packagekit role='update-packages'
Upgrade: teamviewer:amd64 (14.3.4730, 14.4.2669)
End-Date: 2019-07-12  10:17:55
Tutti sanno che una cosa è impossibile da realizzare, finchè arriva uno sprovveduto che non lo sa e la inventa. (Albert Einstein)
Immagine Immagine
Avatar utente
PallaBall
Full Member
Full Member
 
Messaggi: 129
Iscritto il: 14/06/2008, 18:40
Località: Italia

Re: Dopo l'ultimo aggiornamento l'audio non funziona

Messaggioda Aki » 21/07/2019, 10:46

Non mi sembra di vedere nessun pacchetto che implica un cambio di configurazione dell'audio, fatto salvo alcuni programmi proprietari che usando l’audio come, appunto, Skype.

EDIT: hai impostato tu questa configurazione che risulta dai log :
Codice: Seleziona tutto
******************************************
/etc/modprobe.d/alsa-base.conf
******************************************
options snd-hda-intel model=headset-mic probe_mask=0x103

Vedi, inoltre, https://wiki.debian.org/PulseAudio#Missing_playback_devices_or_audio_capture
Aki
Global Moderator
Global Moderator
 
Messaggi: 8704
Iscritto il: 27/12/2007, 16:59

Re: Dopo l'ultimo aggiornamento l'audio non funziona

Messaggioda PallaBall » 22/07/2019, 19:16

Aki ha scritto:Non mi sembra di vedere nessun pacchetto che implica un cambio di configurazione dell'audio, fatto salvo alcuni programmi proprietari che usando l’audio come, appunto, Skype.

EDIT: hai impostato tu questa configurazione che risulta dai log :
Codice: Seleziona tutto
******************************************
/etc/modprobe.d/alsa-base.conf
******************************************
options snd-hda-intel model=headset-mic probe_mask=0x103

Vedi, inoltre, https://wiki.debian.org/PulseAudio#Missing_playback_devices_or_audio_capture


La configurazione l'ho fatta io cercando sul web la configurazione del Dell che ho a disposizione.

Comunque la quida che mi hai indicato è stata ottima e ha risolto il problema

O0
Tutti sanno che una cosa è impossibile da realizzare, finchè arriva uno sprovveduto che non lo sa e la inventa. (Albert Einstein)
Immagine Immagine
Avatar utente
PallaBall
Full Member
Full Member
 
Messaggi: 129
Iscritto il: 14/06/2008, 18:40
Località: Italia

Re: [RISOLTO] Dopo l'ultimo aggiornamento l'audio non funzio

Messaggioda Aki » 23/07/2019, 22:14

Felice di esserti stato d'aiuto.
Aki
Global Moderator
Global Moderator
 
Messaggi: 8704
Iscritto il: 27/12/2007, 16:59


Torna a Generale

Chi c’è in linea

Visitano il forum: Nessuno e 7 ospiti