[RISOLTO] Shutdown Freeze

Discussioni relative a Debian e Linux

[RISOLTO] Shutdown Freeze

Messaggioda SerFeda » 18/07/2019, 20:07

Buonasera a tutti,
ho recentemente fatto l'upgrade da Debian 9 al 10, tuttavia ora mi si presenta un problema alquanto particolare:
quando tento di spegnere o riavviare il sistema, questo si blocca, la schermata diventa tutta nera ma il pc rimane acceso.
Ho provato ad aspettare un pò di tempo ma nulla da fare...
Inoltre ho seguito alcune guide online che consigliavano di mettere nel file del grub "acpi=force", ma senza successo.
Non riesco a spegnerlo da linea di comando e devo fare un arresto forzato tenendo premuto il tasto di accensione ogni volta.
Aiuto please!!! :'(
SerFeda
Newbie
Newbie
 
Messaggi: 6
Iscritto il: 18/07/2019, 19:59

Re: Shutdown Freeze

Messaggioda Aki » 19/07/2019, 7:11

SerFeda ha scritto:Buonasera a tutti,
ho recentemente fatto l'upgrade da Debian 9 al 10, tuttavia ora mi si presenta un problema alquanto particolare:
quando tento di spegnere o riavviare il sistema, questo si blocca, la schermata diventa tutta nera ma il pc rimane acceso.
Ho provato ad aspettare un pò di tempo ma nulla da fare...
Inoltre ho seguito alcune guide online che consigliavano di mettere nel file del grub "acpi=force", ma senza successo.
Non riesco a spegnerlo da linea di comando e devo fare un arresto forzato tenendo premuto il tasto di accensione ogni volta.
Aiuto please!!! :'(

Cosa appare a schermo durante l’attesa ?

Puoi fornire una registrazione video di cosa compare a schermo durante lo spegnimento ?

Quanto tempo hai atteso, al massimo, lo spegnimento ?

Hai provato dopo l’attesa se il computer risponde alla sequenza reisub (vedi https://www.debian.org/doc/manuals/debi ... _sysrq_key ) ?

Hai letto la precedente discussione (http://forum.debianizzati.org/viewtopic.php?f=20&t=54949&hilit=shutdown) su un argomento simile ?

Puoi fornire un log della tua installazione usando lo script citato in calce in rosso nel mio messaggio ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 8613
Iscritto il: 27/12/2007, 16:59

Re: Shutdown Freeze

Messaggioda SerFeda » 22/07/2019, 7:12

Ho aspettato anche più di un'ora per l'arresto. Essenzialmente quando faccio click sul pulsante di spegnimento o riavvio, lo schermo diventa tutto nero, ma il pc rimane acceso (si può vedere la tastiera retroilluminata e i pixel di colore nero).
Sto cercando di eseguire la sequenza suggerita ma non riesco a fare la combinazione di tasti (ho un laptop Dell XPS 15), il tasto sysRq è lo stesso dello Stamp? Come faccio a fare il log dell'installazione che ho fatto la settimana scorsa?
Grazie mille
SerFeda
Newbie
Newbie
 
Messaggi: 6
Iscritto il: 18/07/2019, 19:59

Re: Shutdown Freeze

Messaggioda Aki » 22/07/2019, 8:05

SerFeda ha scritto:il tasto sysRq è lo stesso dello Stamp?

Di solito è scritto sul tasto, talvolta è in combinazione con il tasto Fn nel caso dei portatili.

SerFeda ha scritto:Come faccio a fare il log dell'installazione che ho fatto la settimana scorsa?

Puoi usare lo script a tal fine preposto nelle guide del forum: http://guide.debianizzati.org/index.php/Creazione_automatica_di_un_file_di_log_per_inviare_quesiti_al_forum.

Una ulteriore possibilità, è spegnere il computer non dalla sessione grafica, ma da una sessione di terminale a caratteri, da avviare con la combinazione di tasti CTRL ALT F1, quindi esegui la login come utente root, quindi impartisci il comando seguente per comandare lo spegnimento del computer:
Codice: Seleziona tutto
shutdown -h now

Questo ti dovrebbe permettere di vedere tutti i messaggi del sistema operativo che appaiono a schermo, compresi quelli che potrebbero suggerirti una possibile causa di blocco dello spegnimento. Potrebbe essere utile effettuare una registrazione video da sottoporre all'attenzione di quanti fossero interessati ad aiutarti.
Aki
Global Moderator
Global Moderator
 
Messaggi: 8613
Iscritto il: 27/12/2007, 16:59

Re: Shutdown Freeze

Messaggioda SerFeda » 27/07/2019, 16:03

Ho provato a seguire la guida ed eseguire lo script, tuttavia il computer rallenta e il terminale inizia a dare messaggi di errore del tipo "Hard LOCKUP detected on CPU 1" e diversi blocchi di altre CPU (5 e 6) per 22/23 secondi. L'esecuzione non termina se premo Ctrl+C, ma devo fare un arresto forzato... cosa potrebbe essere?
PS non riesco ad inserire il log prodotto o aggiungerlo come estensione perchè troppo lungo
Grazie!
SerFeda
Newbie
Newbie
 
Messaggi: 6
Iscritto il: 18/07/2019, 19:59

Re: Shutdown Freeze

Messaggioda Aki » 27/07/2019, 17:05

SerFeda ha scritto:Ho provato a seguire la guida ed eseguire lo script, tuttavia il computer rallenta e il terminale inizia a dare messaggi di errore del tipo "Hard LOCKUP detected on CPU 1" e diversi blocchi di altre CPU (5 e 6) per 22/23 secondi. L'esecuzione non termina se premo Ctrl+C, ma devo fare un arresto forzato... cosa potrebbe essere?
PS non riesco ad inserire il log prodotto o aggiungerlo come estensione perchè troppo lungo
Grazie!

Puoi almeno fornire una registrazione video, ad esempio, eseguita con il cellulare di quello che ti appare sullo schermo ?

Per quanto riguarda il log, se lungo, puoi comprimerlo con gzip ed allegarlo oppure inviarlo con servizi gratuiti come http://tinyupload.com

Edit: vedi anche https://youtu.be/nPprHes-K_Y
Aki
Global Moderator
Global Moderator
 
Messaggi: 8613
Iscritto il: 27/12/2007, 16:59

Re: Shutdown Freeze

Messaggioda SerFeda » 29/07/2019, 14:40

Intanto mando il link del log, magari si riesce a trovare il problema da lì. Appena riesco registro il video dello schermo per completezza.
http://s000.tinyupload.com/index.php?file_id=96694452006309372493

UPDATE: dopo vari tentativi ho notato che il comando lscpi dava problemi, pertanto ho seguito questa guida
https://askubuntu.com/questions/879584/what-to-do-when-lspci-and-hwinfo-freeze-the-system
che mi ha permesso di mostrare questo hardware da terminale
Immagine
e comunque il sistema si blocca sul CHECKING 01:00.0.
Credo che sia un problema di driver per la scheda video, inoltre inserendo acpi=off nouveau.modeset=0 nelle impostazioni del GRUB, il sistema si spegne e riavvia normalmente (attualmente impostato su acpi=force).

Grazie
SerFeda
Newbie
Newbie
 
Messaggi: 6
Iscritto il: 18/07/2019, 19:59

Re: Shutdown Freeze

Messaggioda Aki » 31/07/2019, 20:50

Dall'immagine che hai inviato, risulta un errore a carico della periferica PCI con identificativo 01:00.0.

Dal log che hai inviato, tale identificativo corrisponde alla scheda grafica nvidia:
Codice: Seleziona tutto
$ grep 01:00.0 log_27lug_165311
lug 27 14:30:53 debian kernel: pci 0000:01:00.0: [10de:1c8d] type 00 class 0x030200
lug 27 14:30:53 debian kernel: pci 0000:01:00.0: reg 0x10: [mem 0xec000000-0xecffffff]
lug 27 14:30:53 debian kernel: pci 0000:01:00.0: reg 0x14: [mem 0xc0000000-0xcfffffff 64bit pref]
lug 27 14:30:53 debian kernel: pci 0000:01:00.0: reg 0x1c: [mem 0xd0000000-0xd1ffffff 64bit pref]
lug 27 14:30:53 debian kernel: pci 0000:01:00.0: reg 0x24: [io  0xe000-0xe07f]
lug 27 14:30:53 debian kernel: pci 0000:01:00.0: reg 0x30: [mem 0xed000000-0xed07ffff pref]
lug 27 14:30:53 debian kernel: pci 0000:01:00.0: optimus capabilities: enabled, status dynamic power,
lug 27 14:30:53 debian kernel: nouveau 0000:01:00.0: NVIDIA GP107 (137000a1)
lug 27 14:30:53 debian kernel: nouveau 0000:01:00.0: bios: version 86.07.3e.00.1c
lug 27 14:30:53 debian kernel: nouveau 0000:01:00.0: firmware: failed to load nvidia/gp107/gr/sw_nonctx.bin (-2)
lug 27 14:30:53 debian kernel: nouveau 0000:01:00.0: Direct firmware load for nvidia/gp107/gr/sw_nonctx.bin failed with error -2
lug 27 14:30:53 debian kernel: nouveau 0000:01:00.0: gr: failed to load gr/sw_nonctx
lug 27 14:30:53 debian kernel: nouveau 0000:01:00.0: fb: 4096 MiB GDDR5
lug 27 14:30:53 debian kernel: nouveau 0000:01:00.0: DRM: VRAM: 4096 MiB
lug 27 14:30:53 debian kernel: nouveau 0000:01:00.0: DRM: GART: 536870912 MiB
lug 27 14:30:53 debian kernel: nouveau 0000:01:00.0: DRM: BIT table 'A' not found
lug 27 14:30:53 debian kernel: nouveau 0000:01:00.0: DRM: BIT table 'L' not found
lug 27 14:30:53 debian kernel: nouveau 0000:01:00.0: DRM: Pointer to TMDS table invalid
lug 27 14:30:53 debian kernel: nouveau 0000:01:00.0: DRM: DCB version 4.1
lug 27 14:30:53 debian kernel: nouveau 0000:01:00.0: DRM: failed to create kernel channel, -22
lug 27 14:30:53 debian kernel: [drm] Initialized nouveau 1.3.1 20120801 for 0000:01:00.0 on minor 1
lug 27 14:30:53 debian kernel: nouveau 0000:01:00.0: firmware: failed to load nvidia/gp107/gr/sw_nonctx.bin (-2)
lug 27 14:30:53 debian kernel: nouveau 0000:01:00.0: gr: failed to load gr/sw_nonctx
lug 27 14:30:53 debian kernel: nouveau 0000:01:00.0: DRM: Pointer to TMDS table invalid
lug 27 14:30:53 debian kernel: nouveau 0000:01:00.0: DRM: failed to create kernel channel, -22
lug 27 14:30:53 debian kernel: nouveau 0000:01:00.0: firmware: failed to load nvidia/gp107/gr/sw_nonctx.bin (-2)
lug 27 14:30:53 debian kernel: nouveau 0000:01:00.0: Direct firmware load for nvidia/gp107/gr/sw_nonctx.bin failed with error -2
lug 27 14:30:53 debian kernel: nouveau 0000:01:00.0: gr: failed to load gr/sw_nonctx
lug 27 14:30:53 debian kernel: nouveau 0000:01:00.0: DRM: Pointer to TMDS table invalid
lug 27 14:30:53 debian kernel: nouveau 0000:01:00.0: DRM: failed to create kernel channel, -22

Dal log sopra riportato, risulta che il driver nouveau della scheda grafica nvidia fallisce il caricamento del firmware chiamato nvidia/gp107/gr/sw_nonctx.bin; tale firmware è distribuito con il pacchetto firmware-misc-nonfree:
Codice: Seleziona tutto
$ apt-file search sw_nonctx.bin
firmware-misc-nonfree: /lib/firmware/nvidia/gk20a/sw_nonctx.bin
firmware-misc-nonfree: /lib/firmware/nvidia/gm200/gr/sw_nonctx.bin
firmware-misc-nonfree: /lib/firmware/nvidia/gm204/gr/sw_nonctx.bin
firmware-misc-nonfree: /lib/firmware/nvidia/gm206/gr/sw_nonctx.bin
firmware-misc-nonfree: /lib/firmware/nvidia/gm20b/gr/sw_nonctx.bin
firmware-misc-nonfree: /lib/firmware/nvidia/gp100/gr/sw_nonctx.bin
firmware-misc-nonfree: /lib/firmware/nvidia/gp102/gr/sw_nonctx.bin
firmware-misc-nonfree: /lib/firmware/nvidia/gp104/gr/sw_nonctx.bin
firmware-misc-nonfree: /lib/firmware/nvidia/gp106/gr/sw_nonctx.bin
firmware-misc-nonfree: /lib/firmware/nvidia/gp107/gr/sw_nonctx.bin
firmware-misc-nonfree: /lib/firmware/nvidia/gp108/gr/sw_nonctx.bin
firmware-misc-nonfree: /lib/firmware/nvidia/gp10b/gr/sw_nonctx.bin

Puoi verificare se il pacchetto firmware-misc-nonfree è installato ed, in caso negativo, installarlo e verificare gli effetti riavviando il computer e provando a generare nuovamente il log dell'installazione senza ricorrere all'uso dell'opzione nomodeset che hai citato nel precedente messaggio ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 8613
Iscritto il: 27/12/2007, 16:59

Re: Shutdown Freeze

Messaggioda SerFeda » 01/08/2019, 21:31

Il pacchetto non era installato correttamente ed ho provveduto ad installarlo, tuttavia ancora ci sono problemi nello shutdown o riavvio, anche l'esecuzione del comando lspci mostra i risultati e blocca il sistema.
Allego alla discussione il log compresso prodotto dopo l'insatallazione del pacchetto.
Grazie
Allegati
log_01ago_222734.xz
(55.32 KiB) Scaricato 8 volte
SerFeda
Newbie
Newbie
 
Messaggi: 6
Iscritto il: 18/07/2019, 19:59

Re: Shutdown Freeze

Messaggioda Aki » 01/08/2019, 22:36

Dall'ultimo log che hai inviato risulta che non hai avviato il sistema operativo con il kernel distribuito con Debian Buster; ad esempio, la versione del kernel utilizzata per l'avvio è la 4.9.0-8-amd64, mentre con Debian Buster è distribuita la 4.19.0-5-amd64:
Codice: Seleziona tutto
ago 01 22:26:10 debian kernel: Linux version 4.9.0-8-amd64 (debian-kernel@lists.debian.org) (gcc version 6.3.0 20170516 (Debian 6.3.0-18+deb9u1) ) #1 SMP Debian 4.9.144-3.1 (2019-02-19)

Sempre dai log, risulta che il sistema operativo è configurato per installare pacchetti da repository esterni, in particolare da i seguenti repository, con la stessa priorità di quelli Debian; questo è un dei modi per creare una "frankenstein debian" (vedi https://wiki.debian.org/DontBreakDebian):
Codice: Seleziona tutto
 500 http://ppa.launchpad.net/gns3/ppa/ubuntu xenial/main i386 Packages
     release v=16.04,o=LP-PPA-gns3,a=xenial,n=xenial,l=GNS3 PPA,c=main,b=i386
     origin ppa.launchpad.net
 500 http://ppa.launchpad.net/gns3/ppa/ubuntu xenial/main amd64 Packages
     release v=16.04,o=LP-PPA-gns3,a=xenial,n=xenial,l=GNS3 PPA,c=main,b=amd64
     origin ppa.launchpad.net
 500 http://ppa.launchpad.net/atareao/telegram/ubuntu xenial/main i386 Packages
     release v=16.04,o=LP-PPA-atareao-telegram,a=xenial,n=xenial,l=Telegram,c=main,b=i386
     origin ppa.launchpad.net
 500 http://ppa.launchpad.net/atareao/telegram/ubuntu xenial/main amd64 Packages
     release v=16.04,o=LP-PPA-atareao-telegram,a=xenial,n=xenial,l=Telegram,c=main,b=amd64
     origin ppa.launchpad.net
 500 http://repository.spotify.com stable/non-free i386 Packages
     release v=0.4,o=Spotify LTD,a=stable,n=stable,l=Spotify Public Repository,c=non-free,b=i386
     origin repository.spotify.com
 500 http://repository.spotify.com stable/non-free amd64 Packages
     release v=0.4,o=Spotify LTD,a=stable,n=stable,l=Spotify Public Repository,c=non-free,b=amd64
     origin repository.spotify.com
 500 http://ppa.launchpad.net/mkusb/ppa/ubuntu xenial/main i386 Packages
     release v=16.04,o=LP-PPA-mkusb,a=xenial,n=xenial,l=MKUSB PPA,c=main,b=i386
     origin ppa.launchpad.net
 500 http://ppa.launchpad.net/mkusb/ppa/ubuntu xenial/main amd64 Packages
     release v=16.04,o=LP-PPA-mkusb,a=xenial,n=xenial,l=MKUSB PPA,c=main,b=amd64
     origin ppa.launchpad.net

Sempre la log, inoltre, risulta che il computer utilizza una scheda video intel e, presumibilmente come secondaria con tecnologia grafica ibrida, una scheda nvidia:
Codice: Seleziona tutto
00:02.0 VGA compatible controller [0300]: Intel Corporation HD Graphics 630 [8086:591b] (rev 04)
        Subsystem: Dell HD Graphics 630 [1028:07be]
        Kernel driver in use: i915
        Kernel modules: i915
01:00.0 3D controller [0302]: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] [10de:1c8d] (rev a1)
        Subsystem: Dell GP107M [GeForce GTX 1050 Mobile] [1028:07be]
        Kernel modules: nouveau

Disponendo di una configurazione grafica ibrida, per utilizzare la scheda nvidia devi installare un software come optimus:
Codice: Seleziona tutto
$ grep -i optimus log_01ago_222734
ago 01 22:26:10 debian kernel: pci 0000:01:00.0: optimus capabilities: enabled, status dynamic power,
ago 01 22:26:10 debian kernel: VGA switcheroo: detected Optimus DSM method \_SB_.PCI0.PEG0.PEGP handle

È probabile che il driver nouveau non supporti correttamente questa scheda grafica nella configurazione con cui il computer è realizzato e, quindi, potresti disabilitare il modulo nouveau del kernel oppure installare il supporto per i driver proprietari nvidia.
Aki
Global Moderator
Global Moderator
 
Messaggi: 8613
Iscritto il: 27/12/2007, 16:59

Re: Shutdown Freeze

Messaggioda SerFeda » 05/08/2019, 20:34

Grazie per questi consigli e dritte :)
Alla fine sono riuscito a sistemare il tutto installando i driver open-source di Debian con questa guida:

https://wiki.debian.org/NvidiaGraphicsDrivers#Version_340.102_.28legacy_GPUs.29

ho aggiunto "buster" invece che "stretch" perchè sto usando la versione 10.

Spero possa essere d'aiuto a qualcun altro!
Ciao ;D
SerFeda
Newbie
Newbie
 
Messaggi: 6
Iscritto il: 18/07/2019, 19:59

Re: Shutdown Freeze

Messaggioda Aki » 05/08/2019, 22:27

SerFeda ha scritto:Grazie per questi consigli e dritte :)
Alla fine sono riuscito a sistemare il tutto installando i driver open-source di Debian con questa guida:

https://wiki.debian.org/NvidiaGraphicsDrivers#Version_340.102_.28legacy_GPUs.29

ho aggiunto "buster" invece che "stretch" perchè sto usando la versione 10.

Spero possa essere d'aiuto a qualcun altro!
Ciao ;D

Felice di esserti stato d’aiuto. Da quanto scrivi hai installato i driver proprietari (“legacy “) nvidia. Ricordati di contrassegnare la discussione come risolta.
Aki
Global Moderator
Global Moderator
 
Messaggi: 8613
Iscritto il: 27/12/2007, 16:59


Torna a Generale

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti