Pagina 1 di 1

il problema è tornato: malfunzionamento icone desktop KDE

MessaggioInviato: 06/02/2020, 18:09
da paolo-m
ciao a tutti
avevo già fatto, in agosto dell'anno scorso, un post chiedendo aiuto per questo stesso problema ( viewtopic.php?f=15&t=55315 ) ed avevo (non so come e perchè) risolto il tutto, però da una decina di giorni si è ripresentato tale e quale, dopo che ho sostituito uno dei due monitor collegati al mio pc.

Succede che ad ogni riavvio le icone del desktop (sono con Debian 10 e KDE) sono del tutto inerti: non possono essere cliccate e non si reagiscono in alcun modo al passaggio della freccetta del mouse.
Posso risolvere la cosa temporaneamente accedendo a "Configura desktop" e qui cambiando la "Disposizione" da "vista cartelle" a "Desktop": applicando questa modifica e ritornando poi a "vista cartelle" le possibilità di interagire con le icone ritornano normali, fino ad il successivo riavvio.
Il tutto si è ripresentato dopo che ho sostituito uno dei due monitor che tengo collegati al pc ad una scheda ATI radeon HD 5400, che ha una porta hdmi e una DVI, ora i monitor sono due identici HP LP2065.
Il problema mi si era risolto, lo scorso anno, sul mio utente normale creando un nuovo utente... adesso però questo escamotage non funziona.

Alla fine ci si può anche abituare a dover cambiare la configurazione del desktop ogni volta che serve un qualche file che è sul desktop... però se qualcuno potesse aiutarmi per provare a risolvere la cosa ...

grazie
scusate se sono stato prolisso

Re: il problema è tornato: malfunzionamento icone desktop KD

MessaggioInviato: 08/02/2020, 10:21
da s3v
Puoi allegare il file nascosto ".xsession-errors" che trovi nella tua home directory?
Hai configurato manualmente il file "/etc/X11/xorg.conf" (se usi XOrg) o aggiunto/modificato file/directory in "/etc/X11"?

Re: il problema è tornato: malfunzionamento icone desktop KD

MessaggioInviato: 08/02/2020, 12:14
da paolo-m
ciao
grazie per la risposta

Assolutamente non ho modificato nulla manualmente, non saprei proprio come: non sono affatto un esperto di informatica!
Uso i settaggi automatici che si creano con la normale installazione tramite netinst, avevo a suo tempo installato debian 9 e poi ho fatto l'aggiornamento a debian 10 con un normale "apt upgrade" e "apt dist-upgrade" , cosa che ha provocato la prima volta questo problema: creando un nuovo profilo di prova, utilizzato solo a questo scopo, tutto si era risolto anche sul mio profilo "normale".

Ho provato ad allegare il file che mi hai chiesto, togliendo il punto iniziale per renderlo visibile, ma compare la scritta "invio richiesta a forum.debianizzati.org" che permane per diversi minuti e non succede altro, forse è troppo grande (25.9 MiB). Sperando che la cosa sia ammessa l'ho reso disponibile al download da Mega.nz a questo link :
(edit : ho tolto il link, come mi è stato suggerito.)
grazie per tutti i suggerimenti che possiate darmi
paolo

Re: il problema è tornato: malfunzionamento icone desktop KD

MessaggioInviato: 08/02/2020, 16:46
da s3v
Il file è enorme perché ha raccolto tutto dal 18 novembre a oggi.
Cambiagli il nome per conservarlo (magari da ".xsession-errors" a "xsession-errors-backup") e riavvia il sistema. Dovresti ritrovarti un file molto più piccolo.
Allega quello e rimuovi i riferimenti al precedente presenti in questa discussione (meglio se rimuovi anche il file da megavideo).
Grazie.

Re: il problema è tornato: malfunzionamento icone desktop KD

MessaggioInviato: 09/02/2020, 18:05
da Aki
Scusate se mi inserisco.

Dal log che hai inviato, comunque, risulterebbero dei componenti mancanti segnalati da kde ed, in particolare:
Codice: Seleziona tutto
$ grep -i "error loading" xsession-errors | sort | uniq
Il file binario xsession-errors corrisponde
org.kde.kcoreaddons: Error loading plugin "akregatorplugin" "La libreria dinamica non è stata trovata."
org.kde.kcoreaddons: Error loading plugin "kcm_desktoptheme" "La libreria dinamica non è stata trovata."
org.kde.kcoreaddons: Error loading plugin "kcm_fonts" "La libreria dinamica non è stata trovata."
org.kde.kcoreaddons: Error loading plugin "kcm_icons" "La libreria dinamica non è stata trovata."
org.kde.kcoreaddons: Error loading plugin "kcm_launchfeedback" "La libreria dinamica non è stata trovata."
org.kde.kcoreaddons: Error loading plugin "kcm_lookandfeel" "La libreria dinamica non è stata trovata."
org.kde.kcoreaddons: Error loading plugin "kcm_workspace" "La libreria dinamica non è stata trovata."

Potresti provare a installare/reinstallare i pacchetti contenenti le librerie mancanti.

Per trovarle, puoi usare il comando apt-file search, ad esempio:
Codice: Seleziona tutto
$ apt-file search kcm_workspace.so
plasma-desktop: /usr/lib/x86_64-linux-gnu/qt5/plugins/kcms/kcm_workspace.so

Quindi, se i repository sono aggiornati:
Codice: Seleziona tutto
script log.txt
apt reinstall plasma-desktop
exit

Il log dei comandi impartiti sarà in log.txt

Re: il problema è tornato: malfunzionamento icone desktop KD

MessaggioInviato: 11/02/2020, 17:05
da paolo-m
grazie per le risposte
scusate se non mi sono fatto vivo prima, ma ieri all'avvio del pc il problema era magicamente scomparso... oggi si è ripresentato
allego i file di .xsession-errors rinominati, sia quello di ieri con le icone normalmente reattive che quello di oggi con le icone completamente inattive, spero che con entrambi si riesca a capire dove sta il problema.

Tolgo, come suggerito, il link al file caricato su Mega.

grazie
paolo

ps: ho dovuto rinominare i file allegati come ".log" perchè senza estensione veniva bloccato l'upload per "estensione non permessa"

Re: il problema è tornato: malfunzionamento icone desktop KD

MessaggioInviato: 13/02/2020, 12:43
da paolo-m
ciao
un aggiornamento:
come suggerito da Aki, ho provato a reinstallare i pacchetti che risultavano mancanti , in effetti ho reinstallato solo "plasma-workspace" che fa parte di kde-plasma-desktop...

e il problema delle icone non si è più ripresentato (ho fatto però solo 3-4 riavvii)
aspetto ancora qualche giorno e se tutto continuerà a funzionate bene metterò il risolto

grazie a tutti per l'aiuto
paolo

Re: il problema è tornato: malfunzionamento icone desktop KD

MessaggioInviato: 18/02/2020, 10:32
da paolo-m
ciao
dunque, ancora il problema si ripresenta..

Ho fatto il "apt reinstall" di plasma-desktop, anche di kde-plasma-desktop, e libkf5coreaddons5 ; però scarica ogni volta solo pochi kb per reinstallare i pacchetti e ci mette pochi secondi a eseguire il comando.
Ho installato anche "gnome-icon-theme" perchè nel .xsession-errors indicava come errore che non trovava le gnome-icon, anche se non mi sembra di aver mai usato questo set di icone prima...

sembrava aver funzionato, ma dopo 1 massimo 2 riavvii le icone tornano ad essere inattive...

riallego il log del reinstall e per il il .xsession-errors metto il link per scaricarlo da mega.nz in quanto più grande dei 256Kib ammessi per gli allegati
https://mega.nz/#!8KAnDSTJ!HdqetvEOEJLWrHfa1_QTQkCxXNEOKkQ4Q2VTTJoow8A

grazie per qualunque suggerimanto

paolo

Re: il problema è tornato: malfunzionamento icone desktop KD

MessaggioInviato: 21/02/2020, 7:07
da Aki
In caso di comparsa del blocco delle icone del desktop, il comando di seguito indicato, se impartito, sblocca le icone ?
Codice: Seleziona tutto
plasmashell --replace > /dev/null 2>&1 &

Re: il problema è tornato: malfunzionamento icone desktop KD

MessaggioInviato: 25/02/2020, 18:05
da paolo-m
grazie del suggerimento, sono comunque 5-6 giorni che non si blocca più niente.... e non riesco proprio a capire il perchè e il come ogni tanto si ripresenta il problema, spero che continui a funzionare tutto come adesso, eventualmente proverò la tua soluzione

paolo