Vulkan su Debian 9

Audio, Video, Grafica...

Vulkan su Debian 9

Messaggioda tochiro » 16/04/2019, 19:12

Buonasera Forum,

Volevo avere qualche informazione su questi driver. Ho bisogno di installarli per far girare delle applicazioni con Lutris ma non riesco a trovare quelli open....

Ho seguito la procedura trovata qui https://wiki.debian.org/it/NvidiaGraphicsDrivers per identificare la scheda video con il seguente comando sudo lspci -nn | egrep -i "3d|display|vga" e mi restituisce questo messaggio:
Codice: Seleziona tutto
00:02.0 VGA compatible controller [0300]: Intel Corporation HD Graphics 5500 [8086:1616] (rev 09)
09:00.0 3D controller [0302]: NVIDIA Corporation GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M] [10de:1140] (rev ff)


Da quello che ho capito ( e da quello che ho sperimentato ) NON devo usare i driver ufficiali di NVidia ma quelli di Bumblebee....solo che su tutte le guide ho trovato che per i suddetti driver servono quelli ufficiali!!!!!

Scusate se non sono molto preciso con le spiegazioni ma non sono molto esperto e spero di essermi spiegato al meglio....se avete qualunque domanda sono a vostra disposiozione. Se avete direttamente la soluzione al mio problema, ancora meglio ;D
tochiro
Newbie
Newbie
 
Messaggi: 10
Iscritto il: 23/02/2019, 17:18

Re: Vulkan su Debian 9

Messaggioda Aki » 17/04/2019, 7:44

tochiro ha scritto:Ho seguito la procedura trovata qui https://wiki.debian.org/it/NvidiaGraphicsDrivers [..]
Da quello che ho capito ( e da quello che ho sperimentato ) NON devo usare i driver ufficiali di Nvidia ma quelli di Bumblebee....solo che su tutte le guide ho trovato che per i suddetti driver servono quelli ufficiali!!!!![..]

Il progetto bumblebee fornisce il software che gestisce per l'utente il passaggio dalla attivazione della scheda grafica integrata (intel) a quella discreta (nvidia) e viceversa in funzione dell'input dell'utente o con meccanismi semi-automatici. Quindi, bumblebee istruisce il sistema operativo ad utilizzare l'uno o l'altro driver video. Di conseguenza, il software fornito dal progetto bumblebee non fornisce driver video (nota: in Linux la componente del kernel dei "driver" si chiamano "moduli" del kernel). I moduli del kernel per le schede grafiche presenti nel tuo computer sono forniti rispettivamente da intel e nvidia (in quest'ultimo caso nel caso del modulo del kernel "proprietario"). Spero che così ti sia più chiaro. Se hai altri quesiti, restiamo a tua disposizione.
Aki
Global Moderator
Global Moderator
 
Messaggi: 8429
Iscritto il: 27/12/2007, 16:59

Re: Vulkan su Debian 9

Messaggioda tochiro » 18/04/2019, 0:05

Grazie per la risposta Aki, adesso ho un pò più chiaro il funzionamento di bumblebee.

Però rimane ancora il problema su Vulkan: per poterli installare devo passare obbligatoriamente attraverso i repository di Nvidia ma, tutte le volte che li ho installati, mi bloccano Debian e devo formattare tutto perchè non riesco ad avviarlo sia in modalità normale sia in modalità recovery ??? Scusa se pongo delle domanda forse banali ma non ho ancora molta esperienza
tochiro
Newbie
Newbie
 
Messaggi: 10
Iscritto il: 23/02/2019, 17:18

Re: Vulkan su Debian 9

Messaggioda Aki » 18/04/2019, 17:07

tochiro ha scritto:Però rimane ancora il problema su Vulkan: per poterli installare devo passare obbligatoriamente attraverso i repository di Nvidia ma, tutte le volte che li ho installati, mi bloccano Debian e devo formattare tutto perchè non riesco ad avviarlo sia in modalità normale sia in modalità recovery [..] Scusa se pongo delle domanda forse banali ma non ho ancora molta esperienza

L'installazione del supporto software alla sezione video per i sistemi con hardware ibrido per la scheda grafica (come nel caso che descrivi) è spesso non immediato. Ciò non di meno, anche in caso di fallimento, resta attivo ed utilizzabile il terminale a caratteri da cui puoi provare ad analizzare cosa è accaduto. Sulla base degli elementi che hai (o, forse, sarebbe megli dire, non hai) fornito, aiutarti non è possibile (almeno per me). Al contrario, se segui accuratamente le istruzioni esistenti per questo tipo di installazione, riesci a documentare nel minimo dettaglio ciò che fai (comandi impartiti) ed i risultati ottenuti e riesci a raccogliere i log utili ad analizzare la situazione, in tal caso si può provare a darti una mano, ma resta inteso che devi avere adeguati margini di autonomia operativa.
Aki
Global Moderator
Global Moderator
 
Messaggi: 8429
Iscritto il: 27/12/2007, 16:59

Re: Vulkan su Debian 9

Messaggioda Aki » 28/04/2019, 19:09

@tochiro: puoi aggiornare la discussione ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 8429
Iscritto il: 27/12/2007, 16:59

Re: Vulkan su Debian 9

Messaggioda tochiro » 30/04/2019, 18:57

Salve a tutti, sono riuscito ad installare il modulo del Kernel Vulkan

Codice: Seleziona tutto
tochiro@arkadia:~$ sudo apt install vulkan-utils
[sudo] password di tochiro:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
vulkan-utils is already the newest version (1.0.39.0+dfsg1-1).
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
tochiro@arkadia:~$


Ma quando vado ad avviare Lutris, l'applicazione che mi richiede le librerie Vulkan, mi restituisce questo messaggio

Codice: Seleziona tutto
Missing vulkan libraries
The Vulkan librart for 1386 has not been found. This will prevent games using Vulkan (such as DXVK games) from running. To install it, please follow [u]the instructions on our Wiki[/u]


mentre da terminale mi esce questo messaggio
Codice: Seleziona tutto
tochiro@arkadia:~$ lutris
2019-04-30 18:48:17,991: GLib.set_option_context_summary missing, was added in GLib 2.56 (Released 2018-03-12)
2019-04-30 18:48:18,051: Running Lutris 0.5.2.1
2019-04-30 18:48:18,052: Using Intel Open Source Technology Center
2019-04-30 18:48:18,052: Running Mesa driver 13.0.6 on Mesa DRI Intel(R) HD Graphics 5500 (Broadwell GT2)  (0x1616)
2019-04-30 18:48:18,052: GPU: 8086:1616 103C:2337 using i915 drivers
2019-04-30 18:48:18,053: i386 libvulkan.so.1 missing (needed by vulkan)
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
2019-04-30 18:59:14,166: Vulkan is not available or your system isn't Vulkan capable
2019-04-30 18:59:14,174: Updating DXVK versions
2019-04-30 18:59:16,891: Shutting down Lutris


Mentre la guida che viene menzionata nel messaggio di errore si trova a questa pagina
https://github.com/lutris/lutris/wiki/Installing-drivers

Una volta che ho installato i moduli di NVIDIA, riavvio il portatile e si installano i cambiamenti. Il problema principale è che facendo così mi si blocca l'intero sistema operativo!!! Sia che provi ad avviarlo in modalità normale sia che provi ad avviarlo in modalità recovery si blocca con una schermata grigia e non và avanti
tochiro
Newbie
Newbie
 
Messaggi: 10
Iscritto il: 23/02/2019, 17:18

Re: Vulkan su Debian 9

Messaggioda Aki » 01/05/2019, 8:36

tochiro ha scritto:sono riuscito ad installare il modulo del Kernel Vulkan
Codice: Seleziona tutto
tochiro@arkadia:~$ sudo apt install vulkan-utils
[sudo] password di tochiro:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
vulkan-utils is already the newest version (1.0.39.0+dfsg1-1).
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
tochiro@arkadia:~$

Il pacchetto vulkan-utils [0] non contiene il modulo del Kernel Vulkan, ma programmi di utilità.

tochiro ha scritto:da terminale mi esce questo messaggio
Codice: Seleziona tutto
tochiro@arkadia:~$ lutris
[..]
2019-04-30 18:48:18,053: i386 libvulkan.so.1 missing (needed by vulkan)
2019-04-30 18:59:14,166: Vulkan is not available or your system isn't Vulkan capable

L'errore indicato specifica che il programma lutris non ha trovato la versione i386 (versione per architettura a 32 bit) delle librerie Vulkan. Nel caso di Debian, questa libreria è distribuita nel pacchetto chiamato libvulkan1 [1]. L'errore compare perché, probabilmente, hai installato una versione di Debian a 64 bit, mentre il programma che stai cercando di usare (lutris) richiede le librerie indicate (e tutte le altre dipendenti) sia in versione a 32 bit (per compatibilità con programmi "datati") sia in versione a 64 bit (per programmi più recenti). Se confermato, dovresti attivare in Debian il supporto per il multiarch [2] (supporto simultaneo a più architetture, ad esempio, sia 32 bit che 64 bit) ed installare sia le versioni a 32 bit che a 64 bit.

Come hai installato il programma lutris ?

tochiro ha scritto: la guida che viene menzionata nel messaggio di errore si trova a questa pagina
https://github.com/lutris/lutris/wiki/Installing-drivers Una volta che ho installato i moduli di NVIDIA, riavvio il portatile e si installano i cambiamenti. Il problema principale è che facendo così mi si blocca l'intero sistema operativo!!!

All'indirizzo che hai specificato (https://github.com/lutris/lutris/wiki/Installing-drivers) è indicato di installare i driver da repository non Debian (in particolare, per Ubuntu): nel caso di Debian questo è generalmente sconsigliabile, in quanto, soprattutto per quanto riguarda parti vitali del sistema operativo, è molto probabile ci siano incompatibilità binarie che possono condurre ai blocchi che descrivi. I driver (moduli del kernel) e tutti i pacchetti software dovrebbero essere installati attingendo dai pacchetti distribuiti nei repository ufficiali Debian.

[0] https://packages.debian.org/search?suite=default&section=all&arch=any&searchon=names&keywords=vulkan-utils
[1] https://packages.debian.org/search?searchon=names&keywords=libvulkan1
[2] https://wiki.debian.org/Multiarch/HOWTO
Aki
Global Moderator
Global Moderator
 
Messaggi: 8429
Iscritto il: 27/12/2007, 16:59

Re: Vulkan su Debian 9

Messaggioda tochiro » 01/05/2019, 23:18

Non appena ho avviato Debian mi è apparso il messaggio di errore critico e non riesco più ad avviare il s.o.

Il messaggio dice:

Oh n! Qualcosa è andato storto.
Si è verificato un problema impossibile da recuperare
Terminare la sessione e provare di nuovo

Provo a far ripartire la sessione ma si ripresenta sempre il solito messaggio di errore

L'errore persiste e non riesco ad avviare Debian. Se non trovo qualche soluzione entro domani, formatto e re-installo tutto
tochiro
Newbie
Newbie
 
Messaggi: 10
Iscritto il: 23/02/2019, 17:18

Re: Vulkan su Debian 9

Messaggioda Aki » 05/05/2019, 10:14

Ho provato a darti alcune indicazioni. Non hai specificato se le hai seguite o meno, né hai specificato cosa hai fatto di diverso rispetto a prima, da quale condizione iniziale partivi e quali comandi (con i rispettivi output) hanno portato alla situazione che sotto descrivi, né hai risposto ai quesiti che ho provato a porti. In questo modo è molto difficile esserti di ausilio.
tochiro ha scritto:Non appena ho avviato Debian mi è apparso il messaggio di errore critico e non riesco più ad avviare il s.o.
Il messaggio dice:
Oh n! Qualcosa è andato storto.
Si è verificato un problema impossibile da recuperare
Terminare la sessione e provare di nuovo
Provo a far ripartire la sessione ma si ripresenta sempre il solito messaggio di errore

Il computer non è bloccato, ma è la sessione grafica (probabilmente di GNOME) che non si avvia in quanto l'installazione manca del supporto ad alcune funzionalità grafiche accelerate di cui abbisogna l'ambiente grafico GNOME per funzionare (essendo il tal senso, al pari di altri ambienti grafici, esigente). Il sistema operativo è regolarmente funzionante, tant'è che se premessi CTRL-ALT-F1 potresti accedere alla console testuale, effettuare login ed eseguire le verifiche del caso.

tochiro ha scritto:L'errore persiste e non riesco ad avviare Debian. Se non trovo qualche soluzione entro domani, formatto e re-installo tutto

Cos'è, una minaccia ? :-) Sei libero di far ciò che desideri.
Aki
Global Moderator
Global Moderator
 
Messaggi: 8429
Iscritto il: 27/12/2007, 16:59


Torna a Multimedia

Chi c’è in linea

Visitano il forum: Nessuno e 4 ospiti