Audio muto all'avvio di jessie

Audio, Video, Grafica...

Re: audio muto all'avvio di jessie

Messaggioda nydebianized » 09/11/2015, 12:26

ok sostituisci il file con questo

http://paste.debian.net/329883/

da root :

Codice: Seleziona tutto
mv /var/lib/alsa/asound.state /var/lib/alsa/asound.state.bck

nano /var/lib/alsa/asound.state


incolla dentro il contenuto del pastebin

poi dai ctrl-o
salva non y
infine ctrl-x

Nota: se anche così non va dopo il riavvio vuol dire che pulseaudio prende il controllo e non permette ad alsa di riprendersi le impostazioni.

Facci sapere :D
dd if=/dev/brain of=/dev/head
Avatar utente
nydebianized
Sr. Member
Sr. Member
 
Messaggi: 338
Iscritto il: 08/11/2006, 4:43

Re: audio muto all'avvio di jessie

Messaggioda pota » 09/11/2015, 17:47

nydebianized ha scritto:ok sostituisci il file con questo

http://paste.debian.net/329883/

da root :

Codice: Seleziona tutto
mv /var/lib/alsa/asound.state /var/lib/alsa/asound.state.bck

nano /var/lib/alsa/asound.state


incolla dentro il contenuto del pastebin

poi dai ctrl-o
salva non y
infine ctrl-x

Nota: se anche così non va dopo il riavvio vuol dire che pulseaudio prende il controllo e non permette ad alsa di riprendersi le impostazioni.

Facci sapere :D

niente..non funziona manco così
pota
Sr. Member
Sr. Member
 
Messaggi: 306
Iscritto il: 26/09/2011, 14:40

Re: audio muto all'avvio di jessie

Messaggioda pota » 01/08/2016, 10:42

con l'attuale testing (stretch) l'audio torna attivo ad ogni avvio.l'unico problema è che temo sia ancora un pò azzardato passare ora a testing
pota
Sr. Member
Sr. Member
 
Messaggi: 306
Iscritto il: 26/09/2011, 14:40

Re: audio muto all'avvio di jessie

Messaggioda agomonos » 02/08/2016, 21:43

Anche a me la versione pulseaudio di debian jessie da alcuni problemi (l'audio dalle cuffie è muto all'avvio). Prova con la versione da debian backports, a me funziona bene.
In questo modo non aggiorni tutto debian ma solo pulseaudio.
agomonos
Newbie
Newbie
 
Messaggi: 32
Iscritto il: 05/04/2010, 8:59

Re: audio muto all'avvio di jessie

Messaggioda pota » 09/08/2016, 11:41

agomonos ha scritto:Anche a me la versione pulseaudio di debian jessie da alcuni problemi (l'audio dalle cuffie è muto all'avvio). Prova con la versione da debian backports, a me funziona bene.
In questo modo non aggiorni tutto debian ma solo pulseaudio.


ho provato ad aggiungere pulseaudio da backports ma m'ha rimosso mezzo ambiente desktop (mate)
pota
Sr. Member
Sr. Member
 
Messaggi: 306
Iscritto il: 26/09/2011, 14:40

Re: audio muto all'avvio di jessie

Messaggioda antoninoalain2 » 17/08/2016, 14:13

io simili problemi di audio in jessie, soprattutto quando uso skype, li ho risolti semplicemente installando "pavucontrol", prova, magari risolvi anche tu
Avatar utente
antoninoalain2
Newbie
Newbie
 
Messaggi: 39
Iscritto il: 18/11/2015, 12:44

Re: audio muto all'avvio di jessie

Messaggioda agomonos » 17/08/2016, 14:26

scusa se rispondo solo ora, ma pulseaudio come l'hai installato da backport?
Io uso kde e dando
Codice: Seleziona tutto
sudo apt-get -t jessie-backports install pulseaudio

mi ha aggiornato solo pulseaudio senza problemi..
Inoltro se simulo l'installazione di mate non mi da conflitti.
agomonos
Newbie
Newbie
 
Messaggi: 32
Iscritto il: 05/04/2010, 8:59

Re: audio muto all'avvio di jessie

Messaggioda pota » 19/08/2016, 12:10

agomonos ha scritto:scusa se rispondo solo ora, ma pulseaudio come l'hai installato da backport?
Io uso kde e dando
Codice: Seleziona tutto
sudo apt-get -t jessie-backports install pulseaudio

mi ha aggiornato solo pulseaudio senza problemi..
Inoltro se simulo l'installazione di mate non mi da conflitti.

ho riprovato ed effettivamente sta volta non m'ha dato problemi.pulseaudio è aggiornato ma ancora resta muto al riavvio
pota
Sr. Member
Sr. Member
 
Messaggi: 306
Iscritto il: 26/09/2011, 14:40

Re: audio muto all'avvio di jessie

Messaggioda agomonos » 21/08/2016, 8:44

hai provato a staccare le cuffie e riattaccarle un paio di volte?
e adesso avviando la alsamixer vedi un comando 'master' al centro?
dovresti avere card: pulseaudio, chip: pulseaudio in altro a sinistra.
agomonos
Newbie
Newbie
 
Messaggi: 32
Iscritto il: 05/04/2010, 8:59

Re: audio muto all'avvio di jessie

Messaggioda pota » 22/08/2016, 13:11

agomonos ha scritto:hai provato a staccare le cuffie e riattaccarle un paio di volte?
e adesso avviando la alsamixer vedi un comando 'master' al centro?
dovresti avere card: pulseaudio, chip: pulseaudio in altro a sinistra.

in realtà questo è esattamente quello che mi si presenta "di base" ad ogni avvio di alsamixer.se poi voglio attivare l'audio devo premere f6, selezionare la scheda audio, attivare "headphone" e alzarne il volume.allego le immagini
Allegati
Schermata-2.png
Schermata-2.png (23.95 KiB) Osservato 4127 volte
Schermata-1.png
Schermata-1.png (19.61 KiB) Osservato 4127 volte
Schermata.png
Schermata.png (15.88 KiB) Osservato 4127 volte
pota
Sr. Member
Sr. Member
 
Messaggi: 306
Iscritto il: 26/09/2011, 14:40

Re: Audio muto all'avvio di jessie

Messaggioda s3v » 22/08/2016, 16:34

Scusate se intervengo ma ho una curiosità personale: rimuovendo Pulseaudio:
Codice: Seleziona tutto
# apt-get purge pulseaudio

la situazione cambia?
Avatar utente
s3v
Global Moderator
Global Moderator
 
Messaggi: 5753
Iscritto il: 31/12/2008, 11:54

Re: Audio muto all'avvio di jessie

Messaggioda agomonos » 28/08/2016, 21:53

L'unica altra cosa che potresti provare è aggiornare anche il kernel per vedere se la situazione cambia.
Lo trovi sempre nei backports:
Codice: Seleziona tutto
apt-get install -t jessie-backports linux-image-amd64

cambia amd64 con i386 se hai un computer a 32 bit
agomonos
Newbie
Newbie
 
Messaggi: 32
Iscritto il: 05/04/2010, 8:59

Re: Audio muto all'avvio di jessie

Messaggioda pota » 12/04/2019, 12:12

ritorno sull'argomento perchè da jessie in poi mi si è sempre ripresentato il problema (anche con devuan). l'unica soluzione che ho trovato - a parte alzare il volume manualmente da alsamixer ad ogni riavvio - è rimuovendo pulseaudio ma non so se definirla una soluzione. senza pulseadio il volume resta "salvato" in alsamixer anche al riavvio. qualcuno conosce soluzioni più appropriate?
pota
Sr. Member
Sr. Member
 
Messaggi: 306
Iscritto il: 26/09/2011, 14:40

Re: Audio muto all'avvio di jessie

Messaggioda s3v » 12/04/2019, 19:01

Che riporta il comando:
Codice: Seleziona tutto
$ systemctl list-unit-files --state=enabled
?
Avatar utente
s3v
Global Moderator
Global Moderator
 
Messaggi: 5753
Iscritto il: 31/12/2008, 11:54

Re: Audio muto all'avvio di jessie

Messaggioda pota » 12/04/2019, 19:43

s3v ha scritto:Che riporta il comando:
Codice: Seleziona tutto
$ systemctl list-unit-files --state=enabled
?


premetto che ora pulseaudio è disinstallato.

Codice: Seleziona tutto
systemctl list-unit-files --state=enabled
UNIT FILE                          STATE 
anacron.service                    enabled
autovt@.service                    enabled
avahi-daemon.service               enabled
bluetooth.service                  enabled
console-setup.service              enabled
cron.service                       enabled
dbus-org.bluez.service             enabled
dbus-org.freedesktop.Avahi.service enabled
display-manager.service            enabled
getty@.service                     enabled
keyboard-setup.service             enabled
lightdm.service                    enabled
networking.service                 enabled
rsyslog.service                    enabled
syslog.service                     enabled
systemd-timesyncd.service          enabled
unattended-upgrades.service        enabled
avahi-daemon.socket                enabled
remote-fs.target                   enabled
anacron.timer                      enabled
apt-daily-upgrade.timer            enabled
apt-daily.timer                    enabled
lines 1-23...skipping...
UNIT FILE                          STATE 
anacron.service                    enabled
autovt@.service                    enabled
avahi-daemon.service               enabled
bluetooth.service                  enabled
console-setup.service              enabled
cron.service                       enabled
dbus-org.bluez.service             enabled
dbus-org.freedesktop.Avahi.service enabled
display-manager.service            enabled
getty@.service                     enabled
keyboard-setup.service             enabled
lightdm.service                    enabled
networking.service                 enabled
rsyslog.service                    enabled
syslog.service                     enabled
systemd-timesyncd.service          enabled
unattended-upgrades.service        enabled
avahi-daemon.socket                enabled
remote-fs.target                   enabled
anacron.timer                      enabled
apt-daily-upgrade.timer            enabled
apt-daily.timer                    enabled

22 unit files listed.
pota
Sr. Member
Sr. Member
 
Messaggi: 306
Iscritto il: 26/09/2011, 14:40

PrecedenteProssimo

Torna a Multimedia

Chi c’è in linea

Visitano il forum: Nessuno e 4 ospiti

cron