Aggiornare pepperflashplugin-nonfree 32 bit

Audio, Video, Grafica...

Aggiornare pepperflashplugin-nonfree 32 bit

Messaggioda Lioce » 18/03/2016, 19:38

Buonasera.
Ho Debian 8.3, i386 e Firefox 45.0-1~bpo80+1 i386 (ex Iceweasel).
Sto cercando di aggiornare pepperflashplugin-nonfree all'ultima versione (che attualmente è la 21.0.0.182
e che si trova in latest-beta e latest-beta-verified) eseguendo i comandi riportati in questa discussione:
http://forum.debianizzati.org/viewtopic.php?f=17&t=51660

Purtroppo non ottengo nessun risultato:

Codice: Seleziona tutto
# update-pepperflashplugin-nonfree --verbose --install
options :  --verbose --install --
temporary directory: /tmp/pepperflashplugin-nonfree.O8reO1Cj9X
doing apt-get update on google repository
# update-pepperflashplugin-nonfree --verbose --install --beta
options :  --verbose --install --beta --
temporary directory: /tmp/pepperflashplugin-nonfree.tksWmQl5YK
doing apt-get update on google repository
# update-pepperflashplugin-nonfree --verbose --install --unverified
options :  --verbose --install --unverified --
temporary directory: /tmp/pepperflashplugin-nonfree.LNCXCLRBJx
doing apt-get update on google repository
# update-pepperflashplugin-nonfree --verbose --install --beta --unverified
options :  --verbose --install --beta --unverified --
temporary directory: /tmp/pepperflashplugin-nonfree.3cFsqo1Vzd
doing apt-get update on google repository
# update-pepperflashplugin-nonfree --verbose --install --beta --verified
update-pepperflashplugin-nonfree: opzione non riconosciuta "--verified"
Usage:
  update-pepperflashplugin-nonfree --install
  update-pepperflashplugin-nonfree --uninstall
  update-pepperflashplugin-nonfree --status
Additional options:
  --verbose
  --quiet


Quello che mi preoccupa è che anche l'opzione --status non funziona:

Codice: Seleziona tutto
# update-pepperflashplugin-nonfree --verbose --status
options :  --verbose --status --
temporary directory: /tmp/pepperflashplugin-nonfree.Xv36k4pEGO
doing apt-get update on google repository
# update-pepperflashplugin-nonfree --status
#


La versione installata sul mio sistema è:

Codice: Seleziona tutto
$ cat /usr/lib/pepperflashplugin-nonfree/manifest.json
{
    "description": "Pepper Flash Player",
    "name": "Flapper",
    "version": "20.0.0.306",
    "x-flapper-revision": "39074",
    "x-ppapi-arch": "ia32",
    "x-ppapi-os": "linux",
    .......


Sbaglio qualcosa o succede anche ad altri?
Ultima modifica di Lioce il 21/03/2016, 15:04, modificato 1 volta in totale.
Lioce
Full Member
Full Member
 
Messaggi: 146
Iscritto il: 30/03/2014, 21:17

Re: Aggiornare pepperflashplugin-nonfree

Messaggioda Selky » 18/03/2016, 20:37

Ciao Lioce
forse il problema è che hai un sistema a 32 bit e Chrome per Linux non supporta più questa architettura.
Selky
wiki member
wiki member
 
Messaggi: 1434
Iscritto il: 30/12/2011, 1:00

Re: Aggiornare pepperflashplugin-nonfree

Messaggioda Lioce » 18/03/2016, 21:15

Ciao Selky, grazie della risposta. Penso che tu abbia ragione: ho trovato proprio adesso questa discussione sul forum internazionale che dice la stessa cosa
http://forums.debian.net/viewtopic.php?f=6&t=127561

Ma non mi è chiara la soluzione adottata dall'utente.

Sarò costretto a ritornare al normale Flashplayer.
Lioce
Full Member
Full Member
 
Messaggi: 146
Iscritto il: 30/03/2014, 21:17

Re: Aggiornare pepperflashplugin-nonfree

Messaggioda Selky » 18/03/2016, 23:58

Ha prelevato il plugin da un browser che non conoscevo, Slimjet Download per poi inserirlo nella directory dei plugin di Chromium.

Puoi scaricare la versione zip di Linux, troverai la cartella PepperFlash/ con all'interno il plugin da copiare.
Però tu parli di Firefox, quindi ti serve per Freshplayerplugin e in tutta onestà non so se la cosa può funzionare.
Ora non riesco a provare.
Selky
wiki member
wiki member
 
Messaggi: 1434
Iscritto il: 30/12/2011, 1:00

Re: Aggiornare pepperflashplugin-nonfree

Messaggioda Lioce » 19/03/2016, 0:46

Ti ringrazio per la spiegazione.

Sì, infatti ho Firefox e non Chromium.

Ma se il plugin non viene più supportato per la versione 32 bit, immagino che fra un po' il problema si ripresenterà.

Comunque questo browser Slimjet sembra interessante.

EDIT
Ho scritto plugin, volevo dire Chrome.
Inoltre ho letto che: "Slimjet is NOT open source."
Lioce
Full Member
Full Member
 
Messaggi: 146
Iscritto il: 30/03/2014, 21:17

Re: Aggiornare pepperflashplugin-nonfree

Messaggioda Selky » 19/03/2016, 12:25

Lioce ha scritto:Ma se il plugin non viene più supportato per la versione 32 bit, immagino che fra un po' il problema si ripresenterà.

Non conosco il browser in questione e non ho idea di come venga gestito.
Sì è freeware, come tanti altri si appoggia su codice open (Chromium) ma poi...

Comunque ormai la situazione è quella che è.
Debian stessa accetta di rilasciare Firefox senza battere ciglio su:
- software proprietario che vi è attualmente integrato. Vedesi pocket e hello.
- safebrowsing, trackingprotection, ecc... basati su connessioni automatiche a terze parti che generalmente si preferisce evitare.
- mi impone dei limiti di utilizzo (esempio estensioni anche se per ora è ancora fattibile aggirare l'ostacolo)
Per i primi due punti, ognuno ha proprie politiche d'uso e privacy che la gente generalmente non legge.

La maggior parte degli utenti utilizza ancora Iceweasel 38 prelevata dai repo ufficiali e, sempre la maggior parte, non sta a guardare a fondo. Ogni versione successiva alla 38 ha apportato/apporta modifiche non da poco.
Fortunatamente per ora è ancora possibile intervenire su diversi punti ma sta al singolo utente mettervi mano e personalizzarlo.

Tutto il mondo è paese, ognuno utilizzi ciò che vuole e preferisce. ;)
Selky
wiki member
wiki member
 
Messaggi: 1434
Iscritto il: 30/12/2011, 1:00

Re: Aggiornare pepperflashplugin-nonfree

Messaggioda Lioce » 20/03/2016, 14:26

A quanto pare per un sistema a 32 bit il problema è attualmente irrisolvibile.

Ho scartato la soluzione descritta nella discussione sul forum in lingua inglese già citata.

Ho disinstallato pepperflash ecc. e ho riscaricato Flashplayer dal sito di Adobe.
Purtroppo non ne posso fare a meno per tenermi aggiornato, dato che non vivo in Italia e la televisione non mi piace.

Sono passato alla versione aggiornata di Iceweasel, ora Firefox, dei repo mozilla.debian.net già un bel po' di tempo fa, perché alcuni siti per me importanti mi creavano dei problemi per via della ESR. Se non succede a tutti, tanto meglio

Per quanto riguarda il browser Slimjet il mio interesse è venuto meno nel momento in cui ne ho visto su YouTube la pagina iniziale, con tutti quei siti commerciali... Non fa per me.

@Selky
hai scritto:

Selky ha scritto:- software proprietario che vi è attualmente integrato. Vedesi pocket e hello.
- safebrowsing, trackingprotection, ecc... basati su connessioni automatiche a terze parti che generalmente si preferisce evitare.
- mi impone dei limiti di utilizzo (esempio estensioni anche se per ora è ancora fattibile aggirare l'ostacolo)


Potresti dirmi per cortesia, quando hai tempo, quali sono le terze parti di cui parli, a parte Google, e quali estensioni non ti permette di usare?

E di hello cosa ne pensi?
Grazie
Lioce
Full Member
Full Member
 
Messaggi: 146
Iscritto il: 30/03/2014, 21:17

Re: Aggiornare pepperflashplugin-nonfree

Messaggioda AS » 20/03/2016, 16:16

Lioce ha scritto:Purtroppo non ne posso fare a meno per tenermi aggiornato, dato che non vivo in Italia e la televisione non mi piace.


Di preciso su cosa vuoi essere aggiornato? Anche a me la tv non piace ma non piace neanche flash e non lo uso da anni: perché ti è indispensabile?
Se la casa del tuo vicino brucia, la cosa ti riguarda, e parecchio.


Immagine
Avatar utente
AS
Hero Member
Hero Member
 
Messaggi: 1162
Iscritto il: 01/05/2010, 10:22

Re: Aggiornare pepperflashplugin-nonfree

Messaggioda Selky » 20/03/2016, 20:13

Lioce ha scritto:@Selky
hai scritto:

Selky ha scritto:- software proprietario che vi è attualmente integrato. Vedesi pocket e hello.
- safebrowsing, trackingprotection, ecc... basati su connessioni automatiche a terze parti che generalmente si preferisce evitare.
- mi impone dei limiti di utilizzo (esempio estensioni anche se per ora è ancora fattibile aggirare l'ostacolo)


Potresti dirmi per cortesia, quando hai tempo, quali sono le terze parti di cui parli, a parte Google, e quali estensioni non ti permette di usare?

E di hello cosa ne pensi?
Grazie

Ci sono di mezzo anche altre questioni alle mie parole ma non mi va di affrontarle e mi limito a darti una spiegazione purtroppo ugualmente lunga.
Farò riferimento alla versione ESR perchè è quella che interessa i repository ufficiali.

Hello è un servizio offerto da società telefonica spagnola con proprie regole di privacy e uso: TokBox. Sulle versioni ESR è disabilitato. Però su Stretch nei repo ufficiali la versione Iceweasel è la v.44 (entrata in testing come 43.x a gennaio. Prima anche stretch aveva la v38.x esr) e non è disabilitato. Ora se si aggiorna si passa direttamente alla ESR ma fino a qualche giorno fa era impostato normalmente.
Dalla 45 ESR è incluso come estensione (/usr/lib/firefox-esr/browser/features/) non visibile nella finestra delle estensioni, quindi non la si può disinstallare nel classico modo ma solo cancellandolo direttamente. Al nuovo aggiornamento te la ritrovi e la si può visualizzare come voce digitando "about:support" (scheda Risoluzione dei problemi)

Pocket: è abilitato anche sulla ESR dei repo ufficiali ed è software proprietario.
Lo si può comunque disabilitare tramite "about:config" ma con dei se e con dei ma perchè le voci sono diverse.
È vero che per utilizzarlo bisogna registrarsi ma rimane il fatto che è lì. Dalla v.46 anche questa dovrebbe essere integrata come estensione.

Il plugin cisco è stato prontamente disabilitato a suo tempo senza possibilità d installarlo. Se uno lo vuole, deve abilitarlo.
Questo lo trovo in contraddizione con la filosofia Debian. Poi ripeto ognuno fa quello che vuole. ;)

Tu dici a parte Google..., io dico che non voglio essere costantemente tracciata da questa compagnia e Firefox è pieno di riferimenti a riguardo.
"about:networkng" della v. 45-esr con un profilo pulito, riporto solo Google:
Codice: Seleziona tutto
http://www.googletagmanager.com
http://www.google-analytics.com
http://www.google.com
clients1.google.com
http://www.google.it (questo perchè la ricerca è impostata di default con google, in questo caso concordo che non interessa. Basta cambiare motore di ricerca.)
stats.g.doubleclick.net

Al secondo avvio, qualcosa in meno, semplicemente perchè non si aprono tutte le pagine relative a Firefox. Come richiesta account, ecc....
Senza considerare il safebrowsing, trackingprotection, geoip. ecc...

Si entra in un discorso troppo vasto, mi limito a dire che è inutile parlami di sicurezza quando sono costretta a modifiche sostanziali e salvaguardarmi utilizzando estensioni come noscript, ublock-origin e umatrix e quant'altro per evitare di inviare informazioni a chicchessia. Esempio stupido
"dom.battery.enabled" abilitato di default su true. (fingerprinting)

Per quanto riguarda le estensioni provo a darti una spiegazione. Preciso che al momento ancora è possibile usarle tutte modificando la voce "xpinstall.signatures.required" su false e che non ho ancora capito come i manutentori di Debian si muoveranno a riguardo, su Firefox verrà eliminata la possibilità dalla v.46.
Nel caso si utilizzi un'estensione che, per un qualche motivo, necessita di modifica: crei una traduzione, modifichi la versione supportata del browser o altro. Ecco che non puoi più utilizzarla.
Dalla v.46 sarà obbligatorio utilizzare la versione developer (attualmente aurora su mozilla.debian) o Nightly (di firefox perchè su mozilla.debian non esiste al momento). Due versioni che, per loro definizione, sono in sviluppo quindi pro e contro.

Infine scusa per il papiro, nonostante abbia provato ad essere succinta, non ci sono riuscita.

Edit:
@Lioce ho corretto una cosa relativa alle estensioni integrate. Mi ero organizzata tutto il discorso e ho sbagliato ugualmente a scrivere :D

Aggiungo mi spiace tu abbia cancellato tutto, volevo chiederti i percorsi, le cartelle e i contenuti (cioè tutti i riferimenti) di pepperflash perchè senza poterlo installare mi confondo e non riesco a provare.
Ultima modifica di Selky il 21/03/2016, 4:49, modificato 2 volte in totale.
Selky
wiki member
wiki member
 
Messaggi: 1434
Iscritto il: 30/12/2011, 1:00

Re: Aggiornare pepperflashplugin-nonfree

Messaggioda Lioce » 20/03/2016, 20:47

@Selky
Grazie anche di queste spiegazioni. La lunghezza è un pregio.

@AS
AS ha scritto:Di preciso su cosa vuoi essere aggiornato? Anche a me la tv non piace ma non piace neanche flash e non lo uso da anni: perché ti è indispensabile?


Voglio essere aggiornato su quello che succede in Italia, ovviamente. Senza questo plugin siti come Rainews24, La7, Sky TG24, e i video di tutti i maggiori quotidiani non sono visibili.
Tu come fai?
Lioce
Full Member
Full Member
 
Messaggi: 146
Iscritto il: 30/03/2014, 21:17

Re: Aggiornare pepperflashplugin-nonfree

Messaggioda Underpass » 21/03/2016, 8:39

Ciao, ritorno un momento all'argomento del thread: significa quindi che PepperFlash a 32-bit non verrà più aggiornato e rimarrà all'attuale versione, giusto?
Materia: contrasta i tentativi di mutazione operati dal Tempo, resiste agli attacchi dell'Energia, costringe il Pensiero a divenire pratico.
Avatar utente
Underpass
Hero Member
Hero Member
 
Messaggi: 754
Iscritto il: 09/08/2006, 2:09

Re: Aggiornare pepperflashplugin-nonfree

Messaggioda Lioce » 21/03/2016, 15:02

Ottima domanda. Le mie ricerche non mi portano a niente di definitivo.
Spero che chi ne sa di più si pronunci.
Modifico il titolo della discussione aggiungendo "32 bit" per chiarezza.
Lioce
Full Member
Full Member
 
Messaggi: 146
Iscritto il: 30/03/2014, 21:17

Re: Aggiornare pepperflashplugin-nonfree 32 bit

Messaggioda Selky » 21/03/2016, 15:58

Sono su un 32 bit. Ho scaricato google chrome 64bit per vedere la versione di Pepperflash. È la "version": "20.0.0.306", uguale a Slimjet. Ossia la penultima e non sicura.
Però la versione attuale è un'altra, ossia "version": "21.0.0.182", e per la 32 bit l'ho trovato qua: http://www.slackware.com/~alien/slackbu ... g/current/

Bisogna provare se si riesce a farlo funzionare.

Edit
FUNZIONA!

Procedura che ho messo in atto:
  • 1 - installare il pacchetto "pepperflashplugin-nonfree"
    nel output alla fine apparirà questo
    Codice: Seleziona tutto
        E: Nessun pacchetto trovato
        E: Nessun pacchetto trovato
        E: Nessun pacchetto trovato
        E: Nessun pacchetto trovato
        E: Nessun pacchetto trovato
        ls: impossibile accedere a '/var/cache/pepperflashplugin-nonfree/*.deb': File o directory non esistente
  • 2 - Prelevare i due file: "manifest.json" e "libpepflashplayer.so" e copiarli in "/usr/lib/pepperflashplugin-nonfree/"
  • 3 - Installare il pacchetto "browser-plugin-freshplayer-pepperflash"
Nella scheda plugin di Iceweasel c'è Shockwave Flash 21.0.0.182
Ultima modifica di Selky il 21/03/2016, 16:30, modificato 1 volta in totale.
Selky
wiki member
wiki member
 
Messaggi: 1434
Iscritto il: 30/12/2011, 1:00

Re: Aggiornare pepperflashplugin-nonfree 32 bit

Messaggioda Underpass » 21/03/2016, 16:25

Ciao, mi pare che la 21.0.0.182 sono riuscito a scaricarla qualche giorno fa utilizzando update-pepperflashplugin-nonfree.

Mi preoccupa più che altro il futuro...
Materia: contrasta i tentativi di mutazione operati dal Tempo, resiste agli attacchi dell'Energia, costringe il Pensiero a divenire pratico.
Avatar utente
Underpass
Hero Member
Hero Member
 
Messaggi: 754
Iscritto il: 09/08/2006, 2:09

Re: Aggiornare pepperflashplugin-nonfree 32 bit

Messaggioda Selky » 21/03/2016, 16:32

Ciao underpass
ho appena modificato il mio messaggio precedente.
Per il futuro non so cosa dire. Per ora qualcuno si occupa di mantenere aggiornato il pacchetto anche per le architetture a 32 bit.
Selky
wiki member
wiki member
 
Messaggi: 1434
Iscritto il: 30/12/2011, 1:00

Prossimo

Torna a Multimedia

Chi c’è in linea

Visitano il forum: Nessuno e 5 ospiti