[RISOLTO]Usb video grab (snd_pcm_recover) underrun occurred

Audio, Video, Grafica...

[RISOLTO]Usb video grab (snd_pcm_recover) underrun occurred

Messaggioda Alkatron » 22/03/2016, 11:50

Ho un usb video grabber di questo tipo
Codice: Seleziona tutto
Mar 21 22:19:29 debj kernel: [  691.786190] usb 2-1.3: new high-speed USB device number 6 using ehci-pci
Mar 21 22:19:29 debj kernel: [  691.878889] usb 2-1.3: New USB device found, idVendor=05e1, idProduct=0408
Mar 21 22:19:29 debj kernel: [  691.878894] usb 2-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Mar 21 22:19:29 debj kernel: [  691.878896] usb 2-1.3: Product: USB 2.0 Video Capture Controller
Mar 21 22:19:29 debj kernel: [  691.878898] usb 2-1.3: Manufacturer: Syntek Semiconductor
Mar 21 22:19:29 debj kernel: [  691.879153] usb 2-1.3: New device Syntek Semiconductor USB 2.0 Video Capture Controller @ 480 Mbps (05e1:0408, interface 0, class 0)
Mar 21 22:19:29 debj kernel: [  691.879156] usb 2-1.3: video interface 0 found
Mar 21 22:19:30 debj kernel: [  692.463886] saa7115 12-0025: saa7113 found @ 0x4a (stk1160)
Mar 21 22:19:31 debj kernel: [  693.565157] stk1160: driver ver 0.9.5 successfully loaded
Mar 21 22:19:31 debj kernel: [  693.927847] stk1160 2-1.3:1.0: V4L2 device registered as video0
Mar 21 22:19:31 debj mtp-probe: checking bus 2, device 6: "/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.3"
Mar 21 22:19:31 debj mtp-probe: bus: 2, device: 6 was not an MTP device
Mar 21 22:19:31 debj pulseaudio[1237]: Default and alternate sample rates are the same.

Funziona tutto correttamente tranne l'audio, nel senso che si sente ma gracchia e va a scatti, sia xatv che qv4l2 mi danno continuamente questo errore
Codice: Seleziona tutto
ALSA lib pcm.c:7843:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:7843:(snd_pcm_recover) overrun occurred

Altre informazioni
Codice: Seleziona tutto
~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

~$ arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 2: ALC887-VD Alt Analog [ALC887-VD Alt Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 3: Controlle [USB 2.0 Video Capture Controlle], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

~$ cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version k3.16.0-4-amd64.

:~$ pulseaudio --version
pulseaudio 5.0

~$ cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7100000 irq 45
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xf7080000 irq 17
 2 [stk1160mixer   ]: stk1160 - stk1160-mixer
                      stk1160 ac97 codec mixer control
 3 [Controlle      ]: USB-Audio - USB 2.0 Video Capture Controlle
                      Syntek Semiconductor USB 2.0 Video Capture Controlle at usb-0000:00:1d.0-1.3, h



Grazie

P.S. il grabber funziona, con win non da problemi
Ultima modifica di Alkatron il 23/03/2016, 22:31, modificato 1 volta in totale.
Alkatron
Jr. Member
Jr. Member
 
Messaggi: 83
Iscritto il: 30/06/2010, 13:49

Re: Usb video grabber - (snd_pcm_recover) underrun occurred

Messaggioda mrdebug » 22/03/2016, 16:23

Lo stai provando sullo stesso pc oppure su pc diverso?
mrdebug
Sr. Member
Sr. Member
 
Messaggi: 368
Iscritto il: 23/07/2005, 7:38

Re: Usb video grabber - (snd_pcm_recover) underrun occurred

Messaggioda Alkatron » 23/03/2016, 22:30

Era un problema di player, usando mplayer2 non da problemi
Codice: Seleziona tutto
mplayer2 tv:// -tv driver=v4l2:norm=PAL:width=720:height=576:outfmt=uyvy:device=/dev/video0:input=0:fps=25:alsa:amode=1:forcechan=2:audiorate=48000:adevice=hw.3,0:forceaudio:immediatemode=0 -vf filmdint -ao sdl -vo x11 --dr -zoom

Grazie a tutti
Alkatron
Jr. Member
Jr. Member
 
Messaggi: 83
Iscritto il: 30/06/2010, 13:49


Torna a Multimedia

Chi c’è in linea

Visitano il forum: Nessuno e 5 ospiti

cron