Pagina 1 di 1

[RISOLTO] Amule crashes

MessaggioInviato: 11/08/2016, 17:36
da duccio
Salve a tutti della comunità. :) Allora: io ho debian 8 con gnome 3 e ho installato amule - ID alto, KAD connessa, funziona come deve. Solo che amule crasha ogni 5 min e così è inutilizzabile. Leggendo qua e là in rete si capisce che è un bug. Come posso fare a risolverlo?

Re: Amule crashes

MessaggioInviato: 11/08/2016, 20:07
da Aki
Il pacchetto amule non è distribuito con la versione 8 di Debian: che versione di Debian stai usando ? Da dove hai preso il pacchetto amule ? La versione in testing e in unstable ha ricevuto questa patch per un errore assimilabile a quello che riferisci: https://bugs.debian.org/cgi-bin/bugrepo ... bug=807453 . Prova a fornire maggiori dettagli sulla tua installaIone usando lo script citato in rosso in calce nel mio messaggio.

Re: Amule crashes

MessaggioInviato: 11/08/2016, 21:08
da duccio
Ho installato debian 8.5 stable e ho scaricato amule con il gestore dei pacchetti, dopo aver abilitato dai repositori, il download dei pacchetti contrib e non free.
Ho letto il link che mi hai inviato, ma non ne vengo a capo; è un po' troppo complicato. Ad un certo punto si parla di una patch, ma non so minimamente come fare per installarla.

Re: Amule crashes

MessaggioInviato: 11/08/2016, 23:25
da AS
Hai Debian Jessie e hai scaricato Amule? Da quali repository?

Re: Amule crashes

MessaggioInviato: 12/08/2016, 1:16
da Aki
Puoi fornire maggiori dettagli su programma amule installato, come, ad esempio, la versione e il repository di provenienza ? Puoi fornire maggiori informazioni sulla tua installazione usando lo script in calce al mio messaggio (riportato in rosso)?

Re: Amule crashes

MessaggioInviato: 12/08/2016, 16:52
da duccio
Allora, la versione di amule è la 2.2.4 e il repository dove l'ho scaricata è, dovrebbe, essere

Codice: Seleziona tutto
http://www.deb-multimedia.org/

che ho abilitato ai contrib non free per scaricare il codec necessario a guardare i DVD.
Dai vostri messaggi mi sembra di capire che non avrei dovuto scaricare amule; per quale motivo? Il tuo link rimanda ad una cosa un po' complicata per me; puoi dirmi come devo fare ad abilitare il programma per la ricerca delle informazioni del mio sistema e come faccio per installare e settare il tutto?

ps
Adesso ho reinstallato amule e pare funzionare. Cmq, da quello che leggevo in rete, i crash sono direttamente proporzionali al numero di tracce in download. Adesso ne ho quattro, di cui due soltanto attive.

Re: Amule crashes

MessaggioInviato: 12/08/2016, 17:29
da Aki
Il repository che hai utilizzato non è supportato da Debian e può risultare incompatibile a livello binario con i repository Debian: quasi certamente il malfunzionamento si ripresenterà.

Una soluzione maggiormente stabile è indicata qui: http://forums.debian.net/viewtopic.php?f=17&t=125643

Re: Amule crashes

MessaggioInviato: 12/08/2016, 17:55
da duccio
Ho abilitato quel repository perché avevo necessità che funzionasse il lettore per leggere i dvd; non ricordo come si chiama il codec necessario. Puoi indicarmi una soluzione per poter leggere i dvd senza utilizzare quel repository?

Re: Amule crashes

MessaggioInviato: 12/08/2016, 18:02
da Aki
duccio ha scritto:Ho abilitato quel repository perché avevo necessità che funzionasse il lettore per leggere i dvd; non ricordo come si chiama il codec necessario.

Puoi installare le librerie richieste per la riproduzione di contenuti protetti su DVD senza necessariamente installare tutti i pacchetti del repository non ufficiale: vedi il link https://wiki.debian.org/it/MultimediaCodecs . Per quanto riguarda amule, dovresti disinstallarlo, eseguire il backport del pacchetto dì unstable ed installare quest'ultimo (come da link precedentemente inviato) se pensi di essere in grado. In caso contrario, ti tieni i malfunzionamenti.

Re: Amule crashes

MessaggioInviato: 16/08/2016, 17:04
da duccio
Puoi installare le librerie richieste per la riproduzione di contenuti protetti su DVD senza necessariamente installare tutti i pacchetti del repository non ufficiale: vedi il link https://wiki.debian.org/it/MultimediaCodecs

E' proprio da codesta pagina che ho seguito le istruzioni per scaricare il codec che mi occorreva:
Codice: Seleziona tutto
libdvdcss2 non è disponibile nei repository ufficiali di Debian. Le informazioni dettagliate su dove ottenere libdvdcss2 sono descritte in it/CDDVD#DVD.

C'è un codec alternativo a libdvdcss2? Forse scaricare direttamente il pacchetto e installarlo a mano, senza abilitare il repository suddetto, è una buona mossa?

Re: Amule crashes

MessaggioInviato: 21/08/2016, 10:44
da Aki
duccio ha scritto:C'è un codec alternativo a libdvdcss2? Forse scaricare direttamente il pacchetto e installarlo a mano, senza abilitare il repository suddetto, è una buona mossa?

Non mi sembra ci sia un pacchetto alternativo. Quanto da te sopra indicato è probabilmente il modo migliore per installare il pacchetto libdvdcss2 senza configurare il sistema ad attingere pacchetti dal repository deb-multimedia. Il pacchetto libdvdcss2, infatti, non ha particolari dipendenze.

Re: Amule crashes

MessaggioInviato: 03/09/2016, 12:10
da Aki
@duccio: puoi aggiornare la discussione ?

Re:[risolto] Amule crashes

MessaggioInviato: 03/11/2016, 17:36
da duccio
Sì, scusatemi, non ho potuto aggiornare fino ad adesso. Amule adesso funziona bene il 90% delle volte, e non avendo particolari esigenze, lo tengo con i suoi saltuari crash. Perciò chiudo la discussione. Grazie a tutti. ;)