Problema funzionamento tasti volume (f1, f2, f3)

Audio, Video, Grafica...

Problema funzionamento tasti volume (f1, f2, f3)

Messaggioda misterti » 21/09/2016, 15:50

Buongiorno a tutti,

ho una debian testing (stretch) xfce4 su un lenovo ideapad flex 10.

I tasti funzione lavorano perfettamente, sia da soli che in combinazione col tasto FN, tranne che per la regolazione volume (tasti f1, f2 e f3). in questi casi rispondono alla combinazione Fn ma non lavorano da soli.

Cercando in rete ho modificato il file /etc/default/grub aggiungendo acpi_backlight=vendor dove veniva indicato di fare, ma non è cambiato nulla.

Ho visto in rete che è possibile configurarli a mano ma non ho capito bene dove.

Aggiungo che prima del passaggio alla testing, quindi con jessie, funzionavano, anche se avevo cmq qualche problemino con l'audio (ad es. se inserivo le cuffie e poi le toglievo l'audio si impostava su muto e i tasti non lo modificavano, dovevo andare su alsamixer); ora questi problemi li ho risolti, ho aggiunto al pannello inferiore l'icona della regolazione volume di PulseAudio per alzare o abbassare ma ovviamente è scomodissima...

qualcuno mi sa aiutare?

PS: se devo risolvere impostando delle scorciatorie da tastiera, quali sono i comandi per alzare, abbassare o escludere l'audio?

grazie a tutti!
misterti
Newbie
Newbie
 
Messaggi: 14
Iscritto il: 12/09/2016, 15:12

Re: Problema funzionamento tasti volume (f1, f2, f3)

Messaggioda gajm » 21/09/2016, 22:41

Il vecchio metodo, che ora è deprecato, era quello di usare acpid configurando uno script in etc/acpi/. Le chiavi emesse dai tasti si possono reperire con acpi_listen. Ma visto che prima ti funzionavano, proverei ad indagare se c'è stata una regressione nel modulo che gestisce i tasti.

Se usi pulseaudio, i comandi sono questi:
Codice: Seleziona tutto
pactl set-sink-volume 0 +5%
pactl set-sink-volume 0 +5%
gajm
Jr. Member
Jr. Member
 
Messaggi: 75
Iscritto il: 23/08/2016, 13:20

Re: Problema funzionamento tasti volume (f1, f2, f3)

Messaggioda misterti » 22/09/2016, 6:30

L'output di acpi_listen sembra corretto (almeno a me):
francescotirro@dhcppc3:~$ acpi_listen
button/volumedown VOLDN 00000080 00000000 K
button/volumeup VOLUP 00000080 00000000 K
button/mute MUTE 00000080 00000000 K
^C


al momento sono intervenuto in modo poco elegante dalla GUI per impostare le scorciatoie da tastiera, associando i comandi che mi hai scritto ai tasti e inserendo il comando pactl set-sink-volume 0 0 per il tasto MUTE: funziona, l'unica cosa è che la doppia pressione sul tasto MUTE non ripristina, ovviamente, l'audio, però per il momento mi accontento. se ci sono altre soluzioni possibili ogni suggerimento è il benvenuto!
misterti
Newbie
Newbie
 
Messaggi: 14
Iscritto il: 12/09/2016, 15:12

Re: Problema funzionamento tasti volume (f1, f2, f3)

Messaggioda gajm » 22/09/2016, 10:13

Sì, è corretto, i tasti vengono gestiti correttamente. Che sia un problema di xfce?
Per il mute, prova a cercare con qualcosa tipo "pulseaudio mute toggle command line", anch'io, per i comandi che ho postato, ho usato il web. ;)
gajm
Jr. Member
Jr. Member
 
Messaggi: 75
Iscritto il: 23/08/2016, 13:20

Re: Problema funzionamento tasti volume (f1, f2, f3)

Messaggioda misterti » 22/09/2016, 13:16

grazie! verificherò ;)
misterti
Newbie
Newbie
 
Messaggi: 14
Iscritto il: 12/09/2016, 15:12


Torna a Multimedia

Chi c’è in linea

Visitano il forum: Nessuno e 4 ospiti

cron