pacchetti ubuntu

Audio, Video, Grafica...

pacchetti ubuntu

Messaggioda zypepox » 01/02/2017, 8:52

si possono installare pacchetti ubuntu su debian?

mi interessa questo : https://booktab.it/download/
Avatar utente
zypepox
Full Member
Full Member
 
Messaggi: 230
Iscritto il: 28/06/2007, 20:41

Re: pacchetti ubuntu

Messaggioda Ombra » 01/02/2017, 10:10

Ciao,
si possono installare pacchetti ubuntu su debian?


in generale è sconsigliato, puoi comunque farlo se sei in grado di affrontare i potenziali conflitti/dipendenze non risolte che si possono generare in fase di installazione.
A una rapida occhiata il progetto non mi sembra opensource quindi non puoi nemmeno ricompilare una versione tu su Debian; per avere una anteprima dei possibili problemi sacrica il pacchetto e poi dai
Codice: Seleziona tutto
dpkg -I nomepacchetto.deb

guarda nelle dipendenze se quei pacchetti esistono sul tuo sistema e se le versioni sono giuste
Ombra
wiki member
wiki member
 
Messaggi: 474
Iscritto il: 11/08/2007, 18:06
Località: Bologna

Re: pacchetti ubuntu

Messaggioda byte64 » 01/02/2017, 10:15

In genere se non ci sono dipendenze particolari si pù installare, anche se personalmente preferisco ricompilare dai sorgenti se sono disponibili.
Che versione debian utilizzi? E' importante per capire quale pacchetto Ubuntu scaricare dei 3 disponibili.
Qui sotto una tabella di comparazione ubuntu-debian
17.04 zesty stretch / sid
16.10 yakkety stretch / sid
16.04 xenial stretch / sid
15.10 wily jessie / sid
15.04 vivid jessie / sid
14.10 utopic jessie / sid
14.04 trusty jessie / sid
13.10 saucy wheezy / sid
13.04 raring wheezy / sid
12.10 quantal wheezy / sid
byte64
Sr. Member
Sr. Member
 
Messaggi: 372
Iscritto il: 07/01/2017, 19:02
Località: Bergamo

Re: pacchetti ubuntu

Messaggioda zypepox » 01/02/2017, 11:40

Codice: Seleziona tutto
giuss@debian:~/Scaricati$ dpkg -I BooktabZSetup-16.04.deb
 nuovo pacchetto debian, versione 2.0.
 dimensione 200035812 byte: archivio di controllo=63540 byte.
     276 byte,    11 righe      control             
  251977 byte,  2311 righe      md5sums             
     265 byte,    15 righe      postinst             #!/bin/sh
     168 byte,     4 righe      prerm                #!/bin/sh
 Package: booktab
 Version: 1.8-1
 Section: devel
 Priority: optional
 Architecture: amd64
 Depends: libgstreamer-plugins-base0.10-0
 Recommends: flashplugin-installer | adobe-flashplugin
 Installed-Size: 676955
 Maintainer: duDat Developers <info@dudat.it>
 Description: Booktab demo
Avatar utente
zypepox
Full Member
Full Member
 
Messaggi: 230
Iscritto il: 28/06/2007, 20:41

Re: pacchetti ubuntu

Messaggioda zypepox » 01/02/2017, 11:42

byte64 ha scritto:In genere se non ci sono dipendenze particolari si pù installare, anche se personalmente preferisco ricompilare dai sorgenti se sono disponibili.
Che versione debian utilizzi?


ho la debian stable jessie

ricompilare dai sorgenti è un'operazione complessa? puoi darmi delle dritte a riguardo?
Avatar utente
zypepox
Full Member
Full Member
 
Messaggi: 230
Iscritto il: 28/06/2007, 20:41

Re: pacchetti ubuntu

Messaggioda byte64 » 01/02/2017, 11:56

Non sembra ci siano i sorgenti disponibili, puoi provare a scrivere al maintainer del pacchetto e chiedere se sono disponibili o se può creare un pacchetto deb anche per debian jessie. (Trovi la mail del maintaiiner nelle info del pacchetto che hai postato)
Per compilare ti serve il pacchetto build-essential e poi seguire le indicazioni dello specifico pacchetto, trovi parecchie guide generali a riguardo su internet.
byte64
Sr. Member
Sr. Member
 
Messaggi: 372
Iscritto il: 07/01/2017, 19:02
Località: Bergamo

Re: pacchetti ubuntu

Messaggioda Ombra » 01/02/2017, 12:01

Scusate sarò addormentato ma io non trovo nessun sorgente, me lo linkate per favore?

EDIT: non vista la risposta di byte64, stavo scrivendo..

@zypepox:
verifica di aver installato libgstreamer-plugins-base0.10-0, poi puoi procedere all'installazione del pacchetto
Ombra
wiki member
wiki member
 
Messaggi: 474
Iscritto il: 11/08/2007, 18:06
Località: Bologna

Re: pacchetti ubuntu

Messaggioda zypepox » 01/02/2017, 12:14

Ombra ha scritto:verifica di aver installato libgstreamer-plugins-base0.10-0, poi puoi procedere all'installazione del pacchetto


ho fatto come mi hai detto. mi è sembrato che l'installazione sia andata a buon fine, ma non trovo nessuna icona per lanciare il programma. :o non ho trovato nulla nemmeno nell' /usr/bin

vuol dire che non l'ha installato? o che altro posso fare??
Avatar utente
zypepox
Full Member
Full Member
 
Messaggi: 230
Iscritto il: 28/06/2007, 20:41

Re: pacchetti ubuntu

Messaggioda Ombra » 01/02/2017, 12:26

hai provato direttamente da console?
Codice: Seleziona tutto
$ booktab


comunque puoi aprire il file deb con un gestore di archivi e cercare all'interno dove ti installa gli eseguibili e come si chiamano
Ombra
wiki member
wiki member
 
Messaggi: 474
Iscritto il: 11/08/2007, 18:06
Località: Bologna

Re: pacchetti ubuntu

Messaggioda zypepox » 01/02/2017, 13:06

con
Codice: Seleziona tutto
$ booktab
non parte.

ho provato a spacchettare con il gestore archivi, ma non so bene come cercare gli eseguibili.
Avatar utente
zypepox
Full Member
Full Member
 
Messaggi: 230
Iscritto il: 28/06/2007, 20:41

Re: pacchetti ubuntu

Messaggioda byte64 » 01/02/2017, 13:37

L'eseguibile dovrebbe essere in /usr/bin
Sicuro di aver installato la libreria?
sudo apt install libgstreamer-plugins-base0.10-0
poi
sudo dpkg -i BooktabZSetup-15.10.deb
byte64
Sr. Member
Sr. Member
 
Messaggi: 372
Iscritto il: 07/01/2017, 19:02
Località: Bergamo

Re: pacchetti ubuntu

Messaggioda Ombra » 01/02/2017, 13:48

apri il deb, all'interno c'è un file "data.tar.xz", apri anche quello e dentro vedi le directory e i files che sono installate dal pacchetto.
Ombra
wiki member
wiki member
 
Messaggi: 474
Iscritto il: 11/08/2007, 18:06
Località: Bologna

Re: pacchetti ubuntu

Messaggioda zypepox » 01/02/2017, 15:42

Codice: Seleziona tutto
$ dpkg -I BooktabZSetup-15.10.deb
 nuovo pacchetto debian, versione 2.0.
 dimensione 151899076 byte: archivio di controllo=61624 byte.
     276 byte,    11 righe      control             
  252990 byte,  2324 righe      md5sums             
     265 byte,    15 righe   *  postinst             #!/bin/sh
     168 byte,     4 righe   *  prerm                #!/bin/sh
 Package: booktab
 Version: 1.8-1
 Section: devel
 Priority: optional
 Architecture: amd64
 Depends: libgstreamer-plugins-base0.10-0
 Recommends: flashplugin-installer | adobe-flashplugin
 Installed-Size: 786603
 Maintainer: duDat Developers <info@dudat.it>
 Description: Booktab demo


effettivamente non ho i Recommends..
Avatar utente
zypepox
Full Member
Full Member
 
Messaggi: 230
Iscritto il: 28/06/2007, 20:41

Re: pacchetti ubuntu

Messaggioda Ombra » 01/02/2017, 16:26

L'eseguibile che viene installato è /usr/bin/booktab
cosa ti dice se dai
Codice: Seleziona tutto
$ /usr/bin/booktab

?
qual'è il risultato di
Codice: Seleziona tutto
# dpkg -i BooktabZSetup-15.10.deb

?

L'assenza dei Recommends, se il pacchetto è fatto bene, non impedisce al programma di partire correttamente; al limite ne limita le funzionalità. In debian comunque si chiama flashplugin-nonfree, lo trovi nella sezione contrib.
Ombra
wiki member
wiki member
 
Messaggi: 474
Iscritto il: 11/08/2007, 18:06
Località: Bologna

Re: pacchetti ubuntu

Messaggioda zypepox » 01/02/2017, 18:15

Codice: Seleziona tutto
dpkg -i BooktabZSetup-15.10.deb
Selezionato il pacchetto booktab non precedentemente selezionato.
(Lettura del database... 138593 file e directory attualmente installati.)
Preparativi per estrarre BooktabZSetup-15.10.deb...
Estrazione di booktab (1.8-1)...
Configurazione di booktab (1.8-1)...
Elaborazione dei trigger per desktop-file-utils (0.22-1)...
Elaborazione dei trigger per gnome-menus (3.13.3-6)...
Elaborazione dei trigger per mime-support (3.58)...
Elaborazione dei trigger per libc-bin (2.19-18+deb8u7)...


Codice: Seleziona tutto
$ /usr/bin/booktab
/usr/share/duDat/BooktabZ/btb: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/share/duDat/BooktabZ/btb)
/usr/share/duDat/BooktabZ/btb: /lib/x86_64-linux-gnu/libdbus-1.so.3: no version information available (required by /usr/share/duDat/BooktabZ/libQt5WebEngineCore.so.5)
/usr/share/duDat/BooktabZ/btb: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/share/duDat/BooktabZ/libQt5WebEngineCore.so.5)


se non ce la faccio ad installare, potrò ripulire il computer di tutta questa roba scompattata inutilmente??

comunque ho scritto a info@dudat.it e mi hanno risposto che purtroppo non possono fornirmi il materiale che gli ho richiesto.
Avatar utente
zypepox
Full Member
Full Member
 
Messaggi: 230
Iscritto il: 28/06/2007, 20:41

Prossimo

Torna a Multimedia

Chi c’è in linea

Visitano il forum: Nessuno e 5 ospiti