[RISOLTO] xrandr e xorg.conf

Discussioni relative all'ambiente grafico X (Xfree e XOrg)

Re: xrandr e xorg.conf

Messaggioda Aki » 07/06/2020, 13:51

andrea.deroni ha scritto:Dopo una infinità di tentativi con xorg.conf ho deciso di metterlo momentaneamente da parte: lo rimetto al suo posto e rifaccio il log, poi lo allego a un pèrossimo messaggio.

Credo che tu abbia configurato il file xorg.conf in una posizione sbagliata, non vedo infatti perché debba funzionare con xrandr e non con xorg.conf

Il server X sul tuo computer si configura automaticamente con risoluzione massima 1024x768 perché il monitor dichiara queste risoluzioni, a cui il server X si attiene quando esegue la configurazione automatica:
Codice: Seleziona tutto
[   273.904] (II) NOUVEAU(0): EDID for output VGA-1
[   273.904] (II) NOUVEAU(0): Printing probed modes for output VGA-1
[   273.904] (II) NOUVEAU(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz e)
[   273.904] (II) NOUVEAU(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz e)
[   273.904] (II) NOUVEAU(0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz e)
[   273.904] (II) NOUVEAU(0): Modeline "848x480"x60.0   33.75  848 864 976 1088  480 486 494 517 +hsync +vsync (31.0 kHz e)
[   273.904] (II) NOUVEAU(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz e)
[   273.904] (II) NOUVEAU(0): Output VGA-1 connected
[   273.904] (II) NOUVEAU(0): Using exact sizes for initial modes
[   273.904] (II) NOUVEAU(0): Output VGA-1 using initial mode 1024x768 +0+0

L'EDID è il protocollo con cui il computer via cavo VGA interroga il monitor che riporta come risoluzione massima 1024x768 con una frequenza di pixel clock di 65.00 MHz.

Nei comandi con cui effettui la configurazione manuale tramite xrandr (che hai indicato in un'altra discussione e che riporto in questa per maggior utilità tua e dei lettori) imposti una risoluzione ed una frequenza di pixel clock della scheda video (109.0 MHz) che il monitor non ha comunicato come valida (pur funzionante, come riferisci):
Codice: Seleziona tutto
xrandr --newmode "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
xrandr --addmode VGA-1 "1280x1024_60.00"
xrandr --output VGA-1 --mode "1280x1024_60.00"

Quale monitor (produttore e modello) stai usando ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 9441
Iscritto il: 27/12/2007, 16:59

Re: xrandr e xorg.conf

Messaggioda andrea.deroni » 08/06/2020, 15:08

Non avevo visto la tua risposta.

Uso un Philips Brilliance 180P2 che supporta risoluzioni superiori a 1024x768. Lo usavo su un Mac e veniva riconosciuto senza problemi.

Il file xorg.conf è in /etc/X11, che mi pare il posto giusto.

Ho provato a configurarlo in vario modo, per esempio dichiarando o non dichiarando esplicitamente i range di frequenza, la modalità preferita ecc. In alcuni casi accadeva qualcosa di strano: appariva la schermata di login di gnome, mettevo la password e il sistema, invece di procedere al desktop dell'utente, tornava alla pagina di login. Siccome prima di te nessuno aveva saputo dire neanche una parola sulla questione avevo deciso di provare con uno script, come hai visto nell'altra discussione.

Riporto il file di configurazione, nell'ultima delle versioni che avevo provato. Ci ho messo solo una configurazione. I dati di frequenza li ho dedotti dal manuale del monitor, la ModeLine è quella che funziona con xrandr e che avevo dedotto con il comando cvt
Codice: Seleziona tutto
ection "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Device"
  Identifier "Geforce 7100"
  Driver     "nouveau"
EndSection

Section "Monitor"
  Identifier "Monitor0"
  HorizSync  30 - 82
  VertRefresh  56 - 76
  ModeLine  "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
EndSection

Section "Screen"
  Identifier "Screen0"
  Device     "Geforce 7100"
  Monitor    "Philips 180P2"
  SubSection "Display"
    Depth  24
    Modes "1280x1024_60.00"
  EndSubSection
EndSection
andrea.deroni
Newbie
Newbie
 
Messaggi: 25
Iscritto il: 15/05/2020, 22:02

Re: xrandr e xorg.conf

Messaggioda andrea.deroni » 08/06/2020, 15:10

P.s. - C'è un errore di copiatura banale, che non è nel file di origine: "ection" è "Section", ovviamente
andrea.deroni
Newbie
Newbie
 
Messaggi: 25
Iscritto il: 15/05/2020, 22:02

Re: xrandr e xorg.conf

Messaggioda andrea.deroni » 08/06/2020, 16:31

Forse qui c'è un indizio, il logfile in home/manutenzione/.local/share/Xorg

Codice: Seleziona tutto
[    53.536] (--) Log file renamed from "/home/manutenzione/.local/share/xorg/Xorg.pid-844.log" to "/home/manutenzione/.local/share/xorg/Xorg.0.log"
[    53.537]
X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
[    53.537] Build Operating System: Linux 4.9.0-8-amd64 x86_64 Debian
[    53.537] Current Operating System: Linux Archimede 4.19.0-9-amd64 #1 SMP Debian 4.19.118-2 (2020-04-29) x86_64
[    53.537] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.19.0-9-amd64 root=UUID=399d1f21-bc15-4236-b12e-3dbd2f8a466e ro quiet
[    53.538] Build Date: 05 March 2019  08:11:12PM
[    53.538] xorg-server 2:1.20.4-1 (https://www.debian.org/support)
[    53.538] Current version of pixman: 0.36.0
[    53.538]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    53.538] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    53.538] (==) Log file: "/home/manutenzione/.local/share/xorg/Xorg.0.log", Time: Mon Jun  8 16:57:33 2020
[    53.550] (==) Using config file: "/etc/X11/xorg.conf"
[    53.550] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    53.585] Data incomplete in file /etc/X11/xorg.conf
   Undefined InputDevice "Mouse0" referenced by ServerLayout "X.org Configured".
[    53.585] (EE) Problem parsing the config file
[    53.585] (EE) Error parsing the config file
[    53.585] (EE)
Fatal server error:
[    53.585] (EE) no screens found(EE)
[    53.585] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[    53.585] (EE) Please also check the log file at "/home/manutenzione/.local/share/xorg/Xorg.0.log" for additional information.
[    53.585] (EE)
[    53.585] (EE) Server terminated with error (1). Closing log file.


da quello che capisco si blocca nella lettura e decodifica del file di configurazione (Error parsing) e poi non trova lo screen ...
... ma non capisco dove possa essere l'errore
andrea.deroni
Newbie
Newbie
 
Messaggi: 25
Iscritto il: 15/05/2020, 22:02

Re: xrandr e xorg.conf

Messaggioda mark » 08/06/2020, 18:02

Codice: Seleziona tutto
Undefined InputDevice "Mouse0" referenced by ServerLayout "X.org Configured".

dovrebbe essere il messaggio rilevante, prova a cercare in quale configurazione "Mouse0" è citato
Avatar utente
mark
Hero Member
Hero Member
 
Messaggi: 791
Iscritto il: 10/01/2007, 16:53

Re: xrandr e xorg.conf

Messaggioda Aki » 08/06/2020, 21:35

andrea.deroni ha scritto:da quello che capisco si blocca nella lettura e decodifica del file di configurazione (Error parsing) e poi non trova lo screen ...... ma non capisco dove possa essere l'errore

Puoi inviare il file xorg.conf in allegato al prossimo messaggio in modo da evitare errori di trascrizione e copia & incolla e da poterlo verificare direttamente ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 9441
Iscritto il: 27/12/2007, 16:59

Re: xrandr e xorg.conf

Messaggioda Rudi » 08/06/2020, 22:57

Non ho conoscenze approfondite sulla configurazione manuale di xorg ma noto che nella sezione "Monitor" hai identificato quest' ultimo come "Monitor0", mentre nella sezione "Screen" ti sei riferito al monitor come "Philips 180P2"
Sostituisci "Philips 180P2" con "Monitor0" o viceversa.
Per quanto riguarda l' errore :
Codice: Seleziona tutto
Undefined InputDevice "Mouse0" referenced by ServerLayout "X.org Configured".

Credo che manca una sezione che descriva il mouse ma sembra un errore non fatale e quindi il server grafico dovrebbe comunque partire.
Rudi
Full Member
Full Member
 
Messaggi: 186
Iscritto il: 12/11/2005, 6:14

Re: xrandr e xorg.conf

Messaggioda andrea.deroni » 09/06/2020, 7:55

RISOLTO!
i problemi erano proprio:
- nella riga che definiva il mouse (ed era la causa del comportamento strano nella finestra di login): era scritta nel template del file xorg.conf che avevo trovato chissà dove e a cui non avevo dedicato la giusta attenzione;
- nella errata specificazione del monitor;

Insomma, non avevo mai messo le mani "dentro il cofano" e avevo così tante incertezze che, tentando di districarmi, ho commesso pasticci di tutti i generi, non ultimo quello di scrivere male, senza accorgermi, il nome del file xorg.conf (c'era uno spazio che non sapevo di avere messo e non ho notato per un bel po'...). ma intanto ho cominciato a capire qualcosa dell'uso dei file di log.

Grazie a tutti!
andrea.deroni
Newbie
Newbie
 
Messaggi: 25
Iscritto il: 15/05/2020, 22:02

Precedente

Torna a X

Chi c’è in linea

Visitano il forum: Nessuno e 5 ospiti