Pagina 1 di 3

Sddm no reboot poweroff al login

MessaggioInviato: 14/06/2017, 9:07
da Lioce
Un saluto a tutti.

Stretch KDE con sysvinit.
Al login sddm-greeter non mostra i pulsanti spegni e riavvia. Ho provato ad installare sddm-theme-breeze e
sddm-theme-debian-breeze: il tema brezza li mostra ma sono inattivi (grigi).

In /etc/sddm.conf ho:

Codice: Seleziona tutto
[General]
EnableHiDPI=false
HaltCommand=/bin/systemctl poweroff
InputMethod=
Numlock=none
RebootCommand=/bin/systemctl reboot


I due comandi, /bin/systemctl poweroff e /bin/systemctl reboot sono presenti anche in impostazioni di sistema > avvio e spegnimento > schermata di accesso > avanzate.

I log di sddm sono sempre vuoti:

Codice: Seleziona tutto
ls /var/log/sddm.log
-rw-r--r-- 1 sddm  sddm  0 mag  1 21:24 sddm.log


lo stesso in: ~/.local/share/sddm/xorg-session.log

In rete non ho trovato moltissimo. Qualcuno parla di problemi con pam.
Potreste darmi qualche idea?
Grazie

Re: Sddm no reboot poweroff al login

MessaggioInviato: 14/06/2017, 15:08
da s3v
powerdevil è installato?

Re: Sddm no reboot poweroff al login

MessaggioInviato: 14/06/2017, 20:43
da Lioce
s3v ha scritto:powerdevil è installato?


SÌ, è installato:

Codice: Seleziona tutto
$ dpkg -l powerdevil
ii  powerdevil         4:5.8.4-1      i386           Global power saver settings.

Re: Sddm no reboot poweroff al login

MessaggioInviato: 15/06/2017, 9:46
da Ombra
Ho avuto un problema simile con sddm, dovuto a un errato ordine nella sequenza di boot: prova a fare un logout, poi vai in console vt, fai un restart di sddm con
Codice: Seleziona tutto
# /etc/init.d/sddm stop

Codice: Seleziona tutto
# /etc/init.d/sddm start

e vedi se così i pulsanti diventano cliccabili.

Re: Sddm no reboot poweroff al login

MessaggioInviato: 15/06/2017, 22:02
da Lioce
@Ombra
Grazie, sembra che il problema sia proprio quello da te indicato.
Infatti, dando il secondo comando:

Codice: Seleziona tutto
/etc/init.d/sddm start


appare il greeter con i pulsanti cliccabili sia con il tema Debian Maui che con Brezza.
Al riavvio, però, è tutto come prima.

In syslog ho trovato questo messaggio:

Codice: Seleziona tutto
# cat /var/log/syslog | grep sddm-greeter
Jun 15 12:51:43 debtest kernel: [  622.538230] sddm-greeter[11095]: segfault at 8 ip b341c4d7 sp bfaf46e4 error 4 in libQt5XcbQpa.so.5.7.1[b33f2000+11e000]


che però non si è più ripetuto dopo i vari riavvii che ho effettuato.
(Nei syslog da me controllati non appare mai sddm-greeter e solo raramente qualcosa che riguarda org.kde.kcontrol.kcmsddm).

Non ne vengo a capo: ho provato un apt-get install --reinstall sddm, senza successo e, anche se uso sysvinit, un systemctl enable sddm.service -f (tanto per) ottenendo

Codice: Seleziona tutto
# systemctl enable sddm.service -f
Synchronizing state of sddm.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable sddm
The unit files have no installation config (WantedBy, RequiredBy, Also, Alias
settings in the [Install] section, and DefaultInstance for template units).
This means they are not meant to be enabled using systemctl.
Possible reasons for having this kind of units are:
1) A unit may be statically enabled by being symlinked from another unit's
   .wants/ or .requires/ directory.
2) A unit's purpose may be to act as a helper for some other unit which has
   a requirement dependency on it.
3) A unit may be started when needed via activation (socket, path, timer,
   D-Bus, udev, scripted systemctl call, ...).
4) In case of template units, the unit is meant to be enabled with some
   instance name specified.


Ovviamente senza successo. Tu come hai risolto?

Re: Sddm no reboot poweroff al login

MessaggioInviato: 16/06/2017, 12:04
da Ombra
Bisogna cambiare l'ordine di boot facendo in modo che sddm di avvii rigorosamente dopo dbus, e non contemporaneamente come probabilmente è adesso nel tuo pc (nel mio /etc/rc2.d avevano tutti e due numero 04).
Modifica l'header dello script init di sddm (ad esempio con nano)
Codice: Seleziona tutto
# nano /etc/init.d/sddm

e aggiungi "dbus" nel campo dei "required start" nel seguente modo

Codice: Seleziona tutto
fi
### BEGIN INIT INFO
# Provides:          sddm
# Required-Start:    $remote_fs $syslog dbus
# Required-Stop:     $remote_fs $syslog
...
### END INIT INFO



poi aggiorna l'ordine di boot con
Codice: Seleziona tutto
# update-rc.d sddm defaults


riavvia e dovrebbe essere risolto.
Qualche dettaglio per capire i comandi impartiti lo trovi nella guida (non è esaustiva cmq)

Spiegone lungo: logind in Debian è avviato come servizio dbus (sia avviano insieme); logind si occupa di creare le sessioni di utenti che saranno poi autorizzati, tramite le regole di pam, a compiere certe azioni che sarebbero prerogativa di root (come riavviare o spegnere).
Se sddm si avvia dopo logind riesce a inserirsi nella sessione, ma se avviene il contrario sddm non trova una sessione in cui inserirsi e quindi rimane non autorizzato..
Spero sia vagamente comprensibile, sarebbe da segnalare un Bug su sddm, ma io mi trovo in una posizione scomoda dato che utilizzo elogind (non è in Debian) al posto di logind..
Intanto vedi se così risolvi, poi valuta se segnalare il bug

Re: Sddm no reboot poweroff al login

MessaggioInviato: 16/06/2017, 12:36
da s3v
Da qui il numero di avvio dello script è "30".
???

Codice: Seleziona tutto
...
# update-rc.d levels
S=30
K=01

if [ -x /etc/init.d/sddm ]; then
    update-rc.d sddm defaults $S $K >/dev/null 2>&1
fi
...

Re: Sddm no reboot poweroff al login

MessaggioInviato: 16/06/2017, 13:42
da Ombra
update-rc.d sddm defaults $S $K

quel comando secondo me è inefficace; non si trova più nella manpage la possibilità di inserire direttamente l'ordine di start e stop, a partire da Debian6 se ne occupa insserv invocato direttamente da update-rc.d, in base all'header LSB dello script di init.
Per i dettagli guarda qui
La guida in effetti andrebbe aggiornata...

Re: Sddm no reboot poweroff al login

MessaggioInviato: 16/06/2017, 14:10
da s3v
Ombra ha scritto:
update-rc.d sddm defaults $S $K

quel comando secondo me è inefficace; non si trova più nella manpage la possibilità di inserire direttamente l'ordine di start e stop, a partire da Debian6 se ne occupa insserv invocato direttamente da update-rc.d, in base all'header LSB dello script di init.

Giusto.
Puoi confermare che, pur specificando i numeri di start e stop da "update-rc.d", insserv non li prende in considerazione?
Io ho systemd e non posso controllare.

In caso affermativo andrebbe segnalato il bug.

Re: Sddm no reboot poweroff al login

MessaggioInviato: 16/06/2017, 14:54
da Ombra
A me il numero rimane lo stesso, la cosa un po' strana è che se inseriti dopo "defaults" i numeri non restituiscon errore (vedi sotto)
Codice: Seleziona tutto
Script started on Fri 16 Jun 2017 03:46:10 PM CEST
root@lorenz:/home/ombra# ls /etc/rc2.d/ | grep 04
S04acpid
S04acpi-support
S04anacron
S04cgproxy
S04cron
S04dbus
S04elogind-sysv.sh
S04gdomap
S04hddtemp
S04irqbalance
S04lircd
S04loadcpufreq
S04mdadm
S04mysql
S04proftpd
S04quotarpc
S04sddm
S04sensord
S04smartmontools
root@lorenz:/home/ombra# update-rc.d sddm defaults 05 01
root@lorenz:/home/ombra# ls /etc/rc2.d/ | grep sddm
S04sddm
root@lorenz:/home/ombra# exit
exit

Script done on Fri 16 Jun 2017 03:46:55 PM CEST


mentre se uso solo i numeri da errore
Codice: Seleziona tutto
# update-rc.d sddm 05 01
usage: update-rc.d [-n] [-f] <basename> remove
       update-rc.d [-n] [-f] <basename> defaults
       update-rc.d [-n] <basename> disable|enable [S|2|3|4|5]
                -n: not really
                -f: force

The disable|enable API is not stable and might change in the future.


Se fai la segnalazione di bug, cortesemente potresti linkarla qui?

Re: Sddm no reboot poweroff al login

MessaggioInviato: 16/06/2017, 15:13
da s3v
Ombra ha scritto:Se fai la segnalazione di bug, cortesemente potresti linkarla qui?

Io la farei pure ma se mi chiedono informazioni aggiuntive che rispondo? :)
L'ideale è che la inviasse @Lioce.
Al massimo posso aprirne una se nessuno lo fa e poi fare da "medium" :P

Re: Sddm no reboot poweroff al login

MessaggioInviato: 16/06/2017, 20:35
da Lioce
Ho modificato /etc/init.d/sddm aggiungendo dbus

Codice: Seleziona tutto
$ cat /etc/init.d/sddm
# Required-Start:    $remote_fs $syslog dbus


ho eseguito

Codice: Seleziona tutto
# update-rc.d sddm defaults


ma purtroppo la situazione *non è cambiata*: i pulsanti con il tema Debian Maui non appaiono, con il tema Brezza continuano a essere grigi e non cliccabili. Syslog e dmesg non dicono niente di rilevante e i log di sddm continuano a essere vuoti.

L'ordine di avvio è invece cambiato: prima della modifica era 03 sia per dbus che per sddm

Codice: Seleziona tutto
$ ls /etc/rc2.d
...
lrwxrwxrwx   1 root root   14 mag  2 21:30 S03dbus -> ../init.d/dbus
...
lrwxrwxrwx   1 root root   14 mag  2 21:30 S03sddm -> ../init.d/sddm


Dopo la modifica:

Codice: Seleziona tutto
$ ls /etc/rc2.d | grep dbus
lrwxrwxrwx   1 root root   14 mag  2 21:30 S03dbus -> ../init.d/dbus

$ ls /etc/rc2.d | grep sddm
lrwxrwxrwx   1 root root   14 giu 16 19:17 S04sddm -> ../init.d/sddm


sddm è passato a 04.

Per me ha un'importanza molto pratica avere i pulsanti riavvia e spegni attivi perché il mio laptop ha un problema hardware di questo tipo:

Codice: Seleziona tutto
usb 1-1.6: device not accepting address 7, error -71
usb 1-1.6: device not accepting address 8, error -71


in genere mi basta riavviare (ogni tanto anche due o tre volte) per ottenere una sessione normale, e poterlo fare al login mi risparmia tempo e nervi.

Per quanto riguarda la segnalazione del Bug penso che s3v abbia le idee molto più chiare di quanto ce le abbia io e temo che avrei problemi a formulare in inglese cose così complicate. Naturalmente sarei disponibile a fornire tutte le informazioni necessarie.

Re: Sddm no reboot poweroff al login

MessaggioInviato: 16/06/2017, 21:10
da s3v
Puoi fornire cortesemente il contenuto di "/etc/rc2.d" in modo tale che @Ombra possa fare un confronto?

Altra cosa che mi lascia perplesso:
[...]
Using sysvinit-core you'll see that sddm disables the poweroff/reboot/suspend
buttons, as these are provided by systemd.
[...]

da qui.
Come se il comportamento fosse voluto...

Per curiosità, un altro DM (tipo LightDM) ha lo stesso problema?

Re: Sddm no reboot poweroff al login

MessaggioInviato: 16/06/2017, 22:31
da Lioce
Questo era /etc/rc2.d prima della modifica di /etc/init.d/sddm

Codice: Seleziona tutto
$ ls /etc/rc2.d
totale 20K
drwxr-xr-x   2 root root 4,0K giu 14 09:12 .
drwxr-xr-x 128 root root  12K giu 16 18:07 ..
-rw-r--r--   1 root root  677 feb 12 22:55 README
lrwxrwxrwx   1 root root   26 mag  1 20:43 S01console-setup.sh -> ../init.d/console-setup.sh
lrwxrwxrwx   1 root root   18 mag  2 21:31 S02bootlogs -> ../init.d/bootlogs
lrwxrwxrwx   1 root root   19 mag  2 21:30 S02cgmanager -> ../init.d/cgmanager
lrwxrwxrwx   1 root root   14 mag  2 21:31 S02motd -> ../init.d/motd
lrwxrwxrwx   1 root root   17 mag  2 21:30 S02rsyslog -> ../init.d/rsyslog
lrwxrwxrwx   1 root root   29 mag 17 22:48 S02unattended-upgrades -> ../init.d/unattended-upgrades
lrwxrwxrwx   1 root root   17 mag  2 21:30 S03anacron -> ../init.d/anacron
lrwxrwxrwx   1 root root   17 mag  2 21:30 S03cgproxy -> ../init.d/cgproxy
lrwxrwxrwx   1 root root   14 mag  2 21:30 S03cron -> ../init.d/cron
lrwxrwxrwx   1 root root   14 mag  2 21:30 S03dbus -> ../init.d/dbus
lrwxrwxrwx   1 root root   16 mag  2 21:30 S03gdomap -> ../init.d/gdomap
lrwxrwxrwx   1 root root   13 mag  3 23:39 S03gpm -> ../init.d/gpm
lrwxrwxrwx   1 root root   20 mag  6 01:41 S03irqbalance -> ../init.d/irqbalance
lrwxrwxrwx   1 root root   15 mag  2 21:30 S03rsync -> ../init.d/rsync
lrwxrwxrwx   1 root root   14 mag  2 21:30 S03sddm -> ../init.d/sddm
lrwxrwxrwx   1 root root   27 mag  2 21:30 S03speech-dispatcher -> ../init.d/speech-dispatcher
lrwxrwxrwx   1 root root   22 mag  2 21:30 S04avahi-daemon -> ../init.d/avahi-daemon
lrwxrwxrwx   1 root root   19 mag  2 21:30 S04bluetooth -> ../init.d/bluetooth
lrwxrwxrwx   1 root root   25 mag  2 21:30 S04network-manager -> ../init.d/network-manager     
lrwxrwxrwx   1 root root   14 mag  2 21:30 S05cups -> ../init.d/cups
lrwxrwxrwx   1 root root   22 mag  2 21:30 S05cups-browsed -> ../init.d/cups-browsed
lrwxrwxrwx   1 root root   15 mag  2 21:30 S05saned -> ../init.d/saned
lrwxrwxrwx   1 root root   18 mag  2 21:31 S06rc.local -> ../init.d/rc.local
lrwxrwxrwx   1 root root   19 mag  2 21:31 S06rmnologin -> ../init.d/rmnologin


e questo è quello che ho attualmente

Codice: Seleziona tutto
$ ls /etc/rc2.d
totale 20K
drwxr-xr-x   2 root root 4,0K giu 16 19:17 .
drwxr-xr-x 128 root root  12K giu 16 19:24 ..
-rw-r--r--   1 root root  677 feb 12 22:55 README
lrwxrwxrwx   1 root root   26 mag  1 20:43 S01console-setup.sh -> ../init.d/console-setup.sh
lrwxrwxrwx   1 root root   18 mag  2 21:31 S02bootlogs -> ../init.d/bootlogs
lrwxrwxrwx   1 root root   19 mag  2 21:30 S02cgmanager -> ../init.d/cgmanager
lrwxrwxrwx   1 root root   14 mag  2 21:31 S02motd -> ../init.d/motd
lrwxrwxrwx   1 root root   17 mag  2 21:30 S02rsyslog -> ../init.d/rsyslog
lrwxrwxrwx   1 root root   29 mag 17 22:48 S02unattended-upgrades -> ../init.d/unattended-upgrades
lrwxrwxrwx   1 root root   17 mag  2 21:30 S03anacron -> ../init.d/anacron
lrwxrwxrwx   1 root root   17 mag  2 21:30 S03cgproxy -> ../init.d/cgproxy
lrwxrwxrwx   1 root root   14 mag  2 21:30 S03cron -> ../init.d/cron
lrwxrwxrwx   1 root root   14 mag  2 21:30 S03dbus -> ../init.d/dbus
lrwxrwxrwx   1 root root   16 mag  2 21:30 S03gdomap -> ../init.d/gdomap
lrwxrwxrwx   1 root root   13 mag  3 23:39 S03gpm -> ../init.d/gpm
lrwxrwxrwx   1 root root   20 mag  6 01:41 S03irqbalance -> ../init.d/irqbalance
lrwxrwxrwx   1 root root   15 mag  2 21:30 S03rsync -> ../init.d/rsync
lrwxrwxrwx   1 root root   27 mag  2 21:30 S03speech-dispatcher -> ../init.d/speech-dispatcher
lrwxrwxrwx   1 root root   22 mag  2 21:30 S04avahi-daemon -> ../init.d/avahi-daemon
lrwxrwxrwx   1 root root   19 mag  2 21:30 S04bluetooth -> ../init.d/bluetooth
lrwxrwxrwx   1 root root   25 mag  2 21:30 S04network-manager -> ../init.d/network-manager
lrwxrwxrwx   1 root root   14 giu 16 19:17 S04sddm -> ../init.d/sddm
lrwxrwxrwx   1 root root   14 mag  2 21:30 S05cups -> ../init.d/cups
lrwxrwxrwx   1 root root   22 mag  2 21:30 S05cups-browsed -> ../init.d/cups-browsed
lrwxrwxrwx   1 root root   15 mag  2 21:30 S05saned -> ../init.d/saned
lrwxrwxrwx   1 root root   18 mag  2 21:31 S06rc.local -> ../init.d/rc.local
lrwxrwxrwx   1 root root   19 mag  2 21:31 S06rmnologin -> ../init.d/rmnologin

Re: Sddm no reboot poweroff al login

MessaggioInviato: 16/06/2017, 22:42
da Lioce
(Ho dovuto dividere il messaggio perché troppo lungo)

Altre informazioni:

Codice: Seleziona tutto
dpkg -l sddm
ii  sddm               0.14.0-4       i386


Codice: Seleziona tutto
$ uname -ar
Linux debtest 4.9.0-3-686-pae #1 SMP Debian 4.9.30-2 (2017-06-12) i686 GNU/Linux


e ovviamente ho sysvinit-core

Codice: Seleziona tutto
$ dpkg -l *sysvinit*
un  sysvinit           <nessuna>      <nessuna>      (nessuna descrizione disponibile)
ii  sysvinit-core      2.88dsf-59.9   i386           System-V-like init utilities
ii  sysvinit-utils     2.88dsf-59.9   i386           System-V-like utilities


s3v ha scritto:Per curiosità, un altro DM (tipo LightDM) ha lo stesso problema?


Scusate, ho dimenticato di dirvi che prima di aprire questa discussione ho provato lightdm + lightdm-kde-greeter e funzionava benissimo.
Poi l'ho disinstallato perché volevo capire la ragione del malfunzionamento di sddm.

Preciso ancora che il problema si presenta solamente al login, al logout tutti i pulsanti funzionano correttamente.