[RISOLTO] Debian 9.5: non funziona più il WIFI

La rete, Internet, configurazione di Servizi e tutto ciò che permette la comunicazione tra macchine

[RISOLTO] Debian 9.5: non funziona più il WIFI

Messaggioda Virus » 18/08/2018, 18:58

Buona sera a tutti.
Sono nuovo del forum e anche di Debian.
Sono passato a Debian dopo aver militato per un po' di tempo in Ubuntu. (ultima distribuzione Ubuntu 18.04LTS )
Tre giorni fa mi sono deciso a passare in Debian e finita l'installazione funzionava tutto bene. (per l'installazione ho usato il WIFI) Oggi mentre navigavo in internet ho ricevuto l'errore di connessione assente, dopo un po' di sbattimenti ho provato ad riavviare il modem ma non è cambiato nulla. Ho avviato il portatile con Ubuntu e funziona correttamente mentre Debian non mi fa più vedere le reti WIFI disponibili. Riesco a connettermi solo tramite filo ( che deve attraversare mezza casa e 2 stanze ) il che è molto scomodo.

Ho provato a fare qualche ricerca ma non sono riuscito a trovare niente di utile.
Qualche suggerimento?

Grazie in anticipo a chiunque provi ad aiutarmi

P.S. Ho un desktop con scheda WIFI PCIe

nota di moderazione: al fine di rendere l'oggetto della discussione maggiormente comprensibile ad altri utenti interessati si modifica da "Non funziona più il WIFI" a "Debian 9.5: non funziona più il WIFI dopo installazione".
Ultima modifica di Virus il 28/08/2018, 15:52, modificato 1 volta in totale.
Virus
Newbie
Newbie
 
Messaggi: 9
Iscritto il: 18/08/2018, 18:31

Re: Non funziona più il WIFI

Messaggioda Aki » 18/08/2018, 19:43

Benvenuto nel forum; come da regolamento sarebbe utile poter avere ulteriori informazioni e prendere visione del log da generare con le istruzioni indicate all’indirizzo http://guide.debianizzati.org/index.php ... i_al_forum
Aki
Global Moderator
Global Moderator
 
Messaggi: 7928
Iscritto il: 27/12/2007, 16:59

Re: Non funziona più il WIFI

Messaggioda Virus » 18/08/2018, 20:43

Intanto ti ringrazio di avermi risposto.
Perdona la mia ignoranza ma non riesco ad allegare il file compresso che ho generato. Come posso fare?
Virus
Newbie
Newbie
 
Messaggi: 9
Iscritto il: 18/08/2018, 18:31

Re: Non funziona più il WIFI

Messaggioda Virus » 18/08/2018, 20:51

log_18ago_213439.xz
(84.83 KiB) Scaricato 23 volte
Bene, credo di aver capito come allegre i file
Virus
Newbie
Newbie
 
Messaggi: 9
Iscritto il: 18/08/2018, 18:31

Re: Non funziona più il WIFI

Messaggioda Aki » 19/08/2018, 9:25

Nel file inviato risulta che mancherebbe il firmware per la scheda WiFi:
Codice: Seleziona tutto
$ lspci
[..]
03:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8192CE PCIe Wireless Network Adapter [10ec:8178] (rev 01)
        Subsystem: Realtek Semiconductor Co., Ltd. RTL8192CE PCIe Wireless Network Adapter [10ec:8178]
        Kernel driver in use: rtl8192ce
        Kernel modules: rtl8192ce

$ grep firmware log_18ago_213439  | grep rtl8192ce
ago 18 18:39:46 nomehost kernel: rtl8192ce: Using firmware rtlwifi/rtl8192cfw.bin
ago 18 18:39:46 nomehost kernel: rtl8192ce 0000:03:00.0: firmware: failed to load rtlwifi/rtl8192cfw.bin (-2)
ago 18 18:39:46 nomehost kernel: rtl8192ce 0000:03:00.0: Direct firmware load for rtlwifi/rtl8192cfw.bin failed with error -2
ago 18 18:39:46 nomehost kernel: rtl8192ce 0000:03:00.0: firmware: failed to load rtlwifi/rtl8192cfw.bin (-2)
ago 18 18:39:46 nomehost kernel: rtl8192ce 0000:03:00.0: firmware: failed to load rtlwifi/rtl8192cfw.bin (-2)
ago 18 18:39:46 nomehost kernel: rtl8192ce 0000:03:00.0: Direct firmware load for rtlwifi/rtl8192cfw.bin failed with error -2

Prima di procedere ad ulteriori verifiche, potresti installare il firmware mancante (pacchetto firmware-realtek) verificare se ci sono benefici e quindi rigenerare il log in caso di persistenza del malfunzionamento ?

Virus ha scritto:Tre giorni fa mi sono deciso a passare in Debian9 e finita l'installazione funzionava tutto bene. (per l'installazione ho usato il WIFI) Oggi mentre navigavo in internet ho ricevuto l'errore di connessione assente, dopo un po' di sbattimenti ho provato ad riavviare il modem ma non è cambiato nulla.

Inoltre, potresti indicarci in concomitanza di quale evento (se lo hai notato, ad esempio, un aggiornamento) e da quando si è verificato il malfunzionamento che riferisci ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 7928
Iscritto il: 27/12/2007, 16:59

Re: Non funziona più il WIFI

Messaggioda Virus » 19/08/2018, 9:58

Buongiorno e ancora grazie.
Inizio dicendo che stamani all'accensione del pc (per una decina di volte) appena arrivava al grub si riavviava da solo.
Stanco, ho inserito il dvd per formattare e per 4 volte appena arrivava alla analisi network mi segnalava la mancanza di "rtlwifi/rtl8192cfw.bin" e mi chiedeva se avevo un supporto fisico per installarlo. Alla risposta NO si riavviava il bios e tentava di accendersi.
Per curiosità ho provato ad avviarlo nuovamente senza dvd di installazione e si è acceso senza problemi ed è tornata a funzionare la wifi.

Detto questo ho letto ora il tuo messaggio ed ho provato a fare comunque quanto mi hai suggerito e credo di essere riuscito (che poi se non ho capito male è lo stessa cosa che cercava in fase di installazione). Ti allego nuovo LOG per controllare

log_19ago_104014.xz
(39.89 KiB) Scaricato 21 volte
Virus
Newbie
Newbie
 
Messaggi: 9
Iscritto il: 18/08/2018, 18:31

Re: Non funziona più il WIFI

Messaggioda Aki » 19/08/2018, 16:58

Virus ha scritto:Inizio dicendo che stamani all'accensione del pc (per una decina di volte) appena arrivava al grub si riavviava da solo.

Questo sintomo, in assenza di altri elementi, potrebbe far ipotizzare un malfunzionamento hardware (ad esempio, del disco o suoi collegamenti, della memoria, della scheda madre o della CPU) .

Virus ha scritto:Stanco, ho inserito il dvd per formattare e per 4 volte appena arrivava alla analisi network mi segnalava la mancanza di "rtlwifi/rtl8192cfw.bin" e mi chiedeva se avevo un supporto fisico per installarlo. Alla risposta NO si riavviava il bios e tentava di accendersi.

Come sopra, oppure conseguenza di un supporto di installazione difettoso oppure una immagine ISO incompleta o difettosa (hai verificato il checksum dell'immagine ISO prima ed del contenuto del DVD dopo la masterizzazione ?).

Virus ha scritto:Per curiosità ho provato ad avviarlo nuovamente senza dvd di installazione e si è acceso senza problemi ed è tornata a funzionare la wifi.

Quindi il malfunzionamento WiFi è risolto ?

Virus ha scritto:[..] ho provato a fare comunque quanto mi hai suggerito e credo di essere riuscito (che poi se non ho capito male è lo stessa cosa che cercava in fase di installazione). Ti allego nuovo LOG per controllare

Purtroppo, la segnalazione di mancanza del firmware persiste:
Codice: Seleziona tutto
ago 19 10:25:41 nomehost kernel: rtl8192ce 0000:03:00.0: firmware: failed to load rtlwifi/rtl8192cfw.bin (-2)
ago 19 10:25:41 nomehost kernel: rtl8192ce 0000:03:00.0: Direct firmware load for rtlwifi/rtl8192cfw.bin failed with error -2

Per risolvere dovresti poter impartire i seguenti comandi come utente root:
Codice: Seleziona tutto
script log.txt
wget http://ftp.us.debian.org/debian/pool/non-free/f/firmware-nonfree/firmware-realtek_20161130-3_all.deb
dpkg -i firmware-realtek_20161130-3_all.deb
exit

L'esito dei comandi impartiti e dei relativi output sarà in log.txt
Aki
Global Moderator
Global Moderator
 
Messaggi: 7928
Iscritto il: 27/12/2007, 16:59

Re: Debian 9.5: non funziona più il WIFI dopo installazione

Messaggioda Virus » 21/08/2018, 0:46

Si, di fatto non ha funzionato per un paio di giorni. Poi ha iniziato a funzionare nuovamente come prima.
Nel frattempo ho fatto ciò che mi hai suggerito.
Codice: Seleziona tutto
Script started on mar 21 ago 2018 01:38:48 CEST
root@Virus:/home/virus# fc-cache -f -vrm -fr /usr/share/fonts/truetype/fonts700/
fc-cache -f -vfc-cache -f -vrm -fr /usr/share/fonts/truetype/fonts700/
exitfc-cache -f -vsudo -v && wget -nv -O- https://download.calibre-ebook.co
om/linux-installer.sh | sudo sh /dev/stdinexit

wget http://ftp.us.debian.org/debian/pool/non-free/f/firm
mware-nonfree/firmware-realtek_20161130-3_all.deb
--2018-08-21 01:39:26--  http://ftp.us.debian.org/debian/pool/non-free/f/firmware-nonfree/firmware-realtek_20161130-3_all.deb
Risoluzione di ftp.us.debian.org (ftp.us.debian.org)... 128.30.2.26, 64.50.236.52, 64.50.233.100, ...
Connessione a ftp.us.debian.org (ftp.us.debian.org)|128.30.2.26|:80... connesso.
Richiesta HTTP inviata, in attesa di risposta... 200 OK
Lunghezza: 341740 (334K) [application/x-debian-package]
Salvataggio in: "firmware-realtek_20161130-3_all.deb.1"


          firmware-   0%[                    ]       0  --.-KB/s               
         firmware-r   8%[>                   ]  28,65K   111KB/s               
        firmware-re  30%[=====>              ] 102,37K   222KB/s               
       firmware-rea  42%[=======>            ] 140,55K   162KB/s               
      firmware-real  42%[=======>            ] 141,86K  84,8KB/s               
     firmware-realt  61%[===========>        ] 206,37K   109KB/s               
    firmware-realte  98%[==================> ] 327,48K   156KB/s               
firmware-realtek_20 100%[===================>] 333,73K   158KB/s    in 2,1s   

2018-08-21 01:39:29 (158 KB/s) - "firmware-realtek_20161130-3_all.deb.1" salvato [341740/341740]

root@Virus:/home/virus# dpkg -i firmware-realtek_20161130-3_all.deb
(Lettura del database...
(Lettura del database... 5%
(Lettura del database... 10%
(Lettura del database... 15%
(Lettura del database... 20%
(Lettura del database... 25%
(Lettura del database... 30%
(Lettura del database... 35%
(Lettura del database... 40%
(Lettura del database... 45%
(Lettura del database... 50%
(Lettura del database... 55%
(Lettura del database... 60%
(Lettura del database... 65%
(Lettura del database... 70%
(Lettura del database... 75%
(Lettura del database... 80%
(Lettura del database... 85%
(Lettura del database... 90%
(Lettura del database... 95%
(Lettura del database... 100%
(Lettura del database... 155422 file e directory attualmente installati.)
Preparativi per estrarre firmware-realtek_20161130-3_all.deb...
Estrazione di firmware-realtek (20161130-3) su (20161130-3)...
Configurazione di firmware-realtek (20161130-3)...
update-initramfs: deferring update (trigger activated)
Elaborazione dei trigger per initramfs-tools (0.130)...
update-initramfs: Generating /boot/initrd.img-4.9.0-8-amd64
root@Virus:/home/virus# exit
exit

Script done on mar 21 ago 2018 01:40:05 CEST

Sperando non dia più questo problema...
Grazie ancora!
Virus
Newbie
Newbie
 
Messaggi: 9
Iscritto il: 18/08/2018, 18:31

Re: Debian 9.5: non funziona più il WIFI dopo installazione

Messaggioda Virus » 21/08/2018, 0:57

Ti invio anche questo per un ulteriore controllo (ho provato a dare un'occhiata ma non ci ho capito nulla)
log_21ago_014752.xz
(40.95 KiB) Scaricato 25 volte
Virus
Newbie
Newbie
 
Messaggi: 9
Iscritto il: 18/08/2018, 18:31

Re: Debian 9.5: non funziona più il WIFI dopo installazione

Messaggioda Aki » 25/08/2018, 8:23

Mi sembra non ci siano altri elementi di rilievo rispetto alla segnalazione che avevi fatto. Se condividi, puoi contrassegnare la discussione come risolta ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 7928
Iscritto il: 27/12/2007, 16:59


Torna a Network

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron