[RISOLTO] Url rewrite in Apache

La rete, Internet, configurazione di Servizi e tutto ciò che permette la comunicazione tra macchine

[RISOLTO] Url rewrite in Apache

Messaggioda berserk-ivix » 14/05/2017, 4:52

Ciao a tutti.
Sto provando a installare BlaBlaNet sul mio server per fare qualche esperimento, nella schermata di verifica e' tutto ok tranne l'ultimo punto:
Url rewrite funziona correttamente
e mi da questo errore:
Codice: Seleziona tutto
Url rewrite in .htaccess is not working. Check your server configuration.Test: array ( 'return_code' => 0, 'success' => false, 'header' => '', 'body' => '', 'error' => 'Failed to connect to localhost port 443: Connection refused', 'debug' => array ( 'url' => 'https://localhost/setup/testrewrite', 'content_type' => NULL, 'http_code' => 0, 'header_size' => 0, 'request_size' => 0, 'filetime' => -1, 'ssl_verify_result' => 0, 'redirect_count' => 0, 'total_time' => 0.0042370000000000003, 'namelookup_time' => 0.0041289999999999999, 'connect_time' => 0.0, 'pretransfer_time' => 0.0, 'size_upload' => 0.0, 'size_download' => 0.0, 'speed_download' => 0.0, 'speed_upload' => 0.0, 'download_content_length' => -1.0, 'upload_content_length' => -1.0, 'starttransfer_time' => 0.0, 'redirect_time' => 0.0, 'redirect_url' => '', 'primary_ip' => '', 'certinfo' => array ( ), 'primary_port' => 0, 'local_ip' => '', 'local_port' => 0, ), )


Come risolvo?

Grazie in anticipo.

Ciao, Ivano.
Ultima modifica di berserk-ivix il 14/05/2017, 5:20, modificato 1 volta in totale.
Ciao, Ivano.
.
berserk-ivix
Jr. Member
Jr. Member
 
Messaggi: 96
Iscritto il: 25/11/2015, 7:14

Re: Url rewrite in Apache

Messaggioda berserk-ivix » 14/05/2017, 5:00

P.S.: Questo e' il contenuto di .htaccess:
Codice: Seleziona tutto
# START - Disable server signature Protect Your BlaBlaNet Ants Node#
ServerSignature Off
# END - Disable server signature #

Options -Indexes
AddType application/x-java-archive .jar
AddType audio/ogg .oga
#SSLCipherSuite HIGH:AES256-SHA:AES128-SHA:RC4:!aNULL:!eNULL:!EDH

# don't allow any web access to logfiles, even after rotation/compression
<FilesMatch "\.(out|log|gz)$">
  <IfModule mod_authz_core.c>
    Require all denied
  </IfModule>
  <IfModule !mod_authz_core.c>
    Order deny,allow
    Deny from all
  </IfModule>
</FilesMatch>

<IfModule mod_rewrite.c>
  RewriteEngine on
  # Protect repository directory from browsing
  RewriteRule "(^|/)\.git" - [F]
  RewriteRule "(^|/)store" - [F]

  # Rewrite current-style URLs of the form 'index.php?q=x'.
  # Also place auth information into REMOTE_USER for sites running
  # in CGI mode.

  RewriteCond %{REQUEST_URI} ^/\.well\-known/.*
  RewriteRule ^(.*)$ index.php?q=$1 [E=REMOTE_USER:%{HTTP:Authorization},L,QSA]

  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteRule ^(.*)$ index.php?q=$1 [E=REMOTE_USER:%{HTTP:Authorization},L,QSA]
</IfModule>
Ciao, Ivano.
.
berserk-ivix
Jr. Member
Jr. Member
 
Messaggi: 96
Iscritto il: 25/11/2015, 7:14

Re: [RISOLTO] Url rewrite in Apache

Messaggioda berserk-ivix » 14/05/2017, 5:22

Ho risolto, bastava mettere
AllowOverride All
nel file di configurazione /etc/apache2/apache2.conf
Ciao, Ivano.
.
berserk-ivix
Jr. Member
Jr. Member
 
Messaggi: 96
Iscritto il: 25/11/2015, 7:14


Torna a Network

Chi c’è in linea

Visitano il forum: Google [Bot] e 4 ospiti