[RISOLTO] LXDE - Collegamento wifi con server radius AD

La rete, Internet, configurazione di Servizi e tutto ciò che permette la comunicazione tra macchine

[RISOLTO] LXDE - Collegamento wifi con server radius AD

Messaggioda gano » 15/06/2017, 18:23

Salve.
Ho un vecchio netbook Samsung N150 con processore Atom e 2GB di RAM. Tempo fa avevo istallato Debian 8 con gnome3 e riuscivo a connettermi alla rete wifi del lavoro. Siccome il pc era molto lento, ho provato a reistallare tutto con la solita .iso sulla solita chiavetta USB ma con ambiente grafico lxde. Il pc in se va meglio. La connessione al wifi di casa funziona.
I parametri di connessione che usavo con l'interfaccia grafica di network-manager, e che funzionavano, erano:

  • Sicurezza: WPA e WPA 2 Enterprise
  • Autenticazione: EAP Protetto (PEAP)
  • Identità anonima: -
  • Certificato della CA: (Nessuno)
  • Versione PEAP: Automatico
  • Autenticazione interna: MSCHAPv2
  • Nome utente: <utente>@<dominio_AD>
  • Password: ***

Conosco l'SSID della rete ma la rete è nascosta.
Ho provato invano sia con Wicd che con wpa_supplicant + wpa_cli (le mie conoscenze in merito sono quasi zero).
wpa_cli retituisce qualcosa del tipo: "Association request to the driver failed".
Posto l'output di lspci:

Codice: Seleziona tutto
# lspci -v -d 168c:002b
05:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
   Subsystem: Foxconn International, Inc. T77H121.05 802.11bgn Wireless Half-size Mini PCIe Card
   Flags: bus master, fast devsel, latency 0, IRQ 16
   Memory at f0100000 (64-bit, non-prefetchable) [size=64K]
   Capabilities: [40] Power Management version 3
   Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit-
   Capabilities: [60] Express Legacy Endpoint, MSI 00
   Capabilities: [100] Advanced Error Reporting
   Capabilities: [140] Virtual Channel
   Capabilities: [160] Device Serial Number 00-15-17-ff-ff-24-14-12
   Capabilities: [170] Power Budgeting <?>
   Kernel driver in use: ath9k


Per connettermi a questa rete mi hanno sempre fatto usare un certificato. Normalmente l'ho sempre importato in modo grafico, ma siccome stavolta il pulsante Importa era disabilitato, ho creato una cartella in /usr/share/ca-certificates/ e ci ho copiato il certificato. Dopodiché ho dato:

Codice: Seleziona tutto
sudo update-ca-certificates


Ho finito le idee...
gano
Newbie
Newbie
 
Messaggi: 13
Iscritto il: 16/06/2013, 23:57

[RISOLTO] LXDE - Collegamento wifi con server radius Active

Messaggioda gano » 10/10/2017, 16:57

Un mese fa ho dovuto re-istallare il sistema. Ho di nuovo messo Debian Jesse con LXDE. Il problema del wifi persisteva.
Ho scoperto che la questione principale era relativa ai template di wicd ma, siccome mi avevano detto di usare il certificato, forse ho effettuato qualche passaggio in più che magari non serviva ma che comunque elenco:
    (Parte - forse - "opzionale")
  • Ho copiato il certificato nel pc e mi sono posizionato con una shell nella cartella dove l'ho inserito.
  • Ho istallato il certificato con:
    Codice: Seleziona tutto
    sudo cp miocert.crt /usr/local/share/ca-certificates/cacert-miocert.crt
    sudo update-ca-certificates
    sudo apt-file list ca-certificates | grep miocert //verifica istal. e path

    (Fine parte -forse- "opzionale")
  • Da qui in avanti mi sono promosso come root con sudo -i
  • La rete era nascosta ma conoscevo il MAC col quale viene esposta. Ho modificato il file /etc/wicd/wireless-settings.conf in modo che la gui di wicd distinguesse questa <hidden> dalle altre.
    Codice: Seleziona tutto
    cd /etc/wicd/
    cp wireless-settings.conf wireless-settings.conf.bkp.gano
    vi wireless-settings.conf

    Ho cercato la entry nominata con il MAC desiderato ed all'interno di essa ho cambiato il valore della chiave essid da <hidden> a quello nascosto che però conoscevo ed ho salvato il file:
    Codice: Seleziona tutto
    [00:11:22:33:44:55:66]
    ...
    essid=MioSSID
    ...
  • Andava editato un nuovo template, perché quello di default utilizzato da wicd per MSCHAPv2 mischia questo con TKIP e non prevede di NON passare il certificato (googlate un po' alla ricerca di wicd templates per approfondire la questione, soprattutto in merito alla sintassi da utilizzare nei template). Per editare questo file avevo però bisogno di informazioni sulla rete wireless che ho reperito con iwlist:
    Codice: Seleziona tutto
    iwlist wlan0 scan

    OUT:

    Cell 05 - Address: 00:11:22:33:44:55:66
    ...
                        IE: IEEE 802.11i/WPA2 Version 1
                            Group Cipher : CCMP
                            Pairwise Ciphers (1) : CCMP
                            Authentication Suites (1) : 802.1x
    ...
  • Ho così potuto creare il nuovo template:
    Codice: Seleziona tutto
    cd /etc/wicd/encryption/templates/
    //dare un'occhiata a quello che c'è:
    ls -l
    //il file incriminato dovrebbe essere peap-tkip
    //ne creo uno nuovo e controllo che il proprietario ed i
    //permessi siano a posto ed edito il file:
    touch peap-mschapv2
    ls -l peap-mschapv2
    vi peap-mschapv2

    Ho incollato nel file:
    Codice: Seleziona tutto
    name = PEAP with MSCHAPV2
    author = Gano
    version = 1
    require identity *Identity password *Password
    protected password *Password
    -----
    ctrl_interface=/var/run/wpa_supplicant
    network={
            ssid="$_ESSID"
            scan_ssid=$_SCAN
            key_mgmt=WPA-EAP
            pairwise=CCMP
            group=CCMP
            eap=PEAP
            phase2="auth=MSCHAPV2"
            identity="$_IDENTITY"
            password="$_PASSWORD"
    }
  • A questo punto arriva una questione che mi ha fatto impazzire, perché dalla gui di wicd non riuscivo a far apparire il mio template nel menù a tendina. Occorre editare il file active presente nella stessa directory ed aggiungere il nome del template nella posizione desiderata. Nel mio caso:
    Codice: Seleziona tutto
    wpa
    wpa-peap
    wpa-psk
    wpa2-leap
    wpa2-peap
    wep-hex
    wep-passphrase
    wep-shared
    leap
    ttls
    eap
    peap
    peap-mschapv2      --- io l'ho inserito qui
    peap-tkip
    eap-tls
    psu

    Ho riavviato wicd:
    Codice: Seleziona tutto
    /etc/init.d/wicd restart
  • A questo punto aprendo la gui di wicd, dopo la scansione ho trovato l'SSID impostato nel file /etc/wicd/wireless-settings.conf, ho cliccato su Proprietà e spuntando cifratura nel menù a tendina ho visto anche la descrizione usata nel file peap-mschapv2, e cioè PEAP with MSCHAPV2. Ho inserito le mie credenziali per il dominio Active Directory e la connessione è andata a buon fine.
gano
Newbie
Newbie
 
Messaggi: 13
Iscritto il: 16/06/2013, 23:57


Torna a Network

Chi c’è in linea

Visitano il forum: Google [Bot] e 3 ospiti