[RISOLTO] Hotspot con debian 9

La rete, Internet, configurazione di Servizi e tutto ciò che permette la comunicazione tra macchine

Re: Hotspot con debian 9

Messaggioda Aki » 29/06/2017, 11:47

Mi sembra che hai risolto, giusto ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 8318
Iscritto il: 27/12/2007, 16:59

Re: Hotspot con debian 9

Messaggioda acciderboli » 29/06/2017, 13:24

Parzialmente, nel senso che vorrei attivare l'hotspot dall apposito tasto del network manager e non dal terminale.
Se funziona da terminale appunto, non riesco a capire perchè non riesco a farlo tramite il network manger.
Suggerimenti?
acciderboli
Newbie
Newbie
 
Messaggi: 25
Iscritto il: 14/06/2012, 14:24

Re: Hotspot con debian 9

Messaggioda Aki » 29/06/2017, 13:40

Dall'applicazione di kde che gestisce il network manager dovrebbe essere possibile impostare una specifica connessione affinché si connetta automaticamente quando è rilevata: hai attivato tale opzione ?

Al contrario, cosa accade se, con la connessione GSM/UMTS attiva, attivi manualmente la connessione WiFi ? Puoi fornire il log di questa situazione ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 8318
Iscritto il: 27/12/2007, 16:59

Re: Hotspot con debian 9

Messaggioda acciderboli » 29/06/2017, 13:49

Sono su gnome.
Vuoi il log di quando provo a fare l'hotspot da network manager?
acciderboli
Newbie
Newbie
 
Messaggi: 25
Iscritto il: 14/06/2012, 14:24

Re: Hotspot con debian 9

Messaggioda Aki » 29/06/2017, 13:53

Sì. Avvia il computer, avvia la connessione GSM/UMTS, quindi attiva la connessione WiFi, quindi impartisci da linea di comando - se non funzionate come hotspot - il comando che ti è stato suggerito, quindi genera il log da inviare.

Ed, inoltre, come ti chiedevo in un precedente messaggio hai abilitato sul WiFi la connessione automatica (vedi immagine sotto riportata di gnome, nell'esempio riferita ad una connessione su cavi) ?
Allegati
dialog.png
dialog.png (5.33 KiB) Osservato 3043 volte
Aki
Global Moderator
Global Moderator
 
Messaggi: 8318
Iscritto il: 27/12/2007, 16:59

Re: Hotspot con debian 9

Messaggioda acciderboli » 29/06/2017, 14:20

Appena arrivo a casa provo.
Grazie mille intanto!
acciderboli
Newbie
Newbie
 
Messaggi: 25
Iscritto il: 14/06/2012, 14:24

Re: Hotspot con debian 9

Messaggioda acciderboli » 29/06/2017, 17:06

Fatto il log dopo aver dato il comando, la connessione automatica del wifi è abilitata.
Una domanda, non è che se creo un ap nuovo magari risolvo?
Perchè il sid e la password sono quelli che avevo su jessie.
Grazie!
Allegati
log_29giu_180245.xz
(46.62 KiB) Scaricato 86 volte
acciderboli
Newbie
Newbie
 
Messaggi: 25
Iscritto il: 14/06/2012, 14:24

Re: Hotspot con debian 9

Messaggioda Aki » 01/07/2017, 9:28

Dall'ultimo log che hai inviato risulta che all'avvio del gestore delle connessioni di rete (network manager) l'interfaccia di rete WiFi (chiamata wlan0) è disattivata ("WiFi hardware radio set disabled", presumibilmente spenta da configurazione a livello di firmware/BIOS), mentre è attiva quella GSM/UMTS ("WWAN hardware radio set enabled"):
Codice: Seleziona tutto
giu 29 17:37:45  NetworkManager[501]: <info>  [1498750665.2584] rfkill2: found WiFi radio killswitch (at /sys/devices/pci0000:00/0000:00:1c.1/0000:03:00.0/ieee80211/phy0/rfkill2) (driver iwlwifi)
giu 29 17:37:45  NetworkManager[501]: <info>  [1498750665.2587] rfkill1: found WWAN radio killswitch (at /sys/devices/platform/thinkpad_acpi/rfkill/rfkill1) (platform driver thinkpad_acpi)
giu 29 17:37:45  NetworkManager[501]: <info>  [1498750665.2593] manager[0x56001b5ea040]: WiFi hardware radio set disabled
giu 29 17:37:45  NetworkManager[501]: <info>  [1498750665.2601] manager[0x56001b5ea040]: WWAN hardware radio set enabled

Inoltre dai log risulta che quando il network manager tenta di avviare la scheda di rete WiFi la prima volta, risulta che non riesce a farlo in quanto la scheda di rete WiFi è disattivata a livello di hardware o software (il messaggio nel log è: "manager: WiFi now disabled by radio killswitch"):
Codice: Seleziona tutto
giu 29 17:37:46  NetworkManager[501]: <info>  [1498750666.3672] device (wlan0): driver supports Access Point (AP) mode
giu 29 17:37:46  NetworkManager[501]: <info>  [1498750666.3701] manager: (wlan0): new 802.11 WiFi device (/org/freedesktop/NetworkManager/Devices/3)
giu 29 17:37:46  NetworkManager[501]: <info>  [1498750666.3744] device (wlan0): state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
giu 29 17:37:46  NetworkManager[501]: <info>  [1498750666.3758] device (wlan0): set-hw-addr: set MAC address to 6E:D9:23:B0:DF:CE (scanning)
giu 29 17:37:46  kernel: IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
giu 29 17:37:46  NetworkManager[501]: <info>  [1498750666.4019] manager: WiFi now disabled by radio killswitch
giu 29 17:37:46  dbus[323]: [system] Activating via systemd: service name='fi.w1.wpa_supplicant1' unit='wpa_supplicant.service'

Il tuo computer (Lenovo ThinkPad T420s) dispone di un interruttore o di un pulsante che attiva / disattiva la scheda di rete WiFi ? In caso affermativo, in che posizione si trova ? Dispone di una configurazione nel BIOS/firmware UEFI relativo allo stato della scheda di rete WiFi all'avvio del computer ?

Inoltre, il computer dispone di una combinazione di tasti (ad esempio, FN + F5) che permette di attivare/disattivare la scheda di rete WiFi ?

Come utente root, dopo l'avvio del computer con la scheda di rete WiFi presumibilmente inattiva, puoi impartire i seguenti comandi come utente root e poi inviare il contenuto del file log.txt:
Codice: Seleziona tutto
script log.txt
apt-get install rfkill
rfkill list
exit
Aki
Global Moderator
Global Moderator
 
Messaggi: 8318
Iscritto il: 27/12/2007, 16:59

Re: Hotspot con debian 9

Messaggioda acciderboli » 02/07/2017, 11:20

Ciao, sì ho il tasto fisico e i tasti funzione per accendere il wifi.
Ho fatto 2 log, uno con il wifi acceso e uno con il wifi spento.
Grazie per l'aiuto.

logwifion

Codice: Seleziona tutto
$ sudo rfkill list
0: tpacpi_bluetooth_sw: Bluetooth
   Soft blocked: no
   Hard blocked: no
1: tpacpi_wwan_sw: Wireless WAN
   Soft blocked: no
   Hard blocked: no
2: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: no
9: hci0: Bluetooth
   Soft blocked: yes
   Hard blocked: no
$ exit
Script done on dom 02 lug 2017 12:16:22 CEST


logwifioff

Codice: Seleziona tutto
Script started on dom 02 lug 2017 12:17:25 CEST
$ exitsudo rfkill list
0: tpacpi_bluetooth_sw: Bluetooth
   Soft blocked: no
   Hard blocked: no
1: tpacpi_wwan_sw: Wireless WAN
   Soft blocked: no
   Hard blocked: no
2: phy0: Wireless LAN
   Soft blocked: yes
   Hard blocked: no
9: hci0: Bluetooth
   Soft blocked: yes
   Hard blocked: no
exit
Script done on dom 02 lug 2017 12:17:35 CEST
acciderboli
Newbie
Newbie
 
Messaggi: 25
Iscritto il: 14/06/2012, 14:24

Re: Hotspot con debian 9

Messaggioda Aki » 02/07/2017, 11:50

Sì, ma rispetto al riferito malfunzionamento ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 8318
Iscritto il: 27/12/2007, 16:59

Re: Hotspot con debian 9

Messaggioda acciderboli » 02/07/2017, 12:12

Io ancora non riesco a farlo funzionare dal tasto del network manager.
acciderboli
Newbie
Newbie
 
Messaggi: 25
Iscritto il: 14/06/2012, 14:24

Re: Hotspot con debian 9

Messaggioda byte64 » 02/07/2017, 12:55

Proviamo così:
Attiva la scheda wifi e la wwan
Apri un terninale e digita:
Codice: Seleziona tutto
tail -f /var/log/syslog > hotspot.log

Attiva l'hotspot da network manager
Dopo qualche secondo fai ctrl+c sul terminale e poi posta il contenuto del file hotspot.log
byte64
Sr. Member
Sr. Member
 
Messaggi: 367
Iscritto il: 07/01/2017, 19:02
Località: Bergamo

Re: Hotspot con debian 9

Messaggioda acciderboli » 02/07/2017, 17:20

byte64 ha scritto:Proviamo così:
Attiva la scheda wifi e la wwan
Apri un terninale e digita:
Codice: Seleziona tutto
tail -f /var/log/syslog > hotspot.log

Attiva l'hotspot da network manager
Dopo qualche secondo fai ctrl+c sul terminale e poi posta il contenuto del file hotspot.log


Non riesco a trovare il file hotspot.log.
In var non c'è, si trova da un'altra parte?
Grazie
acciderboli
Newbie
Newbie
 
Messaggi: 25
Iscritto il: 14/06/2012, 14:24

Re: Hotspot con debian 9

Messaggioda byte64 » 02/07/2017, 17:51

Si trova nella dir dove hai aperto il terminale. Probabilmente in /home/tuonomeutente
Per controllare, una volta aperto il terminale digita il comando pwd che ti mostra la directory corrente.
byte64
Sr. Member
Sr. Member
 
Messaggi: 367
Iscritto il: 07/01/2017, 19:02
Località: Bergamo

Re: Hotspot con debian 9

Messaggioda acciderboli » 03/07/2017, 17:02

byte64 ha scritto:Si trova nella dir dove hai aperto il terminale. Probabilmente in /home/tuonomeutente
Per controllare, una volta aperto il terminale digita il comando pwd che ti mostra la directory corrente.


Trovato. Questo è il log di quando provo ad attivare l'hotspot dal network manager( non si avvia).
Grazie
Codice: Seleziona tutto
Jul  3 17:59:51 Daniel NetworkManager[465]: <info>  [1499097591.3809] Executing: /sbin/iptables --table filter --delete FORWARD --source 10.42.0.0/255.255.255.0 --in-interface wlan0 --jump ACCEPT
Jul  3 17:59:51 Daniel NetworkManager[465]: <info>  [1499097591.3852] Executing: /sbin/iptables --table filter --delete FORWARD --in-interface wlan0 --out-interface wlan0 --jump ACCEPT
Jul  3 17:59:51 Daniel NetworkManager[465]: <info>  [1499097591.3881] Executing: /sbin/iptables --table filter --delete FORWARD --out-interface wlan0 --jump REJECT
Jul  3 17:59:51 Daniel NetworkManager[465]: <info>  [1499097591.3908] Executing: /sbin/iptables --table filter --delete FORWARD --in-interface wlan0 --jump REJECT
Jul  3 17:59:51 Daniel NetworkManager[465]: <info>  [1499097591.3937] Executing: /sbin/iptables --table filter --delete INPUT --in-interface wlan0 --protocol udp --destination-port 67 --jump ACCEPT
Jul  3 17:59:51 Daniel NetworkManager[465]: <info>  [1499097591.3966] Executing: /sbin/iptables --table filter --delete INPUT --in-interface wlan0 --protocol tcp --destination-port 67 --jump ACCEPT
Jul  3 17:59:51 Daniel NetworkManager[465]: <info>  [1499097591.3993] Executing: /sbin/iptables --table filter --delete INPUT --in-interface wlan0 --protocol udp --destination-port 53 --jump ACCEPT
Jul  3 17:59:51 Daniel NetworkManager[465]: <info>  [1499097591.4039] Executing: /sbin/iptables --table filter --delete INPUT --in-interface wlan0 --protocol tcp --destination-port 53 --jump ACCEPT
Jul  3 17:59:52 Daniel goa-daemon[1132]: secret_password_lookup_sync() returned NULL
Jul  3 17:59:53 Daniel goa-daemon[1132]: secret_password_lookup_sync() returned NULL
Jul  3 18:00:00 Daniel tracker-extract[1259]: unable to create file '/run/user/1000/dconf/user': Permesso negato.  dconf will not work properly.
Jul  3 18:00:03 Daniel dbus[308]: [system] Activating via systemd: service name='org.freedesktop.hostname1' unit='dbus-org.freedesktop.hostname1.service'
Jul  3 18:00:03 Daniel systemd[1]: Starting Hostname Service...
Jul  3 18:00:03 Daniel tracker-extract[1259]: unable to create file '/run/user/1000/dconf/user': Permesso negato.  dconf will not work properly.
Jul  3 18:00:03 Daniel dbus[308]: [system] Successfully activated service 'org.freedesktop.hostname1'
Jul  3 18:00:03 Daniel systemd[1]: Started Hostname Service.
Jul  3 18:00:03 Daniel NetworkManager[465]: <info>  [1499097603.8758] audit: op="connection-update" uuid="157ca1c7-1330-4d77-b7ef-fb8b9a467cd2" name="Hotspot" result="fail" reason="802-11-wireless.ssid: manca la proprietà"
Jul  3 18:00:03 Daniel gnome-control-c[2060]: Failed to save hotspot's settings to disk: 802-11-wireless.ssid: manca la proprietà
Jul  3 18:00:05 Daniel tracker-extract[1259]: unable to create file '/run/user/1000/dconf/user': Permesso negato.  dconf will not work properly.
acciderboli
Newbie
Newbie
 
Messaggi: 25
Iscritto il: 14/06/2012, 14:24

PrecedenteProssimo

Torna a Network

Chi c’è in linea

Visitano il forum: Nessuno e 4 ospiti