[Risolto] Failed to start Raise network interfaces-Debian9

La rete, Internet, configurazione di Servizi e tutto ciò che permette la comunicazione tra macchine

[Risolto] Failed to start Raise network interfaces-Debian9

Messaggioda GuidoU » 11/07/2017, 22:26

Gentile Forum,
ricevo il messaggio di errore presente nel titolo al boot, dopo aver installato debian 9 gnome live.
Durante l'istallazione ho avuto il messaggio di mancanza firmware citato nella guida http://guide.debianizzati.org/index.php/Debian_e_firmware,
ma ho continuato comunque l'istallazione e dopo che è terminata ho installato firmware-realtek, come consigliato.
La rete (il collegamento ad internet) comunque, nonostante il messaggio, funziona regolarmente.
Al boot la mia scheda di rete viene rinominata (enp2s0 rimpiazza eth0) e viene caricato il firmware rtl8168g-2.fw (tutte le info le ho avute da dmesg). Cosa c'è allora che non va? Perchè quel messaggio?
Grazie,
Guido.
Ultima modifica di GuidoU il 13/07/2017, 14:53, modificato 1 volta in totale.
GuidoU
Newbie
Newbie
 
Messaggi: 10
Iscritto il: 31/01/2013, 16:18
Località: Vicenza

Re: Failed to start Raise network interfaces - debian 9

Messaggioda Aki » 12/07/2017, 2:09

Puoi riportare esattamente il messaggio ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 7866
Iscritto il: 27/12/2007, 16:59

Re: Failed to start Raise network interfaces - debian 9

Messaggioda byte64 » 12/07/2017, 6:53

Probabilmente il sistema cerca di attivare l'interfaccia di rete prima di network-manager, proprio il cambio di nome dell'interfaccia dovrebbe essere la causa. Anche l'installazione del firmware postumo potrebbe esserne in parte causa.
Puoi postare il contenuto del file /etc/network/interfaces ?
Inoltre l'output dei comandi:
Codice: Seleziona tutto
systemctl status networking.service
systemctl status network-manager.service
byte64
Sr. Member
Sr. Member
 
Messaggi: 366
Iscritto il: 07/01/2017, 19:02
Località: Bergamo

Re: Failed to start Raise network interfaces - debian 9

Messaggioda GuidoU » 12/07/2017, 21:09

Si dunque:

dal comando
Codice: Seleziona tutto
systemctl status network.service
ottengo la seguente risposta:

Codice: Seleziona tutto
● networking.service - Raise network interfaces
   Loaded: loaded (/lib/systemd/system/networking.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Wed 2017-07-12 21:58:16 CEST; 3min 48s ago
     Docs: man:interfaces(5)
  Process: 628 ExecStart=/sbin/ifup -a --read-environment (code=exited, status=1/FAILURE)
  Process: 504 ExecStartPre=/bin/sh -c [ "$CONFIGURE_INTERFACES" != "no" ] && [ -n "$(ifquery --read-environment --list --exclude=lo)" ] &&
 Main PID: 628 (code=exited, status=1/FAILURE)


il comando
Codice: Seleziona tutto
systemctl status network-manager.service
fornisce:

Codice: Seleziona tutto
● NetworkManager.service - Network Manager
   Loaded: loaded (/lib/systemd/system/NetworkManager.service; enabled; vendor preset: enabled)
   Active: active (running) since Wed 2017-07-12 21:58:01 CEST; 11min ago
     Docs: man:NetworkManager(8)
 Main PID: 549 (NetworkManager)
    Tasks: 3 (limit: 4915)
   CGroup: /system.slice/NetworkManager.service
           └─549 /usr/sbin/NetworkManager --no-daemon

lug 12 21:58:02 debian9 NetworkManager[549]: <info>  [1499889482.4826] Loaded device plugin: NMBluezManager (/usr/lib/x86_64-linux-gnu/Netwo
lug 12 21:58:02 debian9 NetworkManager[549]: <info>  [1499889482.4972] Loaded device plugin: NMTeamFactory (/usr/lib/x86_64-linux-gnu/Networ
lug 12 21:58:02 debian9 NetworkManager[549]: <info>  [1499889482.5053] device (lo): link connected
lug 12 21:58:02 debian9 NetworkManager[549]: <info>  [1499889482.5057] manager: (lo): new Generic device (/org/freedesktop/NetworkManager/De
lug 12 21:58:02 debian9 NetworkManager[549]: <info>  [1499889482.5063] manager: (enp2s0): new Ethernet device (/org/freedesktop/NetworkManag
lug 12 21:58:02 debian9 NetworkManager[549]: <info>  [1499889482.5150] manager: startup complete
lug 12 21:58:02 debian9 NetworkManager[549]: <warn>  [1499889482.5150] Error: failed to open /run/network/ifstate
lug 12 21:58:02 debian9 NetworkManager[549]: <info>  [1499889482.5195] ModemManager available in the bus
lug 12 21:58:11 debian9 NetworkManager[549]: <info>  [1499889491.2368] manager: NetworkManager state is now CONNECTED_GLOBAL
lug 12 21:58:14 debian9 NetworkManager[549]: <info>  [1499889494.1295] device (enp2s0): link connected
lines 1-19/19 (END)


mentre da
Codice: Seleziona tutto
dmesg tail
ottengo il seguente:

Codice: Seleziona tutto
[   21.879190] r8169 0000:02:00.0: firmware: direct-loading firmware rtl_nic/rtl8168g-2.fw
[   21.924165] r8169 0000:02:00.0 enp2s0: link down
[   21.924180] r8169 0000:02:00.0 enp2s0: link down
[   21.924213] IPv6: ADDRCONF(NETDEV_UP): enp2s0: link is not ready
[   24.623170] r8169 0000:02:00.0 enp2s0: link up
[   24.623182] IPv6: ADDRCONF(NETDEV_CHANGE): enp2s0: link becomes ready
[   31.733001] usb 3-6: reset high-speed USB device number 7 using xhci_hcd
[   43.665884] fuse init (API version 7.26)


Ho provato a sostituire enp2s0 nei files

/etc/network/interfaces.d/setup

(contenuto del file:

Codice: Seleziona tutto
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

/etc/network/interfaces

(contenuto del file:

Codice: Seleziona tutto
source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

)

al posto di eth0, ma senza successo: l'errore al boot è rimasto.

Comunque, ripeto, la rete funziona normalmente.

Guido.
GuidoU
Newbie
Newbie
 
Messaggi: 10
Iscritto il: 31/01/2013, 16:18
Località: Vicenza

Re: Failed to start Raise network interfaces - debian 9

Messaggioda byte64 » 12/07/2017, 21:56

Elimina il ffile setup in /etc/network/interfaces.d/ e lascia il file interfaces in /etc/network/ con questo contenuto
Codice: Seleziona tutto
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback


riavvia il servizio, anzi meglio fai un reboot e ricontrolla il dmesg
Codice: Seleziona tutto
dmesg |grep eth0
byte64
Sr. Member
Sr. Member
 
Messaggi: 366
Iscritto il: 07/01/2017, 19:02
Località: Bergamo

Re: [Risolto]Failed to start Raise network interfaces - debi

Messaggioda GuidoU » 13/07/2017, 15:03

Si,
è bastato commentare le due righe del file /etc/network/interfaces.d/setup
ottenendo quindi il seguente contenuto:

Codice: Seleziona tutto
auto lo
iface lo inet loopback

# auto eth0
# iface eth0 inet dhcp


ed il messaggio è scomparso, anzi ora la "Raise" network viene attivata:

il comando
Codice: Seleziona tutto
systemctl status networking.service
fornisce infatti il seguente output:

Codice: Seleziona tutto
● networking.service - Raise network interfaces
   Loaded: loaded (/lib/systemd/system/networking.service; enabled; vendor preset: enabled)
   Active: active (exited) since Thu 2017-07-13 15:50:42 CEST; 9min ago
     Docs: man:interfaces(5)
  Process: 493 ExecStart=/sbin/ifup -a --read-environment (code=exited, status=0/SUCCESS)
  Process: 484 ExecStartPre=/bin/sh -c [ "$CONFIGURE_INTERFACES" != "no" ] && [ -n "$(ifquery --read-environment --list --exclude=lo)" ] &&
 Main PID: 493 (code=exited, status=0/SUCCESS)
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/networking.service
           └─654 /sbin/dhclient -4 -v -pf /run/dhclient.enp2s0.pid -lf /var/lib/dhcp/dhclient.enp2s0.leases -I -df /var/lib/dhcp/dhclient6.e

lug 13 15:50:42 debian9 dhclient[591]: DHCPDISCOVER on enp2s0 to 255.255.255.255 port 67 interval 20
lug 13 15:50:42 debian9 ifup[493]: DHCPDISCOVER on enp2s0 to 255.255.255.255 port 67 interval 20
lug 13 15:50:42 debian9 dhclient[591]: DHCPREQUEST of 192.168.1.3 on enp2s0 to 255.255.255.255 port 67
lug 13 15:50:42 debian9 ifup[493]: DHCPREQUEST of 192.168.1.3 on enp2s0 to 255.255.255.255 port 67
lug 13 15:50:42 debian9 ifup[493]: DHCPOFFER of 192.168.1.3 from 192.168.1.1
lug 13 15:50:42 debian9 dhclient[591]: DHCPOFFER of 192.168.1.3 from 192.168.1.1
lug 13 15:50:42 debian9 dhclient[591]: DHCPACK of 192.168.1.3 from 192.168.1.1
lug 13 15:50:42 debian9 ifup[493]: DHCPACK of 192.168.1.3 from 192.168.1.1
lug 13 15:50:42 debian9 ifup[493]: bound to 192.168.1.3 -- renewal in 41069 seconds.
lug 13 15:50:42 debian9 systemd[1]: Started Raise network interfaces.


ed il comando
Codice: Seleziona tutto
dmesg | grep eth0
genera il seguente output:

Codice: Seleziona tutto
[    1.074638] r8169 0000:02:00.0 eth0: RTL8168g/8111g at 0xffffbc63c0c75000, d0:50:99:84:23:8d, XID 0c000800 IRQ 25
[    1.074639] r8169 0000:02:00.0 eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]
[    1.074934] r8169 0000:02:00.0 enp2s0: renamed from eth0


Grazie,
Guido.

P.S. Se è possibile sapere qualcosa di più di questa "Raise network" e di ciò che è successo ringrazio ulteriormente.
GuidoU
Newbie
Newbie
 
Messaggi: 10
Iscritto il: 31/01/2013, 16:18
Località: Vicenza

Re: [Risolto] Failed to start Raise network interfaces-Debia

Messaggioda Kioji » 23/05/2018, 17:15

anch'io ugualissimo discorso.
Ho commentato le righe come hai fatto tu e l'errore è sparito.
Rinnovo l'invito, se qualcuno conosce il motivo batta un colpo :)
Grazie.
Kioji
Newbie
Newbie
 
Messaggi: 3
Iscritto il: 03/03/2016, 12:43


Torna a Network

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti