[RISOLTO] Debian 9 problema bizzarro

La rete, Internet, configurazione di Servizi e tutto ciò che permette la comunicazione tra macchine

[RISOLTO] Debian 9 problema bizzarro

Messaggioda fsck » 27/11/2018, 18:09

Ciao a tutti,

ho installato da qualche giorno debian 9 e fin da subito ho avuto problemi con l'accesso ad internet.
Mi spiego meglio, il mio server è in una rete privata, funziona benissimo, ma solo nella rete privata. Server samba attivo tutte le macchine lo vedono quindi zero problemi. Il problema sorge quando dal server cerco di accedere ad internet, a volte va a volte no. Dopo giorni di scervellamento mi sono deciso di chiedere aiuto. Ho notato che da modalità grafica aprendo un browsere magicamente vede la rete esterna alla lan ma se rebooto ed accedo via shell nulla, ogni tanto qualcosa fa si che rifunzi. Penso sia qualcosa in systemd ma non so piu' che fare.
Sapreste aiutarmi?

Vi incollo la mia config:

Codice: Seleziona tutto
root@debian:/home/andrea# systemctl status networking.service
â networking.service - Raise network interfaces
   Loaded: loaded (/lib/systemd/system/networking.service; enabled; vendor preset: enabled)
   Active: active (exited) since Tue 2018-11-27 17:47:34 CET; 7min ago
     Docs: man:interfaces(5)
  Process: 436 ExecStart=/sbin/ifup -a --read-environment (code=exited, status=0/SUCCESS)
  Process: 429 ExecStartPre=/bin/sh -c [ "$CONFIGURE_INTERFACES" != "no" ] && [ -n "$(ifquery --read-environment --list --exclude=lo)" ] && udevadm settle (code=exited, status=0/SUCCESS)
 Main PID: 436 (code=exited, status=0/SUCCESS)
    Tasks: 0 (limit: 4915)
   CGroup: /system.slice/networking.service

nov 27 17:47:22 debian systemd[1]: Starting Raise network interfaces...
nov 27 17:47:34 debian systemd[1]: Started Raise network interfaces.


Codice: Seleziona tutto
root@debian:/home/andrea# cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

auto enp4s0
iface enp4s0 inet static
        address 192.168.1.41
        netmask 255.255.255.0
        gateway 192.168.1.1
root@debian:/home/andrea#


Codice: Seleziona tutto
root@debian:/home/andrea# cat /etc/resolv.conf
nameserver 8.8.8.8
root@debian:/home/andrea#


Se serve altro fatemi sapere.

Grazie.
Ultima modifica di fsck il 28/11/2018, 18:40, modificato 1 volta in totale.
fsck
Newbie
Newbie
 
Messaggi: 4
Iscritto il: 16/04/2006, 7:48

Re: Debian 9 problema bizzarro

Messaggioda fsck » 28/11/2018, 17:42

Forse risolto, era un problema di router ( modello zywall usg 20 ) è stato reboottato ed ora va. Il problema lo si aveva solo con Debian le altre workstation andavano in internet senza problemi
fsck
Newbie
Newbie
 
Messaggi: 4
Iscritto il: 16/04/2006, 7:48


Torna a Network

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron