Pagina 2 di 2

Re: [RISOLTO] Gestione allegati

MessaggioInviato: 31/05/2016, 17:01
da s3v
Tutto ok ;)
Grazie 1000!

Re: Gestione allegati

MessaggioInviato: 31/05/2016, 19:10
da Aki
ferdybassi ha scritto:Sistemato,i PDF non erano permessi, tindal aveva scritto una cosa sbagliata.
Nessun formato di documenti (Office, LibreOffice, PDF) era ammesso.
Adesso sono permessi i seguenti tipi di file:
- immagini (jpg, png, gif, tiff)
- archivi (7z, tgz, rar, zip, etc)
- pdf

Dimensione massima 256Kb.
Ho mantenuto le impostazioni configurate da chi ha gestito il server prima di me.

Puoi indicare, se lo ritieni in sezione privata, le modalità di soluzione di questo malfunzionamento per referenza futura ?

Re: [RISOLTO] Gestione allegati

MessaggioInviato: 31/05/2016, 21:03
da ferdybassi
A differenza di quanto avevo sostenuto prima con troppa leggerezza, la directory di upload aveva dei permessi sbagliati.
C'erano due script che facevano cose opposte uno all'altro e il risultato era un pasticcio nei permessi che rendeva la directory non scrivibile se non da root.
Il problema è stato trovare i due script e capire come partivano, dato che non erano in cron.

Ciao ciao

Re: [RISOLTO] Gestione allegati

MessaggioInviato: 04/06/2016, 14:25
da Aki
Puoi fornire la path assoluta ed il nome degli script ?

Re: [RISOLTO] Gestione allegati

MessaggioInviato: 04/06/2016, 14:40
da ferdybassi
Ciao,
erano due script legati a ISPConfig e avevano qualcosa a che fare con un vecchio server FTP (penso vsftpd) che è poi stato rimosso.
Essendo due script inutili sono stati rimossi, per cui non c'è più alcun path da fornire.

Re: [RISOLTO] Gestione allegati

MessaggioInviato: 08/06/2016, 0:01
da Aki
Come mai gli script avevano smesso di funzionare ? Qualcuno aveva modificato dei permessi ? In caso affermativo, con quale utenza ?