[RISOLTO] Problema installazione Python3.7

Sezione dedicata alle problematiche sull'uso dei tool di installazione e gestione di pacchetti, in una distribuzione Debian-based.

[RISOLTO] Problema installazione Python3.7

Messaggioda LorenzoTinfena » 09/01/2020, 18:46

Salve, sono nuovo, mi chiamo lorenzo tinfena, ho Debian 10.2.0 su vmware, e volevo provare a mettere postmarketos su un mio telefono samsung che non uso, per farlo dovevo installare pmbootstrap, e per installarlo necessito di almeno python 3.4, per questo ho provato ad installare python 3.7 ma mi da il seguente errore:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
python3-eccodes : Breaks: python3-gribapi but 1.28.0-2 is to be installed
python3-gribapi : Conflicts: python3-eccodes but 2.12.0-1 is to be installed
python3-xattr : Conflicts: python3-pyxattr
E: Unable to correct problems, you have held broken packages.

Il problema non è della connessione internet e ne del dns (open dns) che funzionano correttamente, ma sembra essere un "conflitto" di pacchetti? Infatti prima avevo python 2.7, però poi ho rimosso con purge tutti i pacchetti di python per poi pettere il 3.7 (quelli che che contenevano la parola python XD).
Non sono bravo e mi sto cimentando alle prime armi con linux.
Qualcuno potrebbe darmi una mano?
LorenzoTinfena
Newbie
Newbie
 
Messaggi: 2
Iscritto il: 09/01/2020, 18:33

Re: Problema installazione Python3.7

Messaggioda Aki » 09/01/2020, 22:56

CIao, benvenuto nel forum. Credo tu abbia pasticciato con l'installazione o la disinstallazione di alcuni pacchetti. Dovresti fornire un log completo dei comandi che impartisci per installare python3.7; puoi farlo impartendo i seguenti comandi:
Codice: Seleziona tutto
scritp log.txt
apt-get update
apt-get upgrade
apt-get -f install
apt-get upgrade
apt-get install python3.7
exit

L'elenco dei comandi impartiti e dei relativi output sarà nel file log.txt che potrai inviare in allegato nel forum.
Aki
Global Moderator
Global Moderator
 
Messaggi: 8918
Iscritto il: 27/12/2007, 16:59

Re: Problema installazione Python3.7

Messaggioda LorenzoTinfena » 10/01/2020, 14:47

Ho fatto quello che hai detto te e stavolta ha funzionato XD, grazie mille.
ho installato pmbootstrap da repository https://gitlab.com/postmarketOS/pmbootstrap.git, e poi eseguendo il comando "pmboostrap init", mi da il seguente errore:

Codice: Seleziona tutto
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2419, in resolve
    return functools.reduce(getattr, self.attrs, module)
AttributeError: module 'pmb' has no attribute 'main'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/local/bin/pmbootstrap", line 11, in <module>
    load_entry_point('pmbootstrap==1.13.0', 'console_scripts', 'pmbootstrap')()
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 489, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2793, in load_entry_point
    return ep.load()
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2411, in load
    return self.resolve()
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2421, in resolve
    raise ImportError(str(exc))
ImportError: module 'pmb' has no attribute 'main'


pmb non so cosa sia, ma sembra un modulo da installare,quindi ho fatto "pip3 install pmb", e mi da che è gia installato, sai cosa può essere?
LorenzoTinfena
Newbie
Newbie
 
Messaggi: 2
Iscritto il: 09/01/2020, 18:33

Re: Problema installazione Python3.7

Messaggioda Aki » 11/01/2020, 11:39

LorenzoTinfena ha scritto:Ho fatto quello che hai detto te e stavolta ha funzionato XD, grazie mille.

Felice di esserti stato d’aiuto. Ricordati di contrassegnare la discussione come risolta secondo le modalità indicate nel regolamento del forum.

LorenzoTinfena ha scritto:ho installato pmbootstrap da repository https://gitlab.com/postmarketOS/pmbootstrap.git, e poi eseguendo il comando "pmboostrap init", mi da il seguente errore:
Codice: Seleziona tutto
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2419, in resolve
    return functools.reduce(getattr, self.attrs, module)
AttributeError: module 'pmb' has no attribute 'main'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/local/bin/pmbootstrap", line 11, in <module>
    load_entry_point('pmbootstrap==1.13.0', 'console_scripts', 'pmbootstrap')()
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 489, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2793, in load_entry_point
    return ep.load()
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2411, in load
    return self.resolve()
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 2421, in resolve
    raise ImportError(str(exc))
ImportError: module 'pmb' has no attribute 'main'

pmb non so cosa sia, ma sembra un modulo da installare,quindi ho fatto "pip3 install pmb", e mi da che è gia installato, sai cosa può essere?

Sarebbe opportuno aprissi una discussione dedicata a questo nuovo quesito in una sezione appropriata del forum. In ogni caso, di primo acchito, direi che hai pasticciato nell’installazione di pmboostrap
Aki
Global Moderator
Global Moderator
 
Messaggi: 8918
Iscritto il: 27/12/2007, 16:59

Re: Problema installazione Python3.7

Messaggioda Aki » oggi, 14:39

nota di moderazione: si contrassegna la discussione risolta in mancanza di riscontro da parte del richiedente.
Aki
Global Moderator
Global Moderator
 
Messaggi: 8918
Iscritto il: 27/12/2007, 16:59


Torna a Apt-get and friends

Chi c’è in linea

Visitano il forum: Nessuno e 5 ospiti