installazione di kdelibs4-dev

Sezione dedicata alle problematiche sull'uso dei tool di installazione e gestione di pacchetti, in una distribuzione Debian-based.

installazione di kdelibs4-dev

Messaggioda skuro » 22/07/2005, 10:59

salve a tutti

sto provando ad installare il pacchetto succitato sulla mia sid, ma non ci riesco a causa del fatto che, nella catena delle dipendenze, compare libfam0, che per l'installazione richiede la rimozione di libfam0c102, con la conseguente eliminazione di mezzo kde.

mi chiedo, è normale questo fatto? mi viene in mente di aver letto qualcosa riguardo l'eliminazione dei pacchetti xxxxc102 dall'introduzione del gcc-4...

oppure

come risolvo?
:-D

grazie

sku

:ciauz:
Utente Debian SID Registered Linux User #372086 This post has Super Cow Powers
skuro
Jr. Member
Jr. Member
 
Messaggi: 75
Iscritto il: 12/06/2005, 9:53

Re: installazione di kdelibs4-dev

Messaggioda Ldonesty » 22/07/2005, 11:13

Si, fam sta cambiando denominazione proprio in questi giorni, quindi è abbastanza critica come situazione.
Per il momento ti consiglio di non aggiornare/installare, sperando che a breve, nel giro di qualche giorno, la situazione venga risolta.
Il reggiseno e' uno strumento democratico perche' separa la destra dalla sinistra, solleva le masse e attira i popoli.
Avatar utente
Ldonesty
Hero Member
Hero Member
 
Messaggi: 763
Iscritto il: 22/12/2004, 17:31
Località: Un po' a Gaeta, un po' a Signa

Re: installazione di kdelibs4-dev

Messaggioda skuro » 22/07/2005, 15:26

per curiosità, mi sai dire (eventualmente dove andare a leggermi) quale sarà la procedura da eseguire per "ripulire" il proprio sistema dai pacchett c102? faranno un lavoro automatico gestendo in maniera particolare le dipendenze/conflitti/rimpiazzamenti o che?

denghiu
sku
:ciauz:
Utente Debian SID Registered Linux User #372086 This post has Super Cow Powers
skuro
Jr. Member
Jr. Member
 
Messaggi: 75
Iscritto il: 12/06/2005, 9:53

Re: installazione di kdelibs4-dev

Messaggioda Ldonesty » 22/07/2005, 21:09

Molto probabilmente (dico probabilmente perche non ne sono certo, pero per alcuni pacchetti e già cosi), i nuovi pacchetti che verranno ricompilati, utilizzeranno tra le dipendenze la nuova denominazione, mentre metteranno nella sezione Conflicts il vecchio nome.
Così in fase di upgrade verra disinstallata la vecchia versione, prima di aggiornare alla nuova.
Per esempio libfam0 (nuovo pacchetto-nuova denominazione) mostra:
Codice: Seleziona tutto
io@Chiba:~$ apt-cache show libfam0 | grep Conf
Conflicts: libfam0c102
Il reggiseno e' uno strumento democratico perche' separa la destra dalla sinistra, solleva le masse e attira i popoli.
Avatar utente
Ldonesty
Hero Member
Hero Member
 
Messaggi: 763
Iscritto il: 22/12/2004, 17:31
Località: Un po' a Gaeta, un po' a Signa


Torna a Apt-get and friends

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite