Problema con zlib1g

Sezione dedicata alle problematiche sull'uso dei tool di installazione e gestione di pacchetti, in una distribuzione Debian-based.

Problema con zlib1g

Messaggioda mannobug » 01/08/2005, 11:54

Ciao a tutti ho un problema molto strano e secondo me anche un po' grave. Ho necessità di installare il pacchetto libclamav-dev per esigenze di lavoro ma (utilizzo Debian testing) con apt ottengo il seguente errore:

....Alcuni pacchetti non possono essere installati. Questo può voler dire che è stata richiesta una situazione impossibile oppure, se si sta usando la distribuzione "unstable", che alcuni pacchetti richiesti non sono ancora stati creati o spostati da Incoming.
Poichè è stata richiesta solo una singola operazione è molto facile che il pacchetto semplicemente non sia installabile, si consiglia di inviare un "bug report" per tale pacchetto.
Le seguenti informazioni possono aiutare a risolvere la situazione:
I seguenti pacchetti hanno dipendenze non soddisfatte:
libclamav-dev: Dipende: zlib1g-dev (>= 1:1.1.4) ma non sta per essere installato Dipende: libcurl3-dev ma non sta per essere installato E: Pacchetto non integro

A questo punto mi sono detto sarà il zlib1g-dev il problema, visto che è l'unico che viene citato nell'errore. Cosi è facendo dpkg -l | grep -i zlib scopro che:

ii zlib1g 1.2.2-4.sarge.1 compression library - runtime

il pacchetto è marcato come sarge e non me lo fa togliere (mi dice che l'operazione è rischiosa e dipendono troppi pacchetti da lui), e tantomeno reinstallare.
Come faccio a portare questo pacchetto alla versione testing senza distruggere il mio sistema? :-O Oppure come posso risolvere...
Grazie per l'aiuto :-)
m@nnobug
P.S: sono disperato potri perdere un sacco di lavoro :sboing:
[color=FF0033]"Information wants to be free"[/color]
mannobug
Newbie
Newbie
 
Messaggi: 36
Iscritto il: 27/03/2005, 16:07

Re: Problema con zlib1g

Messaggioda MaXeR » 01/08/2005, 12:05

noto un po' di confusione nel tuo post...

il fatto che non ti permetta di rimuovere quel pacchetto mi sembra abbastanza ovvio, visto che è fondamentale per il funzionamento del sistema.

Prova ad installare i pacchetti libcurl3-dev e zlib1g-dev e vedere da chi dei due dipende l'errore...
e soprattutto perchè non te li installa...

comunque, quando si parla di lavoro...è sempre meglio una stable... :ciauz:
http://leevee.it - Leevee Soluzioni Informatiche
Avatar utente
MaXeR
Hero Member
Hero Member
 
Messaggi: 3211
Iscritto il: 22/12/2004, 17:01
Località: Garda - VR

Re: Problema con zlib1g

Messaggioda mannobug » 01/08/2005, 12:15

Ciao scusa per la confusione....
comunque provando ad installare libcurl3-dev mi dice:
Alcuni pacchetti non possono essere installati. Questo può voler dire che è stata richiesta una situazione impossibile oppure, se si sta usando la distribuzione "unstable", che alcuni pacchetti richiesti non sono ancora stati creati o spostati da Incoming.
Poichè è stata richiesta solo una singola operazione è molto facile che il pacchetto semplicemente non sia installabile, si consiglia di inviare un "bug report" per tale pacchetto.
Le seguenti informazioni possono aiutare a risolvere la situazione:
I seguenti pacchetti hanno dipendenze non soddisfatte:
libcurl3-dev: Dipende: zlib1g-dev ma non sta per essere installato
E: Pacchetto non integro


Mentre se provo ad installare zlib1g-dev mi dice:
Alcuni pacchetti non possono essere installati. Questo può voler dire che è stata richiesta una situazione impossibile oppure, se si sta usando la distribuzione "unstable", che alcuni pacchetti richiesti non sono ancora stati creati o spostati da Incoming.
Poichè è stata richiesta solo una singola operazione è molto facile che il pacchetto semplicemente non sia installabile, si consiglia di inviare un "bug report" per tale pacchetto.
Le seguenti informazioni possono aiutare a risolvere la situazione:
I seguenti pacchetti hanno dipendenze non soddisfatte:
zlib1g-dev: Dipende: zlib1g (= 1:1.2.2-4) ma 1:1.2.2-4.sarge.1 sta per essere installato
E: Pacchetto non integro


Ho provato anche a fare apt-get -f install ma non ho risolto nulla il fatto è che non mi fa installare queste librerie.
Spero di essere stato piu' chiaro :-D
grazie m@nnobug
(forse era meglio mettere sarge ma sinceramente mo è un po' tardi :-))
[color=FF0033]"Information wants to be free"[/color]
mannobug
Newbie
Newbie
 
Messaggi: 36
Iscritto il: 27/03/2005, 16:07

Re: Problema con zlib1g

Messaggioda MaXeR » 01/08/2005, 12:49

ora è un po' più chiaro...
quando un pacchetto ha, nella versione, una stringa "sargeX", dove 'X' è un numero, vuol dire che proviene dal repository di Sicurezza di Sarge.
Hai un sources.list sbagliato: devi rimuovere il repository di sicurezza.

una volta fatto, aggiorna con
Codice: Seleziona tutto
# apt-get update
e:
* vai sul sito http://pagkages.debian.org e scarica la versione per etch di "zlib1g"
* una volta scaricata, dai il seguente comando:
Codice: Seleziona tutto
# dpkg --force-downgrade -i nomepacchetto.deb
http://leevee.it - Leevee Soluzioni Informatiche
Avatar utente
MaXeR
Hero Member
Hero Member
 
Messaggi: 3211
Iscritto il: 22/12/2004, 17:01
Località: Garda - VR

Re: Problema con zlib1g

Messaggioda mannobug » 01/08/2005, 12:58

:-D senti dimmi un modo per offrirti un pranzo via web!!!!!!
Non so come ringraziarti mi hai risolto (salvato forse è piu' corretto!!!!! ;-)) la giornata
ciao m@nnobug :ciauz:
[color=FF0033]"Information wants to be free"[/color]
mannobug
Newbie
Newbie
 
Messaggi: 36
Iscritto il: 27/03/2005, 16:07

Re: Problema con zlib1g

Messaggioda MaXeR » 03/08/2005, 17:50

un pranzo via web?

tra un po' dovremo aprire ristorante.debianizzati.org :-D

l'importante è che il problema sia stato risolto ;-)...

mai 'mischiare' i repository :-)
http://leevee.it - Leevee Soluzioni Informatiche
Avatar utente
MaXeR
Hero Member
Hero Member
 
Messaggi: 3211
Iscritto il: 22/12/2004, 17:01
Località: Garda - VR


Torna a Apt-get and friends

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti