dpkg error code 1 & 2

Sezione dedicata alle problematiche sull'uso dei tool di installazione e gestione di pacchetti, in una distribuzione Debian-based.

dpkg error code 1 & 2

Messaggioda le0n » 03/08/2005, 21:34

Ciao a tutti!
ho un problemone dovuto a dpkg&apt...
sto aggiornando la mia distro al corrente ramo unstable (sid?) ma dopo aver downloadato 250mb di pacchetti mi trovo errori in dpkg come da titolo...

inizialmente il problema era "errore in status nella riga 2 di /var/lib/dpkg/available
E: Sub-process /usr/bin/dpkg returned an error code (2)" che ho risolto con "dpkg --clear-avail" ma ora il problema è un altro...

facendo apt-get dist-upgrade, dopo alcuni "unpacking replacement" appare l'errore
Errors were encountered while processing:
/var/cache/apt/archives/x11-common_6.8.2.dfsg.1-4_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
e sinceramente non so cosa fare...ho provato a eliminare il file e riscaricarlo ma nulla...

cosa mi consigliate di fare??

Grazie a tutti!!
Coltiva linux tanto windows si pianta da solo
Nessun sistema è sicuro se c'è un idiota a gestirlo!
La mia Debian sul portatile HP Pavilion dv6270EU
le0n
Hero Member
Hero Member
 
Messaggi: 523
Iscritto il: 11/05/2005, 16:09

Re: dpkg error code 1 & 2

Messaggioda MaXeR » 04/08/2005, 0:02

Rispondo qua con le stesse cose che ho postato sulla ml:
le0n ha scritto:
Ciao a tutti!
ho un problemone dovuto a dpkg&apt...
sto aggiornando la mia distro al corrente ramo unstable (sid?) ma dopo aver downloadato 250mb di pacchetti mi trovo errori in dpkg come da titolo...

inizialmente il problema era "errore in status nella riga 2 di /var/lib/dpkg/available
E: Sub-process /usr/bin/dpkg returned an error code (2)" che ho risolto con "dpkg --clear-avail" ma ora il problema è un altro...

bello quel comando, non lo conoscevo..
normalmente quando incontravo questi errori agivo più, ehm, manualmente ;)

facendo apt-get dist-upgrade, dopo alcuni "unpacking replacement" appare l'errore
Codice: Seleziona tutto
Errors were encountered while processing:
 /var/cache/apt/archives/x11-common_6.8.2.dfsg.1-4_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
e sinceramente non so cosa fare...ho provato a eliminare il file e riscaricarlo ma nulla...

cosa mi consigliate di fare??

beh, non citi completamente il problema...
probabilmente è un file che va a sovrascrivere un altro file presente in un
pacchetto già installato...

dovrebbe bastare un
# dpkg --force-overwrite -i \
/var/cache/apt/archives/x11-common_6.8.2.dfsg.1-4_all.deb
(ovviamente tutto su una riga...)

:ciauz:
http://leevee.it - Leevee Soluzioni Informatiche
Avatar utente
MaXeR
Administrator
Administrator
 
Messaggi: 3576
Iscritto il: 22/12/2004, 17:01
Località: Garda - VR

Re: dpkg error code 1 & 2

Messaggioda le0n » 04/08/2005, 11:48

bello quel comando, non lo conoscevo..
si imparano sempre cose nuove :-D ...prima di ieri non lo conoscevo neanche io :-D ...

beh, non citi completamente il problema...
probabilmente è un file che va a sovrascrivere un altro file presente in un
pacchetto già installato...

dovrebbe bastare un
# dpkg --force-overwrite -i \
/var/cache/apt/archives/x11-common_6.8.2.dfsg.1-4_all.deb
(ovviamente tutto su una riga...)

:ciauz:

la sequenza di comandi (e di risposte) è:
apt-get dist-upgrade
Reading package lists... Done
Building dependency tree... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
evolution: Depends: evolution-data-server (>= 1.2.3) but 1.0.4-1 is installed
libx11-6: Depends: x11-common (> 4.3.0) but it is not installed
E: Unmet dependencies. Try using -f.

apt-get -f dist-upgrade
Reading package lists... Done
Building dependency tree... Done
Correcting dependencies... Done
Calculating upgrade... Done
[cut]
252 upgraded, 12 newly installed, 6 to remove and 4 not upgraded.
72 not fully installed or removed.
Need to get 0B/177MB of archives.
After unpacking 10.4MB of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
binutils findutils base-files nano openssh-server openssh-client libwraster3 wmaker ssh
Install these packages without verification [y/N]? y
Reading package fields... Done
Reading package status... Done
Retrieving bug reports... Done
Preconfiguring packages ...
(Reading database ... 119249 files and directories currently installed.)
Unpacking x11-common (from .../x11-common_6.8.2.dfsg.1-4_all.deb) ...
dpkg: error processing /var/cache/apt/archives/x11-common_6.8.2.dfsg.1-4_all.deb (--unpack):
trying to overwrite `/etc/X11/Xsession', which is also in package xorg-common
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/x11-common_6.8.2.dfsg.1-4_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


e ora dopo il --force-overwrite mi dice
trying to overwrite `/usr/lib/X11', which is also in package xorg-common
dpkg - warning, overriding problem because --force enabled:
(la parte precedente la ripete per molti files)
dpkg: dependency problems prevent configuration of x11-common:
x11-common depends on debconf (>= 1.2.9); however:
Package debconf is not configured yet.
dpkg: error processing x11-common (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
x11-common


sto pensando al repository debian.linux-systeme...avendo xorg scaricato da li non è che mi va in conflitto con xorg presente su ftp.it.debian del ramo unstable?

Thanks!

ps sorry per il post lunghino :-D
Coltiva linux tanto windows si pianta da solo
Nessun sistema è sicuro se c'è un idiota a gestirlo!
La mia Debian sul portatile HP Pavilion dv6270EU
le0n
Hero Member
Hero Member
 
Messaggi: 523
Iscritto il: 11/05/2005, 16:09

Re: dpkg error code 1 & 2

Messaggioda MaXeR » 04/08/2005, 12:13

ora dovrebbe bastare un
Codice: Seleziona tutto
# apt-get -f install


per sapere cosa vuol dire -f:
Codice: Seleziona tutto
$ man apt-get
http://leevee.it - Leevee Soluzioni Informatiche
Avatar utente
MaXeR
Administrator
Administrator
 
Messaggi: 3576
Iscritto il: 22/12/2004, 17:01
Località: Garda - VR

Re: dpkg error code 1 & 2

Messaggioda le0n » 04/08/2005, 12:32

aggiornamento:

ho commentato il repository di linux-systeme.com e ho rimosso tutto ciò che riguarda evolution e già synatic mi ha fatto delle domande sulle impostazioni di x11 e ha fatto il "setting up" di molti pacchetti...

ora, via shell, con dist-upgrade sembra deciso a finire il lavoro...

[...]

ha finito!!

ps direi di lasciar perdere il repository debian.linux-systeme.com che xorg ormai è nel ramo [url=packages.debian.org/unstable/allpackages]unstable[/url]!

Hasta!
Coltiva linux tanto windows si pianta da solo
Nessun sistema è sicuro se c'è un idiota a gestirlo!
La mia Debian sul portatile HP Pavilion dv6270EU
le0n
Hero Member
Hero Member
 
Messaggi: 523
Iscritto il: 11/05/2005, 16:09


Torna a Apt-get and friends

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti