Dselect

Sezione dedicata alle problematiche sull'uso dei tool di installazione e gestione di pacchetti, in una distribuzione Debian-based.

Dselect

Messaggioda marechiaro » 09/09/2005, 12:49

Chi vuole aiutarmi a capire xchè quando con dselect voglio installare mi restituisce questi errori:

dpkg: errore processando /var/cache/apt/archives/libldap2.2_2.2.23-0.pre3_i386.deb (--unpack):
tentata sovrascrittura di `/usr/lib/liblber-2.2.so.7', che si trova anche nel pacchetto libldap-2.2-7

Sono occorsi degli errori processando:
/var/cache/apt/archives/libldap2.2_2.2.23-0.pre3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Si sono verificati alcuni errori nella scompattazione. Si cercherà di
configurare i pacchetti che sono stati installati. Questo potrebbe generare
errori duplicati o errori causati da dipendenze non soddisfatte. Questo va
bene solo se gli errori sopra questo messaggio sono importanti. Si prega di correggerli e di eseguire [I]nstall un'altra volta
Premere invio per continuare.

Configuro traceroute (1.4a12-20) ...

Configuro etc etc.....

lo script di installazione ha restituito un codice di errore 100 in uscita.
Premi per continuare.
Ciao
marechiaro
Newbie
Newbie
 
Messaggi: 16
Iscritto il: 22/08/2005, 2:44

Re: Dselect

Messaggioda MaXeR » 09/09/2005, 17:30

Codice: Seleziona tutto
dpkg: errore processando /var/cache/apt/archives/libldap2.2_2.2.23-0.pre3_i386.deb
(--unpack):
tentata sovrascrittura di `/usr/lib/liblber-2.2.so.7', che si trova anche nel
pacchetto libldap-2.2-7


c'è una tentata sovrascrittura...
quello che mi sembra strano è che stai installando due pacchetti uguali, solo che ibldap2.2_2.2.23-0.pre3_i386.deb non mi sembra ufficiale (a giudicare dalla mancanza del carattere '-' tra il nome e la versione)... puoi cercare di rimuovere questo pacchetto? o il repository dove è presente?

:ciauz:
http://leevee.it - Leevee Soluzioni Informatiche
Avatar utente
MaXeR
Administrator
Administrator
 
Messaggi: 3211
Iscritto il: 22/12/2004, 17:01
Località: Garda - VR

Re: Dselect

Messaggioda marechiaro » 10/09/2005, 11:34

Grazie,6 GRANDE, ho risolto non installando il pacchetto, è opzionale.
Ciao
marechiaro
Newbie
Newbie
 
Messaggi: 16
Iscritto il: 22/08/2005, 2:44


Torna a Apt-get and friends

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite