Installazione PHP5

Sezione dedicata alle problematiche sull'uso dei tool di installazione e gestione di pacchetti, in una distribuzione Debian-based.

Installazione PHP5

Messaggioda Cescoc75 » 23/07/2016, 11:00

Ciao a tutti.

Sto cercando di installare un ambiente LAMP ( il mio sistema è Debian GNU/Linux stretch/sid 64-bit ) e per farlo sto seguendo questa guida:

http://guide.debianizzati.org/index.php ... igurazione

Il mio problema è che non riesco ad installare PHP5 , perchè quando lancio il comando

sudo aptitude install php5 libapache2-mod-php5

ottengo questo messaggio di errore

php5 is already installed at the requested version (5.6.22+dfsg-2)
No candidate version found for libapache2-mod-php5
php5 is already installed at the requested version (5.6.22+dfsg-2)
No candidate version found for libapache2-mod-php5
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 224 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.

La mia sensazione è che ci sia qualcosa di sbagliato nella lista dei miei repository, infatti se provo ad installare lo steso pacchetto da synaptic ottengo

Package libapache2-mod-php5 has no available version, but exists in the database.
This typically means that the package was mentioned in a dependency and never uploaded, has been obsoleted or is not available with the contents of sources.list

Qualcuno sa qua'è il repository da aggiungere al mio sources.list , oppure secondo voi il problema è un altro ?

Grazie mille.
Cescoc75
Newbie
Newbie
 
Messaggi: 2
Iscritto il: 23/07/2016, 9:57

Re: Installazione PHP5

Messaggioda mark » 23/07/2016, 11:18

succede perchè quel pacchetto per ora non è disponibile per stretch
https://packages.debian.org/search?keywords=libapache2-mod-php5
Avatar utente
mark
Hero Member
Hero Member
 
Messaggi: 635
Iscritto il: 10/01/2007, 16:53

Re: Installazione PHP5

Messaggioda Selky » 23/07/2016, 12:09

Per ottenere php5 devi provare a prelevarlo dalla stable Jessie perchè è stato eliminato da Stretch il 01 luglio 2016, su quest'ultima c'è php7.
Selky
wiki member
wiki member
 
Messaggi: 1417
Iscritto il: 30/12/2011, 1:00

Re: Installazione PHP5

Messaggioda Cescoc75 » 23/07/2016, 22:57

Nonostante abbia inserito i repository

deb http://ftp.it.debian.org/debian/ jessie main contrib non-free
deb-src http://ftp.it.debian.org/debian/ jessie main contrib non-free

continuo ad avere qualche problema di reperimento dei pacchetti.

Alla fine ho risloto installando PHP7.

Vi ringrazio molto per l'aiuto.
Cescoc75
Newbie
Newbie
 
Messaggi: 2
Iscritto il: 23/07/2016, 9:57

Re: Installazione PHP5

Messaggioda Selky » 24/07/2016, 0:31

Se ritieni risolta la questione e ti sta bene utilizzare php7 ok, a riguardo ricordati di anteporre il tag [Risolto] all'oggetto del tuo primo messaggio, anche se personalmente modificherei il titolo perché troppo generico. ;)

Se desideri e/o hai necessità di utilizzare php5:
leggendo ciò che hai scritto, mi sorge il dubbio che tu abbia provato ad installare normalmente. In questo caso essendo su Stretch devi dare
Codice: Seleziona tutto
# apt-get install -t jessie...


Come passare da php7 a php5 e viceversa, trovi degli spunti su come attivare i moduli qua viewtopic.php?f=25&t=51956&sid=6bf325169c19f1b631218c88dcb6dded#p202814

P.S,
Utile magari anche per altri, la guida segnalata non contempla la testing Stretch ma arriva sino alla stable Jessie.
Selky
wiki member
wiki member
 
Messaggi: 1417
Iscritto il: 30/12/2011, 1:00


Torna a Apt-get and friends

Chi c’è in linea

Visitano il forum: Google [Bot] e 2 ospiti