problemi re-installare openoffice 2.0

Sezione dedicata alle problematiche sull'uso dei tool di installazione e gestione di pacchetti, in una distribuzione Debian-based.

problemi re-installare openoffice 2.0

Messaggioda sacarde » 24/09/2005, 13:00

ciao,
allora....saro' breve........
un giorno ho installato openoffice beta 2...ok
dopo un po di tempo lo ho disinstallato perfettamente

dopo altro tempo (e qualche installazione...) mi accingo a reinstallarlo...sempre la beta 2


sembra andare quasi tutto bene....... i programmi funzionano anche se ho visto un errore ........:

...
Configuro openoffice.org-core04 (1.9.125-2) ...
dpkg: problemi con le dipendenze impediscono la configurazione di openoffice.org-core04u:
openoffice.org-core04u dipende da kdelibs4 (>= 4:3.4.0); comunque:
Il pacchetto kdelibs4 non è installato.
openoffice.org-core04u dipende da libqt3c102-mt (>= 3:3.3.4); comunque:
Il pacchetto libqt3c102-mt non è installato.
dpkg: errore processando openoffice.org-core04u (--install):
problemi con le dipendenze - lasciato non configurato
Sono occorsi degli errori processando:
openoffice.org-core04u
.....

anche se ripeto i programmi funzionano


....segue....
sacarde
Jr. Member
Jr. Member
 
Messaggi: 72
Iscritto il: 24/09/2005, 5:56

Re: problemi re-installare openoffice 2.0

Messaggioda sacarde » 24/09/2005, 13:01

ho fatto: apt-get install kdelibs4

Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
È consigliabile eseguire 'apt-get -f install' per correggere questi problemi:
I seguenti pacchetti hanno dipendenze non soddisfatte:
kdelibs-data: Va in conflitto: kdelibs4 ma 4:3.3.2-6.1 sta per essere installato
kdelibs4: Dipende: libarts1 (>= 1.3.2) ma non sta per essere installato
Dipende: libopenexr2 (>= 1.2.2) ma non sta per essere installato
Dipende: libqt3c102-mt (>= 3:3.3.4) ma non sta per essere installato
Dipende: kdelibs-bin (= 4:3.3.2-6.1) ma 4:3.4.2-4 sta per essere installato
kdelibs4c2: Va in conflitto: kdelibs4 ma 4:3.3.2-6.1 sta per essere installato
openoffice.org-core04u: Dipende: kdelibs4 (>= 4:3.4.0) ma 4:3.3.2-6.1 sta per essere installato
Dipende: libqt3c102-mt (>= 3:3.3.4) ma non sta per essere installato
E: Dipendenze non soddisfatte. Provare 'apt-get -f install' senza pacchetti (o specificare una soluzione)

....segue.....
sacarde
Jr. Member
Jr. Member
 
Messaggi: 72
Iscritto il: 24/09/2005, 5:56

Re: problemi re-installare openoffice 2.0

Messaggioda sacarde » 24/09/2005, 13:01

ho fatto: apt-get install libqt3c102-mt

Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
È consigliabile eseguire 'apt-get -f install' per correggere questi problemi:
I seguenti pacchetti hanno dipendenze non soddisfatte:
libqt3-mt: Va in conflitto: libqt3c102-mt ma 3:3.3.4-3 sta per essere installato
libqt3c102-mt: Va in conflitto: libqt3-mt ma 3:3.3.5-1 sta per essere installato
openoffice.org-core04u: Dipende: kdelibs4 (>= 4:3.4.0) ma non sta per essere installato
E: Dipendenze non soddisfatte. Provare 'apt-get -f install' senza pacchetti (o specificare una soluzione).

......segue......
sacarde
Jr. Member
Jr. Member
 
Messaggi: 72
Iscritto il: 24/09/2005, 5:56

Re: problemi re-installare openoffice 2.0

Messaggioda sacarde » 24/09/2005, 13:01

se faccio: apt-get -f install

Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
Correzione delle dipendenze in corso... Fatto
I seguenti pacchetti saranno RIMOSSI:
openoffice.org-core04u
0 aggiornati, 0 installati, 1 da rimuovere e 488 non aggiornati.
1 non completamente installati o rimossi.
È necessario prendere 0B di archivi.
Dopo l'estrazione, verranno liberati 63,1MB di spazio su disco.
Continuare? [S/n]



?????????????? che faccio ???????????????
sacarde
Jr. Member
Jr. Member
 
Messaggi: 72
Iscritto il: 24/09/2005, 5:56

Re: problemi re-installare openoffice 2.0

Messaggioda keltik » 24/09/2005, 17:58

?????????????? che faccio ???????????????


un buon inizio sarebbe stato quello di fare un unico post ;-)

I seguenti pacchetti saranno RIMOSSI:
openoffice.org-core04u


beh, se vuoi rimuovere OpenOffice direi proprio che basta tu risponda "S".

se invece vuoi reinstallarlo, prima di tutto disinstallalo (eventualmente con opzione "--purge"). una volta disinstallato, puoi seguire la guida ospitata sul nostro sito per la documentazione (guide.debianizzati.org).

:ciauz:
Avatar utente
keltik
Hero Member
Hero Member
 
Messaggi: 1257
Iscritto il: 01/01/2005, 17:12

Re: problemi re-installare openoffice 2.0

Messaggioda sacarde » 24/09/2005, 20:13

spezzettare il problema mi sembrava aiutasse !!!
sacarde
Jr. Member
Jr. Member
 
Messaggi: 72
Iscritto il: 24/09/2005, 5:56

Re: problemi re-installare openoffice 2.0

Messaggioda sacarde » 24/09/2005, 21:12

ho deciso di togliere il vecchio openoffice e di riprovare come descritto sulla guida "Debianizzati":

Installare OpenOffice2 su Debian Etch

ho seguito tutti i vari passi...

ma allinstallazione ho l'errore:

Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler
dire che è stata richiesta una situazione impossibile oppure, se
si sta usando la distribuzione "unstable", che alcuni pacchetti
richiesti non sono ancora stati creati o spostati da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
openoffice.org2-base: Dipende: java-gcj-compat ma non sta per essere installato oppure
j2re1.4 ma non è installabile oppure
java2-runtime ma non è installabile
Dipende: libhsqldb-java (>= 1.8.0.0-2) ma non sta per essere installato
E: Pacchetto non integro



p.s.
sto' eseguendo il tutto da una knoppix3.9 (personalizzata)
sacarde
Jr. Member
Jr. Member
 
Messaggi: 72
Iscritto il: 24/09/2005, 5:56

Re: problemi re-installare openoffice 2.0

Messaggioda Fart » 24/09/2005, 21:54

hai il java runtime environment installato?
Senza java open office 2 non è installabile a meno che tu non scelga quello senza java, ma è decisamente incompleto.
Quindi ti conviene installare prima i pacchetti che ti richiede! :ciauz:
Out beyond the New Frontiers..
Fart
Hero Member
Hero Member
 
Messaggi: 984
Iscritto il: 22/06/2005, 7:52

Re: problemi re-installare openoffice 2.0

Messaggioda sacarde » 25/09/2005, 9:14

il jre ce l'ho installato a mano.....

ho provato a insallare java-gcj-compat:

I seguenti pacchetti hanno dipendenze non soddisfatte:
java-gcj-compat: Dipende: libgcj6 (>= 4.0.1-3) ma 4.0.1-2 sta per essere installato
Dipende: libgcj6-common (>= 4.0.1-3) ma 4.0.1-2 sta per essere installato
E: Pacchetto non integro



libhsqldb-java me lo ha installato OK

ma all'installazione di openoffice rimangono gli stessi errori
sacarde
Jr. Member
Jr. Member
 
Messaggi: 72
Iscritto il: 24/09/2005, 5:56

Re: problemi re-installare openoffice 2.0

Messaggioda keltik » 25/09/2005, 12:52

se hai seguito quanto riportato nella guida, per installare direttamente pacchetti provenienti da un ramo diverso da quello di default (nel caso della guida 'testing'), è necessario usare il parametro '-t'. ad esempio:
Codice: Seleziona tutto
# apt-get install -t unstable <pacchetto>
installa la versione del pacchetto che richiedi dal ramo unstable.

nel tuo caso potrebbe essere risolutivo usare:
Codice: Seleziona tutto
# apt-get install -t unstable libgcj6 libgcj6-common
.

:ciauz:
Avatar utente
keltik
Hero Member
Hero Member
 
Messaggi: 1257
Iscritto il: 01/01/2005, 17:12

Re: problemi re-installare openoffice 2.0

Messaggioda sacarde » 25/09/2005, 13:29

abbiamo fatto un'altro passo .......

ho istallato libgcj6-common e java-gcj-compat !!!

adesso quando installo i pacchetti openoffice ho:

Alcuni pacchetti non possono essere installati. Questo può voler
dire che è stata richiesta una situazione impossibile oppure, se
si sta usando la distribuzione "unstable", che alcuni pacchetti
richiesti non sono ancora stati creati o spostati da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
openoffice.org2-base: Dipende: libhsqldb-java (>= 1.8.0.0-2) ma 1.7.3.3-3 sta per essere installato
E: Pacchetto non integro




e se faccio:
apt-get install libhsqldb-java ho:


libhsqldb-java è già alla versione più recente

in effetti ho: libhsqldb-java 1.7.3.3-3
sacarde
Jr. Member
Jr. Member
 
Messaggi: 72
Iscritto il: 24/09/2005, 5:56

Re: problemi re-installare openoffice 2.0

Messaggioda Fart » 25/09/2005, 15:02


I seguenti pacchetti hanno dipendenze non soddisfatte:
openoffice.org2-base: Dipende: libhsqldb-java (>= 1.8.0.0-2) ma 1.7.3.3-3 sta per essere installato
E: Pacchetto non integro

e se faccio:
apt-get install libhsqldb-java ho:

libhsqldb-java è già alla versione più recente

in effetti ho: libhsqldb-java 1.7.3.3-3


La versione che serve a te è la 1.8.0.0-2 che come puoi vedere da QUESTO
link è ancora in experimental, quindi non è disponibile per testing. Quindi o aspetti che entra in testing, oppure unstabilizzi la tua distro! :s6:
Out beyond the New Frontiers..
Fart
Hero Member
Hero Member
 
Messaggi: 984
Iscritto il: 22/06/2005, 7:52

Re: problemi re-installare openoffice 2.0

Messaggioda keltik » 25/09/2005, 16:11

non è sempre necessario 'unstabilizzare': utilizzando il pinning è possibile usare pacchetti di experimental anche avendo un' installazione basata su stable o testing.

nella guida di cui ho postato il link prima c'è spiegato tutto, compreso il link alla guida per utilizzare sistemi misti.
infatti sul mio sistema (testing) io ho installato:
Codice: Seleziona tutto
keltik@debby:~$ apt-show-versions libhsqldb-java
libhsqldb-java/experimental uptodate 1.8.0.0-2
keltik@debby:~$ sudo apt-get install -t experimental libhsqldb-java
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
libhsqldb-java è già alla versione più recente.

poi - ovviamente - ognuno prende le decisioni che ritiene migliori.

:ciauz:
Avatar utente
keltik
Hero Member
Hero Member
 
Messaggi: 1257
Iscritto il: 01/01/2005, 17:12

Re: problemi re-installare openoffice 2.0

Messaggioda sacarde » 25/09/2005, 16:13

scusami......

che significa ....... "a te serve 1.8..." .....cosa e' che lo fa rendere obbligatotio a me ?

non so bene cosa significhi "unstabilizzare"...

......ho letto la possibilita' di mixare con experimental

quasi quasi ......

voi che mi consiglieresti?

grazie mille
sacarde
Jr. Member
Jr. Member
 
Messaggi: 72
Iscritto il: 24/09/2005, 5:56

Re: problemi re-installare openoffice 2.0

Messaggioda keltik » 25/09/2005, 16:35

fart ha ragione a dirti che ti serve quella versione specifica del pacchetto. di questa necessità ti avverte infatti proprio APT quando stampa:
Codice: Seleziona tutto
 openoffice.org2-base: Dipende: libhsqldb-java (>= 1.8.0.0-2) ma 1.7.3.3-3 sta per essere installato
.come vedi, le dipendenze di openoffice2-base richiedono la versione 1.8.0.0-2, ma il settaggio del tuo sistema prevede che venga installata la versione 1.7.3.3-3.

a questo punto hai due alternative, ma in realtà si riducono a una sola:

1) fai un upgrade dalla tua versione di debian a quella unstable: in questo modo però avrai sempre il problema di prima quando ti servono pacchetti di altre release;

2) utilizzi un sistema misto basato su testing (che per un desktop è una scelta ottima come compromesso tra stabilità e software recente) e scegli di volta in volta la versione del pacchetto da utilizzare.

come vedi l' unica scelta ragionevole consiste nella 2), perchè ti permette di avere un sistema stabile ma - all' occorrenza - hai la possibilità di usare software instabile senza compromettere tutta l' installazione.

nella guida che ti ho indicato e nei post precedenti hai tutte le informazioni per agire in questa direzione.
Avatar utente
keltik
Hero Member
Hero Member
 
Messaggi: 1257
Iscritto il: 01/01/2005, 17:12

Prossimo

Torna a Apt-get and friends

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti