Installazione skype

Sezione dedicata alle problematiche sull'uso dei tool di installazione e gestione di pacchetti, in una distribuzione Debian-based.

Installazione skype

Messaggioda alex859 » 26/09/2005, 18:15

Ciao a tutti!

Ho provato ad installare skype con apt-get ma ottengo il seguente errore:

Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler
dire che è stata richiesta una situazione impossibile oppure, se
si sta usando la distribuzione "unstable", che alcuni pacchetti
richiesti non sono ancora stati creati o spostati da Incoming.

Poichè è stata richiesta solo una singola operazione è molto facile che
il pacchetto semplicemente non sia installabile, si consiglia
di inviare un "bug report" per tale pacchetto.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
skype: Dipende: libqt3c102-mt (>= 3:3.3.4) ma non sta per essere installato
E: Pacchetto non integro

Penso di aver combinato qualche casino con le dipendenze dei pacchetti.

Infatti, inizialmente usavo solo la testing, poi, però ho installato kde 3.4.2 da unstable, ed ora la mia è diventata una testing/unstable.

Cosa mi consigliate di fare?

Disintallare kde e reinstallare la versione 3.3 o continuare così?

Vi prego datemi un consiglio!!!
alex859
Newbie
Newbie
 
Messaggi: 30
Iscritto il: 19/09/2005, 7:58

Re: Installazione skype

Messaggioda keltik » 26/09/2005, 18:38

Ho provato ad installare skype con apt-get


in genere skype viene installato scaricando il pacchetto dal sito ufficiale di Skype e quindi:
Codice: Seleziona tutto
# dpkg -i skype_versione.deb
.

a parte questo ... mescolare versioni differenti di Debian senza configurare opportunamente il sistema è una pratica ALTAMENTE sconsigliata.

il mio consiglio personale è quello di utilizzare un sistema misto: leggi il thread relativo all' installazione di OpenOffice2 che trovi sempre in questo forum. in esso sono riportati sia i files di configurazione che le guide necessarie a impostare e far girare un sistema misto: non è niente di complicato.

:ciauz:
Avatar utente
keltik
Hero Member
Hero Member
 
Messaggi: 1257
Iscritto il: 01/01/2005, 17:12

Re: Installazione skype

Messaggioda alex859 » 26/09/2005, 19:10

Ho seguito la guida sul sistema misto prima di installare kde 3.4, impostando nel file apt-conf testing come distribuzione e mettendo in preferences il pin + alto a testing e + bassoa unstable.

Lascio quindi le cose come stanno?
alex859
Newbie
Newbie
 
Messaggi: 30
Iscritto il: 19/09/2005, 7:58

Re: Installazione skype

Messaggioda alex859 » 26/09/2005, 19:20

Ho installato il singolo pacchetto di skype ottenendo il seguente errore in fase di configurazione:

elezionato il pacchetto skype, che non lo era.
(Lettura del database ... 142375 file e directory attualmente installati.)
Spacchetto skype (da skype_1.2.0.17-1_i386.deb) ...
dpkg: problemi con le dipendenze impediscono la configurazione di skype:
skype dipende da libqt3c102-mt (>= 3:3.3.3.2); comunque:
Il pacchetto libqt3c102-mt non è installato.
dpkg: errore processando skype (--install):
problemi con le dipendenze - lasciato non configurato
Sono occorsi degli errori processando:
skype


Nonostante ciò il programma funziona correttamente.
alex859
Newbie
Newbie
 
Messaggi: 30
Iscritto il: 19/09/2005, 7:58

Re: Installazione skype

Messaggioda keltik » 26/09/2005, 19:28

beh, strano, ma se funziona ... :-)
Avatar utente
keltik
Hero Member
Hero Member
 
Messaggi: 1257
Iscritto il: 01/01/2005, 17:12

Re: Installazione skype

Messaggioda Ldonesty » 26/09/2005, 23:08

L'ultimo pacchetto debian di skype è stato realizzato impostando come dipendenze le vecchie librerie qt (quelle precedenti alla transizione delle ABI, come si nota dal anche dal tag c102 presente nel nome)..
Attualmente in sid/unstable lo stesso pacchetto delle qt è denominato in modo differente (stesso nome, postfisso con c2) per sottolineare l'avvenuta transizione.
Il nuovo pacchetto delle qt però non fornisce esattamente le stesse cose che forniva il vecchio, e pertanto non ne prende completamente il posto.
Pertanto se si forza comunque l'installazione, penso non ci siano grossi problemi a far funzionare skype, a parte le dipendenze non corrette nel database di apt.
Io per il momento rimango con il pacchetto precedente che funziona anche con le qt post-transizione.
Il reggiseno e' uno strumento democratico perche' separa la destra dalla sinistra, solleva le masse e attira i popoli.
Avatar utente
Ldonesty
Hero Member
Hero Member
 
Messaggi: 618
Iscritto il: 22/12/2004, 17:31
Località: Un po' a Gaeta, un po' a Signa


Torna a Apt-get and friends

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti