aggiornamento sarge problematico

Sezione dedicata alle problematiche sull'uso dei tool di installazione e gestione di pacchetti, in una distribuzione Debian-based.

aggiornamento sarge problematico

Messaggioda darkblack » 02/10/2005, 22:57

ciao a tutti!
vorrei riuscire a capire qualcosa di più rispetto al problema che vi sottopongo...

ho da poco tempo installato su una macchina debian sarge con kernel 2.6 tramite l'immagine cd scaricata da un mirror qualche mese fa.

ho impostato il source.list aggiungendo alle riche che mi venivano già proposte la riga che riporto:
deb ftp:\\ftp.debian.org\debian testing main contrib non-free

ho fatto un apt-get update e fin qui tutto bene.

nel momento che tento di dare un apt-get dist-upgrade (in modo da aggiornare i pacchetti) l'operazione parte correttamente, ma poi mi viene visulaizzato un messaggio che dice che l'operazione non può continuare perchè è impossibile sostituire il pacchetto e2fsprogs.
(ho provato anche a rimuovere il pacchetto tramite apt-get remove e2fsprogs, ma insieeme a questo mi vengono rimossi anche altri pacchetti che all'avvio del sistema sono necessari mandandomi così in kernel panic la macchina...)

le mie domande sono queste:
1. cosa posso fare per il problema sopra descritto?
2. come faccio a non fare aggiornare tramite apt-get install i pachetti già installati? (calcolando che il file apt.conf che dovrebbe trovarsi se non erro in /etc/atp/apt.conf non c'è e tentando di crearlo mi viene restituito un errore all'avvio di apt-get update)

Grazie in anticipo per l'aiuto che vorrete fornirmi.
:-(
darkblack
Newbie
Newbie
 
Messaggi: 8
Iscritto il: 02/10/2005, 16:09

Re: aggiornamento sarge problematico

Messaggioda hanska » 03/10/2005, 10:17

ciao,
anzitutto potresti postare l'errore preciso che ti dà tentando di aggiornare e2fsprogs?

magari prova:

Codice: Seleziona tutto
# apt-get install e2fsprogs


così vedi solo gli errori che ti dà questo pacchetto... magari sono dipendenze...

per quanto riguarda l'impedire l'aggiornamento di alcuni pacchetti, su Guide@Debianizzati.org ce n'è una che fa per te: --> link

al momento non ho una debian sotto mano, quindi non so dirti se apt.conf stia effettivamente in /etc/apt/ (dovrebbe esser lì comunque)... quindi per questo problema non so aiutarti...

appena rimetto mano su una debian ti dico dove si trova esattamente (se da me c'è... :rofl: )


saluti
hanska
Full Member
Full Member
 
Messaggi: 172
Iscritto il: 31/12/2004, 11:04

Re: aggiornamento sarge problematico

Messaggioda Fart » 03/10/2005, 13:43

Questo lo posso confermare io:
apt.conf è in /etc/apt

..
Codice: Seleziona tutto
oileo:/etc/apt# ls
#source.list#   apt.conf    sources.list      sources.list~
apt-build.conf  apt.conf.d  sources.list.old


Inoltre non sò se aiuta ma per me:
Codice: Seleziona tutto
oileo:/etc/apt# apt-cache show e2fsprogs |grep Version
Version: 1.38-2
Version: 1.37-2sarge1


Io ho una partizione EXT2 poichè ho installato inizialmente sarge e poi ho upgradato a testing, ma non ho avuto il tuo problema! :ciauz:
Out beyond the New Frontiers..
Fart
Hero Member
Hero Member
 
Messaggi: 984
Iscritto il: 22/06/2005, 7:52

Re: aggiornamento sarge problematico

Messaggioda LoSpippolo » 03/10/2005, 16:44

prova a dargli

apt-get -u -o APT::Force-LoopBreak=1

oppure

apt-get install -u -o APT::Force-LoopBreak=1

e vedi se ti risolve.

ciauz
L'Universo puo' essere visto come una battaglia fra i sistemisti, che cercano di realizzare sistemi a prova d'idiota, e la Natura che crea idioti sempre piu' sofisticati. E' lampante che, per ora, la Natura vince di brutto...
LoSpippolo
Jr. Member
Jr. Member
 
Messaggi: 54
Iscritto il: 28/09/2005, 7:53

Re: aggiornamento sarge problematico

Messaggioda hanska » 03/10/2005, 16:52

[semi OT]
che roba è? :-o :-o :-o

mai vista una cosa simile... stasera torno a casa e un bel man non me lo toglie nessuno... :rtfm:
[/semi OT]
hanska
Full Member
Full Member
 
Messaggi: 172
Iscritto il: 31/12/2004, 11:04

Re: aggiornamento sarge problematico

Messaggioda MaXeR » 03/10/2005, 17:13

LoSpippolo ha perfettamente ragione...


A volte è necessario abilitare l'opzione APT::Force-LoopBreak perché APT possa rimuovere temporaneamente un pacchetto essenziale, per via di un un circolo vizioso “è in conflitto con”/“pre-dipende da”. Di norma aptitude emetterà un avviso e cesserà l'aggiornamento. Si può per l'appunto evitare ciò specificando l'opzione -o APT::Force-LoopBreak=1 nella riga di comando di aptitude.

Release Note di Sarge

mai vista quella opzione... thx a LoSpippolo per la segnalazione: spettacolare :ciauz:
http://leevee.it - Leevee Soluzioni Informatiche
Avatar utente
MaXeR
Administrator
Administrator
 
Messaggi: 3211
Iscritto il: 22/12/2004, 17:01
Località: Garda - VR

Re: aggiornamento sarge problematico

Messaggioda hanska » 03/10/2005, 17:16

spettacolo davvero...

non c'è un'iconcina che fa gli applausi? ci vorrebbe proprio...

complimenti a LoSpippolo :-)
hanska
Full Member
Full Member
 
Messaggi: 172
Iscritto il: 31/12/2004, 11:04

Re: aggiornamento sarge problematico

Messaggioda LoSpippolo » 03/10/2005, 19:17

Grazie, grazie, per gli autografi mettetevi pure in fila...

:rofl: :rofl: :rofl: :rofl: :rofl:

cmq il trucco c'e': quell'erorre lo avevo avuto anch'io qualche gg fa' nella stessa condizione ed un'occhiata a google ed un po' di [d]cul...[/d] ahem fortuna mi ha aiutato nella soluzione

ciauz
L'Universo puo' essere visto come una battaglia fra i sistemisti, che cercano di realizzare sistemi a prova d'idiota, e la Natura che crea idioti sempre piu' sofisticati. E' lampante che, per ora, la Natura vince di brutto...
LoSpippolo
Jr. Member
Jr. Member
 
Messaggi: 54
Iscritto il: 28/09/2005, 7:53

Re: aggiornamento sarge problematico

Messaggioda keltik » 03/10/2005, 19:47

grazie LoSpippolo: pochi colpi ma precisi :-D
Avatar utente
keltik
Hero Member
Hero Member
 
Messaggi: 1257
Iscritto il: 01/01/2005, 17:12

Re: aggiornamento sarge problematico

Messaggioda LoSpippolo » 03/10/2005, 20:30

Dammi tempo... :s6:

ciauz
L'Universo puo' essere visto come una battaglia fra i sistemisti, che cercano di realizzare sistemi a prova d'idiota, e la Natura che crea idioti sempre piu' sofisticati. E' lampante che, per ora, la Natura vince di brutto...
LoSpippolo
Jr. Member
Jr. Member
 
Messaggi: 54
Iscritto il: 28/09/2005, 7:53

Re: aggiornamento sarge problematico

Messaggioda darkblack » 03/10/2005, 22:33

grazie a tutti... vedo che siete reattivi a dare risposte...

mi scuso per il ritardo nel postare l'errore esatto infatti mentre io rifacevo l'operazione per rivedere l'errore voi gia mi avevate dato la soluzione! Complimenti...

così, solo e puramente a titolo informativo posto l'errore:
---------------------------------------------
E: this installation run will require temporarily removing the essential package e2fsprogs due to a Conflicts/Pre-Depends loop. This is often bad, but if you really wont to do it, activate the APT::Force-LoopBreak option.

E: Internal error, cold not early remove e2fsprogs.
---------------------------------------------

ora! visto che ho capito perchè mi ha dato l'errore e che ho capito come risolverlo, mi piacerebbe capire perchè tramite l'installazione dal mio cd non trovo in /etc/apt/ il file apt.conf file dove potrei impostare perennemente APT::Force-LoopBreak e altre impostazioni....

Sapete darmi indicazione anche su questo?

Secondo me si...

Grazie infinite a tutti! :ciauz:
darkblack
Newbie
Newbie
 
Messaggi: 8
Iscritto il: 02/10/2005, 16:09

Re: aggiornamento sarge problematico

Messaggioda MaXeR » 03/10/2005, 22:37

per il semplice motivo che di default il file non viene creato...

lo puoi creare tu, senza problemi :-D

:ciauz:
http://leevee.it - Leevee Soluzioni Informatiche
Avatar utente
MaXeR
Administrator
Administrator
 
Messaggi: 3211
Iscritto il: 22/12/2004, 17:01
Località: Garda - VR

Re: aggiornamento sarge problematico

Messaggioda hanska » 04/10/2005, 7:50

ho bisogno di andarmi a studiare un pò apt... :rtfm: :rtfm: :rtfm:


sciau belli!

(e ancora complimenti a LoSpippolo... me la mandi una tua foto con autografo? magari nudo... :rofl: )

ariciau
hanska
Full Member
Full Member
 
Messaggi: 172
Iscritto il: 31/12/2004, 11:04

Re: aggiornamento sarge problematico

Messaggioda keltik » 04/10/2005, 15:46

ti sconsiglio di impostare Force-LoopBreak tra i comportamenti di default di apt (in etc/apt/apt.conf), perchè potenzialmente dannoso.

meglio utilizzarlo direttamente dalla command line quando necessario.

imho, ovviamente :-)

:ciauz:
Avatar utente
keltik
Hero Member
Hero Member
 
Messaggi: 1257
Iscritto il: 01/01/2005, 17:12

Re: aggiornamento sarge problematico

Messaggioda hanska » 04/10/2005, 16:16

concordo pienamente!

:ciauz:
hanska
Full Member
Full Member
 
Messaggi: 172
Iscritto il: 31/12/2004, 11:04

Prossimo

Torna a Apt-get and friends

Chi c’è in linea

Visitano il forum: Nessuno e 4 ospiti