amsn e amule

Sezione dedicata alle problematiche sull'uso dei tool di installazione e gestione di pacchetti, in una distribuzione Debian-based.
Rispondi
gelo

amsn e amule

Messaggio da gelo »

volevo chiedervi una delle mie tante domande al quale non riesco a dare soluzione... ho provato vari cd debian (solo debian perche' mi sono innamorato di apt-get) :s1: e ho trovato problemi nell'istallare sia amule che amsn l'unico dove non ho problemi a istallarlo è su knomax... apt-get install amule mi dice che il pacchetto non lo trova... uguale con amsn.. perchè? invece con knomax istalla normalmente?
Fart
Hero Member
Hero Member
Messaggi: 984
Iscritto il: 22/06/2005, 7:52

Re: amsn e amule

Messaggio da Fart »

Bè dipende da che cd hai...magari su quelli non ci sono. Al limite scaricati i pacchetti a mano e poi installali con dpkg -i nomepacchetto.deb
Out beyond the New Frontiers..
gelo

Re: amsn e amule

Messaggio da gelo »

ho provato anche a scaricare i pacchetti ma nell'istallazione da terminale mi dice che mancano delle dipendenze che non sono istallate e lo lascia non configurato... per esempio nel cd di knomax amsn non c'è e con apt-get install amsn lo istalla tranquillamente
Avatar utente
keltik
Hero Member
Hero Member
Messaggi: 1257
Iscritto il: 01/01/2005, 17:12
Contatta:

Re: amsn e amule

Messaggio da keltik »

controlla il tuo file "/etc/sources.list" ed assicurati che sia presente almeno una linea relativa ai repository online.

in questo modo apt può scaricare i pacchetti e le dipendenze in automatico.

se non vuoi editare il file a mano, usa il comando "apt-setup"
[url=http://www.jaxx.it/keltik]keltik's blog[/url]
gelo

Re: amsn e amule

Messaggio da gelo »

si anche perchè editare il file a mano non so' nemmeno cosa vuol dire... ne devo fare ancora di strada pero' mi sto' impegnando infatti per un po' non sono venuto a scassare qui :ave: :ave:
fantasma
Jr. Member
Jr. Member
Messaggi: 94
Iscritto il: 08/10/2005, 13:12

Re: amsn e amule

Messaggio da fantasma »

Ciao anchio mi sono debianizato da poco e posso dirti il metodo che ho usato io per installare amule
Scaricati nella cartello root amule_2.0.3-2.1_i386.deb che trovi qui ovviamente scaricati la versione it
da root dai il comando

Codice: Seleziona tutto

dpkg -i amule_2.0.3-2.1_i386.deb
ti dirà che ti mancano dei pacchetti li trovi qui instalali dando il comando

Codice: Seleziona tutto

dpkg -i nomepacchetto.deb
quando hai instalato tutti i pacchetti che ti mancavano ridai il comando

Codice: Seleziona tutto

dpkg -i amule_2.0.3-2.1_i386.deb
e dovrebbe funzionare tutto.
spero di eserti stato d'aiuto e non averti incasinato di +
gelo

Re: amsn e amule

Messaggio da gelo »

ok avevo gia fatto un'esperimento del genere su un'altra distro ma poi avevo rinunciato... sono tante le dipendenze da istallare sono tutte quelle in rosso?
fantasma
Jr. Member
Jr. Member
Messaggi: 94
Iscritto il: 08/10/2005, 13:12

Re: amsn e amule

Messaggio da fantasma »

no. Le dipendenze che ti servono sono tutte quelle in rosso quelle da instalare sono solo quelle che ti mancano per sapere quale sono prova ad installare amule e prendi nota degli erori
gelo

Re: amsn e amule

Messaggio da gelo »

questo l'ultimo errore che mi da...
Spacchetto il rimpiazzo di amule ...
dpkg: problemi con le dipendenze impediscono la configurazione di amule:
amule dipende da libc6 (>= 2.3.5-1); comunque:
La versione di libc6 nel sistema è 2.3.2.ds1-22.
amule dipende da libcrypto++5.2c2; comunque:
Il pacchetto libcrypto++5.2c2 non è ancora configurato.
amule dipende da libgcc1 (>= 1:4.0.1); comunque:
La versione di libgcc1 nel sistema è 1:3.4.3-13.
amule dipende da libstdc++6 (>= 4.0.1); comunque:
Il pacchetto libstdc++6 non è ancora configurato.
amule dipende da libwxbase2.4-1 (>= 2.4.4.1.1); comunque:
Il pacchetto libwxbase2.4-1 non è ancora configurato.
amule dipende da libwxgtk2.4-1 (>= 2.4.4.1.1); comunque:
Il pacchetto libwxgtk2.4-1 non è ancora configurato.
dpkg: errore processando amule (--install):
problemi con le dipendenze - lasciato non configurato
Sono occorsi degli errori processando:
amule


come configuro i pacchetti? e quelli con una versione diversa vanno sostituiti? grazie..
Avatar utente
MaXeR
Hero Member
Hero Member
Messaggi: 3211
Iscritto il: 22/12/2004, 17:01
Località: Garda - VR
Contatta:

Re: amsn e amule

Messaggio da MaXeR »

ehm...
quel pacchetto non è fatto per sarge, ma per etch (o superiori)...
quindi non è possibile installarlo..

ciauu :ciauz:
http://leevee.it - Leevee Soluzioni Informatiche
gelo

Re: amsn e amule

Messaggio da gelo »

grazie :ciauz:
fantasma
Jr. Member
Jr. Member
Messaggi: 94
Iscritto il: 08/10/2005, 13:12

Re: amsn e amule

Messaggio da fantasma »

Grazie che sei riuscito ad installarlo o che hai rinunciato comunque quando dice la libreria non è ancora configurata devi installarla quindi installa:
libc6
libcrypto++5.2c2
libgcc1
libstdc++6
libwxbase2.4-1
libwxgtk2.4-1
Alcuni di questi file hanno le loro dipendenze se ti appare un errore simile devi installare anche quelle.
gelo

Re: amsn e amule

Messaggio da gelo »

per ora ho reistallato knomax che non da' nessun problema... comunque il fatto è che non è tanto a istallare queste dipendenze è a configurarle che non ho capito ciao grazie delle risposte
kappe
Sr. Member
Sr. Member
Messaggi: 326
Iscritto il: 05/09/2005, 3:12

Re: amsn e amule

Messaggio da kappe »

Se ti interessa la versione 'testing' di amule, puoi facilmente scaricarlo / configurarlo aggioungendo queste due voci al tuo sources.list:

deb http://www.vollstreckernet.de/debian/ testing amule
deb http://www.vollstreckernet.de/debian/ testing wx

:ciauz:
$ aptitude moo $ aptitude -v moo $ aptitude -v -v moo . . $ aptitude -v -v -v -v -v -v moo
gelo

Re: amsn e amule

Messaggio da gelo »

wx serve per configurare le dipendenze?
Rispondi