installare gambas

Sezione dedicata alle problematiche sull'uso dei tool di installazione e gestione di pacchetti, in una distribuzione Debian-based.
Rispondi
net_deity
Full Member
Full Member
Messaggi: 210
Iscritto il: 16/08/2005, 12:34

installare gambas

Messaggio da net_deity »

Ciao a tutti..

dovrei installare gambas...e sul sito ufficiale ho trovato i repository per scaricare le ultime versioni.

Il problema è che nei repository di testing è attualmente presente gambas, ma a una versione nettamente inferiore.

Ho mixato le release come scritto sulla guida..tutto ok. Ho impostato il file preferences così:

Package: *
Pin: release a=testing
Pin-Priority: 850

Package: *
Pin: release a=unstable
Pin-Priority: 800

Package: *
Pin: release a=experimental
Pin-Priority: 750

Package: *
Pin: release a=Progeny
Pin-priority: 700


Questo è quello che ottengo leggendo il file http://www.linex.org/sources/linex/debi ... cl/Release

Origin: Progeny
Suite: cl
Codename: cl
Date: Mon, 13 Sep 2004 16:35:24 UTC
Architectures: i386
Description: Progeny Componentized Linux
Components: linex2004
Description: Progeny Componentized Linux

Ma quando cerco di dare:
apt-get install gambas-ide

ottengo:

I seguenti pacchetti hanno dipendenze non soddisfatte:
gambas-ide: Dipende: gambas-gb-qt (>= 1.9.19) ma 1.0.3-1 sta per essere installato
Dipende: gambas-gb-qt-editor (>= 1.9.19) ma 1.0.3-1 sta per essere installato
Dipende: gambas-gb-qt-ext (>= 1.9.19) ma 1.0.3-1 sta per essere installato
Dipende: gambas-gb-pcre (>= 1.9.19) ma non sta per essere installato
Dipende: gambas-gb-settings (>= 1.9.19) ma non sta per essere installato
Dipende: gambas-gb-form (>= 1.9.19) ma non sta per essere installato
Dipende: gambas-runtime (>= 1.9.20) ma 1.0.3-1 sta per essere installato
E: Pacchetto non integro

Non riesco a scavalcare le priorità dei repository testing..help :-D
Powered->Debian Sid [img align=left]http://pkg-mono.alioth.debian.org/banners/monodeb.png[/img]
Avatar utente
Ldonesty
Hero Member
Hero Member
Messaggi: 618
Iscritto il: 22/12/2004, 17:31
Località: Un po' a Gaeta, un po' a Signa

Re: installare gambas

Messaggio da Ldonesty »

Prova ad usare il flag -t, specificando la versione che vuoi utilizzare e vedi se cosi ti permette di installare quella particolare versione.
Il reggiseno e' uno strumento democratico perche' separa la destra dalla sinistra, solleva le masse e attira i popoli.
net_deity
Full Member
Full Member
Messaggi: 210
Iscritto il: 16/08/2005, 12:34

Re: installare gambas

Messaggio da net_deity »

Non cambia nulla. :-(

ma se faccio un:

apt-get update

mi da alla fine...

Hit http://www.linex.org cl/gambas Packages
Ign http://www.linex.org cl/gambas Release


quell'Ign....significa che mi ignora le Release?


Ho aperto Synaptic...e ho visto che l'archivio dei pacchetti è stato aggiornato...ma non con tutto il necessario. Di fatti i pacchetti necessari a gambas alcuni sono nell'archivio dei pacchetti disponibili, e altri solo sul repository.
Powered->Debian Sid [img align=left]http://pkg-mono.alioth.debian.org/banners/monodeb.png[/img]
Avatar utente
MaXeR
Hero Member
Hero Member
Messaggi: 3211
Iscritto il: 22/12/2004, 17:01
Località: Garda - VR
Contatta:

Re: installare gambas

Messaggio da MaXeR »

ma l'opzione giusta non è 'o=' al posto di 'a=' ?
http://leevee.it - Leevee Soluzioni Informatiche
net_deity
Full Member
Full Member
Messaggi: 210
Iscritto il: 16/08/2005, 12:34

Re: installare gambas

Messaggio da net_deity »

Anche specificando l'origine con o= ...ho gli stessi errori.
Powered->Debian Sid [img align=left]http://pkg-mono.alioth.debian.org/banners/monodeb.png[/img]
Avatar utente
keltik
Hero Member
Hero Member
Messaggi: 1257
Iscritto il: 01/01/2005, 17:12
Contatta:

Re: installare gambas

Messaggio da keltik »

non puoi risolvere il problema utilizzando il pinning, non questa volta almeno.

il repository che vuoi utilizzare non è pienamente compatibile con il funzionamento standard di APT, ed infatti quest'ultimo non riesce a reperire un file Release valido.

se te la senti, ti consiglio di procedere in un altro modo: io di quando in quando lo uso e non ho generalmente problemi.

1) ripristina i tuoi files preferences ed apt.conf;
2) edita sources.list e commenta tutti i repositories all' infurori di quello Linex relativo a gambas.
3) apt-get update;
4)

Codice: Seleziona tutto

$ sudo apt-get install gambas-ide -s
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
I seguenti pacchetti verranno inoltre installati:
  gambas-gb-form gambas-gb-net gambas-gb-net-curl gambas-gb-pcre gambas-gb-qt
  gambas-gb-qt-editor gambas-gb-qt-ext gambas-gb-settings gambas-gb-xml
  gambas-runtime
Pacchetti raccomandati:
  gambas-doc
I seguenti pacchetti NUOVI (NEW) saranno installati:
  gambas-gb-form gambas-gb-net gambas-gb-net-curl gambas-gb-pcre gambas-gb-qt
  gambas-gb-qt-editor gambas-gb-qt-ext gambas-gb-settings gambas-gb-xml
  gambas-ide gambas-runtime
0 aggiornati, 11 installati, 0 da rimuovere e 0 non aggiornati.
Inst gambas-runtime (1.9.20-4 www.linex.org)
Inst gambas-gb-qt (1.9.19-1 www.linex.org)
Inst gambas-gb-form (1.9.19-2 www.linex.org)
Inst gambas-gb-net (1.9.19-1 www.linex.org)
Inst gambas-gb-net-curl (1.9.19-1 www.linex.org)
Inst gambas-gb-pcre (1.9.19-1 www.linex.org)
Inst gambas-gb-qt-editor (1.9.19-1 www.linex.org)
Inst gambas-gb-qt-ext (1.9.19-1 www.linex.org)
Inst gambas-gb-xml (1.9.19-2 www.linex.org)
Inst gambas-gb-settings (1.9.19-2 www.linex.org)
Inst gambas-ide (1.9.20-2 www.linex.org)
5) ripristina il tuo sources.list.

così facendo abbiamo bypassato il problema, che consisteva nel fatto che APT poteva risolvere le dipendenze di gambas-ide unicamente usando il repository di default.

futuri upgrades non dovrebbero pregiudicare l' installazione dei pacchetti Linex, almeno finchè i numeri di versione restano più alti di quelli dei pacchetti ufficiali.

:ciauz:
[url=http://www.jaxx.it/keltik]keltik's blog[/url]
net_deity
Full Member
Full Member
Messaggi: 210
Iscritto il: 16/08/2005, 12:34

Re: installare gambas

Messaggio da net_deity »

OK! L'avevo pensato di proseguire in quel modo...ma mi sembrava macchinoso..e magari poi non era quello ma una semplice svista in qualche file di configurazione di APT.

Comunque perfetto ora funziona...!!

Grazie Mille!
Powered->Debian Sid [img align=left]http://pkg-mono.alioth.debian.org/banners/monodeb.png[/img]
joy

Re: installare gambas

Messaggio da joy »

Ciao, anche io ho avuto dei problemi con gambas e ho cercato di seguire le istruzioni che hai dato, ma il risultato non è stato felicissimo. Ti riporto tutto vista la mia poca esperienza con linux. Premetto che avevo marcato con # tutti i repositories e lasciato solo quello di gambas come da te consigliato. Questo è quanto mi è successo:

alecci:/etc/apt# apt-get update
Get:1 http://www.linex.org cl/gambas Packages [3737B]
Ign http://www.linex.org cl/gambas Release
Scaricato 3737B in 0s (9978B/s)
Lettura della lista dei pacchetti in corso... Fatto
alecci:/etc/apt# sudo apt-get install gambas-ide -s
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler
dire che è stata richiesta una situazione impossibile oppure, se
si sta usando la distribuzione "unstable", che alcuni pacchetti
richiesti non sono ancora stati creati o spostati da Incoming.

Poichè è stata richiesta solo una singola operazione è molto facile che
il pacchetto semplicemente non sia installabile, si consiglia
di inviare un "bug report" per tale pacchetto.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
gambas-ide: Dipende: fakeroot ma non è installabile
E: Pacchetto non integro
alecci:/etc/apt#
net_deity
Full Member
Full Member
Messaggi: 210
Iscritto il: 16/08/2005, 12:34

Re: installare gambas

Messaggio da net_deity »

Prova ad installare il pacchetto gambas-ide senza sudo cioè da root...mi sembra strano che gambas richieda fakeroot come dipendenza....
Powered->Debian Sid [img align=left]http://pkg-mono.alioth.debian.org/banners/monodeb.png[/img]
joy

Re: installare gambas

Messaggio da joy »

Ho riprovato, ma anche prima ero root e mi da sempre la stessa dipendenza da "fakeroot" come mess precedente. :sboing:
joy

Re: installare gambas

Messaggio da joy »

Ci sono riuscito, ho risolto, ho provato a gestire la cosa con synaptic ed è andato tutto a posto. Grazie di tutto :ave:
Rispondi