installazione newton, problemi con le dipendenze.

Sezione dedicata alle problematiche sull'uso dei tool di installazione e gestione di pacchetti, in una distribuzione Debian-based.
Rispondi
Belzebu
Newbie
Newbie
Messaggi: 39
Iscritto il: 10/10/2005, 11:26

installazione newton, problemi con le dipendenze.

Messaggio da Belzebu »

Sto tentando di installare newton (http://newton.sourceforge.net/) ed ho problemi con le dipendenze, durante l'installazione ho il seguente errore:

Codice: Seleziona tutto

dpkg: problemi con le dipendenze impediscono la configurazione di newton:
 newton dipende da python (>= 2.4); comunque:
  La versione di python nel sistema è 2.3.5-3.
 newton dipende da python-gnome2; comunque:
  Il pacchetto python-gnome2 non è installato.
 newton dipende da python-gnome2-extras; comunque:
  Il pacchetto python-gnome2-extras non è installato.
dpkg: errore processando newton (--install):
 problemi con le dipendenze - lasciato non configurato
Sono occorsi degli errori processando:
 newton
python 2.4 e relativi python-gnome2 e python-gnome2-extras sono installati; come faccio ad indicare a dpkg dove andare a trovarli per usarli al posto delle versioni precedenti?
Avatar utente
MaXeR
Hero Member
Hero Member
Messaggi: 3211
Iscritto il: 22/12/2004, 17:01
Località: Garda - VR
Contatta:

Re: installazione newton, problemi con le dipendenze.

Messaggio da MaXeR »

prova a guardare cosa pensa di fare apt:

Codice: Seleziona tutto

# apt-get -f install
dovrebbe risolvere la cosa..

NB: -f, come da manuale, non indica un force, ma un fix...
http://leevee.it - Leevee Soluzioni Informatiche
Belzebu
Newbie
Newbie
Messaggi: 39
Iscritto il: 10/10/2005, 11:26

Re: installazione newton, problemi con le dipendenze.

Messaggio da Belzebu »

Ho sistemato apt-get per installare pacchetti da locale come indicato al punto 2.2 diquesta guida ma apt-get non trova il pacchetto. Con aptitude e synaptic invece compare. In synaptic ho visto che ci sono tre python. python, python2.3 e python2.4 li ho tutti e tre ma credo che newton cerchi il primo la cui versione più recente nei repository che ho io è 2.3.5-3. Qualcuno sa indicarmi un repository con una versione del pacchetto python superiore a 2.4?
Avatar utente
MaXeR
Hero Member
Hero Member
Messaggi: 3211
Iscritto il: 22/12/2004, 17:01
Località: Garda - VR
Contatta:

Re: installazione newton, problemi con le dipendenze.

Messaggio da MaXeR »

premesso che potrebbe essere anche un problema del pacchetto...

comunque dpkg -l "python*" mi restituisce una cosa del genere:

Codice: Seleziona tutto

ii  python2.4        2.4.2-1        An interactive high-level object-oriented language (version 2.4)
Probabilmente si tratta di un bug del pacchetto che hai scaricato...
ora ci do una occhiata!
http://leevee.it - Leevee Soluzioni Informatiche
Rispondi