[RISOLTO] Problemi di connessione con usb adapter TL-WN725N

Discussioni sulla compatibilità dell'Hardware con linux, Drivers, ...

[RISOLTO] Problemi di connessione con usb adapter TL-WN725N

Messaggioda Kibalcic » 09/09/2017, 12:31

Ciao a tutti.
Ho comprato la usb adapter TL-WN725N per installarla sul mio debian 8 mate. All'inizio non la vedeva, ma dopo aver seguito qualche guida in rete, sono riuscito ad installarla. Il problema è che adesso vede le reti wi-fi ma non si connette alla mia. Mi chiede continuamente di inserire la password che è quella corretta.
Qualche consiglio? Grazie
Nonostante il rugby resto pessimista
Avatar utente
Kibalcic
Newbie
Newbie
 
Messaggi: 40
Iscritto il: 23/05/2011, 13:53

Re: Problemi di connessione con usb adapter TL-WN725N

Messaggioda Aki » 09/09/2017, 16:00

Per cortesia, fornisci un log usando lo script indicato in http://guide.debianizzati.org/index.php ... i_al_forum
Aki
Global Moderator
Global Moderator
 
Messaggi: 7423
Iscritto il: 27/12/2007, 16:59

Re: Problemi di connessione con usb adapter TL-WN725N

Messaggioda Kibalcic » 09/09/2017, 18:19

Ecco. Spero di aver creato il file giusto
Allegati
log_09set_191521.xz
(29.13 KiB) Scaricato 27 volte
Nonostante il rugby resto pessimista
Avatar utente
Kibalcic
Newbie
Newbie
 
Messaggi: 40
Iscritto il: 23/05/2011, 13:53

Re: Problemi di connessione con usb adapter TL-WN725N

Messaggioda Aki » 10/09/2017, 11:32

Da log che hai inviato, risulta che per la scheda di rete WiFi stai usando il modulo del kernel chiamato r8188eu con un kernel Debian alla versione 3.16.0-4-686-pae:
Codice: Seleziona tutto
$ grep r8188eu log_09set_191521
set 09 19:04:38 debian kernel: r8188eu: module is from the staging directory, the quality is unknown, you have been warned.
set 09 19:04:38 debian kernel: usbcore: registered new interface driver r8188eu
set 09 19:04:47 debian NetworkManager[537]: <info> (wlan0): new 802.11 WiFi device (driver: 'r8188eu' ifindex: 3)
set 09 19:04:47 debian kernel: r8188eu 5-5:1.0: firmware: direct-loading firmware rtlwifi/rtl8188eufw.bin
r8188eu               615933  0
usbcore               171098  5 uhci_hcd,usb_storage,r8188eu,ehci_hcd,ehci_pci

$ grep Linux log_09set_191521
set 09 19:04:33 debian kernel: Linux version 3.16.0-4-686-pae (debian-kernel@lists.debian.org) (gcc version 4.8.4 (Debian 4.8.4-1) ) #1 SMP Debian 3.16.43-2 (2017-04-30)

Sulla base dei dati che hai fornito, l'argomento è stato già trattato nella precedente discussione: http://forum.debianizzati.org/viewtopic.php?f=3&t=49657&p=182678&hilit=WN725N#p182678.

In ogni caso, il bug report https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=726398 è stato risolto con la versione Debian del kernel 3.13.7-1~bpo70+1
Aki
Global Moderator
Global Moderator
 
Messaggi: 7423
Iscritto il: 27/12/2007, 16:59

Re: Problemi di connessione con usb adapter TL-WN725N

Messaggioda Kibalcic » 10/09/2017, 12:49

Niente.
Avevo già visto quella discussione, ma il problema mi sembrava diverso.
Comunque ho seguito i passi descritti, ma non è cambiato nulla
Nonostante il rugby resto pessimista
Avatar utente
Kibalcic
Newbie
Newbie
 
Messaggi: 40
Iscritto il: 23/05/2011, 13:53

Re: Problemi di connessione con usb adapter TL-WN725N

Messaggioda Aki » 10/09/2017, 14:18

Kibalcic ha scritto: ho seguito i passi descritti, ma non è cambiato nulla

Sei molto sintetico nella risposta ed in questo modo è difficile aiutarti: puoi fornire il dettaglio dei comandi impartiti con i relativi output e fornire nuovamente un log ?

Dai log che hai riportato precedentemente, comunque, sembra un problema del driver del kernel per la scheda WiFi, in particolare per la parte di autenticazione secondo il protocollo wpa; questo è quello che corrisponde nei log a quando il sistema non riconosce la password wpa che hai inserito:
Codice: Seleziona tutto
set 09 19:04:48 debian wpa_supplicant[915]: nl80211: Driver does not support authentication/association or connect commands
set 09 19:04:48 debian wpa_supplicant[915]: ioctl[SIOCSIWAP]: Operation not permitted
set 09 19:04:48 debian wpa_supplicant[915]: ioctl[SIOCSIWENCODEEXT]: Invalid argument
set 09 19:04:48 debian wpa_supplicant[915]: ioctl[SIOCSIWENCODEEXT]: Invalid argument

Poiché nel primo messaggio ha indicato:
Kibalcic ha scritto:All'inizio non la vedeva, ma dopo aver seguito qualche guida in rete, sono riuscito ad installarla.
potresti anche aver pasticciato con i moduli del kernel, oppure sono i driver forniti con il kernel che, essendo "in staging", non supportano tutte le funzionalità. In ogni caso, se vuoi rimanere con Debian Jessie (8), puoi provare risolvere installando l'ultima versione del kernel dal repository dei backports.
Aki
Global Moderator
Global Moderator
 
Messaggi: 7423
Iscritto il: 27/12/2007, 16:59

Re: Problemi di connessione con usb adapter TL-WN725N

Messaggioda Kibalcic » 10/09/2017, 18:38

Scusa, non ho il pc sottomano (è a casa dei miei) e quindi faccio le prove a "rate".
Comunque, il primo passo che ho fatto è stato seguire questa guida: https://wiki.debian.org/rtl819x
Dopo aver installato i drivers il sistema ha visto la chiavetta e mi sono apparse le varie reti wi-fi disponibili. Poi ho avuto il problema che ti dicevo con la continua richiesta di autenticazione nonostante la password fosse corretta.
Ho seguito la discussione precedente alla mia che mi hai linkato e poi ho seguito la guida http://brilliantlyeasy.com/ubuntu-linux ... r-install/
Non essendo assolutamente un esperto, come avrai capito, niente di più strano che abbia fatto qualche casino.
Ti allego un altro log.
Appena possibile vedo come si fa ad aggiornare il kernel.
Grazie per l'aiuto
Allegati
log_10set_193314.xz
(31.86 KiB) Scaricato 20 volte
Nonostante il rugby resto pessimista
Avatar utente
Kibalcic
Newbie
Newbie
 
Messaggi: 40
Iscritto il: 23/05/2011, 13:53

Re: Problemi di connessione con usb adapter TL-WN725N

Messaggioda Aki » 11/09/2017, 7:45

Per l'installazione dai backports vedi http://guide.debianizzati.org/index.php ... _stable.29.
Aki
Global Moderator
Global Moderator
 
Messaggi: 7423
Iscritto il: 27/12/2007, 16:59

Re: Problemi di connessione con usb adapter TL-WN725N

Messaggioda Kibalcic » 11/09/2017, 19:05

Aki ha scritto:Per l'installazione dai backports vedi http://guide.debianizzati.org/index.php ... _stable.29.


Grazie! provo subito
Nonostante il rugby resto pessimista
Avatar utente
Kibalcic
Newbie
Newbie
 
Messaggi: 40
Iscritto il: 23/05/2011, 13:53

Re: Problemi di connessione con usb adapter TL-WN725N

Messaggioda Aki » 15/09/2017, 17:02

@Kibalcic: hai avuto aggiornamenti ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 7423
Iscritto il: 27/12/2007, 16:59

Re: Problemi di connessione con usb adapter TL-WN725N

Messaggioda Kibalcic » 15/09/2017, 19:00

Ciao Aki!
niente ancora, ma ho avuto pochissimo tempo per fare prove.
In questo weekend mi metto sotto e ti aggiorno.
Grazie
Nonostante il rugby resto pessimista
Avatar utente
Kibalcic
Newbie
Newbie
 
Messaggi: 40
Iscritto il: 23/05/2011, 13:53

Re: Problemi di connessione con usb adapter TL-WN725N

Messaggioda Kibalcic » 17/09/2017, 12:17

Ancora niente di fatto, Aki.
Nell'ordine ho fatto i seguenti tentativi.
- ho aggiornato il kernel in jessie;
- ho installato stretch;
- ho provato su ubuntu 17.04 in live session.
Il risultato è stato sempre lo stesso. Dopo aver installato il firmware mancante, vede la chiavetta e le reti wi-fi disponibili, ma non si connette richiedendo sempre la password.
Non so proprio che pensare. Il PC è sicuramente obsoleto ma fa il suo lavoro più che egregiamente.
Potrei provare con un altro PC, magari, e vedere che succede.
Nonostante il rugby resto pessimista
Avatar utente
Kibalcic
Newbie
Newbie
 
Messaggi: 40
Iscritto il: 23/05/2011, 13:53

Re: Problemi di connessione con usb adapter TL-WN725N

Messaggioda Kibalcic » 21/09/2017, 11:19

Aggiornamento. Dopo svariati tentativi con altre distro live falliti come gli altri, ho provato con stretch 32 bit e...miracolo! Funziona!
Cosa può essere successo? Un problema del mio pc o del modem?
P.s.: dimmi se mettere Risolto o eliminare la discussione.
Nonostante il rugby resto pessimista
Avatar utente
Kibalcic
Newbie
Newbie
 
Messaggi: 40
Iscritto il: 23/05/2011, 13:53


Torna a Hardware

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite