Dipendenze Driver Nvidia

Discussioni sulla compatibilità dell'Hardware con linux, Drivers, ...

Dipendenze Driver Nvidia

Messaggioda Ernestus » 08/08/2018, 17:16

Ciao a tutti,
ho un Asus X53S con su Debian 9.5 ma non riesco ad installare i driver nvidia:
Codice: Seleziona tutto
# nvidia-detect
Detected NVIDIA GPUs:
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF119M [GeForce GT 520MX] [10de:1051] (rev a1)

Checking card:  NVIDIA Corporation GF119M [GeForce GT 520MX] (rev a1)
Your card is supported by all driver versions.
It is recommended to install the
    nvidia-driver
package.


Ma...
Codice: Seleziona tutto
# apt-get install nvidia-driver
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
 nvidia-driver : Dipende: nvidia-driver-libs (= 384.130-1) ma non sta per essere
                          nvidia-driver-libs-nonglvnd (= 384.130-1) ma non sta p
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.


I miei repository:
Codice: Seleziona tutto
deb http://ftp.it.debian.org/debian/ stretch main non-free contrib
deb-src http://ftp.it.debian.org/debian/ stretch main non-free contrib

deb http://security.debian.org/debian-security stretch/updates main contrib non-free
deb-src http://security.debian.org/debian-security stretch/updates main contrib non-free

# stretch-updates, previously known as 'volatile'
deb http://ftp.it.debian.org/debian/ stretch-updates main contrib non-free
deb-src http://ftp.it.debian.org/debian/ stretch-updates main contrib non-free

# stretch-backports, previously on backports.debian.org
deb http://ftp.it.debian.org/debian/ stretch-backports main contrib non-free
deb-src http://ftp.it.debian.org/debian/ stretch-backports main contrib non-free


Qualche idea?
Ultima modifica di Ernestus il 10/08/2018, 21:27, modificato 2 volte in totale.
Utente Linux numero: 529380
BLOG PERSONALE: https://nuovanalogica.blogspot.com/
Avatar utente
Ernestus
wiki member
wiki member
 
Messaggi: 673
Iscritto il: 23/06/2010, 20:12
Località: Milano

Re: Dipendenze Driver Nvidia

Messaggioda samiel » 09/08/2018, 0:00

io ho scaricato i driver da
http://www.nvidia.it/Download/index.aspx?lang=it
basta avere gli header del kernel
e non ho mai avuto problemi nelll'installazione

m
samiel
wiki member
wiki member
 
Messaggi: 2088
Iscritto il: 12/08/2006, 15:05
Località: Venezia

Re: Dipendenze Driver Nvidia

Messaggioda Aki » 09/08/2018, 2:11

Dal file /etc/apt/sources.list, che hai inviato, risulta configurato stretch-backports: potresti aver installato pacchetti che entrano in conflitto con quelli che stai cercando di installare adesso ? Inoltre, possibile, fornisci i log completi degli output dei comandi impartiti poiché risultano troncati nel tuo precedente messaggio.
Aki
Global Moderator
Global Moderator
 
Messaggi: 7888
Iscritto il: 27/12/2007, 16:59

Re: Dipendenze Driver Nvidia

Messaggioda Ernestus » 10/08/2018, 18:09

Vorrei evitare di scaricare i driver dal sito perché avendo il portatile con la doppia scheda grafica vorrei usare bumbleblee per utilizzare selettivamente una scheda a seconda di quale mi serve.

Aki non ho capito se ti vanno bene quei comandi oppure hai bisogno di qualche log più accurato - nel caso cosa devo postare?
Utente Linux numero: 529380
BLOG PERSONALE: https://nuovanalogica.blogspot.com/
Avatar utente
Ernestus
wiki member
wiki member
 
Messaggi: 673
Iscritto il: 23/06/2010, 20:12
Località: Milano

Re: Dipendenze Driver Nvidia

Messaggioda Aki » 10/08/2018, 21:04

Ernestus ha scritto:Aki non ho capito se ti vanno bene quei comandi oppure hai bisogno di qualche log più accurato - nel caso cosa devo postare?

Hai fornito dei log incompleti (sono troncati a destra, probabilmente perché non hai registrato un log dell'output dei comandi impartiti, ma ti sei limitato ad eseguire un copia & incolla di quello che vedevi a schermo.

In ogni caso, potrebbe essere utile visionare l'output dei seguenti comandi impartiti come utente root:
Codice: Seleziona tutto
script log.txt
apt-get update
apt-cache policy
apt-cache policy nvidia-driver nvidia-driver-libs nvidia-driver-libs-nonglvnd
apt-get -o Debug::pkgProblemResolver=true install nvidia-driver
dpkg-query -l "nvidia-driver*"
exit

Troverai l'output dei comandi nel file log.txt
Aki
Global Moderator
Global Moderator
 
Messaggi: 7888
Iscritto il: 27/12/2007, 16:59

Re: Dipendenze Driver Nvidia

Messaggioda Aki » 10/08/2018, 21:33

Ciao, ho fatto in tempo a consultare il log nel messaggio che hai cancellato e che sotto riporto in parte:
Codice: Seleziona tutto
root@linux:/home/ernesto# apt-get -o Debug::pkgProblemResolver=true install nvidia-driver
[..omissis..]
Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
The following additional packages will be installed:
  dkms glx-alternative-mesa glx-alternative-nvidia glx-diversions
  libegl-nvidia0 libegl-nvidia0:i386 libegl1-glvnd-nvidia
  libegl1-glvnd-nvidia:i386 libgl1-glvnd-nvidia-glx
  libgl1-glvnd-nvidia-glx:i386 libgl1-nvidia-glvnd-glx
  libgl1-nvidia-glvnd-glx:i386 libgles-nvidia1 libgles-nvidia1:i386
  libgles-nvidia2 libgles-nvidia2:i386 libgles1-glvnd-nvidia
  libgles1-glvnd-nvidia:i386 libgles2-glvnd-nvidia libgles2-glvnd-nvidia:i386
  libglvnd0-nvidia libglvnd0-nvidia:i386 libglx-nvidia0 libglx-nvidia0:i386
  libglx0-glvnd-nvidia libglx0-glvnd-nvidia:i386 libjansson4 libnvidia-cfg1
  libnvidia-cfg1:i386 libnvidia-egl-wayland1 libnvidia-egl-wayland1:i386
  libnvidia-eglcore libnvidia-eglcore:i386 libnvidia-glcore
  libnvidia-glcore:i386 libnvidia-ml1 libopengl0-glvnd-nvidia
  libopengl0-glvnd-nvidia:i386 libvulkan1 libvulkan1:i386
  libwayland-client0:i386 libwayland-server0:i386 libxnvctrl0
  nvidia-alternative nvidia-driver-bin nvidia-driver-libs
  nvidia-driver-libs:i386 nvidia-driver-libs-i386:i386 nvidia-egl-common
  nvidia-egl-icd nvidia-egl-icd:i386 nvidia-egl-wayland-common
  nvidia-egl-wayland-icd nvidia-egl-wayland-icd:i386 nvidia-installer-cleanup
  nvidia-kernel-common nvidia-kernel-dkms nvidia-kernel-support
  nvidia-legacy-check nvidia-modprobe nvidia-persistenced nvidia-settings
  nvidia-support nvidia-vdpau-driver nvidia-vulkan-common nvidia-vulkan-icd
  nvidia-vulkan-icd:i386 update-glx xserver-xorg-video-nvidia
Pacchetti suggeriti:
  python3-apport vulkan-utils vulkan-utils:i386
I seguenti pacchetti NUOVI saranno installati:
  dkms glx-alternative-mesa glx-alternative-nvidia glx-diversions
  libegl-nvidia0 libegl-nvidia0:i386 libegl1-glvnd-nvidia
  libegl1-glvnd-nvidia:i386 libgl1-glvnd-nvidia-glx
  libgl1-glvnd-nvidia-glx:i386 libgl1-nvidia-glvnd-glx
  libgl1-nvidia-glvnd-glx:i386 libgles-nvidia1 libgles-nvidia1:i386
  libgles-nvidia2 libgles-nvidia2:i386 libgles1-glvnd-nvidia
  libgles1-glvnd-nvidia:i386 libgles2-glvnd-nvidia libgles2-glvnd-nvidia:i386
  libglvnd0-nvidia libglvnd0-nvidia:i386 libglx-nvidia0 libglx-nv

Da quanto sopra riportato, risulterebbe, pertanto, che l'installazione del pacchetto nvidia-driver può avvenire senza segnalazioni di errori o dipendenze non soddisfatte.
Aki
Global Moderator
Global Moderator
 
Messaggi: 7888
Iscritto il: 27/12/2007, 16:59

Re: Dipendenze Driver Nvidia

Messaggioda Ernestus » 10/08/2018, 22:04

Ho cancellato perché per sbaglio stavo utilizzando l'altro portatile e quindi mi dava tutto apposto. Appena ho sotto mano quello incriminato, ti mando i log.

PS ne ho approfittato per installarli su questa macchina
Utente Linux numero: 529380
BLOG PERSONALE: https://nuovanalogica.blogspot.com/
Avatar utente
Ernestus
wiki member
wiki member
 
Messaggi: 673
Iscritto il: 23/06/2010, 20:12
Località: Milano


Torna a Hardware

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti