[SOSPESO] Mini wireless tl-wn823n

Discussioni sulla compatibilità dell'Hardware con linux, Drivers, ...

Re: Mini wireless tl-wn823n

Messaggioda brunoS » 19/01/2019, 18:29

su -l funziona, ha compilato senza problemi. Grazie.
Ho staccato il cavo di rete e riavviato. Riconosce la rete wifi ma non accetta la psw. Una volta inserita la stringa (è corretta, sono sicuro) della psw ritorna a chiederla, senza messaggi di alcun tipo.
Fa lo stesso con qualsiasi stringa immessa a caso.
brunoS
Newbie
Newbie
 
Messaggi: 18
Iscritto il: 29/08/2018, 6:40

Re: Mini wireless tl-wn823n

Messaggioda brunoS » 19/01/2019, 19:10

Aggiungo che ho creato un hotspot senza psw col cellulare e il gestore di rete lo vede e si dichiara connesso, ma poi non riesco a navigare.
brunoS
Newbie
Newbie
 
Messaggi: 18
Iscritto il: 29/08/2018, 6:40

Re: Mini wireless tl-wn823n

Messaggioda Aki » 19/01/2019, 20:41

Per analizzare questo dovresti fornire i log di sistema generati con lo script il cui link è riportato in rosso nella parte inferiore del mio messaggio.
Aki
Global Moderator
Global Moderator
 
Messaggi: 8373
Iscritto il: 27/12/2007, 16:59

Re: Mini wireless tl-wn823n

Messaggioda brunoS » 20/01/2019, 0:01

Dopo avere riacceso ho navigato a quanto pare con entrambe le connessioni attive: ethernet e wifi. Allora ho disconnesso il cavo di rete e per un po' ho navigato senza problemi con wifi, ho anche aggiornato il sistema. Poi il wifi si è bloccato e ho riconnesso il cavo, senza attivare la connessione wired: navigo benissimo:.
Ti spedisco il tutto in questo stato.
Allegati
log_19gen_224843.xz
(41.32 KiB) Scaricato 36 volte
brunoS
Newbie
Newbie
 
Messaggi: 18
Iscritto il: 29/08/2018, 6:40

Re: Mini wireless tl-wn823n

Messaggioda brunoS » 20/01/2019, 0:33

Questo allegato invece contiene i log relativi al collegamento con hotspot, e cavo di rete scollegato.
Ovviamente in questo momento sono connesso wired
Allegati
log_19gen_232628_hotspot.xz
(45.52 KiB) Scaricato 36 volte
brunoS
Newbie
Newbie
 
Messaggi: 18
Iscritto il: 29/08/2018, 6:40

Re: Mini wireless tl-wn823n

Messaggioda brunoS » 20/01/2019, 8:46

Per indirizzare il debug e far risparmiare tempo a chi mi aiuta: in questo momento sono collegato con la connessione wifi, lontano dal router e quindi senza cavo. Il gestore di rete wicd dice "nessuna rete wireless trovata", come sempre, ma tutto funziona.
Ho semplicemente acceso il computer, non mi ha chiesto psw di rete.
Ho poi tentato di attivare la connessione hotspot senza psw e non andava.
Ho spento e riacceso e non si collegava al wifi, col solito modo di chiedere continuamente la psw di accesso.
Ho spento e riacceso e adesso sono in questa situazione e va.
brunoS
Newbie
Newbie
 
Messaggi: 18
Iscritto il: 29/08/2018, 6:40

Re: Mini wireless tl-wn823n

Messaggioda Aki » 20/01/2019, 10:45

Da una prima veloce lettura del secondo log risulta che il modulo del kernel chiamato rtl8xxxu (fornito nativamente con il kernel e che sembra non funzionare correttamente con la scheda di rete "Mini wireless tl-wn823n") è stato attivato dal kernel (poiché non inserito nella "blacklist" del kernel) con conseguente possibile conflitto nell'accesso alla scheda di rete wifi rispetto al driver che hai compilato ex-novo chiamato "8192eu"

Per inibire il caricamento da parte del kernel del modulo rtl8xxxu, puoi impartire i seguenti comandi come utente root;
Codice: Seleziona tutto
script log3.txt
echo "blacklist rtl8xxxu" | tee /etc/modprobe.d/rtl8xxxu.conf
update-initramfs -u
exit

Con questi comandi, sarà creato il file /etc/modprobe.d/rtl8xxxu.conf contenente il riferimento al modulo di cui inibire il caricamento all'avvio del kernel e con i successivi comandi si trasmette la configurazione al file initramfs che è utilizzato dal kernel come file system per l'avvio iniziale del computer. Al successivo riavvio del computer, nell'output comando lsmod non dovrebbe più comparire il riferimento al modulo rtl8xxxu, mentre dovrebbe essere presente il riferimento al modulo 8192eu: puoi verificare ?

Sempre dai log risulta che nel tuo computer sono installati simultaneamente due gestori di rete (network manager e wicd):
Codice: Seleziona tutto
******************************************
Network Manager
******************************************
Network Manager è installato (versione 1.14.4)
Network Manager è in esecuzione

******************************************
Wicd
******************************************
Wicd è installato (versione wicd 1.7.4 (bzr-r961) )
Wicd è in esecuzione

Questi due gestori di rete, se attivi simultaneamente, interferiscono nel funzionamento reciproco. Salvo tu non abbia preferenze/esigenze specifiche, potrebbe essere consigliabile disinstallare wicd e gestire la rete tramite network manager. In alternativa, disattivare il network-manager ed usare solo wicd.
Aki
Global Moderator
Global Moderator
 
Messaggi: 8373
Iscritto il: 27/12/2007, 16:59

Re: Mini wireless tl-wn823n

Messaggioda brunoS » 20/01/2019, 11:34

Ho verificato lsmod prima e dopo. In effetti erano presenti i 2 moduli, adesso solo 8192eu. Al riavvio però non si connette e ti scrivo da cellulare. Come faccio a inibire wicd o network manager?
brunoS
Newbie
Newbie
 
Messaggi: 18
Iscritto il: 29/08/2018, 6:40

Re: Mini wireless tl-wn823n

Messaggioda Aki » 20/01/2019, 11:47

Per fermare temporaneamente il servizio wicd dopo l'avvio del computer dovrebbe essere sufficiente impartire il seguente comando come utente root:
Codice: Seleziona tutto
systemctl stop wicd.service

Dovrebbe comparire un output che conferma l'interruzione del funzionamento del servizio. Inoltre, impartendo il seguente comando (se installato) non dovrebbe comparire nessun output:
Codice: Seleziona tutto
pgrep wicd

Per fermare permanentemente il servizio wicd dovrebbe essere sufficiente impartire il seguente comando come utente root:
Codice: Seleziona tutto
systemctl disable wicd.service

Per riattivare il servizio wicd dovrebbe essere sufficiente impartire il seguente comando come utente root:
Codice: Seleziona tutto
systemctl enable wicd.service
systemctl start wicd.service

Per disattivare permanentemente il servizio NetworkManager dovrebbe essere sufficiente impartire il seguente comando come utente root:
Codice: Seleziona tutto
systemctl disable NetworkManager.service

Per attivare permanentemente il servizio NetworkManager dovrebbe essere sufficiente impartire il seguente comando come utente root:
Codice: Seleziona tutto
systemctl enable NetworkManager.service
systemctl start NetworkManager.service

Dai log che hai inviato, comunque, la connessione alla rete wireless risultava essere stata effettuata da wicd.
Aki
Global Moderator
Global Moderator
 
Messaggi: 8373
Iscritto il: 27/12/2007, 16:59

Re: Mini wireless tl-wn823n

Messaggioda brunoS » 20/01/2019, 11:55

Quindi sarebbe preferibile disattivare network manager? Con comandi analoghi?
brunoS
Newbie
Newbie
 
Messaggi: 18
Iscritto il: 29/08/2018, 6:40

Re: Mini wireless tl-wn823n

Messaggioda Aki » 20/01/2019, 11:56

brunoS ha scritto:Quindi sarebbe preferibile disattivare network manager? Con comandi analoghi?

Partirei dal disattivare wicd
Aki
Global Moderator
Global Moderator
 
Messaggi: 8373
Iscritto il: 27/12/2007, 16:59

Re: Mini wireless tl-wn823n

Messaggioda brunoS » 20/01/2019, 12:15

Pgrep wicd produce 1249
Fermando il wicd service non si connette
Fermando il network Manager e riattivando il wicd service, neanche.
Ho riavviato. Sul pannello ho solo l'icona wicd ma non trova nessuna rete wireless
brunoS
Newbie
Newbie
 
Messaggi: 18
Iscritto il: 29/08/2018, 6:40

Re: Mini wireless tl-wn823n

Messaggioda Aki » 20/01/2019, 12:32

brunoS ha scritto:Pgrep wicd produce 1249

Vuol dire che non si è fermato: hai errato ad impartire i comandi oppure il comando è stato inefficace rispetto all'intento desiderato. A questo indirizzo (https://wiki.debian.org/systemd) trovi i riferimenti ai comandi principali con cui controllare l'esecuzione dei servizi di sistema.

brunoS ha scritto:Fermando il wicd service non si connette
Fermando il network Manager e riattivando il wicd service, neanche.
Ho riavviato. Sul pannello ho solo l'icona wicd ma non trova nessuna rete wireless

Servono i log dei comandi impartiti, rispettivi output ed i log di sistema in ciascuna situazione, altrimenti è difficile capire cosa hai fatto e come il sistema ha risposto. Mi rendo conto che richiede tempo ed impegno, ma purtroppo, non sono lì affianco a Te e non posso vedere esattamente i comandi impartiti ed i relativi output oppure analizzare la risposta del sistema operativo agli stessi o controllare eventuali ulteriori variabili che magari stanno entrando in gioco e che non hai evidenziato. Sarebbe altrettanto utile che effettuassi autonomamente un'analisi preliminare di tali log, per cercare di capire tu stesso cosa sta accedendo.
Aki
Global Moderator
Global Moderator
 
Messaggi: 8373
Iscritto il: 27/12/2007, 16:59

Re: Mini wireless tl-wn823n

Messaggioda zambu » 20/01/2019, 17:45

brunoS ha scritto:Fatto. Ho interrotto al solito errore.


Se dai il comando:

sudo apt-get install dkms

cosa ottieni?
Daniele
Avatar utente
zambu
Newbie
Newbie
 
Messaggi: 10
Iscritto il: 11/08/2014, 7:48

Re: Mini wireless tl-wn823n

Messaggioda brunoS » 22/01/2019, 9:25

Ok, sospendo e ritorno quando ne so di più. Per un neofita di debian e inesperto di Linux adattarsi non è uno scherzo e crescere di livello è impegnativo, ma non mollo.
Grazie dell'aiuto a tutti e ad Aki anche della pazienza.
brunoS
Newbie
Newbie
 
Messaggi: 18
Iscritto il: 29/08/2018, 6:40

Precedente

Torna a Hardware

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti

cron