[RISOLTO] VirtualBox - Dispositivi USB non collegati

Discussioni sulla compatibilità dell'Hardware con linux, Drivers, ...

[RISOLTO] VirtualBox - Dispositivi USB non collegati

Messaggioda _Alex_ » 17/05/2019, 13:35

In realtà si tratta di qualcosa che racchiude un campo più ampio e non sapevo dove inserirlo...
La versione di Debian che sto usando, sul mio portatile Dell Latitude E4310 è stable, completamente aggiornata

The story so far:
ho acquistato un programmatore per microchip TL866II, per il quale la ditta produttrice supporta esclusivamente Windows.
Ho trovato in giro la procedura per installare su Linux il software usando Wine32, con la copia di una specifica libreria, ma alla fine il tutto non va.
Pazienza, farò con una macchina virtuale, mi dico, tanto ne ho create in precedenza alcune, licenziate e funzionanti con VirtualBox.
Installo VirtualBox sul mio portatile tramite repository Debian, comprese le estensioni e le guest additions, la macchina virtuale gira correttamente (ho preso Xp Sp3, completamente aggiornata), assegno 1024Mb di ram, 128Mb di video ram, appunti e trascinamento bidirezionale, controller Usb 2.0 e 3.0 funzionanti grazie alle estensioni, dispositivi tutti riconosciuti e funzionanti.
Il problema arriva qui: non riesco a passare le periferiche Usb alla macchina virtuale, VBox mi dice sempre Nessun dispositivo Usb collegato.
Provo con una chiavetta Usb al posto del programmatore, ma niente, non riesce a vederla né montata né da montare.
Allora, con i seguenti comandi, disisntallo VBox allo scopo di scaricare da Oracle la versione più recente ed usare quella:
- sudo apt purge virtualbox*
- sudo apt autoclean
- sudo apt autoremove
Non contento vado sotto la directory .config del mio portatile per eliminare le configurazioni di VBox, così ho tutto pulito.
Scarico la versione nuova, con l'extension pack, la installo senza errori con:
- sudo dpkg -i virtualbox....deb
Doppio click sull'extension pack, che apre VBox e si installa senza errori.
Riprendo la macchina virtuale che avevo preparato (quella originale, non quella mastruzzata con VBox dei repository) ed ho ancora lo stesso problema.

Che cavolo succede?
E' la prima volta che fa così, tutte le altre volte andavo su Dispositivi-Usb e cliccavo sul dispositivo da passare senza problemi, ora non compare affatto, sembra che VBox non lo veda inserito.

Grazie in anticipo a chi vorrà darmi una mano

EDIT:
** Cambio il titolo per renderlo meno generico **
s3v
Ultima modifica di _Alex_ il 20/05/2019, 14:06, modificato 1 volta in totale.
_Alex_
Jr. Member
Jr. Member
 
Messaggi: 73
Iscritto il: 02/09/2017, 8:32
Località: Genova

Re: VirtualBox

Messaggioda azioga » 17/05/2019, 19:12

mi viene in mente questa:
l'utente appartiene al gruppo "vboxusers" ?
azioga
Newbie
Newbie
 
Messaggi: 17
Iscritto il: 03/09/2018, 7:53

Re: VirtualBox

Messaggioda _Alex_ » 20/05/2019, 14:00

L'ho aggiunto, ma il risultato non è cambiato.

Provo a riavviare il pc, in attesa di imparare come riavviare il singolo servizio.
_Alex_
Jr. Member
Jr. Member
 
Messaggi: 73
Iscritto il: 02/09/2017, 8:32
Località: Genova

Re: VirtualBox

Messaggioda _Alex_ » 20/05/2019, 14:06

Update:
dopo il riavvio è andato tutto a posto.

La riga per aggiungere l'utente è la seguente:
- sudo usermod -G vboxusers <utente>

Adesso vede tutti i dispositivi usb collegati.

Grazie
_Alex_
Jr. Member
Jr. Member
 
Messaggi: 73
Iscritto il: 02/09/2017, 8:32
Località: Genova

Re: VirtualBox

Messaggioda azioga » 20/05/2019, 19:40

_Alex_ ha scritto:Provo a riavviare il pc, in attesa di imparare come riavviare il singolo servizio.


Era sufficiente un logout dall'utente e login ;)

Contento di esserti stato d'aiuto.
Luca.
azioga
Newbie
Newbie
 
Messaggi: 17
Iscritto il: 03/09/2018, 7:53

Re: [Risolto]VirtualBox - Dispositivi USB non collegati

Messaggioda _Alex_ » 21/05/2019, 12:45

A corollario della risoluzione è successa una cosa strana:
il mio utente non era più tra i sudoers....

Per risolverlo, dato che si tratta dell'unico utente e non ho abilitato l'accesso a root, è stato necessario riavviare il sistema con una distro live (System Rescue Cd nel mio caso) ed editare il file /etc/sudoers, in modo da riaggiungere alex tra gli utenti abilitati.

Azzarderei che il comando usermod non ha l'effetto di aggiungere l'utente ad ulteriori gruppi, oltre a quelli nei quali è già presente, al contrario imposta globalmente l'utente nei gruppi specificati ed, eventualmente, lo rimuove da quelli non scritti esplicitamente sul comando.

Confermate?
_Alex_
Jr. Member
Jr. Member
 
Messaggi: 73
Iscritto il: 02/09/2017, 8:32
Località: Genova

Re: [Risolto]VirtualBox - Dispositivi USB non collegati

Messaggioda byte64 » 21/05/2019, 15:18

_Alex_ ha scritto:A corollario della risoluzione è successa una cosa strana:
il mio utente non era più tra i sudoers....

Per risolverlo, dato che si tratta dell'unico utente e non ho abilitato l'accesso a root, è stato necessario riavviare il sistema con una distro live (System Rescue Cd nel mio caso) ed editare il file /etc/sudoers, in modo da riaggiungere alex tra gli utenti abilitati.

Azzarderei che il comando usermod non ha l'effetto di aggiungere l'utente ad ulteriori gruppi, oltre a quelli nei quali è già presente, al contrario imposta globalmente l'utente nei gruppi specificati ed, eventualmente, lo rimuove da quelli non scritti esplicitamente sul comando.

Confermate?

Dovevi usare anche l'opzione -a , da man usermod:
Codice: Seleziona tutto
-G, --groups GRUPPO1[,GRUPPO2,...[,GRUPPON]]]
Una lista di gruppi supplementari di cui l'utente è altresì membro. Ciascun gruppo è separato dal successivo da una virgola, senza spazi bianchi intermedi. I gruppi sono soggetti alle stesse restrizioni del gruppo dato con l'opzione -g.

Se l'utente è attualmente membro di un gruppo che non è elencato, l'utente verrà rimosso dal gruppo. Questo comportamento può essere cambiato con l'opzione -a che aggiunge all'utente i gruppi supplementari dei quali fa attualmente parte.


Ciao
byte64
Sr. Member
Sr. Member
 
Messaggi: 372
Iscritto il: 07/01/2017, 19:02
Località: Bergamo


Torna a Hardware

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

cron