[RISOLTO] Webcam Trust WB-1400T

Discussioni sulla compatibilità dell'Hardware con linux, Drivers, ...

[RISOLTO] Webcam Trust WB-1400T

Messaggioda stephanie » 19/03/2020, 14:28

Un saluto a tutto il forum, vorrei collegare una Webcam Trust WB-1400T al mio pc su cui ho installato Debian Buster a 64 bit.

Ricordo che anni addietro (e' una webcam che ha i suoi anni) l'avevo collegata ad una Debian Squeeze a 32 bit senza problemi e senza dovere installare nulla.

Purtroppo sotto Buster non riesco a farla funzionare, con lsusb la legge come Pixart Imaging, Inc. SoC PC-Camera, ma Cheese o altri software similari non la vedono collegata.

Codice: Seleziona tutto
lsusb
Bus 002 Device 002: ID 152d:0567 JMicron Technology Corp. / JMicron USA Technology Corp. JMS567 SATA 6Gb/s bridge
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 045e:00cb Microsoft Corp. Basic Optical Mouse v2.0
Bus 001 Device 005: ID 04fc:0c15 Sunplus Technology Co., Ltd SPIF215A SATA bridge
Bus 001 Device 004: ID 0424:2412 Standard Microsystems Corp.
Bus 001 Device 003: ID 093a:2468 Pixart Imaging, Inc. SoC PC-Camera
Bus 001 Device 002: ID 0924:42dc Xerox
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
stephanie@PcServer:~$ lsmod | grep gspca
gspca_pac207           16384  0
gspca_main             28672  1 gspca_pac207
videobuf2_vmalloc      16384  1 gspca_main
videobuf2_v4l2         28672  1 gspca_main
videobuf2_common       53248  2 gspca_main,videobuf2_v4l2
videodev              212992  4 gspca_main,videobuf2_v4l2,gspca_pac207,videobuf2_common
usbcore               294912  8 gspca_main,xhci_hcd,usbhid,usblp,gspca_pac207,usb_storage,xhci_pci,uas


Avevo trovato queste indicazioni per Ubuntu che ho provato a replicare su Debian:

https://wiki.ubuntu.com/TrustWebcamWB-1400T

Però, dopo avere modificato il file pac207.h, non riesco a compilare:

Codice: Seleziona tutto
root@PcServer:/home/stephanie# cd /home/stephanie/Software/Webcam/gspcav1-20071224
root@PcServer:/home/stephanie/Software/Webcam/gspcav1-20071224# make clean
rm -r -f *.o decoder/.gspcadecoder.o.cmd decoder/*.o \
.gspca.o.cmd  *.o *.ko *.mod.* .[a-z]* core *.i \
*.symvers *.err


Tuttavia sembra che gspca sia gia' presente sul pc:

Codice: Seleziona tutto
root@PcServer:/home/stephanie/Software/Webcam/gspcav1-20071224# dmesg |  grep gspca
[    9.548748] gspca_main: v2.14.0 registered
[    9.549764] gspca_main: pac207-2.14.0 probing 093a:2468
[  675.353219] gspca_main: pac207-2.14.0 probing 093a:2468
root@PcServer:/home/stephanie/Software/Webcam/gspcav1-20071224#


Avete qualche consiglio per riuscire a fare riconoscere dal sistema questa webcam?

Grazie mille e buona giornata a tutti,

Stéphanie
Ultima modifica di stephanie il 23/03/2020, 23:19, modificato 1 volta in totale.
stephanie
Jr. Member
Jr. Member
 
Messaggi: 61
Iscritto il: 05/08/2017, 12:44

Re: Webcam Trust WB-1400T

Messaggioda Aki » 19/03/2020, 19:13

Dopo aver collegato la telecamera puoi generare un log completo usando lo script http://guide.debianizzati.org/index.php ... i_al_forum ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 9187
Iscritto il: 27/12/2007, 16:59

Re: Webcam Trust WB-1400T

Messaggioda stephanie » 19/03/2020, 21:12

Grazie per la risposta,

allego due log: il primo log (210646) l'ho fatto selezionando 8 (altro), il secondo log (210744) selezionando problemi di mount/unmount.

Ancora grazie e buona serata,

Stéphanie
Allegati
log_19mar_210744.xz
(59.97 KiB) Scaricato 17 volte
log_19mar_210646.xz
(57.17 KiB) Scaricato 14 volte
stephanie
Jr. Member
Jr. Member
 
Messaggi: 61
Iscritto il: 05/08/2017, 12:44

Re: Webcam Trust WB-1400T

Messaggioda Aki » 21/03/2020, 0:38

Dal log che hai inviato, risultano alcuni messaggi di anomalie nel riconoscimento di alcune caratteristiche dell’interfaccia USB della webcam:
Codice: Seleziona tutto
$ grep 'usb 1-4' log_19mar_210744
[..]
mar 19 13:17:54 nomehost kernel: usb 1-4: new full-speed USB device number 3 using xhci_hcd
mar 19 13:17:54 nomehost kernel: usb 1-4: config 1 interface 0 altsetting 1 endpoint 0x6 has invalid wMaxPacketSize 0
mar 19 13:17:54 nomehost kernel: usb 1-4: config 1 interface 0 altsetting 2 endpoint 0x6 has invalid wMaxPacketSize 0
mar 19 13:17:54 nomehost kernel: usb 1-4: config 1 interface 0 altsetting 3 endpoint 0x6 has invalid wMaxPacketSize 0
mar 19 13:17:54 nomehost kernel: usb 1-4: config 1 interface 0 altsetting 4 endpoint 0x6 has invalid wMaxPacketSize 0
mar 19 13:17:54 nomehost kernel: usb 1-4: config 1 interface 0 altsetting 5 endpoint 0x6 has invalid wMaxPacketSize 0
mar 19 13:17:54 nomehost kernel: usb 1-4: config 1 interface 0 altsetting 6 endpoint 0x6 has invalid wMaxPacketSize 0
mar 19 13:17:54 nomehost kernel: usb 1-4: config 1 interface 0 altsetting 7 endpoint 0x6 has invalid wMaxPacketSize 0
mar 19 13:17:54 nomehost kernel: usb 1-4: config 1 interface 0 altsetting 8 endpoint 0x6 has invalid wMaxPacketSize 0
mar 19 13:17:54 nomehost kernel: usb 1-4: New USB device found, idVendor=093a, idProduct=2468, bcdDevice= 1.00
mar 19 13:17:54 nomehost kernel: usb 1-4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
mar 19 13:17:54 nomehost kernel: usb 1-4: Product: CIF Single Chip     
mar 19 13:17:54 nomehost kernel: usb 1-4: Manufacturer: Pixart Imaging Inc.
[..]

Inoltre, risulta la webcam è stata collegata ad una porta USB 3: hai provato a collegarla ad altre porte USB non 3 (ad esempio USB 2) e verificarne il funzionamento ?

Inoltre ti chiederei di inviare, dopo aver collegato la webcam, l'output dei seguenti comandi impartiti come utente root e contenuti nel log log.txt:
Codice: Seleziona tutto
script log.txt
ls /dev/video* -la
lsusb -v
Aki
Global Moderator
Global Moderator
 
Messaggi: 9187
Iscritto il: 27/12/2007, 16:59

Re: Webcam Trust WB-1400T

Messaggioda stephanie » 21/03/2020, 13:43

Grazie della risposta, ho collegato la webcam all'altra USB che ho nella parte frontale del case che è la porta 7, ma purtroppo continua a non vederla.

Allego il log dei comandi.

Ancora grazie e buona giornata,

Stéphanie
Allegati
mylog20200321.txt
(44 KiB) Scaricato 14 volte
stephanie
Jr. Member
Jr. Member
 
Messaggi: 61
Iscritto il: 05/08/2017, 12:44

Re: Webcam Trust WB-1400T

Messaggioda Aki » 21/03/2020, 18:33

OK, vediamo se è riconosciuta da v4l (video for linux); se possibile collegala ad usa porta usb2 e impartisci i seguenti comandi come utente root:
Codice: Seleziona tutto
script log.txt
apt install v4l-utils
v4l2-ctl --list-devices
v4l2-ctl --all
exit

Impartisci i seguenti comandi come utente ordinario:
Codice: Seleziona tutto
script vlc.log
vlc -vvv v4l2:///dev/video0
vlc -vvv v4l2:///dev/video1
exit

Invia, quindi, i file log.txt e vlc.log
Aki
Global Moderator
Global Moderator
 
Messaggi: 9187
Iscritto il: 27/12/2007, 16:59

Re: Webcam Trust WB-1400T

Messaggioda stephanie » 21/03/2020, 21:16

Ancora grazie per la risposta, ho installato v4l-utils, il video0 inizia a fare vedere qualcosa, non è ancora utilizzabile nel senso che l'immagine manca completamente di nitidezza (nel senso che si intravvedono un po' le forme, come sia molto sfocata, ma a prescindere dalla distanza webcam-soggetto), sembra anche avere un ritardo di circa un secondo dal momento in cui passo un oggetto davanti alla webcam a quando l'immagine cambia, ma è già un importante passo avanti, perché prima non riconosceva nulla.

Anche lanciando VLC ed aprendo la periferica di acquisizione ho lo stesso risultato. Con Cheese invece ancora non la risonosce.

Con video1 ricevo l'errore "L'ingresso non può essere aperto: VLC non è in grado di aprire il MRL 'v4l2:///dev/video1'. Controlla il registro per i dettagli."

Grazie del tempo e della pazienza e buona serata,

Stéphanie
Allegati
Schermata del 2020-03-21 20-26-59.png
Schermata del 2020-03-21 20-26-59.png (16.62 KiB) Osservato 540 volte
mylog-vlc-20200321-1.txt
(55.71 KiB) Scaricato 13 volte
mylog20200321-1.txt
(5.24 KiB) Scaricato 14 volte
stephanie
Jr. Member
Jr. Member
 
Messaggi: 61
Iscritto il: 05/08/2017, 12:44

Re: Webcam Trust WB-1400T

Messaggioda Aki » 22/03/2020, 0:34

stephanie ha scritto:ho installato v4l-utils, il video0 inizia a fare vedere qualcosa, non è ancora utilizzabile nel senso che l'immagine manca completamente di nitidezza (nel senso che si intravvedono un po' le forme, come sia molto sfocata, ma a prescindere dalla distanza webcam-soggetto)

Temo che questo non sia un problema software, questa webcam ha la messa a fuoco manuale tramite rotazione in un verso o l'altro dell'anello che circonda l'ottica (vedi il manuale online); scusa l'ovvietà, ma naturalmente verifica anche che l'ottica sia pulita.

stephanie ha scritto:sembra anche avere un ritardo di circa un secondo dal momento in cui passo un oggetto davanti alla webcam a quando l'immagine cambia, ma è già un importante passo avanti, perché prima non riconosceva nulla.

Secondo le specifiche nel manuale, sarebbe capace di arrivare fino a 30 fps, ma non credo proprio alla risoluzione massima.

stephanie ha scritto:Anche lanciando VLC ed aprendo la periferica di acquisizione ho lo stesso risultato.

Dal log che hai inviato risulta che VLC, in mancanza di un frame rate dichiarato dalla periferica, acquisisce (o prova ad acquisire, a 25 fps. Nota che risulta dal log che VLC è aperto a tutto schermo (1920x920) e che ridimensiona in software l'immagine acquisita dalla webcam dalla risoluzione nativa massima 352x288 alla risoluzione 1920x920 (usando il driver video supporto MESA con DRM, presumo intel con limitate capacità di accelerazione): questa operazione può rallentare molto la visualizzazione. Quindi, per avere maggiore velocità di riproduzione potresti ridimensionare la finestra di VLC alle dimensioni effettive della dimensione di immagine. Che CPU usa il tuo computer e che architettura (i386 vs amd64) ?

stephanie ha scritto:Con Cheese invece ancora non la riconosce.

Prova con il comando, acquisendo anche in tal caso il relativo log:
Codice: Seleziona tutto
cheese -d /dev/video0


stephanie ha scritto:Con video1 ricevo l'errore "L'ingresso non può essere aperto: VLC non è in grado di aprire il MRL 'v4l2:///dev/video1'. Controlla il registro per i dettagli."

Questo è normale.

stephanie ha scritto:Grazie del tempo e della pazienza e buona serata,Stéphanie

Felice se posso esserti d'aiuto.
Aki
Global Moderator
Global Moderator
 
Messaggi: 9187
Iscritto il: 27/12/2007, 16:59

Re: Webcam Trust WB-1400T

Messaggioda stephanie » 23/03/2020, 23:19

Ancora grazie per la risposta. Il pc è un i5-7500 3,4 Ghz con 8 Gb di RAM:

Codice: Seleziona tutto
stephanie@PcServer:~$ uname -m
x86_64
stephanie@PcServer:~$ uname -a
Linux PcServer 4.19.0-8-amd64 #1 SMP Debian 4.19.98-1 (2020-01-26) x86_64 GNU/Linux
stephanie@PcServer:~$ arch
x86_64
stephanie@PcServer:~$


Ho provato a ridurre la finestra di VLC, ma permane sempre un discreto ritardo.

Con Cheese invece ancora non la riconosce ("nessun dispositivo trovato").

Per la messa a fuoco, in effetti avevo provato a girare un po' l'anello, ma senza notare particolari differenze, e mi ero fermata perché cominciavo a sentire un po' troppo gioco mano a mano che giravo l'anello. Adesso invece ho fatto diversi giri dell'anello (con un po' di timore che mi rimanesse in mano l'obettivo) e la messa a fuoco va decisamente meglio.

La qualità rimane abbastanza scadente, ma probabilmente mi sembra di capire che i limiti a questo punto siano soprattutto della webcam. Anni addietro quando l'avevo provata su un vecchio pc con una Debian Sqeeze a 32 bit non mi era sembrata così pessima, probabilmente devo acquistare per una webcam di livello decisamente superiore.

Eventualmente hai qualche consiglio? Ho sentito parlare bene delle Logitech C920 e C922 che dovrebbero venire riconosciute da Linux.

Intanto ancora un grandissimo grazie per l'aiuto, almeno adesso VLC la ricosce, per questo metto comunque risolto al topic anche se non so perché Cheese non la vede (allego il log del comando), ma se funziona con VLC va benissimo.

Davvero grazie di tutto e buona serata,

Stéphanie
Allegati
mylog-cheese-20200323-1.txt
(1.96 KiB) Scaricato 9 volte
stephanie
Jr. Member
Jr. Member
 
Messaggi: 61
Iscritto il: 05/08/2017, 12:44

Re: [RISOLTO] Webcam Trust WB-1400T

Messaggioda Aki » 24/03/2020, 23:43

Felice di esserti stato d'aiuto. Non ho particolare esperienza con l'utilizzo delle webcam (di solito uso telecamere incorporate) e, quindi, purtroppo non so darti un suggerimenti di acquisto. Per cheese, posso provare a fare qualche approfondimento, ma in mancanza della webcam disponibile, è piuttosto complicato farlo da remoto.
Aki
Global Moderator
Global Moderator
 
Messaggi: 9187
Iscritto il: 27/12/2007, 16:59


Torna a Hardware

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

cron