[RISOLTO] HP LaserJet MFP M26a - hplip-3.17.7 [HOWTO]

Discussioni sulla compatibilità dell'Hardware con linux, Drivers, ...

[RISOLTO] HP LaserJet MFP M26a - hplip-3.17.7 [HOWTO]

Messaggioda juvenihil » 04/08/2017, 3:18

Recentemente ho acquistato una stampante HP multifunzione, non supportata direttamente da CUPS e SANE, e nemmeno dalle versioni di hplip presenti nei repository (3.14.xx e 3.16.xx). Come per altri modelli recenti, il supporto è presente nell'ultima versione di hplip, la 3.17.7, che però non funziona out-of-the-box su Jessie 8.9.

Sulla scorta della soluzione proposta dall'utente nbanba alla risposta #3 ho modificato l'installer ed il file di configurazione,aggiungendo una modifica alle linee 380-381 dell'installer per consentire l'installazione di python-qt5.

Metto qui il link al file di installazione di hplip-3.17.7 modificato, funzionante su Jessie 8.9, è sufficente eseguirlo.

Da terminale:
Codice: Seleziona tutto
$ ./hplip-3.17.7_jessie-8.9.run

Se dovesse fallire l'installazione di python-qt5, questi sono i pacchetti da installare manualmente:
Codice: Seleziona tutto
# apt-get install python-dbus.mainloop.pyqt5 python-qt5

L'installazione è intuitiva, le istruzioni complete con screenshots sono presenti sul sito ufficiale di hplip.
Spero che questo possa essere d'aiuto a qualcuno.
I bet the human brain is a kludge.
--Marvin Minsky
juvenihil
Newbie
Newbie
 
Messaggi: 2
Iscritto il: 04/08/2017, 1:11

Re: HP LaserJet MFP M26a - hplip-3.17.7 [HOWTO]

Messaggioda Aki » 15/08/2017, 9:58

Ciao,
Grazie per aver condiviso le informazioni sopra riportate. Un quesito: oltre alle funzionalità di stampa, la più recente versione di hplip per la specifica stampante multifunzione da te citata, introduce anche il supporto dello scanner ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 7887
Iscritto il: 27/12/2007, 16:59

Re: [RISOLTO] HP LaserJet MFP M26a - hplip-3.17.7 [HOWTO]

Messaggioda starkdeb » 17/02/2018, 13:38

In seguito a questa discussione

http://forum.debianizzati.org/viewtopic.php?f=24&t=54206

in cui ho fatto un sacco di confusione, sto valutando se intraprendere questa strada, tenendo conto che la Debian in questione è la 9.3 mentre nel caso qui sopra era la 8.9 pensate che possa andare bene? ci sono dei "preliminari" da fare per accertare la validità di questa soluzione anche su Stretch? Attualmente, visto che sulla Debian 9.3 in questione ho fatto e disfatto un po' di cose, ora sto ripartendo da una 9.3 appena installata e aggiornata su chiavetta usb in modo da partire proprio da zero su un sistema "pulito", è un'installazione standard in ambiente Gnome.
Nel frattempo, tanto per fare pratica, provo ad applicare quanto sopra sul mio portatile con una 8.10, nel caso qualcosa non andasse bene non fa nulla perchè con quel portatile non uso nessuna stampante quindi posso provare liberamente senza timore di combinare malanni.
starkdeb
Full Member
Full Member
 
Messaggi: 177
Iscritto il: 01/08/2010, 21:14

Re: [RISOLTO] HP LaserJet MFP M26a - hplip-3.17.7 [HOWTO]

Messaggioda starkdeb » 17/02/2018, 15:26

juvenihil ha scritto:Sulla scorta della soluzione proposta dall'utente nbanba alla risposta #3 ho modificato l'installer ed il file di configurazione,aggiungendo una modifica alle linee 380-381 dell'installer per consentire l'installazione di python-qt5.

Metto qui il link al file di installazione di hplip-3.17.7 modificato, funzionante su Jessie 8.9, è sufficente eseguirlo.

Da terminale:
Codice: Seleziona tutto
$ ./hplip-3.17.7_jessie-8.9.run

Se dovesse fallire l'installazione di python-qt5, questi sono i pacchetti da installare manualmente:
Codice: Seleziona tutto
# apt-get install python-dbus.mainloop.pyqt5 python-qt5

L'installazione è intuitiva, le istruzioni complete con screenshots sono presenti sul sito ufficiale di hplip.


sulla 8.10 continua a dirmi

Codice: Seleziona tutto
error: A required dependency 'python-qt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)' is still missing.
error: A required dependency 'python-qt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))' is still missing.
error: Installation cannot continue without these dependencies.
error: Please manually install this dependency and re-run this installer.


e lanciando come da suggerimento

Codice: Seleziona tutto
# apt-get install python-dbus.mainloop.pyqt5 python-qt5


mi restituisce

Codice: Seleziona tutto
# apt-get install python-dbus.mainloop.pyqt5 python-qt5
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
E: Impossibile trovare il pacchetto python-qt5


:'( :'( :'(
starkdeb
Full Member
Full Member
 
Messaggi: 177
Iscritto il: 01/08/2010, 21:14

Re: [RISOLTO] HP LaserJet MFP M26a - hplip-3.17.7 [HOWTO]

Messaggioda starkdeb » 17/02/2018, 15:31

Da synaptic posso fare qualcosa con questo benedetto python qt4 e qt5? ??? che cosa gli manca?


Immagine


Immagine
starkdeb
Full Member
Full Member
 
Messaggi: 177
Iscritto il: 01/08/2010, 21:14


Torna a Hardware

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron