[RISOLTO] Alimentazione a batteria. Rumori strani

Discussioni sulla compatibilità dell'Hardware con linux, Drivers, ...

[RISOLTO] Alimentazione a batteria. Rumori strani

Messaggioda Lioce » 29/10/2017, 0:59

Un saluto a tutti.
Ho un nuovo laptop, un Asus P756U, FREE DOS, che il sistema vede come:

Codice: Seleziona tutto
DMI: ASUSTeK COMPUTER INC. X756UAK/X756UAK, BIOS X756UAK.307.
CPU: Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz.
Scheda video Intel integrata: VGA compatible controller [0300]: Intel Corporation Device [8086:5916] (rev 02).
HDD 1TB


Ho installato Stretch 9.2 KDE, kernel 4.9.0-4-amd64.

Il problema è che quando il portatile è alimentato a batteria sento dei rumori come dei clic, con frequenza intermittente e non regolare.
Se invece il laptop è alimentato via cavo questi clic non si producono.
In tutti e due i casi non noto niente di anormale per quanto riguarda luminosità, spegnimento, monitor, riproduzione video, ecc.

Ho installato: intelmicrocode, irqbalance, acpi e cercando *power* mi risultano installati i seguenti pacchetti:

Codice: Seleziona tutto
dpkg -l *power* | grep ^ii | awk '{print $2}'
libpowerdevilcore2
libpowerdevilui5
libupower-glib3:amd64
powerdevil
powerdevil-data
powermgmt-base
powertop
ruby-power-assert
upower


Ho provato a installare il kernel 4.12 dai backports ma il malfunzionamento persisteva (anzi la frequenza dei clic era aumentata) e l'ho disinstallato.

smartctl -a /dev/sda non mi dà errori, se capisco bene. La situazione non è cambiata neanche applicando le indicazioni di Powertop.

Come faccio a capire se è un problema hardware o se invece è un malfunzionamento dovuto ala cattiva gestione energetica da parte del sistema?

Allego l'output di smartctl e uno scriptlog, entrambi eseguiti con alimentazione a batteria e con systemd
Allegati
log_29ott_001524-batt.xz
(36.33 KiB) Scaricato 37 volte
smartctl-batteria.xz
(1.84 KiB) Scaricato 40 volte
Ultima modifica di Lioce il 04/11/2017, 1:37, modificato 1 volta in totale.
Lioce
Full Member
Full Member
 
Messaggi: 140
Iscritto il: 30/03/2014, 21:17

Re: Alimentazione a batteria. Rumori strani.

Messaggioda gio14 » 29/10/2017, 2:41

Prova con una distro live magari di Ubuntu o altro e vedi se il problema si riproduce
gio14
Full Member
Full Member
 
Messaggi: 166
Iscritto il: 25/09/2009, 0:22

Re: Alimentazione a batteria. Rumori strani.

Messaggioda Lioce » 29/10/2017, 13:28

Grazie per la risposta.

Ho appena provato Ubuntu 17.10 live con alimentazione a batteria ed è tutto regolare, non ho sentito nessun clic.

Ma non sono convinto che questo test sia decisivo per dirimere la questione.

Il sistema live non viene caricato sulla RAM senza impegnare il disco rigido?

Forse dovrei installare la distro per avere un termine di paragone valido.
Lioce
Full Member
Full Member
 
Messaggi: 140
Iscritto il: 30/03/2014, 21:17

Re: Alimentazione a batteria. Rumori strani.

Messaggioda marcomg » 02/11/2017, 16:00

A naso credo sia il disco rigido che va in standby quindi nulla di preoccupante, prova a disattivarlo http://guide.debianizzati.org/index.php/Hdparm
Windows is what you open when you want fresh air from outside.
Avatar utente
marcomg
Hero Member
Hero Member
 
Messaggi: 5561
Iscritto il: 22/08/2011, 18:54

Re: Alimentazione a batteria. Rumori strani.

Messaggioda Lioce » 04/11/2017, 1:34

@Marcomg, grazie. Era proprio come sospettavi.

Il comando hdparm -B /dev/sda mi dava: = 245 con alimentazione via cavo e = 128 con quella a batteria.

Aggiungere al file /etc/hdparm.conf

Codice: Seleziona tutto
/dev/disk/by-id/ata-HGST_HTS721010A9E630_JR1004D3136UPM {
       spindown_time = 0
}


non ha recato nessun beneficio. Allora ho fatto questa ulteriore modifica:

Codice: Seleziona tutto
/dev/disk/by-id/ata-HGST_HTS721010A9E630_JR1004D3136UPM {
       spindown_time = 0
       apm = 254
       apm_battery = 254
}


che ha risolto il problema.

Per quanto riguarda la sospensione e l'ibernazione ho creato il file /etc/systemd/system/hdparm-resume.service con il seguente contenuto:

Codice: Seleziona tutto
$ cat /etc/systemd/system/hdparm-resume.service
[Unit]
Description=Hdparm resume
After=suspend.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart hdparm

[Install]
WantedBy=suspend.target


e impartito i seguenti comandi:

Codice: Seleziona tutto
# systemctl daemon-reload

# systemctl enable hdparm-resume.service
Created symlink /etc/systemd/system/suspend.target.wants/hdparm-resume.service → /etc/systemd/system/hdparm-resume.service.


Come spiegato qui:
http://forum.debianizzati.org/viewtopic.php?f=15&t=50721&p=193744&hilit=hdparm#p193744

Ora funziona tutto alla perfezione.

Grazie di nuovo.
Lioce
Full Member
Full Member
 
Messaggi: 140
Iscritto il: 30/03/2014, 21:17


Torna a Hardware

Chi c’è in linea

Visitano il forum: Nessuno e 4 ospiti

cron